policycoreutils-2.7-17
- semanage/seobject.py: Fix undefined store check (#1559174)
This commit is contained in:
parent
e7588169c3
commit
3b2c0121a0
@ -9,7 +9,7 @@
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.7
|
||||
Release: 16%{?dist}
|
||||
Release: 17%{?dist}
|
||||
License: GPLv2
|
||||
# https://github.com/SELinuxProject/selinux/wiki/Releases
|
||||
Source0: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/policycoreutils-2.7.tar.gz
|
||||
@ -30,7 +30,7 @@ Source18: selinux-autorelabel.target
|
||||
Source19: selinux-autorelabel-generator.sh
|
||||
# download https://raw.githubusercontent.com/fedora-selinux/scripts/master/selinux/make-fedora-selinux-patch.sh
|
||||
# run:
|
||||
# HEAD https://github.com/fedora-selinux/selinux/commit/4e253a0231ca085df03b55c4c0490ad6a0e261eb
|
||||
# HEAD https://github.com/fedora-selinux/selinux/commit/63b18604d4bf020ca5cd7781ecf8c0e0443e02d1
|
||||
# $ for i in policycoreutils selinux-python selinux-gui selinux-sandbox selinux-dbus semodule-utils restorecond; do
|
||||
# ./make-fedora-selinux-patch.sh $i
|
||||
# done
|
||||
@ -498,6 +498,9 @@ The policycoreutils-restorecond package contains the restorecond service.
|
||||
%systemd_postun_with_restart restorecond.service
|
||||
|
||||
%changelog
|
||||
* Thu Mar 22 2018 Petr Lautrbach <plautrba@redhat.com> - 2.7-17
|
||||
- semanage/seobject.py: Fix undefined store check (#1559174)
|
||||
|
||||
* Fri Mar 16 2018 Petr Lautrbach <plautrba@redhat.com> - 2.7-16
|
||||
- Build python only subpackages as noarch
|
||||
- Move semodule_package to policycoreutils-devel
|
||||
|
@ -423,7 +423,7 @@ index 0bdb90f..0cdcfcc 100644
|
||||
user identities to authorized role sets. In most cases, only the
|
||||
former mapping needs to be adjusted by the administrator; the latter
|
||||
diff --git selinux-python-2.7/semanage/seobject.py selinux-python-2.7/semanage/seobject.py
|
||||
index 70fd192..ac310ea 100644
|
||||
index 70fd192..045eafd 100644
|
||||
--- selinux-python-2.7/semanage/seobject.py
|
||||
+++ selinux-python-2.7/semanage/seobject.py
|
||||
@@ -238,20 +238,30 @@ class semanageRecords:
|
||||
@ -711,6 +711,15 @@ index 70fd192..ac310ea 100644
|
||||
self.dict = {}
|
||||
self.dict["TRUE"] = 1
|
||||
self.dict["FALSE"] = 0
|
||||
@@ -2644,7 +2651,7 @@ class booleanRecords(semanageRecords):
|
||||
self.current_booleans = []
|
||||
ptype = None
|
||||
|
||||
- if self.store is None or self.store == ptype:
|
||||
+ if self.store is "" or self.store == ptype:
|
||||
self.modify_local = True
|
||||
else:
|
||||
self.modify_local = False
|
||||
diff --git selinux-python-2.7/sepolgen/src/sepolgen/Makefile selinux-python-2.7/sepolgen/src/sepolgen/Makefile
|
||||
index d3aa771..c75809a 100644
|
||||
--- selinux-python-2.7/sepolgen/src/sepolgen/Makefile
|
||||
|
Loading…
Reference in New Issue
Block a user