* Mon Nov 5 2007 Dan Walsh <dwalsh@redhat.com> 2.0.31-13
- Remove -v from restorecon in fixfiles
This commit is contained in:
parent
7c2e75773b
commit
3ac73d19b1
@ -1,6 +1,6 @@
|
|||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-2.0.31/audit2why/audit2why.c
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-2.0.31/audit2why/audit2why.c
|
||||||
--- nsapolicycoreutils/audit2why/audit2why.c 2007-07-16 14:20:41.000000000 -0400
|
--- nsapolicycoreutils/audit2why/audit2why.c 2007-07-16 14:20:41.000000000 -0400
|
||||||
+++ policycoreutils-2.0.31/audit2why/audit2why.c 2007-10-15 16:55:02.000000000 -0400
|
+++ policycoreutils-2.0.31/audit2why/audit2why.c 2007-11-02 15:54:42.000000000 -0400
|
||||||
@@ -137,6 +137,8 @@
|
@@ -137,6 +137,8 @@
|
||||||
/* Process the audit messages. */
|
/* Process the audit messages. */
|
||||||
while (getline(&buffer, &len, stdin) > 0) {
|
while (getline(&buffer, &len, stdin) > 0) {
|
||||||
@ -99,7 +99,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
"Invalid %s%s on line %u, skipping...\n",
|
"Invalid %s%s on line %u, skipping...\n",
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.31/Makefile
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.31/Makefile
|
||||||
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
||||||
+++ policycoreutils-2.0.31/Makefile 2007-10-15 16:55:02.000000000 -0400
|
+++ policycoreutils-2.0.31/Makefile 2007-11-02 15:54:42.000000000 -0400
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||||
@ -108,7 +108,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
@for subdir in $(SUBDIRS); do \
|
@for subdir in $(SUBDIRS); do \
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.31/restorecond/restorecond.c
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.31/restorecond/restorecond.c
|
||||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
||||||
+++ policycoreutils-2.0.31/restorecond/restorecond.c 2007-10-15 16:55:02.000000000 -0400
|
+++ policycoreutils-2.0.31/restorecond/restorecond.c 2007-11-02 15:54:42.000000000 -0400
|
||||||
@@ -210,9 +210,10 @@
|
@@ -210,9 +210,10 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -135,9 +135,21 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
}
|
}
|
||||||
free(scontext);
|
free(scontext);
|
||||||
close(fd);
|
close(fd);
|
||||||
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.31/scripts/fixfiles
|
||||||
|
--- nsapolicycoreutils/scripts/fixfiles 2007-08-23 16:52:26.000000000 -0400
|
||||||
|
+++ policycoreutils-2.0.31/scripts/fixfiles 2007-11-06 14:57:22.000000000 -0500
|
||||||
|
@@ -92,7 +92,7 @@
|
||||||
|
! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o \
|
||||||
|
\( -wholename /home -o -wholename /root -o -wholename /tmp -wholename /dev \) -prune -o -print; \
|
||||||
|
done 2> /dev/null | \
|
||||||
|
- ${RESTORECON} $2 -v -f -
|
||||||
|
+ ${RESTORECON} $2 -f -
|
||||||
|
rm -f ${TEMPFILE} ${PREFCTEMPFILE}
|
||||||
|
fi
|
||||||
|
}
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.31/semanage/semanage
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.31/semanage/semanage
|
||||||
--- nsapolicycoreutils/semanage/semanage 2007-10-05 13:09:53.000000000 -0400
|
--- nsapolicycoreutils/semanage/semanage 2007-10-05 13:09:53.000000000 -0400
|
||||||
+++ policycoreutils-2.0.31/semanage/semanage 2007-11-02 15:50:54.000000000 -0400
|
+++ policycoreutils-2.0.31/semanage/semanage 2007-11-02 15:54:42.000000000 -0400
|
||||||
@@ -1,5 +1,5 @@
|
@@ -1,5 +1,5 @@
|
||||||
#! /usr/bin/python -E
|
#! /usr/bin/python -E
|
||||||
-# Copyright (C) 2005 Red Hat
|
-# Copyright (C) 2005 Red Hat
|
||||||
@ -195,7 +207,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
|
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.31/semanage/seobject.py
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.31/semanage/seobject.py
|
||||||
--- nsapolicycoreutils/semanage/seobject.py 2007-10-07 21:46:43.000000000 -0400
|
--- nsapolicycoreutils/semanage/seobject.py 2007-10-07 21:46:43.000000000 -0400
|
||||||
+++ policycoreutils-2.0.31/semanage/seobject.py 2007-11-02 15:51:27.000000000 -0400
|
+++ policycoreutils-2.0.31/semanage/seobject.py 2007-11-02 15:54:42.000000000 -0400
|
||||||
@@ -1,5 +1,5 @@
|
@@ -1,5 +1,5 @@
|
||||||
#! /usr/bin/python -E
|
#! /usr/bin/python -E
|
||||||
-# Copyright (C) 2005 Red Hat
|
-# Copyright (C) 2005 Red Hat
|
||||||
@ -203,7 +215,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
# see file 'COPYING' for use and warranty information
|
# see file 'COPYING' for use and warranty information
|
||||||
#
|
#
|
||||||
# semanage is a tool for managing SELinux configuration files
|
# semanage is a tool for managing SELinux configuration files
|
||||||
@@ -1095,7 +1092,13 @@
|
@@ -1095,7 +1095,13 @@
|
||||||
|
|
||||||
return con
|
return con
|
||||||
|
|
||||||
@ -217,7 +229,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
if is_mls_enabled == 1:
|
if is_mls_enabled == 1:
|
||||||
serange = untranslate(serange)
|
serange = untranslate(serange)
|
||||||
|
|
||||||
@@ -1154,6 +1157,7 @@
|
@@ -1154,6 +1160,7 @@
|
||||||
def modify(self, target, setype, ftype, serange, seuser):
|
def modify(self, target, setype, ftype, serange, seuser):
|
||||||
if serange == "" and setype == "" and seuser == "":
|
if serange == "" and setype == "" and seuser == "":
|
||||||
raise ValueError(_("Requires setype, serange or seuser"))
|
raise ValueError(_("Requires setype, serange or seuser"))
|
||||||
@ -225,7 +237,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
|
|
||||||
(rc,k) = semanage_fcontext_key_create(self.sh, target, file_types[ftype])
|
(rc,k) = semanage_fcontext_key_create(self.sh, target, file_types[ftype])
|
||||||
if rc < 0:
|
if rc < 0:
|
||||||
@@ -1303,9 +1307,35 @@
|
@@ -1303,9 +1310,35 @@
|
||||||
else:
|
else:
|
||||||
print "%-50s %-18s <<None>>" % (fcon[0], fcon[1])
|
print "%-50s %-18s <<None>>" % (fcon[0], fcon[1])
|
||||||
|
|
||||||
@ -261,7 +273,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
|
|
||||||
def modify(self, name, value = ""):
|
def modify(self, name, value = ""):
|
||||||
if value == "":
|
if value == "":
|
||||||
@@ -1328,11 +1358,14 @@
|
@@ -1328,11 +1361,14 @@
|
||||||
if value != "":
|
if value != "":
|
||||||
nvalue = int(value)
|
nvalue = int(value)
|
||||||
semanage_bool_set_value(b, nvalue)
|
semanage_bool_set_value(b, nvalue)
|
||||||
@ -276,7 +288,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
rc = semanage_bool_modify_local(self.sh, k, b)
|
rc = semanage_bool_modify_local(self.sh, k, b)
|
||||||
if rc < 0:
|
if rc < 0:
|
||||||
raise ValueError(_("Could not modify boolean %s") % name)
|
raise ValueError(_("Could not modify boolean %s") % name)
|
||||||
@@ -1416,11 +1449,19 @@
|
@@ -1416,11 +1452,19 @@
|
||||||
|
|
||||||
return ddict
|
return ddict
|
||||||
|
|
||||||
|
@ -6,7 +6,7 @@
|
|||||||
Summary: SELinux policy core utilities
|
Summary: SELinux policy core utilities
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 2.0.31
|
Version: 2.0.31
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||||
@ -207,6 +207,8 @@ if [ "$1" -ge "1" ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 5 2007 Dan Walsh <dwalsh@redhat.com> 2.0.31-13
|
||||||
|
- Remove -v from restorecon in fixfiles
|
||||||
|
|
||||||
* Mon Nov 5 2007 Dan Walsh <dwalsh@redhat.com> 2.0.31-12
|
* Mon Nov 5 2007 Dan Walsh <dwalsh@redhat.com> 2.0.31-12
|
||||||
- Fix filter and search capabilities, add wait cursor
|
- Fix filter and search capabilities, add wait cursor
|
||||||
|
Loading…
Reference in New Issue
Block a user