Remove sandbox init script, should no longer be necessary

This commit is contained in:
Dan Walsh 2012-01-16 14:40:22 -05:00
parent 6312df65b6
commit 3886f5e4a9
2 changed files with 34 additions and 4 deletions

View File

@ -80,6 +80,36 @@ index 9db766c..92034be 100644
/*
* Do not execvp the command directly from run_init; since it would run
* under with a pty under sysadm_devpts_t. Instead, we call open_init_tty,
diff --git a/policycoreutils/sandbox/Makefile b/policycoreutils/sandbox/Makefile
index b817364..981c56c 100644
--- a/policycoreutils/sandbox/Makefile
+++ b/policycoreutils/sandbox/Makefile
@@ -1,6 +1,5 @@
# Installation directories.
PREFIX ?= $(DESTDIR)/usr
-INITDIR ?= $(DESTDIR)/etc/rc.d/init.d/
SYSCONFDIR ?= $(DESTDIR)/etc/sysconfig
LIBDIR ?= $(PREFIX)/lib
BINDIR ?= $(PREFIX)/bin
@@ -29,8 +28,6 @@ install: all
-mkdir -p $(SHAREDIR)
install -m 755 sandboxX.sh $(SHAREDIR)
install -m 755 start $(SHAREDIR)
- -mkdir -p $(INITDIR)
- install -m 755 sandbox.init $(INITDIR)/sandbox
-mkdir -p $(SYSCONFDIR)
install -m 644 sandbox.conf $(SYSCONFDIR)/sandbox
diff --git a/policycoreutils/sandbox/sandbox.conf b/policycoreutils/sandbox/sandbox.conf
index 7c35808..cbab91d 100644
--- a/policycoreutils/sandbox/sandbox.conf
+++ b/policycoreutils/sandbox/sandbox.conf
@@ -1,5 +1,3 @@
-# Space separate list of homedirs
-HOMEDIRS="/home"
# Control group configuration
NAME=sandbox
CPUAFFINITY=ALL
diff --git a/policycoreutils/sandbox/seunshare.c b/policycoreutils/sandbox/seunshare.c
index c493e98..a084e0e 100644
--- a/policycoreutils/sandbox/seunshare.c

View File

@ -7,7 +7,7 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.1.10
Release: 7%{?dist}
Release: 8%{?dist}
License: GPLv2
Group: System Environment/Base
# Based on git repository with tag 20101221
@ -74,7 +74,6 @@ make -C sepolgen-%{sepolgenver} LSPP_PRIV=y LIBDIR="%{_libdir}" CFLAGS="%{optfla
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
mkdir -p %{buildroot}/var/lib/selinux
mkdir -p %{buildroot}%{_bindir}
mkdir -p %{buildroot}%{_sbindir}
@ -84,7 +83,6 @@ mkdir -p %{buildroot}%{_mandir}/man5
mkdir -p %{buildroot}%{_mandir}/man8
mkdir -p %{buildroot}%{_sysconfdir}/pam.d
mkdir -p %{buildroot}%{_sysconfdir}/security/console.apps
%{__mkdir} -p %{buildroot}/%{_sysconfdir}/rc.d/init.d
%{__mkdir} -p %{buildroot}%{_datadir}/icons/hicolor/24x24/apps
%{__mkdir} -p %{buildroot}%{_datadir}/pixmaps
%{__mkdir} -p %{buildroot}/%{_usr}/share/doc/%{name}-%{version}/
@ -279,7 +277,6 @@ rm -rf %{buildroot}
%{_bindir}/semodule_link
%{_bindir}/semodule_package
%{_bindir}/semodule_unpackage
%{_sysconfdir}/rc.d/init.d/sandbox
%config(noreplace) %{_sysconfdir}/sysconfig/sandbox
%config(noreplace) %{_sysconfdir}/pam.d/run_init
%config(noreplace) %{_sysconfdir}/sestatus.conf
@ -358,6 +355,9 @@ fi
/bin/systemctl try-restart restorecond.service >/dev/null 2>&1 || :
%changelog
* Mon Jan 16 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.10-8
- Remove sandbox init script, should no longer be necessary
* Sun Jan 15 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.10-7
- Add unit file support to sepolgen, and cleanup some of the output.