diff --git a/policycoreutils-gui.patch b/policycoreutils-gui.patch
index e0a00c0..817b416 100644
--- a/policycoreutils-gui.patch
+++ b/policycoreutils-gui.patch
@@ -752,8 +752,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py poli
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-2.0.31/gui/modulesPage.py
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.31/gui/modulesPage.py 2007-10-15 16:55:03.000000000 -0400
-@@ -0,0 +1,181 @@
++++ policycoreutils-2.0.31/gui/modulesPage.py 2007-10-16 23:32:51.000000000 -0400
+@@ -0,0 +1,187 @@
+## modulesPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@@ -805,6 +805,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+ self.module_filter = xml.get_widget("modulesFilterEntry")
+ self.module_filter.connect("focus_out_event", self.filter_changed)
+ self.module_filter.connect("activate", self.filter_changed)
++ self.audit_enabled = False
+
+ self.store = gtk.ListStore(gobject.TYPE_STRING, gobject.TYPE_STRING)
+ self.view.set_model(self.store)
@@ -817,8 +818,6 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+ col = gtk.TreeViewColumn(_("Version"), gtk.CellRendererText(), text = 1)
+ self.enable_audit_button = xml.get_widget("enableAuditButton")
+ self.enable_audit_button.connect("clicked", self.enable_audit)
-+ self.disable_audit_button = xml.get_widget("disableAuditButton")
-+ self.disable_audit_button.connect("clicked", self.disable_audit)
+ self.new_button = xml.get_widget("newModuleButton")
+ self.new_button.connect("clicked", self.new_module)
+ col.set_sort_column_id(1)
@@ -881,8 +880,15 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+ self.error(e.args[0])
+
+ def enable_audit(self, button):
++ self.audit_enabled = not self.audit_enabled
+ try:
-+ status, output =commands.getstatusoutput("semodule -b /usr/share/selinux/%s/enableaudit.pp" % self.policy_type)
++ if self.audit_enabled:
++ status, output =commands.getstatusoutput("semodule -DB")
++ button.set_label(_("Disable Audit"))
++ else:
++ status, output =commands.getstatusoutput("semodule -B")
++ button.set_label(_("Enable Audit"))
++
+ if status != 0:
+ self.error(output)
+
@@ -891,7 +897,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+
+ def disable_audit(self, button):
+ try:
-+ status, output =commands.getstatusoutput("semodule -b /usr/share/selinux/%s/base.pp" % self.policy_type)
++ status, output =commands.getstatusoutput("semodule -B")
+ if status != 0:
+ self.error(output)
+
@@ -6318,8 +6324,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policy
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-2.0.31/gui/system-config-selinux.glade
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.31/gui/system-config-selinux.glade 2007-10-15 16:55:03.000000000 -0400
-@@ -0,0 +1,3339 @@
++++ policycoreutils-2.0.31/gui/system-config-selinux.glade 2007-10-16 23:32:02.000000000 -0400
+@@ -0,0 +1,3321 @@
+
+
+
@@ -9472,7 +9478,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+
+ True
-+ Enable additional audit rules, that are normally not reported in the log files.
++ Enable/Disable additional audit rules, that are normally not reported in the log files.
+ Enable Audit
+ True
+ gtk-zoom-in
@@ -9486,24 +9492,6 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ True
+
+
-+
-+
-+
-+ True
-+ Disable additional audit rules, that are normally not reported in the log files.
-+ Disable Audit
-+ True
-+ gtk-zoom-out
-+ True
-+ True
-+ False
-+
-+
-+
-+ False
-+ True
-+
-+
+
+
+ 0
diff --git a/policycoreutils.spec b/policycoreutils.spec
index 699bf6d..e97554f 100644
--- a/policycoreutils.spec
+++ b/policycoreutils.spec
@@ -6,7 +6,7 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.0.31
-Release: 4%{?dist}
+Release: 5%{?dist}
License: GPLv2+
Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@@ -205,6 +205,9 @@ if [ "$1" -ge "1" ]; then
fi
%changelog
+* Tue Oct 16 2007 Dan Walsh 2.0.31-5
+- Fix enable/disable audit messages
+
* Mon Oct 15 2007 Dan Walsh 2.0.31-4
- Add booleans page