* Fri Jun 1 2007 Dan Walsh <dwalsh@redhat.com> 2.0.19-2
- Fix genhomedircon to work in stage2 builds of anaconda
This commit is contained in:
parent
6f8d76967a
commit
2b62f3a02f
@ -1,6 +1,6 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.16/audit2allow/Makefile
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.19/audit2allow/Makefile
|
||||
--- nsapolicycoreutils/audit2allow/Makefile 2007-02-07 12:11:49.000000000 -0500
|
||||
+++ policycoreutils-2.0.16/audit2allow/Makefile 2007-05-17 13:43:57.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/audit2allow/Makefile 2007-06-01 10:29:17.000000000 -0400
|
||||
@@ -1,6 +1,7 @@
|
||||
# Installation directories.
|
||||
PREFIX ?= ${DESTDIR}/usr
|
||||
@ -18,18 +18,18 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
-mkdir -p $(MANDIR)/man1
|
||||
install -m 644 audit2allow.1 $(MANDIR)/man1/
|
||||
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.16/Makefile
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.19/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2007-05-18 09:58:33.000000000 -0400
|
||||
+++ policycoreutils-2.0.16/Makefile 2007-05-17 13:43:57.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/Makefile 2007-06-01 10:29:17.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.16/restorecond/restorecond.c
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.19/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-02-22 08:53:22.000000000 -0500
|
||||
+++ policycoreutils-2.0.16/restorecond/restorecond.c 2007-05-17 13:43:57.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/restorecond/restorecond.c 2007-06-01 10:29:17.000000000 -0400
|
||||
@@ -210,9 +210,10 @@
|
||||
}
|
||||
|
||||
@ -56,9 +56,30 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
}
|
||||
free(scontext);
|
||||
close(fd);
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.16/semanage/seobject.py
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-2.0.19/scripts/genhomedircon
|
||||
--- nsapolicycoreutils/scripts/genhomedircon 2007-05-18 09:58:33.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/scripts/genhomedircon 2007-06-01 10:29:32.000000000 -0400
|
||||
@@ -193,7 +193,7 @@
|
||||
return prefix
|
||||
|
||||
def adduser(self, udict, user, seuser, prefix):
|
||||
- if seuser == "user_u" or user == "__default__" or user == "system_u":
|
||||
+ if seuser == self.default_user or user == "__default__" or user == "system_u":
|
||||
return
|
||||
# !!! chooses first prefix in the list to use in the file context !!!
|
||||
try:
|
||||
@@ -263,7 +263,7 @@
|
||||
i = i.replace("system_u", seuser)
|
||||
# Validate if the generated context exists. Some user types may not exist
|
||||
scon = i.split()[-1]
|
||||
- if selinux.security_check_context(scon) == 0:
|
||||
+ if selinux.is_selinux_enabled() < 1 or selinux.security_check_context(scon) == 0:
|
||||
ret = ret+i
|
||||
fd.close()
|
||||
return ret
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.19/semanage/seobject.py
|
||||
--- nsapolicycoreutils/semanage/seobject.py 2007-04-12 12:43:06.000000000 -0400
|
||||
+++ policycoreutils-2.0.16/semanage/seobject.py 2007-05-17 13:43:57.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/semanage/seobject.py 2007-06-01 10:29:17.000000000 -0400
|
||||
@@ -210,6 +210,7 @@
|
||||
os.write(fd, self.out())
|
||||
os.close(fd)
|
||||
|
@ -6,7 +6,7 @@
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 2.0.19
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -192,6 +192,9 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Jun 1 2007 Dan Walsh <dwalsh@redhat.com> 2.0.19-2
|
||||
- Fix genhomedircon to work in stage2 builds of anaconda
|
||||
|
||||
* Fri May 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.19-1
|
||||
- Update to match NSA
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user