* Mon Sep 24 2007 Dan Walsh <dwalsh@redhat.com> 2.0.26-2

- Fixed spelling mistakes in booleans defs
- Update po
This commit is contained in:
Daniel J Walsh 2007-09-24 16:22:03 +00:00
parent 1452353611
commit 1f2b67a04d
3 changed files with 306585 additions and 3095 deletions

View File

@ -1,14 +1,13 @@
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-2.0.26/gui/booleansPage.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-2.0.26/gui/booleansPage.py
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/booleansPage.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/booleansPage.py 2007-09-24 12:20:29.000000000 -0400
@@ -0,0 +1,226 @@ @@ -0,0 +1,236 @@
+# +#
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel +# booleansPage.py - GUI for Booleans page in system-config-securitylevel
+# +#
+# Brent Fox <bfox@redhat.com>
+# Dan Walsh <dwalsh@redhat.com> +# Dan Walsh <dwalsh@redhat.com>
+# +#
+# Copyright 2006 Red Hat, Inc. +# Copyright 2006, 2007 Red Hat, Inc.
+# +#
+# This program is free software; you can redistribute it and/or modify +# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by +# it under the terms of the GNU General Public License as published by
@ -30,6 +29,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+import gobject +import gobject
+import sys +import sys
+import tempfile +import tempfile
+import seobject
+ +
+INSTALLPATH='/usr/share/system-config-selinux' +INSTALLPATH='/usr/share/system-config-selinux'
+sys.path.append(INSTALLPATH) +sys.path.append(INSTALLPATH)
@ -87,6 +87,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+ try: + try:
+ return _(self.translation[key][0]) + return _(self.translation[key][0])
+ except: + except:
+ #print key, "missing translation"
+ return _("Other") + return _("Other")
+ +
+ def get_value(self,key): + def get_value(self,key):
@ -156,6 +157,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+class booleansPage: +class booleansPage:
+ def __init__(self, xml, doDebug=None): + def __init__(self, xml, doDebug=None):
+ self.xml = xml + self.xml = xml
+ self.local = False
+ self.types=[] + self.types=[]
+ self.selinuxsupport = True + self.selinuxsupport = True
+ self.translation = Translation() + self.translation = Translation()
@ -190,12 +192,12 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+ col = gtk.TreeViewColumn("", gtk.CellRendererText(), text=1) + col = gtk.TreeViewColumn("", gtk.CellRendererText(), text=1)
+ self.booleansView.append_column(col) + self.booleansView.append_column(col)
+ self.filter="" + self.filter=""
+ self.refreshBooleans(self.filter) + self.load(self.filter)
+ +
+ def filter_changed(self, *arg): + def filter_changed(self, *arg):
+ filter = arg[0].get_text() + filter = arg[0].get_text()
+ if filter != self.filter: + if filter != self.filter:
+ self.refreshBooleans(filter) + self.load(filter)
+ self.filter=filter + self.filter=filter
+ +
+ def use_menus(self): + def use_menus(self):
@ -204,18 +206,15 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+ def get_description(self): + def get_description(self):
+ return _("Boolean") + return _("Boolean")
+ +
+ def refreshBooleans(self, filter=None): + def load(self, filter=None):
+ self.modifiers=Modifiers(self.booleansStore) + self.modifiers=Modifiers(self.booleansStore)
+ booleansList=commands.getoutput("/usr/sbin/getsebool -a").split("\n") + booleans=seobject.booleanRecords()
+ for i in booleansList: + booleansList=booleans.get_all(self.local)
+ rec=i.split() +# booleansList=commands.getoutput("/usr/sbin/getsebool -a").split("\n")
+ name=rec[0] + for name in booleansList:
+ rec=booleansList[name]
+ if self.translation.match(name, filter): + if self.translation.match(name, filter):
+ if rec[2]=="on" or rec[2]=="active": + self.modifiers.add(name,Boolean(name,rec[2] == 1))
+ on=1
+ else:
+ on=0
+ self.modifiers.add(name,Boolean(name,on))
+ +
+ def boolean_toggled(self, widget, row): + def boolean_toggled(self, widget, row):
+ if len(row) == 1: + if len(row) == 1:
@ -228,9 +227,20 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+ +
+ setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val) + setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val)
+ commands.getstatusoutput(setsebool) + commands.getstatusoutput(setsebool)
+
+ def on_local_clicked(self, button):
+ self.local = not self.local
+ if self.local:
+ button.set_label(_("all"))
+ else:
+ button.set_label(_("Customized"))
+
+ self.load(self.filter)
+ return True
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-2.0.26/gui/fcontextPage.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-2.0.26/gui/fcontextPage.py
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/fcontextPage.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/fcontextPage.py 2007-09-24 12:20:52.000000000 -0400
@@ -0,0 +1,209 @@ @@ -0,0 +1,209 @@
+## fcontextPage.py - show selinux mappings +## fcontextPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc. +## Copyright (C) 2006 Red Hat, Inc.
@ -350,7 +360,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ def load(self, filter=""): + def load(self, filter=""):
+ self.filter=filter + self.filter=filter
+ self.fcontext=seobject.fcontextRecords() + self.fcontext=seobject.fcontextRecords()
+ fcon_list=self.fcontext.get_all() + fcon_list=self.fcontext.get_all(self.local)
+ self.store.clear() + self.store.clear()
+ for fcon in fcon_list: + for fcon in fcon_list:
+ if not self.match(fcon, filter): + if not self.match(fcon, filter):
@ -369,7 +379,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ filter = arg[0].get_text() + filter = arg[0].get_text()
+ if filter != self.filter: + if filter != self.filter:
+ self.load(filter) + self.load(filter)
+ +
+ def dialogInit(self): + def dialogInit(self):
+ store, iter = self.view.get_selection().get_selected() + store, iter = self.view.get_selection().get_selected()
+ self.fcontextEntry.set_text(store.get_value(iter, SPEC_COL)) + self.fcontextEntry.set_text(store.get_value(iter, SPEC_COL))
@ -443,7 +453,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ self.store.set_value(iter, TYPE_COL, "system_u:object_r:%s:%s" % (type, mls)) + self.store.set_value(iter, TYPE_COL, "system_u:object_r:%s:%s" % (type, mls))
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-2.0.26/gui/loginsPage.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-2.0.26/gui/loginsPage.py
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/loginsPage.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/loginsPage.py 2007-09-24 12:20:58.000000000 -0400
@@ -0,0 +1,179 @@ @@ -0,0 +1,179 @@
+## loginsPage.py - show selinux mappings +## loginsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc. +## Copyright (C) 2006 Red Hat, Inc.
@ -514,7 +524,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policy
+ def load(self, filter = ""): + def load(self, filter = ""):
+ self.filter=filter + self.filter=filter
+ self.login = seobject.loginRecords() + self.login = seobject.loginRecords()
+ dict = self.login.get_all() + dict = self.login.get_all(0)
+ keys = dict.keys() + keys = dict.keys()
+ keys.sort() + keys.sort()
+ self.store.clear() + self.store.clear()
@ -538,7 +548,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policy
+ self.loginsSelinuxUserCombo.pack_start(cell, True) + self.loginsSelinuxUserCombo.pack_start(cell, True)
+ self.loginsSelinuxUserCombo.add_attribute(cell, 'text', 0) + self.loginsSelinuxUserCombo.add_attribute(cell, 'text', 0)
+ +
+ selusers = seobject.seluserRecords().get_all() + selusers = seobject.seluserRecords().get_all(0)
+ keys = selusers.keys() + keys = selusers.keys()
+ keys.sort() + keys.sort()
+ for k in keys: + for k in keys:
@ -664,7 +674,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/Makefile policycoreu
+relabel: +relabel:
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-2.0.26/gui/mappingsPage.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-2.0.26/gui/mappingsPage.py
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/mappingsPage.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/mappingsPage.py 2007-09-24 12:21:12.000000000 -0400
@@ -0,0 +1,56 @@ @@ -0,0 +1,56 @@
+## mappingsPage.py - show selinux mappings +## mappingsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc. +## Copyright (C) 2006 Red Hat, Inc.
@ -716,7 +726,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py poli
+ self.store.set_sort_column_id(0, gtk.SORT_ASCENDING) + self.store.set_sort_column_id(0, gtk.SORT_ASCENDING)
+ self.view.set_model(self.store) + self.view.set_model(self.store)
+ self.login = loginRecords() + self.login = loginRecords()
+ dict = self.login.get_all() + dict = self.login.get_all(0)
+ keys = dict.keys() + keys = dict.keys()
+ keys.sort() + keys.sort()
+ for k in keys: + for k in keys:
@ -4774,9 +4784,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/portsPage.py policyc
+ +
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-2.0.26/gui/selinux.tbl diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-2.0.26/gui/selinux.tbl
--- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/selinux.tbl 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/selinux.tbl 2007-09-24 12:14:07.000000000 -0400
@@ -0,0 +1,296 @@ @@ -0,0 +1,295 @@
+allow_console_login _("Login") _("Allow direct login to the console device. Requiered for System 390") +! allow_console_login _("Login") _("Allow direct login to the console device. Required for System 390")
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon") +acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
+allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow") +allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow")
+allow_daemons_dump_core _("Admin") _("Allow all daemons to write corefiles to /") +allow_daemons_dump_core _("Admin") _("Allow all daemons to write corefiles to /")
@ -4784,7 +4794,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+allow_execheap _("Memory Protection") _("Allow unconfined executables to make their heap memory executable. Doing this is a really bad idea. Probably indicates a badly coded executable, but could indicate an attack. This executable should be reported in bugzilla") +allow_execheap _("Memory Protection") _("Allow unconfined executables to make their heap memory executable. Doing this is a really bad idea. Probably indicates a badly coded executable, but could indicate an attack. This executable should be reported in bugzilla")
+allow_execmem _("Memory Protection") _("Allow unconfined executables to map a memory region as both executable and writable, this is dangerous and the executable should be reported in bugzilla") +allow_execmem _("Memory Protection") _("Allow unconfined executables to map a memory region as both executable and writable, this is dangerous and the executable should be reported in bugzilla")
+allow_execmod _("Memory Protection") _("Allow all unconfined executables to use libraries requiring text relocation that are not labeled textrel_shlib_t") +allow_execmod _("Memory Protection") _("Allow all unconfined executables to use libraries requiring text relocation that are not labeled textrel_shlib_t")
+allow_execstack _("Memory Protection") _("Allow unconfined executables to make their stack executable. This should never, ever be neessary. Probably indicates a badly coded executable, but could indicate an attack. This executable should be reported in bugzilla") +allow_execstack _("Memory Protection") _("Allow unconfined executables to make their stack executable. This should never, ever be necessary. Probably indicates a badly coded executable, but could indicate an attack. This executable should be reported in bugzilla")
+allow_ftpd_full_access _("FTP") _("Allow ftpd to full access to the system") +allow_ftpd_full_access _("FTP") _("Allow ftpd to full access to the system")
+allow_ftpd_anon_write _("FTP") _("Allow ftpd to upload files to directories labeled public_content_rw_t") +allow_ftpd_anon_write _("FTP") _("Allow ftpd to upload files to directories labeled public_content_rw_t")
+allow_ftpd_use_cifs _("FTP") _("Allow ftp servers to use cifs used for public file transfer services") +allow_ftpd_use_cifs _("FTP") _("Allow ftp servers to use cifs used for public file transfer services")
@ -4803,7 +4813,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+allow_mounton_anydir _("Mount") _("Allow mount to mount any directory") +allow_mounton_anydir _("Mount") _("Allow mount to mount any directory")
+allow_mplayer_execstack _("Memory Protection") _("Allow mplayer executable stack") +allow_mplayer_execstack _("Memory Protection") _("Allow mplayer executable stack")
+allow_nfsd_anon_write _("NFS") _("Allow nfs servers to modify public files used for public file transfer services") +allow_nfsd_anon_write _("NFS") _("Allow nfs servers to modify public files used for public file transfer services")
+allow_polyinstantiation _("Polyinstatiation") _("Enable polyinstantiated directory support") +allow_polyinstantiation _("Polyinstantiation") _("Enable polyinstantiated directory support")
+allow_ptrace _("Compatibility") _("Allow sysadm_t to debug or ptrace applications") +allow_ptrace _("Compatibility") _("Allow sysadm_t to debug or ptrace applications")
+allow_rsync_anon_write _("rsync") _("Allow rsync to write files in directories labeled public_content_rw_t") +allow_rsync_anon_write _("rsync") _("Allow rsync to write files in directories labeled public_content_rw_t")
+allow_smbd_anon_write _("Samba") _("Allow Samba to write files in directories labeled public_content_rw_t") +allow_smbd_anon_write _("Samba") _("Allow Samba to write files in directories labeled public_content_rw_t")
@ -4854,7 +4864,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+cpuspeed_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for cpuspeed daemon") +cpuspeed_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for cpuspeed daemon")
+cron_can_relabel _("Cron") _("Allow system cron jobs to relabel filesystem for restoring file contexts") +cron_can_relabel _("Cron") _("Allow system cron jobs to relabel filesystem for restoring file contexts")
+crond_disable_trans _("Cron") _("Disable SELinux protection for crond daemon") +crond_disable_trans _("Cron") _("Disable SELinux protection for crond daemon")
+cupsd_config_disable_trans _("Printing") _("Disable SELinux protection for cupsd backend server") +cupsd_config_disable_trans _("Printing") _("Disable SELinux protection for cupsd back end server")
+cupsd_disable_trans _("Printing") _("Disable SELinux protection for cupsd daemon") +cupsd_disable_trans _("Printing") _("Disable SELinux protection for cupsd daemon")
+cupsd_lpd_disable_trans _("Printing") _("Disable SELinux protection for cupsd_lpd") +cupsd_lpd_disable_trans _("Printing") _("Disable SELinux protection for cupsd_lpd")
+cvs_disable_trans _("CVS") _("Disable SELinux protection for cvs daemon") +cvs_disable_trans _("CVS") _("Disable SELinux protection for cvs daemon")
@ -4890,7 +4900,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+global_ssp _("Admin") _("This should be enabled when all programs are compiled with ProPolice/SSP stack smashing protection. All domains will be allowed to read from /dev/urandom") +global_ssp _("Admin") _("This should be enabled when all programs are compiled with ProPolice/SSP stack smashing protection. All domains will be allowed to read from /dev/urandom")
+gpm_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for gpm daemon") +gpm_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for gpm daemon")
+gssd_disable_trans _("NFS") _("Disable SELinux protection for gss daemon") +gssd_disable_trans _("NFS") _("Disable SELinux protection for gss daemon")
+hald_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for hal daemon") +hald_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for Hal daemon")
+hide_broken_symptoms _("Compatibility") _("Do not audit things that we know to be broken but which are not security risks") +hide_broken_symptoms _("Compatibility") _("Do not audit things that we know to be broken but which are not security risks")
+hostname_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for hostname daemon") +hostname_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for hostname daemon")
+hotplug_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for hotplug daemon") +hotplug_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for hotplug daemon")
@ -4998,7 +5008,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+secure_mode_policyload _("Admin") _("Do not allow any processes to modify kernel SELinux policy") +secure_mode_policyload _("Admin") _("Do not allow any processes to modify kernel SELinux policy")
+sendmail_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for sendmail daemon") +sendmail_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for sendmail daemon")
+setrans_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for setrans") +setrans_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for setrans")
+setroubleshootd_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for setroublesoot daemon") +setroubleshootd_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for setroubleshoot daemon")
+slapd_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for slapd daemon") +slapd_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for slapd daemon")
+slrnpull_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for slrnpull daemon") +slrnpull_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for slrnpull daemon")
+smbd_disable_trans _("Samba") _("Disable SELinux protection for smbd daemon") +smbd_disable_trans _("Samba") _("Disable SELinux protection for smbd daemon")
@ -5006,10 +5016,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+snort_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for snort daemon") +snort_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for snort daemon")
+soundd_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for soundd daemon") +soundd_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for soundd daemon")
+sound_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for sound daemon") +sound_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for sound daemon")
+spamassassin_can_network _("Spam Assassin") _("Allow Spam Assasin daemon network access") +spamd_disable_trans _("Spam Protection") _("Disable SELinux protection for spamd daemon")
+spamd_disable_trans _("spam Protection") _("Disable SELinux protection for spamd daemon") +spamd_enable_home_dirs _("Spam Protection") _("Allow spamd to access home directories")
+spamd_enable_home_dirs _("spam Protection") _("Allow spamd to access home directories") +spamassassin_can_network _("Spam Protection") _("Allow Spam Assassin daemon network access")
+spammassasin_can_network _("spam Protection") _("Allow spammassasin to access the network")
+speedmgmt_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for speedmgmt daemon") +speedmgmt_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for speedmgmt daemon")
+squid_connect_any _("Squid") _("Allow squid daemon to connect to the network") +squid_connect_any _("Squid") _("Allow squid daemon to connect to the network")
+squid_disable_trans _("Squid") _("Disable SELinux protection for squid daemon") +squid_disable_trans _("Squid") _("Disable SELinux protection for squid daemon")
@ -5057,7 +5066,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+xend_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for xen daemon") +xend_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for xen daemon")
+xen_use_raw_disk _("XEN") _("Allow xen to read/write physical disk devices") +xen_use_raw_disk _("XEN") _("Allow xen to read/write physical disk devices")
+xfs_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for xfs daemon") +xfs_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for xfs daemon")
+xm_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for xen constrol") +xm_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for xen control")
+ypbind_disable_trans _("NIS") _("Disable SELinux protection for ypbind daemon") +ypbind_disable_trans _("NIS") _("Disable SELinux protection for ypbind daemon")
+yppasswdd_disable_trans _("NIS") _("Disable SELinux protection for NIS Password Daemon") +yppasswdd_disable_trans _("NIS") _("Disable SELinux protection for NIS Password Daemon")
+ypserv_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for ypserv daemon") +ypserv_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for ypserv daemon")
@ -5069,13 +5078,13 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+samba_export_all_ro _("Samba") _("Allow Samba to share any file/directory read only") +samba_export_all_ro _("Samba") _("Allow Samba to share any file/directory read only")
+samba_export_all_rw _("Samba") _("Allow Samba to share any file/directory read/write") +samba_export_all_rw _("Samba") _("Allow Samba to share any file/directory read/write")
+samba_run_unconfined _("Samba") _("Allow Samba to run unconfined scripts in /var/lib/samba/scripts directory") +samba_run_unconfined _("Samba") _("Allow Samba to run unconfined scripts in /var/lib/samba/scripts directory")
+webadm_manage_user_files _("HTTPD Service") _("Allow SELinux webadm user to manage unprivledged users home directories") +webadm_manage_user_files _("HTTPD Service") _("Allow SELinux webadm user to manage unprivileged users home directories")
+webadm_read_user_files _("HTTPD Service") _("Allow SELinux webadm user to read unprivledged users home directories") +webadm_read_user_files _("HTTPD Service") _("Allow SELinux webadm user to read unprivileged users home directories")
+ +
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-2.0.26/gui/semanagePage.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-2.0.26/gui/semanagePage.py
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/semanagePage.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/semanagePage.py 2007-09-24 12:19:55.000000000 -0400
@@ -0,0 +1,136 @@ @@ -0,0 +1,147 @@
+## semanagePage.py - show selinux mappings +## semanagePage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc. +## Copyright (C) 2006 Red Hat, Inc.
+ +
@ -5121,6 +5130,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py poli
+class semanagePage: +class semanagePage:
+ def __init__(self, xml, name, description): + def __init__(self, xml, name, description):
+ self.xml = xml + self.xml = xml
+ self.local = False
+ self.view = xml.get_widget("%sView" % name) + self.view = xml.get_widget("%sView" % name)
+ self.dialog = xml.get_widget("%sDialog" % name) + self.dialog = xml.get_widget("%sDialog" % name)
+ self.filter_entry = xml.get_widget("%sFilterEntry" % name ) + self.filter_entry = xml.get_widget("%sFilterEntry" % name )
@ -5212,6 +5222,16 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py poli
+ self.dialog.hide() + self.dialog.hide()
+ +
+ +
+ def on_local_clicked(self, button):
+ self.local = not self.local
+ if self.local:
+ button.set_label(_("all"))
+ else:
+ button.set_label(_("Customized"))
+
+ self.load(self.filter)
+ return True
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-2.0.26/gui/statusPage.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-2.0.26/gui/statusPage.py
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/statusPage.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/statusPage.py 2007-09-18 16:40:57.000000000 -0400
@ -5437,8 +5457,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policy
+ +
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-2.0.26/gui/system-config-selinux.glade diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-2.0.26/gui/system-config-selinux.glade
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/system-config-selinux.glade 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/system-config-selinux.glade 2007-09-24 12:19:05.000000000 -0400
@@ -0,0 +1,3326 @@ @@ -0,0 +1,3393 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*--> +<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd"> +<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
+ +
@ -7317,6 +7337,55 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ <property name="spacing">0</property> + <property name="spacing">0</property>
+ +
+ <child> + <child>
+ <widget class="GtkToolbar" id="toolbar9">
+ <property name="visible">True</property>
+ <property name="orientation">GTK_ORIENTATION_HORIZONTAL</property>
+ <property name="toolbar_style">GTK_TOOLBAR_BOTH</property>
+ <property name="tooltips">True</property>
+ <property name="show_arrow">True</property>
+
+ <child>
+ <widget class="GtkToolButton" id="toolbutton33">
+ <property name="visible">True</property>
+ <property name="tooltip" translatable="yes">Revert boolean setting to default</property>
+ <property name="stock_id">gtk-revert-to-saved</property>
+ <property name="visible_horizontal">True</property>
+ <property name="visible_vertical">True</property>
+ <property name="is_important">False</property>
+ <signal name="clicked" handler="on_delete_clicked" last_modification_time="Mon, 16 Jan 2006 18:26:29 GMT"/>
+ </widget>
+ <packing>
+ <property name="expand">False</property>
+ <property name="homogeneous">True</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkToolButton" id="toolbutton34">
+ <property name="visible">True</property>
+ <property name="tooltip" translatable="yes">Toggle between Customized and All Booleans</property>
+ <property name="label" translatable="yes">Customized</property>
+ <property name="use_underline">True</property>
+ <property name="stock_id">gtk-find</property>
+ <property name="visible_horizontal">True</property>
+ <property name="visible_vertical">True</property>
+ <property name="is_important">False</property>
+ <signal name="clicked" handler="on_local_clicked" last_modification_time="Wed, 19 Sep 2007 19:14:08 GMT"/>
+ </widget>
+ <packing>
+ <property name="expand">False</property>
+ <property name="homogeneous">True</property>
+ </packing>
+ </child>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkHBox" id="hbox7"> + <widget class="GtkHBox" id="hbox7">
+ <property name="visible">True</property> + <property name="visible">True</property>
+ <property name="homogeneous">False</property> + <property name="homogeneous">False</property>
@ -7494,6 +7563,24 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ <property name="homogeneous">True</property> + <property name="homogeneous">True</property>
+ </packing> + </packing>
+ </child> + </child>
+
+ <child>
+ <widget class="GtkToolButton" id="customizedButton">
+ <property name="visible">True</property>
+ <property name="tooltip" translatable="yes">Toggle between all and customized file context</property>
+ <property name="label" translatable="yes">Customized</property>
+ <property name="use_underline">True</property>
+ <property name="stock_id">gtk-find</property>
+ <property name="visible_horizontal">True</property>
+ <property name="visible_vertical">True</property>
+ <property name="is_important">False</property>
+ <signal name="clicked" handler="on_local_clicked" last_modification_time="Wed, 19 Sep 2007 19:14:08 GMT"/>
+ </widget>
+ <packing>
+ <property name="expand">False</property>
+ <property name="homogeneous">True</property>
+ </packing>
+ </child>
+ </widget> + </widget>
+ <packing> + <packing>
+ <property name="padding">0</property> + <property name="padding">0</property>
@ -8767,8 +8854,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+</glade-interface> +</glade-interface>
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-2.0.26/gui/system-config-selinux.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-2.0.26/gui/system-config-selinux.py
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.26/gui/system-config-selinux.py 2007-09-18 16:40:57.000000000 -0400 +++ policycoreutils-2.0.26/gui/system-config-selinux.py 2007-09-24 12:19:26.000000000 -0400
@@ -0,0 +1,171 @@ @@ -0,0 +1,175 @@
+#!/usr/bin/python +#!/usr/bin/python
+# +#
+# system-config-selinux.py - GUI for SELinux Config tool in system-config-selinux +# system-config-selinux.py - GUI for SELinux Config tool in system-config-selinux
@ -8849,6 +8936,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ xml.signal_connect("on_delete_clicked", self.delete) + xml.signal_connect("on_delete_clicked", self.delete)
+ xml.signal_connect("on_add_clicked", self.add) + xml.signal_connect("on_add_clicked", self.add)
+ xml.signal_connect("on_properties_clicked", self.properties) + xml.signal_connect("on_properties_clicked", self.properties)
+ xml.signal_connect("on_local_clicked", self.on_local_clicked)
+ self.add_page(statusPage.statusPage(xml)) + self.add_page(statusPage.statusPage(xml))
+ if selinux.is_selinux_enabled() > 0: + if selinux.is_selinux_enabled() > 0:
+ self.add_page(booleansPage.booleansPage(xml)) + self.add_page(booleansPage.booleansPage(xml))
@ -8885,6 +8973,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ def properties(self, args): + def properties(self, args):
+ self.tabs[self.notebook.get_current_page()].propertiesDialog() + self.tabs[self.notebook.get_current_page()].propertiesDialog()
+ +
+ def on_local_clicked(self, button):
+ self.tabs[self.notebook.get_current_page()].on_local_clicked(button)
+
+ def on_about_activate(self, args): + def on_about_activate(self, args):
+ dlg = xml.get_widget ("aboutWindow") + dlg = xml.get_widget ("aboutWindow")
+ dlg.run () + dlg.run ()

File diff suppressed because it is too large Load Diff

View File

@ -6,7 +6,7 @@
Summary: SELinux policy core utilities Summary: SELinux policy core utilities
Name: policycoreutils Name: policycoreutils
Version: 2.0.26 Version: 2.0.26
Release: 1%{?dist} Release: 2%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Base Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@ -199,6 +199,10 @@ if [ "$1" -ge "1" ]; then
fi fi
%changelog %changelog
* Mon Sep 24 2007 Dan Walsh <dwalsh@redhat.com> 2.0.26-2
- Fixed spelling mistakes in booleans defs
- Update po
* Tue Sep 18 2007 Dan Walsh <dwalsh@redhat.com> 2.0.26-1 * Tue Sep 18 2007 Dan Walsh <dwalsh@redhat.com> 2.0.26-1
- Update to upstream - Update to upstream
* Fix setfiles selabel option flag setting for 64-bit from Stephen Smalley. * Fix setfiles selabel option flag setting for 64-bit from Stephen Smalley.