* Mon Jul 23 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-7
- Fix fixfiles to report incorrect rpm - Patch provided by Tony Nelson
This commit is contained in:
parent
e0e7edadda
commit
18e5e753c6
@ -1,6 +1,6 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.22/audit2allow/Makefile
|
||||
--- nsapolicycoreutils/audit2allow/Makefile 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/audit2allow/Makefile 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/audit2allow/Makefile 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -1,6 +1,7 @@
|
||||
# Installation directories.
|
||||
PREFIX ?= ${DESTDIR}/usr
|
||||
@ -18,19 +18,29 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
-mkdir -p $(MANDIR)/man1
|
||||
install -m 644 audit2allow.1 $(MANDIR)/man1/
|
||||
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/ChangeLog policycoreutils-2.0.22/ChangeLog
|
||||
--- nsapolicycoreutils/ChangeLog 2007-07-16 14:20:43.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/ChangeLog 2007-06-21 05:17:13.000000000 -0400
|
||||
@@ -91,7 +91,6 @@
|
||||
1.33.15 2007-01-17
|
||||
* Merged unicode-to-string fix for seobject audit from Dan Walsh.
|
||||
* Merged man page updates to make "apropos selinux" work from Dan Walsh.
|
||||
-
|
||||
1.33.14 2007-01-16
|
||||
* Merged newrole man page patch from Michael Thompson.
|
||||
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.22/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/Makefile 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/Makefile 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
Binary files nsapolicycoreutils/newrole/newrole and policycoreutils-2.0.22/newrole/newrole differ
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/Makefile policycoreutils-2.0.22/restorecond/Makefile
|
||||
--- nsapolicycoreutils/restorecond/Makefile 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/Makefile 2007-07-20 12:02:59.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/Makefile 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
-mkdir -p $(INITDIR)
|
||||
install -m 644 restorecond.init $(INITDIR)/restorecond
|
||||
@ -42,7 +52,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
/sbin/restorecon $(SBINDIR)/restorecond
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.22/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/restorecond.c 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/restorecond.c 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -210,9 +210,10 @@
|
||||
}
|
||||
|
||||
@ -71,7 +81,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
close(fd);
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/run_init/Makefile policycoreutils-2.0.22/run_init/Makefile
|
||||
--- nsapolicycoreutils/run_init/Makefile 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/run_init/Makefile 2007-07-20 12:03:04.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/run_init/Makefile 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -34,8 +34,8 @@
|
||||
install: all
|
||||
test -d $(SBINDIR) || install -m 755 -d $(SBINDIR)
|
||||
@ -85,7 +95,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
ifeq (${PAMH}, /usr/include/security/pam_appl.h)
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.22/scripts/chcat
|
||||
--- nsapolicycoreutils/scripts/chcat 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/scripts/chcat 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/scripts/chcat 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -77,7 +77,7 @@
|
||||
|
||||
if len(cats) > 0:
|
||||
@ -104,9 +114,20 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
new_serange = "%s-%s" % (serange[0], top[0])
|
||||
|
||||
if add_ind:
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.22/scripts/fixfiles
|
||||
--- nsapolicycoreutils/scripts/fixfiles 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/scripts/fixfiles 2007-07-23 10:25:32.000000000 -0400
|
||||
@@ -108,6 +108,7 @@
|
||||
|
||||
rpmlist() {
|
||||
rpm -q --qf '[%{FILESTATES} %{FILENAMES}\n]' "$1" | grep '^0 ' | cut -f2- -d ' '
|
||||
+[ ${PIPESTATUS[0]} != 0 ] && echo "$1 not found" >/dev/stderr
|
||||
}
|
||||
|
||||
#
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-2.0.22/scripts/genhomedircon
|
||||
--- nsapolicycoreutils/scripts/genhomedircon 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/scripts/genhomedircon 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/scripts/genhomedircon 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -302,7 +302,7 @@
|
||||
|
||||
regex = re.sub("\(\/\.\*\)\?", "", regex)
|
||||
@ -118,7 +139,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
continue
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.22/semanage/semanage
|
||||
--- nsapolicycoreutils/semanage/semanage 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/semanage/semanage 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/semanage/semanage 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -34,7 +34,10 @@
|
||||
sys.stdout = codecs.getwriter(locale.getpreferredencoding())(sys.__stdout__, 'replace')
|
||||
|
||||
@ -133,7 +154,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
__builtin__.__dict__['_'] = unicode
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.22/semanage/seobject.py
|
||||
--- nsapolicycoreutils/semanage/seobject.py 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/semanage/seobject.py 2007-07-20 11:16:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/semanage/seobject.py 2007-07-20 12:07:46.000000000 -0400
|
||||
@@ -210,6 +210,7 @@
|
||||
os.write(fd, self.out())
|
||||
os.close(fd)
|
||||
|
@ -6,7 +6,7 @@
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.22
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -192,6 +192,10 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Mon Jul 23 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-7
|
||||
- Fix fixfiles to report incorrect rpm
|
||||
- Patch provided by Tony Nelson
|
||||
|
||||
* Fri Jul 20 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-6
|
||||
- Clean up spec file
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user