* Tue Jan 22 2008 Dan Walsh <dwalsh@redhat.com> 2.0.35-5
- handle files with spaces on upgrades
This commit is contained in:
parent
1aa6d7bef2
commit
138cbeabb6
@ -687,7 +687,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
gettext.install('policycoreutils')
|
gettext.install('policycoreutils')
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.35/scripts/fixfiles
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.35/scripts/fixfiles
|
||||||
--- nsapolicycoreutils/scripts/fixfiles 2007-12-10 21:42:28.000000000 -0500
|
--- nsapolicycoreutils/scripts/fixfiles 2007-12-10 21:42:28.000000000 -0500
|
||||||
+++ policycoreutils-2.0.35/scripts/fixfiles 2008-01-22 15:48:58.000000000 -0500
|
+++ policycoreutils-2.0.35/scripts/fixfiles 2008-01-23 13:32:53.000000000 -0500
|
||||||
@@ -36,8 +36,8 @@
|
@@ -36,8 +36,8 @@
|
||||||
LOGGER=/usr/sbin/logger
|
LOGGER=/usr/sbin/logger
|
||||||
SETFILES=/sbin/setfiles
|
SETFILES=/sbin/setfiles
|
||||||
@ -699,14 +699,16 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
FILESYSTEMS="$FILESYSTEMSRW $FILESYSTEMSRO"
|
FILESYSTEMS="$FILESYSTEMSRW $FILESYSTEMSRO"
|
||||||
SELINUXTYPE="targeted"
|
SELINUXTYPE="targeted"
|
||||||
if [ -e /etc/selinux/config ]; then
|
if [ -e /etc/selinux/config ]; then
|
||||||
@@ -89,10 +89,10 @@
|
@@ -88,11 +88,11 @@
|
||||||
|
esac; \
|
||||||
fi; \
|
fi; \
|
||||||
done | \
|
done | \
|
||||||
while read pattern ; do sh -c "find $pattern" \
|
- while read pattern ; do sh -c "find $pattern" \
|
||||||
- ! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o \
|
- ! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o \
|
||||||
- \( -wholename /home -o -wholename /root -o -wholename /tmp -wholename /dev \) -prune -o -print; \
|
- \( -wholename /home -o -wholename /root -o -wholename /tmp -wholename /dev \) -prune -o -print; \
|
||||||
|
+ while read pattern ; do sh -c "find $pattern \
|
||||||
+ ! \( -fstype ext2 -o -fstype ext3 -o -fstype ext4 -o -fstype ext4dev -o -fstype gfs2 -o -fstype jfs -o -fstype xfs \) -prune -o \
|
+ ! \( -fstype ext2 -o -fstype ext3 -o -fstype ext4 -o -fstype ext4dev -o -fstype gfs2 -o -fstype jfs -o -fstype xfs \) -prune -o \
|
||||||
+ \( -wholename /home -o -wholename /root -o -wholename /tmp -wholename /dev \) -prune -o -print0; \
|
+ \( -wholename /home -o -wholename /root -o -wholename /tmp -wholename /dev \) -prune -o -print0"; \
|
||||||
done 2> /dev/null | \
|
done 2> /dev/null | \
|
||||||
- ${RESTORECON} $2 -f -
|
- ${RESTORECON} $2 -f -
|
||||||
+ ${RESTORECON} $2 -0 -f -
|
+ ${RESTORECON} $2 -0 -f -
|
||||||
@ -792,18 +794,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
- exit 1
|
- exit 1
|
||||||
-esac
|
-esac
|
||||||
+exit $?
|
+exit $?
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/secon/Makefile policycoreutils-2.0.35/secon/Makefile
|
|
||||||
--- nsapolicycoreutils/secon/Makefile 2008-01-11 10:52:37.000000000 -0500
|
|
||||||
+++ policycoreutils-2.0.35/secon/Makefile 2008-01-11 11:17:46.000000000 -0500
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
MANDIR ?= $(PREFIX)/share/man
|
|
||||||
LIBDIR ?= ${PREFIX}/lib
|
|
||||||
|
|
||||||
-WARNS=-Werror -W -Wall -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wno-format-zero-length -Wformat-nonliteral -Wformat-security -Wfloat-equal
|
|
||||||
+WARNS=-W -Wall -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wno-format-zero-length -Wformat-nonliteral -Wformat-security -Wfloat-equal
|
|
||||||
VERSION = $(shell cat ../VERSION)
|
|
||||||
CFLAGS ?= $(WARNS) -O1
|
|
||||||
override CFLAGS += -DVERSION=\"$(VERSION)\" -I$(INCLUDEDIR)
|
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.35/semanage/semanage
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.35/semanage/semanage
|
||||||
--- nsapolicycoreutils/semanage/semanage 2007-10-05 13:09:53.000000000 -0400
|
--- nsapolicycoreutils/semanage/semanage 2007-10-05 13:09:53.000000000 -0400
|
||||||
+++ policycoreutils-2.0.35/semanage/semanage 2008-01-11 11:17:46.000000000 -0500
|
+++ policycoreutils-2.0.35/semanage/semanage 2008-01-11 11:17:46.000000000 -0500
|
||||||
|
@ -6,7 +6,7 @@
|
|||||||
Summary: SELinux policy core utilities
|
Summary: SELinux policy core utilities
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 2.0.35
|
Version: 2.0.35
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||||
@ -193,6 +193,9 @@ if [ "$1" -ge "1" ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 22 2008 Dan Walsh <dwalsh@redhat.com> 2.0.35-5
|
||||||
|
- handle files with spaces on upgrades
|
||||||
|
|
||||||
* Tue Jan 22 2008 Dan Walsh <dwalsh@redhat.com> 2.0.35-4
|
* Tue Jan 22 2008 Dan Walsh <dwalsh@redhat.com> 2.0.35-4
|
||||||
- Add support in fixfiles for ext4 ext4dev and gfs2
|
- Add support in fixfiles for ext4 ext4dev and gfs2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user