* Sun Oct 7 2007 Dan Walsh <dwalsh@redhat.com> 2.0.29-1
- Update to upstream * Add genhomedircon script to invoke semodule -Bn from Dan Walsh. - Add deleteall for ports and fcontext
This commit is contained in:
parent
6827dc2d8b
commit
105dca2943
@ -161,3 +161,4 @@ sepolgen-1.0.10.tgz
|
||||
policycoreutils-2.0.26.tgz
|
||||
policycoreutils-2.0.27.tgz
|
||||
policycoreutils-2.0.28.tgz
|
||||
policycoreutils-2.0.29.tgz
|
||||
|
@ -1,15 +1,15 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.27/Makefile
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.28/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
||||
+++ policycoreutils-2.0.27/Makefile 2007-10-03 11:23:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.28/Makefile 2007-10-07 21:43:11.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.27/restorecond/restorecond.c
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.28/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.27/restorecond/restorecond.c 2007-10-03 11:23:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.28/restorecond/restorecond.c 2007-10-07 21:43:11.000000000 -0400
|
||||
@@ -210,9 +210,10 @@
|
||||
}
|
||||
|
||||
@ -36,67 +36,93 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
||||
}
|
||||
free(scontext);
|
||||
close(fd);
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-2.0.27/scripts/genhomedircon
|
||||
--- nsapolicycoreutils/scripts/genhomedircon 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-2.0.27/scripts/genhomedircon 2007-10-05 13:09:32.000000000 -0400
|
||||
@@ -0,0 +1,2 @@
|
||||
+#!/bin/sh
|
||||
+/usr/sbin/semodule -Bn
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/Makefile policycoreutils-2.0.27/scripts/Makefile
|
||||
--- nsapolicycoreutils/scripts/Makefile 2007-08-23 16:52:26.000000000 -0400
|
||||
+++ policycoreutils-2.0.27/scripts/Makefile 2007-10-04 10:25:50.000000000 -0400
|
||||
@@ -5,12 +5,13 @@
|
||||
MANDIR ?= $(PREFIX)/share/man
|
||||
LOCALEDIR ?= /usr/share/locale
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.28/semanage/seobject.py
|
||||
--- nsapolicycoreutils/semanage/seobject.py 2007-10-07 21:46:43.000000000 -0400
|
||||
+++ policycoreutils-2.0.28/semanage/seobject.py 2007-10-05 13:10:29.000000000 -0400
|
||||
@@ -139,7 +139,7 @@
|
||||
translations = fd.readlines()
|
||||
fd.close()
|
||||
except IOError, e:
|
||||
- raise ValueError(_("Unable to open %s: translations not supported on non-MLS machines: %s") % (self.filename, e) )
|
||||
+ raise ValueError(_("Unable to open %s: translations not supported on non-MLS machines") % (self.filename) )
|
||||
|
||||
self.ddict = {}
|
||||
self.comments = []
|
||||
@@ -236,9 +236,6 @@
|
||||
if rc < 0:
|
||||
semanage_handle_destroy(self.sh)
|
||||
raise ValueError(_("Could not establish semanage connection"))
|
||||
- def deleteall(self):
|
||||
- raise ValueError(_("Not yet implemented"))
|
||||
-
|
||||
|
||||
-all: fixfiles
|
||||
+all: fixfiles genhomedircon
|
||||
class loginRecords(semanageRecords):
|
||||
def __init__(self, store = ""):
|
||||
@@ -779,34 +776,6 @@
|
||||
semanage_port_key_free(k)
|
||||
semanage_port_free(p)
|
||||
|
||||
install: all
|
||||
-mkdir -p $(BINDIR)
|
||||
install -m 755 chcat $(BINDIR)
|
||||
install -m 755 fixfiles $(DESTDIR)/sbin
|
||||
+ install -m 755 genhomedircon $(SBINDIR)
|
||||
-mkdir -p $(MANDIR)/man8
|
||||
install -m 644 fixfiles.8 $(MANDIR)/man8/
|
||||
install -m 644 chcat.8 $(MANDIR)/man8/
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/setfiles/setfiles.c policycoreutils-2.0.27/setfiles/setfiles.c
|
||||
--- nsapolicycoreutils/setfiles/setfiles.c 2007-09-18 16:27:24.000000000 -0400
|
||||
+++ policycoreutils-2.0.27/setfiles/setfiles.c 2007-10-03 11:23:39.000000000 -0400
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <libgen.h>
|
||||
#ifdef USE_AUDIT
|
||||
#include <libaudit.h>
|
||||
+#include <time.h>
|
||||
- def deleteall(self):
|
||||
- (rc, plist) = semanage_port_list_local(self.sh)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not list the ports"))
|
||||
-
|
||||
- rc = semanage_begin_transaction(self.sh)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not start semanage transaction"))
|
||||
-
|
||||
- for port in plist:
|
||||
- proto = semanage_port_get_proto(port)
|
||||
- proto_str = semanage_port_get_proto_str(proto)
|
||||
- low = semanage_port_get_low(port)
|
||||
- high = semanage_port_get_high(port)
|
||||
- port_str = "%s-%s" % (low, high)
|
||||
- ( k, proto_d, low, high ) = self.__genkey(port_str , proto_str)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not create a key for %s") % port_str)
|
||||
-
|
||||
- rc = semanage_port_del_local(self.sh, k)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not delete the port %s") % port_str)
|
||||
- semanage_port_key_free(k)
|
||||
-
|
||||
- rc = semanage_commit(self.sh)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not delete the %s") % port_str)
|
||||
-
|
||||
def delete(self, port, proto):
|
||||
( k, proto_d, low, high ) = self.__genkey(port, proto)
|
||||
(rc,exists) = semanage_port_exists(self.sh, k)
|
||||
@@ -1206,32 +1175,6 @@
|
||||
semanage_fcontext_key_free(k)
|
||||
semanage_fcontext_free(fcontext)
|
||||
|
||||
#ifndef AUDIT_FS_RELABEL
|
||||
#define AUDIT_FS_RELABEL 2309
|
||||
@@ -28,6 +29,7 @@
|
||||
#endif
|
||||
static int mass_relabel;
|
||||
static int mass_relabel_errs;
|
||||
+static time_t starttime;
|
||||
|
||||
static FILE *outfile = NULL;
|
||||
static int force = 0;
|
||||
@@ -540,6 +542,12 @@
|
||||
if (!change || user_only_changed)
|
||||
goto out;
|
||||
|
||||
+ if ( (my_sb.st_nlink>1) ) {
|
||||
+ fprintf(stderr, "warning: %s has hard links\n", my_file);
|
||||
+ if ( my_sb.st_ctime >= starttime) {
|
||||
+ fprintf(stderr, "warning: %s changed since run %s\n", my_file, progname);
|
||||
+ }
|
||||
+ }
|
||||
/*
|
||||
* Relabel the file to the specified context.
|
||||
*/
|
||||
@@ -750,6 +758,7 @@
|
||||
{ SELABEL_OPT_BASEONLY, NULL },
|
||||
{ SELABEL_OPT_PATH, NULL }
|
||||
};
|
||||
+ starttime = time(NULL);
|
||||
|
||||
memset(excludeArray, 0, sizeof(excludeArray));
|
||||
altpath = NULL;
|
||||
- def deleteall(self):
|
||||
- (rc, flist) = semanage_fcontext_list_local(self.sh)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not list the file contexts"))
|
||||
-
|
||||
- rc = semanage_begin_transaction(self.sh)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not start semanage transaction"))
|
||||
-
|
||||
- for fcontext in flist:
|
||||
- target = semanage_fcontext_get_expr(fcontext)
|
||||
- ftype = semanage_fcontext_get_type(fcontext)
|
||||
- ftype_str = semanage_fcontext_get_type_str(ftype)
|
||||
- (rc,k) = semanage_fcontext_key_create(self.sh, target, file_types[ftype_str])
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not create a key for %s") % target)
|
||||
-
|
||||
- rc = semanage_fcontext_del_local(self.sh, k)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not delete the file context %s") % target)
|
||||
- semanage_fcontext_key_free(k)
|
||||
-
|
||||
- rc = semanage_commit(self.sh)
|
||||
- if rc < 0:
|
||||
- raise ValueError(_("Could not delete the file context %s") % target)
|
||||
-
|
||||
def delete(self, target, ftype):
|
||||
(rc,k) = semanage_fcontext_key_create(self.sh, target, file_types[ftype])
|
||||
if rc < 0:
|
||||
|
@ -5,7 +5,7 @@
|
||||
%define sepolgenver 1.0.10
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.28
|
||||
Version: 2.0.29
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -200,6 +200,11 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Sun Oct 7 2007 Dan Walsh <dwalsh@redhat.com> 2.0.29-1
|
||||
- Update to upstream
|
||||
* Add genhomedircon script to invoke semodule -Bn from Dan Walsh.
|
||||
- Add deleteall for ports and fcontext
|
||||
|
||||
* Fri Oct 5 2007 Dan Walsh <dwalsh@redhat.com> 2.0.28-1
|
||||
- Update to upstream
|
||||
* Update semodule man page for -D from Dan Walsh.
|
||||
|
Loading…
Reference in New Issue
Block a user