* Mon Aug 20 2007 Dan Walsh <dwalsh@redhat.com> 2.0.23-1
- Update to match NSA * Disable dontaudits via semodule -D
This commit is contained in:
parent
3de9d83f00
commit
0f56395076
@ -154,3 +154,4 @@ policycoreutils-2.0.19.tgz
|
||||
policycoreutils-2.0.20.tgz
|
||||
policycoreutils-2.0.21.tgz
|
||||
policycoreutils-2.0.22.tgz
|
||||
policycoreutils-2.0.23.tgz
|
||||
|
@ -1,23 +1,3 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.22/audit2allow/Makefile
|
||||
--- nsapolicycoreutils/audit2allow/Makefile 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/audit2allow/Makefile 2007-07-31 15:45:57.000000000 -0400
|
||||
@@ -1,6 +1,7 @@
|
||||
# Installation directories.
|
||||
PREFIX ?= ${DESTDIR}/usr
|
||||
BINDIR ?= $(PREFIX)/bin
|
||||
+SBINDIR ?= $(PREFIX)/sbin
|
||||
LIBDIR ?= $(PREFIX)/lib
|
||||
MANDIR ?= $(PREFIX)/share/man
|
||||
LOCALEDIR ?= /usr/share/locale
|
||||
@@ -10,7 +11,7 @@
|
||||
install: all
|
||||
-mkdir -p $(BINDIR)
|
||||
install -m 755 audit2allow $(BINDIR)
|
||||
- install -m 755 sepolgen-ifgen $(BINDIR)
|
||||
+ install -m 755 sepolgen-ifgen $(SBINDIR)
|
||||
-mkdir -p $(MANDIR)/man1
|
||||
install -m 644 audit2allow.1 $(MANDIR)/man1/
|
||||
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.22/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/Makefile 2007-07-31 15:45:57.000000000 -0400
|
||||
@ -27,18 +7,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/Makefile policycoreutils-2.0.22/restorecond/Makefile
|
||||
--- nsapolicycoreutils/restorecond/Makefile 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/Makefile 2007-07-31 15:45:57.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
-mkdir -p $(INITDIR)
|
||||
install -m 644 restorecond.init $(INITDIR)/restorecond
|
||||
-mkdir -p $(SELINUXDIR)
|
||||
- install -m 600 restorecond.conf $(SELINUXDIR)/restorecond.conf
|
||||
+ install -m 644 restorecond.conf $(SELINUXDIR)/restorecond.conf
|
||||
|
||||
relabel: install
|
||||
/sbin/restorecon $(SBINDIR)/restorecond
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.22/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/restorecond.c 2007-07-31 15:45:57.000000000 -0400
|
||||
|
@ -1,12 +1,12 @@
|
||||
%define libauditver 1.4.2-1
|
||||
%define libsepolver 2.0.4-1
|
||||
%define libsemanagever 1.10.0-1
|
||||
%define libsepolver 2.0.6-1
|
||||
%define libsemanagever 2.0.4-1
|
||||
%define libselinuxver 2.0.23-3
|
||||
%define sepolgenver 1.0.8
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.22
|
||||
Release: 13%{?dist}
|
||||
Version: 2.0.23
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -132,10 +132,10 @@ rm -rf %{buildroot}
|
||||
%{_sbindir}/semanage
|
||||
%{_sbindir}/load_policy
|
||||
%{_sbindir}/genhomedircon
|
||||
%{_sbindir}/sepolgen-ifgen
|
||||
%{_sbindir}/sestatus
|
||||
%{_sbindir}/run_init
|
||||
%{_sbindir}/open_init_pty
|
||||
%{_bindir}/sepolgen-ifgen
|
||||
%{_bindir}/audit2allow
|
||||
%{_bindir}/audit2why
|
||||
%{_bindir}/chcat
|
||||
@ -184,6 +184,7 @@ fi
|
||||
%post
|
||||
/sbin/chkconfig --add restorecond
|
||||
[ -f /usr/share/selinux/devel/include/build.conf ] && /usr/sbin/sepolgen-ifgen > /dev/null
|
||||
/usr/bin/sepolgen-ifgen > /dev/null
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
@ -192,6 +193,10 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Mon Aug 20 2007 Dan Walsh <dwalsh@redhat.com> 2.0.23-1
|
||||
- Update to match NSA
|
||||
* Disable dontaudits via semodule -D
|
||||
|
||||
* Wed Aug 1 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-13
|
||||
- Speed up genhomedircon by an order of magnitude by compiling regex
|
||||
- Allow semanage fcontext -a -t <<none>> /path to work
|
||||
|
Loading…
Reference in New Issue
Block a user