* Wed Jan 3 2007 Dan Walsh <dwalsh@redhat.com> 1.33.7-1
- Update to upstream * Patch from Dan Walsh to correctly suppress warnings in load_policy.
This commit is contained in:
parent
2277c61e04
commit
06aa46e29d
@ -120,3 +120,4 @@ policycoreutils-1.33.2.tgz
|
||||
policycoreutils-1.33.4.tgz
|
||||
policycoreutils-1.33.5.tgz
|
||||
policycoreutils-1.33.6.tgz
|
||||
policycoreutils-1.33.7.tgz
|
||||
|
@ -4865,27 +4865,6 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ except ValueError, e:
|
||||
+ self.error(e.args[0])
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/load_policy/load_policy.c policycoreutils-1.33.6/load_policy/load_policy.c
|
||||
--- nsapolicycoreutils/load_policy/load_policy.c 2006-11-16 17:14:31.000000000 -0500
|
||||
+++ policycoreutils-1.33.6/load_policy/load_policy.c 2006-12-20 14:59:04.000000000 -0500
|
||||
@@ -50,12 +50,12 @@
|
||||
nargs = argc - optind;
|
||||
if (nargs > 2)
|
||||
usage(argv[0]);
|
||||
- if (nargs >= 1) {
|
||||
- fprintf(stderr,
|
||||
- "%s: Warning! Policy file argument (%s) is no longer supported, installed policy is always loaded. Continuing...\n",
|
||||
- argv[0], argv[optind++]);
|
||||
+ if (nargs >= 1 && !quiet) {
|
||||
+ fprintf(stderr,
|
||||
+ "%s: Warning! Policy file argument (%s) is no longer supported, installed policy is always loaded. Continuing...\n",
|
||||
+ argv[0], argv[optind++]);
|
||||
}
|
||||
- if (nargs == 2) {
|
||||
+ if (nargs == 2 && ! quiet) {
|
||||
fprintf(stderr,
|
||||
"%s: Warning! Boolean file argument (%s) is no longer supported, installed booleans file is always used. Continuing...\n",
|
||||
argv[0], argv[optind++]);
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.6/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.6/Makefile 2006-12-20 14:59:04.000000000 -0500
|
||||
@ -4911,18 +4890,6 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
if (fd != 2)
|
||||
goto err_close_pam;
|
||||
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/po/Makefile policycoreutils-1.33.6/po/Makefile
|
||||
--- nsapolicycoreutils/po/Makefile 2006-11-16 17:15:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.6/po/Makefile 2006-12-20 14:59:04.000000000 -0500
|
||||
@@ -64,8 +64,6 @@
|
||||
@rm -fv *mo *~ .depend
|
||||
@rm -rf tmp
|
||||
|
||||
-indent:
|
||||
-
|
||||
install: $(MOFILES)
|
||||
@for n in $(MOFILES); do \
|
||||
l=`basename $$n .mo`; \
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-1.33.6/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2006-11-16 17:14:28.000000000 -0500
|
||||
+++ policycoreutils-1.33.6/restorecond/restorecond.c 2006-12-20 14:59:04.000000000 -0500
|
||||
@ -5048,25 +5015,6 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
class semanageRecords:
|
||||
def __init__(self):
|
||||
self.sh = semanage_handle_create()
|
||||
@@ -228,7 +231,7 @@
|
||||
def __init__(self):
|
||||
semanageRecords.__init__(self)
|
||||
|
||||
- def add(self, name, sename, serange):
|
||||
+ def add(self, name, sename, serange, check_exists = True):
|
||||
if is_mls_enabled == 1:
|
||||
if serange == "":
|
||||
serange = "s0"
|
||||
@@ -249,7 +252,8 @@
|
||||
if exists:
|
||||
raise ValueError(_("Login mapping for %s is already defined") % name)
|
||||
try:
|
||||
- pwd.getpwnam(name)
|
||||
+ if check_exists:
|
||||
+ pwd.getpwnam(name)
|
||||
except:
|
||||
raise ValueError(_("Linux User %s does not exist") % name)
|
||||
|
||||
@@ -456,7 +460,8 @@
|
||||
rc = semanage_user_set_mlslevel(self.sh, u, selevel)
|
||||
if rc < 0:
|
||||
|
@ -4,8 +4,8 @@
|
||||
%define libselinuxver 1.30.29-2
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 1.33.6
|
||||
Release: 9%{?dist}
|
||||
Version: 1.33.7
|
||||
Release: 1{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -168,6 +168,10 @@ fi
|
||||
[ -x /sbin/service ] && /sbin/service restorecond condrestart
|
||||
|
||||
%changelog
|
||||
* Wed Jan 3 2007 Dan Walsh <dwalsh@redhat.com> 1.33.7-1
|
||||
- Update to upstream
|
||||
* Patch from Dan Walsh to correctly suppress warnings in load_policy.
|
||||
|
||||
* Tue Jan 2 2007 Dan Walsh <dwalsh@redhat.com> 1.33.6-9
|
||||
- Fix fixfiles script to use tty command correctly. If this command fails, it
|
||||
should set the LOGFILE to /dev/null
|
||||
|
Loading…
Reference in New Issue
Block a user