diff --git a/policycoreutils-rhat.patch b/policycoreutils-rhat.patch
index 80d1b57..18e4980 100644
--- a/policycoreutils-rhat.patch
+++ b/policycoreutils-rhat.patch
@@ -1,5 +1,5 @@
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.33.1/audit2allow/audit2allow
---- nsapolicycoreutils/audit2allow/audit2allow 2006-09-14 08:07:24.000000000 -0400
+--- nsapolicycoreutils/audit2allow/audit2allow 2006-11-16 17:14:29.000000000 -0500
+++ policycoreutils-1.33.1/audit2allow/audit2allow 2006-11-15 16:29:10.000000000 -0500
@@ -184,22 +184,26 @@
output.write(serules.out(requires, module))
@@ -43,8 +43,8 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.33.1/gui/booleansPage.py
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/booleansPage.py 2006-11-15 18:22:45.000000000 -0500
-@@ -0,0 +1,247 @@
++++ policycoreutils-1.33.1/gui/booleansPage.py 2006-11-17 11:52:44.000000000 -0500
+@@ -0,0 +1,250 @@
+#
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
+#
@@ -231,6 +231,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.booleansView.append_column(col)
+ self.refreshBooleans()
+
++ def get_description(self):
++ return _("Boolean")
++
+ def verify(self, message):
+ dlg = gtk.MessageDialog(None, 0, gtk.MESSAGE_INFO,
+ gtk.BUTTONS_YES_NO,
@@ -294,7 +297,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ return status
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.33.1/gui/fcontextPage.py
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/fcontextPage.py 2006-11-15 18:22:45.000000000 -0500
++++ policycoreutils-1.33.1/gui/fcontextPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,158 @@
+## fcontextPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -339,7 +342,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+class fcontextPage(semanagePage):
+ def __init__(self, xml):
-+ semanagePage.__init__(self, xml, "fcontext", "File Context")
++ semanagePage.__init__(self, xml, "fcontext", _("File Labeling"))
+ self.view = xml.get_widget("fcontextView")
+ self.store = gtk.ListStore(gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING)
+ self.view.set_model(self.store)
@@ -456,7 +459,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_value(iter, 1, "system_u:object_r:%s:%s" % (type, mls))
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.33.1/gui/loginsPage.py
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/loginsPage.py 2006-11-15 18:22:45.000000000 -0500
++++ policycoreutils-1.33.1/gui/loginsPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,161 @@
+## loginsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -654,7 +657,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+relabel:
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.33.1/gui/mappingsPage.py
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/mappingsPage.py 2006-11-15 18:22:45.000000000 -0500
++++ policycoreutils-1.33.1/gui/mappingsPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,54 @@
+## mappingsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -712,7 +715,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.33.1/gui/modulesPage.py
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/modulesPage.py 2006-11-15 18:22:45.000000000 -0500
++++ policycoreutils-1.33.1/gui/modulesPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,157 @@
+## modulesPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -873,7 +876,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.33.1/gui/portsPage.py
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/portsPage.py 2006-11-15 18:22:45.000000000 -0500
++++ policycoreutils-1.33.1/gui/portsPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,209 @@
+## portsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -1086,8 +1089,8 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.33.1/gui/semanagePage.py
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/semanagePage.py 2006-11-15 18:22:45.000000000 -0500
-@@ -0,0 +1,104 @@
++++ policycoreutils-1.33.1/gui/semanagePage.py 2006-11-17 11:52:44.000000000 -0500
+@@ -0,0 +1,107 @@
+## semanagePage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@@ -1136,6 +1139,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.view.connect("row_activated", self.rowActivated)
+ self.view.get_selection().connect("changed", self.itemSelected)
+ self.description = description;
++
++ def get_description(self):
++ return self.description
+
+ def itemSelected(self, args):
+ return
@@ -1194,8 +1200,8 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.33.1/gui/statusPage.py
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/statusPage.py 2006-11-15 18:22:46.000000000 -0500
-@@ -0,0 +1,230 @@
++++ policycoreutils-1.33.1/gui/statusPage.py 2006-11-17 11:52:44.000000000 -0500
+@@ -0,0 +1,213 @@
+## statusPage.py - show selinux status
+## Copyright (C) 2006 Red Hat, Inc.
+
@@ -1215,7 +1221,6 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+## Author: Dan Walsh
+import string
-+import selinux
+import gtk
+import gtk.glade
+import os
@@ -1252,6 +1257,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+import gettext
+gettext.bindtextdomain(PROGNAME, "/usr/share/locale")
+gettext.textdomain(PROGNAME)
++import selinux
+try:
+ gettext.install(PROGNAME, localedir="/usr/share/locale", unicode=1)
+except IOError:
@@ -1261,17 +1267,28 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+class statusPage:
+ def __init__(self, xml):
+ self.xml = xml
-+ self.typechanged = False
+ self.needRelabel = False
+
++ self.type = selinux.selinux_getpolicytype()
+ # Bring in widgets from glade file.
+ self.typeHBox = xml.get_widget("typeHBox")
+ self.selinuxTypeOptionMenu = xml.get_widget("selinuxTypeOptionMenu")
+ self.typeLabel = xml.get_widget("typeLabel")
-+ self.modifySeparator = xml.get_widget("modifySeparator")
+ self.enabledOptionMenu = xml.get_widget("enabledOptionMenu")
+ self.currentOptionMenu = xml.get_widget("currentOptionMenu")
-+ self.currentOptionMenu.set_active(self.get_current_mode())
++ self.relabel_checkbutton = xml.get_widget("relabelCheckbutton")
++ self.relabel_checkbutton.set_active(self.is_relabel())
++ self.relabel_checkbutton.connect("toggled", self.on_relabel_toggle)
++ if self.get_current_mode() == ENFORCING or self.get_current_mode() == PERMISSIVE:
++ self.currentOptionMenu.append_text(_("Enforcing"))
++ self.currentOptionMenu.append_text(_("Permissive"))
++ self.currentOptionMenu.set_active(self.get_current_mode())
++ self.currentOptionMenu.connect("changed", self.set_current_mode)
++ self.currentOptionMenu.set_sensitive(True)
++ else:
++ self.currentOptionMenu.append_text(_("Disabled"))
++ self.currentOptionMenu.set_sensitive(False)
++
+
+ if self.read_selinux_config() == None:
+ self.selinuxsupport = False
@@ -1283,12 +1300,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.selinuxTypeOptionMenu.connect("changed", self.typemenu_changed)
+
+ self.typeLabel.set_mnemonic_widget(self.selinuxTypeOptionMenu)
-+ # This line should always go last
-+ self.dirty = False
-+
-+ def setup_relabel(self):
-+ fd = open(RELABELFILE,"w")
-+ fd.close()
++
++ def get_description(self):
++ return _("Status")
+
+ def get_current_mode(self):
+ if selinux.is_selinux_enabled():
@@ -1299,9 +1313,19 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ else:
+ return DISABLED
+
-+ def set_current_mode(self,value):
-+ if selinux.is_selinux_enabled():
-+ selinux.security_setenforce(value)
++ def set_current_mode(self,menu):
++ selinux.security_setenforce(menu.get_active() == 0)
++
++ def is_relabel(self):
++ return os.access(RELABELFILE, os.F_OK) != 0
++
++ def on_relabel_toggle(self,button):
++ if button.get_active():
++ fd = open(RELABELFILE,"w")
++ fd.close()
++ else:
++ if os.access(RELABELFILE, os.F_OK) != 0:
++ os.unlink(RELABELFILE)
+
+ def verify(self, message):
+ dlg = gtk.MessageDialog(None, 0, gtk.MESSAGE_INFO,
@@ -1314,34 +1338,32 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ return rc
+
+ def typemenu_changed(self, menu):
-+ self.dirty = True
-+ type = self.getType()
++ type = self.get_type()
++ enabled = self.enabledOptionMenu.get_active()
+ if self.initialtype != type:
-+ if self.inFirstboot == False and self.verify(_("Changing the policy type will cause a relabel of the entire file system on the next boot. Relabeling takes a long time depending on the size of the file system. Do you wish to continue?")) == gtk.RESPONSE_NO:
++ if self.verify(_("Changing the policy type will cause a relabel of the entire file system on the next boot. Relabeling takes a long time depending on the size of the file system. Do you wish to continue?")) == gtk.RESPONSE_NO:
+ menu.set_active(self.typeHistory)
+ return None
+
-+ self.needRelabel = True
-+
++ self.relabel_checkbutton.set_active(True)
++ self.conf["SELINUX"] = modearray[enabled]
++ self.conf["SELINUXTYPE"]=type
++ self.conf.write()
++ self.typeHistory = menu.get_active()
++
+ def enabled_changed(self, combo):
-+ self.dirty = True
-+ setting = combo.get_active()
++ enabled = combo.get_active()
++ type = self.get_type()
+
-+ if setting < 2:
-+ enabled = True
-+ else:
-+ enabled = False
-+
-+ if self.initEnabled == DISABLED and enabled:
++ if self.initEnabled == DISABLED and enabled < 2:
+ if self.verify(_("Changing to SELinux enabled will cause a relabel of the entire file system on the next boot. Relabeling takes a long time depending on the size of the file system. Do you wish to continue?")) == gtk.RESPONSE_NO:
+ return None
+
-+ self.needRelabel = True
-+ elif not enabled:
-+ self.needRelabel = False
++ self.relabel_checkbutton.set_active(True)
+
-+ self.typeLabel.set_sensitive(enabled)
-+ self.selinuxTypeOptionMenu.set_sensitive(enabled)
++ self.conf["SELINUX"] = modearray[enabled]
++ self.conf["SELINUXTYPE"]=type
++ self.conf.write()
+
+ def read_selinux_config(self):
+ self.initialtype = "targeted"
@@ -1369,8 +1391,6 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.initEnabled = DISABLED
+ self.enabledOptionMenu.set_active(DISABLED)
+
-+ self.enabled_changed(self.enabledOptionMenu)
-+
+ if self.conf.has_key("SELINUXTYPE"):
+ self.initialtype = self.conf.vars["SELINUXTYPE"].strip()
+ else:
@@ -1387,49 +1407,18 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ current = n
+ n = n+1
+ self.selinuxTypeOptionMenu.set_active(current)
++ self.typeHistory = current
+
+ return 0
+
-+ def getType(self):
++ def get_type(self):
+ return self.types[self.selinuxTypeOptionMenu.get_active()]
+
-+ def apply(self):
-+ retval = 0
+
-+ if self.selinuxsupport == False:
-+ return retval
-+
-+ type = self.getType()
-+
-+ if self.dirty == True:
-+ enabled = self.enabledOptionMenu.get_active()
-+
-+ self.conf["SELINUX"] = modearray[enabled]
-+ if enabled == ENFORCING:
-+ self.set_current_mode(1)
-+ elif enabled == PERMISSIVE:
-+ self.set_current_mode(0)
-+
-+ self.conf["SELINUXTYPE"]=type
-+
-+ if self.doDebug == False:
-+ self.conf.write()
-+
-+ if self.needRelabel:
-+ if self.doDebug == False:
-+ self.setup_relabel()
-+ retval = 1
-+ else:
-+ if os.access(RELABELFILE, os.F_OK) != 0 and self.doDebug == False:
-+ os.unlink(RELABELFILE)
-+
-+ return retval
-+
-+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.33.1/gui/system-config-selinux.glade
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/system-config-selinux.glade 2006-11-15 18:21:26.000000000 -0500
-@@ -0,0 +1,2784 @@
++++ policycoreutils-1.33.1/gui/system-config-selinux.glade 2006-11-17 11:52:26.000000000 -0500
+@@ -0,0 +1,2792 @@
+
+
+
@@ -2883,9 +2872,11 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+ True
+ True
++ 0
+
+
+
++ 5
+ True
+ 0
+ 0.5
@@ -2944,17 +2935,16 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+
+
-+ True
-+ False
++ False
++ True
+
+
+
+
+
+ True
-+ True
+ False
-+ False
++ True
+ GTK_POS_TOP
+ False
+ False
@@ -2966,158 +2956,18 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ 0
+
+
-+
-+ True
-+ 0
-+ 0.5
-+ GTK_SHADOW_NONE
-+
-+
-+
-+ True
-+ 0.5
-+ 0.5
-+ 1
-+ 1
-+ 0
-+ 0
-+ 12
-+ 0
-+
-+
-+
-+ True
-+ False
-+ 0
-+
-+
-+
-+ True
-+ Current
-+ False
-+ False
-+ GTK_JUSTIFY_LEFT
-+ False
-+ False
-+ 0.5
-+ 0.5
-+ 0
-+ 0
-+ PANGO_ELLIPSIZE_NONE
-+ -1
-+ False
-+ 0
-+
-+
-+ 3
-+ False
-+ False
-+
-+
-+
-+
-+
-+
-+ 0
-+ True
-+ True
-+
-+
-+
-+
-+
-+ True
-+ System Default
-+ False
-+ False
-+ GTK_JUSTIFY_LEFT
-+ False
-+ False
-+ 0.5
-+ 0.5
-+ 0
-+ 0
-+ PANGO_ELLIPSIZE_NONE
-+ -1
-+ False
-+ 0
-+
-+
-+ 6
-+ False
-+ False
-+
-+
-+
-+
-+
-+
-+ 0
-+ True
-+ True
-+
-+
-+
-+
-+
-+
-+
-+
-+
-+ True
-+ <b>Enforcement Mode</b>
-+ False
-+ True
-+ GTK_JUSTIFY_LEFT
-+ False
-+ False
-+ 0.5
-+ 0.5
-+ 0
-+ 0
-+ PANGO_ELLIPSIZE_NONE
-+ -1
-+ False
-+ 0
-+
-+
-+ label_item
-+
-+
-+
-+
-+ 5
-+ False
-+ False
-+
-+
-+
-+
-+
++
+ True
++ 4
++ 2
+ False
-+ 0
++ 5
++ 5
+
+
-+
++
+ True
-+ Policy Type:
++ System Default Enforcing Mode
+ False
+ False
+ GTK_JUSTIFY_LEFT
@@ -3133,9 +2983,104 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ 0
+
+
-+ 0
-+ False
-+ True
++ 0
++ 1
++ 0
++ 1
++ fill
++
++
++
++
++
++
++
++ 1
++ 2
++ 0
++ 1
++ fill
++
++
++
++
++
++ True
++ Current Enforcing Mode
++ False
++ False
++ GTK_JUSTIFY_LEFT
++ False
++ False
++ 0.5
++ 0.5
++ 0
++ 0
++ PANGO_ELLIPSIZE_NONE
++ -1
++ False
++ 0
++
++
++ 0
++ 1
++ 1
++ 2
++ fill
++
++
++
++
++
++
++
++ 1
++ 2
++ 1
++ 2
++ fill
++ fill
++
++
++
++
++
++ True
++ System Default Policy Type:
++ False
++ False
++ GTK_JUSTIFY_LEFT
++ False
++ False
++ 0.5
++ 0.5
++ 0
++ 0
++ PANGO_ELLIPSIZE_NONE
++ -1
++ False
++ 0
++
++
++ 0
++ 1
++ 2
++ 3
++ fill
++
+
+
+
@@ -3147,86 +3092,97 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ True
+
+
-+ 0
-+ True
-+ True
-+ GTK_PACK_END
++ 1
++ 2
++ 2
++ 3
++ fill
++ fill
+
+
-+
-+
-+ 9
-+ False
-+ False
-+
-+
-+
-+
-+
-+ True
-+ 0
-+ 0.5
-+ GTK_SHADOW_NONE
+
+
-+
++
+ True
-+ 0.5
-+ 0.5
-+ 1
-+ 1
-+ 0
-+ 0
-+ 12
-+ 0
++ Select if you wish to relabel then entire file system on next reboot. Relabeling can take a very long time, depending on the size of the system. If you are changing policy types or going from disabled to enforing, a relabel is required.
++ True
++ GTK_RELIEF_NORMAL
++ True
++ False
++ False
++ True
+
+
-+
++
+ True
-+ True
-+ GTK_POLICY_ALWAYS
-+ GTK_POLICY_ALWAYS
-+ GTK_SHADOW_NONE
-+ GTK_CORNER_TOP_LEFT
++ 0.5
++ 0.5
++ 0
++ 0
++ 0
++ 0
++ 0
++ 0
+
+
-+
++
+ True
-+ True
-+ False
-+ False
-+ False
-+ True
-+ False
-+ False
-+ False
++ False
++ 2
++
++
++
++ True
++ gtk-refresh
++ 4
++ 0.5
++ 0.5
++ 0
++ 0
++
++
++ 0
++ False
++ False
++
++
++
++
++
++ True
++ Relabel on next reboot.
++ True
++ False
++ GTK_JUSTIFY_LEFT
++ False
++ False
++ 0.5
++ 0.5
++ 0
++ 0
++ PANGO_ELLIPSIZE_NONE
++ -1
++ False
++ 0
++
++
++ 0
++ False
++ False
++
++
+
+
+
+
+
-+
-+
-+
-+
-+ True
-+ <b>Booleans</b>
-+ False
-+ True
-+ GTK_JUSTIFY_LEFT
-+ False
-+ False
-+ 0.5
-+ 0.5
-+ 5
-+ 3
-+ PANGO_ELLIPSIZE_NONE
-+ -1
-+ False
-+ 0
-+
+
-+ label_item
++ 0
++ 2
++ 3
++ 4
++ fill
++ fill
+
+
+
@@ -3267,6 +3223,47 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+
+
++
++ True
++ True
++ False
++ False
++ False
++ True
++ False
++ False
++ False
++
++
++ False
++ True
++
++
++
++
++
++ True
++ label50
++ False
++ False
++ GTK_JUSTIFY_LEFT
++ False
++ False
++ 0.5
++ 0.5
++ 0
++ 0
++ PANGO_ELLIPSIZE_NONE
++ -1
++ False
++ 0
++
++
++ tab
++
++
++
++
+
+ True
+ False
@@ -4216,8 +4213,8 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.33.1/gui/system-config-selinux.py
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/system-config-selinux.py 2006-11-16 14:18:35.000000000 -0500
-@@ -0,0 +1,164 @@
++++ policycoreutils-1.33.1/gui/system-config-selinux.py 2006-11-17 11:52:44.000000000 -0500
+@@ -0,0 +1,156 @@
+#!/usr/bin/python
+#
+# system-config-selinux.py - GUI for SELinux Config tool in system-config-selinux
@@ -4295,21 +4292,23 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ xml.signal_connect("on_delete_clicked", self.delete)
+ xml.signal_connect("on_add_clicked", self.add)
+ xml.signal_connect("on_properties_clicked", self.properties)
-+ self.status_page=statusPage.statusPage(xml)
-+ self.tabs.append(booleansPage.booleansPage(xml))
-+ self.tabs.append(fcontextPage.fcontextPage(xml))
-+ self.tabs.append(loginsPage.loginsPage(xml))
-+ self.tabs.append(usersPage.usersPage(xml))
-+ self.tabs.append(translationsPage.translationsPage(xml))
-+ self.tabs.append(portsPage.portsPage(xml))
-+ self.tabs.append(modulesPage.modulesPage(xml)) # modules
-+ self.tabs.append(None) # interfaces
++ self.add_page(statusPage.statusPage(xml))
++ self.add_page(booleansPage.booleansPage(xml))
++ self.add_page(fcontextPage.fcontextPage(xml))
++ self.add_page(loginsPage.loginsPage(xml))
++ self.add_page(usersPage.usersPage(xml))
++ self.add_page(translationsPage.translationsPage(xml))
++ self.add_page(portsPage.portsPage(xml))
++ self.add_page(modulesPage.modulesPage(xml)) # modules
+
+ xml.signal_connect("on_quit_activate", self.destroy)
+ xml.signal_connect("on_policy_activate", self.policy)
+ xml.signal_connect("on_logging_activate", self.logging)
+ xml.signal_connect("on_about_activate", self.on_about_activate)
+
++ def add_page(self, page):
++ self.tabs.append(page)
++
+ def policy(self, args):
+ os.spawnl(os.P_NOWAIT, "/usr/share/system-config-selinux/semanagegui.py")
+ def logging(self, args):
@@ -4351,20 +4350,10 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ col = gtk.TreeViewColumn("", gtk.CellRendererText(), text = 0)
+ col.set_resizable(True)
+ self.view.append_column(col)
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("Setup"))
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("File Contexts"))
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("SELinux User/Login Mappings"))
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("SELinux Users"))
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("Translations"))
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("Network Ports"))
-+ iter = self.store.append()
-+ self.store.set_value(iter, 0, _("Policy Modules"))
++
++ for page in self.tabs:
++ iter = self.store.append()
++ self.store.set_value(iter, 0, page.get_description())
+ self.view.get_selection().select_path ((0,))
+
+ def stand_alone(self):
@@ -4384,7 +4373,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ app.stand_alone()
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.33.1/gui/translationsPage.py
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/translationsPage.py 2006-11-15 18:22:46.000000000 -0500
++++ policycoreutils-1.33.1/gui/translationsPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,109 @@
+## translationsPage.py - show selinux translations
+## Copyright (C) 2006 Red Hat, Inc.
@@ -4497,7 +4486,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_value(iter, 1, translation)
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.33.1/gui/usersPage.py
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-1.33.1/gui/usersPage.py 2006-11-15 18:22:46.000000000 -0500
++++ policycoreutils-1.33.1/gui/usersPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,155 @@
+## usersPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -4542,7 +4531,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+class usersPage(semanagePage):
+ def __init__(self, xml):
-+ semanagePage.__init__(self, xml, "users", "User")
++ semanagePage.__init__(self, xml, "users", "SELinux User")
+ self.store = gtk.ListStore(gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING)
+ self.view.set_model(self.store)
+ self.store.set_sort_column_id(0, gtk.SORT_ASCENDING)
@@ -4655,7 +4644,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.error(e.args[0])
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.1/Makefile
---- nsapolicycoreutils/Makefile 2006-08-28 16:58:22.000000000 -0400
+--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
+++ policycoreutils-1.33.1/Makefile 2006-11-14 09:54:05.000000000 -0500
@@ -1,4 +1,4 @@
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
@@ -4664,8 +4653,8 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
all install relabel clean indent:
@for subdir in $(SUBDIRS); do \
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/newrole/newrole.c policycoreutils-1.33.1/newrole/newrole.c
---- nsapolicycoreutils/newrole/newrole.c 2006-11-14 09:46:12.000000000 -0500
-+++ policycoreutils-1.33.1/newrole/newrole.c 2006-11-14 09:55:30.000000000 -0500
+--- nsapolicycoreutils/newrole/newrole.c 2006-11-16 17:14:32.000000000 -0500
++++ policycoreutils-1.33.1/newrole/newrole.c 2006-11-17 11:55:39.000000000 -0500
@@ -1028,6 +1028,7 @@
{
fprintf(stderr, _("newrole: incorrect password for %s\n"),
@@ -4674,8 +4663,26 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
goto err_close_pam;
}
+@@ -1067,11 +1068,16 @@
+ */
+ int rc;
+ int exit_code = 0;
++ int status;
+
+ do {
+- rc = wait(NULL);
++ rc = wait(&status);
+ } while (rc < 0 && errno == EINTR);
+
++ /* Preserve child exit status, unless there is another error. */
++ if (WIFEXITED(status))
++ exit_code = WEXITSTATUS(status);
++
+ if (restore_tty_label(fd, ttyn, tty_context, new_tty_context)) {
+ fprintf(stderr, _("Unable to restore tty label...\n"));
+ exit_code = -1;
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/Makefile policycoreutils-1.33.1/restorecond/Makefile
---- nsapolicycoreutils/restorecond/Makefile 2006-08-28 16:58:19.000000000 -0400
+--- nsapolicycoreutils/restorecond/Makefile 2006-11-16 17:14:28.000000000 -0500
+++ policycoreutils-1.33.1/restorecond/Makefile 2006-11-14 09:54:05.000000000 -0500
@@ -5,8 +5,9 @@
INITDIR = $(DESTDIR)/etc/rc.d/init.d
@@ -4690,7 +4697,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
all: restorecond
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-1.33.1/restorecond/restorecond.conf
---- nsapolicycoreutils/restorecond/restorecond.conf 2006-08-28 16:58:19.000000000 -0400
+--- nsapolicycoreutils/restorecond/restorecond.conf 2006-11-16 17:14:28.000000000 -0500
+++ policycoreutils-1.33.1/restorecond/restorecond.conf 2006-11-14 09:54:05.000000000 -0500
@@ -2,5 +2,6 @@
/etc/samba/secrets.tdb
@@ -4700,7 +4707,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
~/public_html
~/.mozilla/plugins/libflashplayer.so
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/run_init/run_init.c policycoreutils-1.33.1/run_init/run_init.c
---- nsapolicycoreutils/run_init/run_init.c 2006-08-28 16:58:19.000000000 -0400
+--- nsapolicycoreutils/run_init/run_init.c 2006-11-16 17:14:27.000000000 -0500
+++ policycoreutils-1.33.1/run_init/run_init.c 2006-11-16 09:37:03.000000000 -0500
@@ -132,6 +132,14 @@
result = 1; /* user authenticated OK! */
@@ -4718,7 +4725,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
pam_end(pam_handle, PAM_SUCCESS);
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/scripts/genhomedircon.8 policycoreutils-1.33.1/scripts/genhomedircon.8
---- nsapolicycoreutils/scripts/genhomedircon.8 2006-08-28 16:58:19.000000000 -0400
+--- nsapolicycoreutils/scripts/genhomedircon.8 2006-11-16 17:14:27.000000000 -0500
+++ policycoreutils-1.33.1/scripts/genhomedircon.8 2006-11-14 09:54:05.000000000 -0500
@@ -45,35 +45,30 @@
.SH DESCRIPTION
@@ -4774,8 +4781,8 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
This manual page was originally written by
.I Manoj Srivastava ,
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-1.33.1/semanage/semanage.8
---- nsapolicycoreutils/semanage/semanage.8 2006-09-14 08:07:24.000000000 -0400
-+++ policycoreutils-1.33.1/semanage/semanage.8 2006-11-14 09:54:05.000000000 -0500
+--- nsapolicycoreutils/semanage/semanage.8 2006-11-16 17:14:26.000000000 -0500
++++ policycoreutils-1.33.1/semanage/semanage.8 2006-11-17 09:57:31.000000000 -0500
@@ -7,7 +7,7 @@
.br
.B semanage login \-{a|d|m} [\-sr] login_name
@@ -4795,8 +4802,18 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
.I \-s, \-\-seuser
SELinux user name
.TP
+@@ -79,9 +82,6 @@
+ .TP
+ .I \-T, \-\-trans
+ SELinux Translation
+-.TP
+-.I \-v, \-\-verbose
+-verbose output
+
+ .SH EXAMPLE
+ .nf
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.33.1/semanage/seobject.py
---- nsapolicycoreutils/semanage/seobject.py 2006-10-17 12:04:55.000000000 -0400
+--- nsapolicycoreutils/semanage/seobject.py 2006-11-16 17:14:26.000000000 -0500
+++ policycoreutils-1.33.1/semanage/seobject.py 2006-11-15 18:20:53.000000000 -0500
@@ -94,23 +94,25 @@
return re.search("^" + reg +"$",raw)
@@ -4879,7 +4896,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
if len(roles) != 0:
for r in roles:
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semodule_expand/semodule_expand.8 policycoreutils-1.33.1/semodule_expand/semodule_expand.8
---- nsapolicycoreutils/semodule_expand/semodule_expand.8 2006-08-28 16:58:20.000000000 -0400
+--- nsapolicycoreutils/semodule_expand/semodule_expand.8 2006-11-16 17:14:34.000000000 -0500
+++ policycoreutils-1.33.1/semodule_expand/semodule_expand.8 2006-11-14 09:54:05.000000000 -0500
@@ -18,7 +18,7 @@
.SH "OPTIONS"