bump to v4.4.1
Fold podman-quadlet into podman main package Signed-off-by: Lokesh Mandvekar <lsm5@fedoraproject.org>
This commit is contained in:
parent
b376f4e57a
commit
313c3e86a8
1
.gitignore
vendored
1
.gitignore
vendored
@ -1820,3 +1820,4 @@
|
|||||||
/v4.4.0-rc2.tar.gz
|
/v4.4.0-rc2.tar.gz
|
||||||
/gvisor-tap-vsock-aab0ac9367fc5142f5857c36ac2352bcb3c60ab7.tar.gz
|
/gvisor-tap-vsock-aab0ac9367fc5142f5857c36ac2352bcb3c60ab7.tar.gz
|
||||||
/v4.4.0.tar.gz
|
/v4.4.0.tar.gz
|
||||||
|
/v4.4.1.tar.gz
|
||||||
|
@ -1,45 +0,0 @@
|
|||||||
From 14563ef132ddaa44083d5b2452ef036abb203493 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ed Santiago <santiago@redhat.com>
|
|
||||||
Date: Tue, 18 Oct 2022 10:24:46 -0600
|
|
||||||
Subject: [PATCH] system tests: fix broken bashisms
|
|
||||||
|
|
||||||
gating tests failing on rawhide, and will probably fail
|
|
||||||
on f36 and f37 due to long-broken bugs that are now
|
|
||||||
caught by (bats, I think? new version of bash? who knows).
|
|
||||||
|
|
||||||
This is a partial cherry-pick of #16220, omitting the
|
|
||||||
change to testimage (not needed here)
|
|
||||||
|
|
||||||
Signed-off-by: Ed Santiago <santiago@redhat.com>
|
|
||||||
---
|
|
||||||
test/system/260-sdnotify.bats | 2 ++
|
|
||||||
test/system/270-socket-activation.bats | 2 +-
|
|
||||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/test/system/260-sdnotify.bats b/test/system/260-sdnotify.bats
|
|
||||||
index c4724d60528..970a2e3c7c5 100644
|
|
||||||
--- a/test/system/260-sdnotify.bats
|
|
||||||
+++ b/test/system/260-sdnotify.bats
|
|
||||||
@@ -41,7 +41,9 @@ function teardown() {
|
|
||||||
function _start_socat() {
|
|
||||||
_SOCAT_LOG="$PODMAN_TMPDIR/socat.log"
|
|
||||||
|
|
||||||
+ # Reset socat logfile to empty
|
|
||||||
rm -f $_SOCAT_LOG
|
|
||||||
+ touch $_SOCAT_LOG
|
|
||||||
# Execute in subshell so we can close fd3 (which BATS uses).
|
|
||||||
# This is a superstitious ritual to try to avoid leaving processes behind,
|
|
||||||
# and thus prevent CI hangs.
|
|
||||||
diff --git a/test/system/270-socket-activation.bats b/test/system/270-socket-activation.bats
|
|
||||||
index 6d582be180f..a8ae2343315 100644
|
|
||||||
--- a/test/system/270-socket-activation.bats
|
|
||||||
+++ b/test/system/270-socket-activation.bats
|
|
||||||
@@ -101,7 +101,7 @@ function teardown() {
|
|
||||||
die "Pause pid file does not exist: $pause_pid_file"
|
|
||||||
fi
|
|
||||||
|
|
||||||
- echo "kill -9 $(< pause_pid_file)"
|
|
||||||
+ echo "kill -9 $(< $pause_pid_file) [pause process]"
|
|
||||||
kill -9 $(< $pause_pid_file)
|
|
||||||
|
|
||||||
run curl -s --max-time 3 --unix-socket $SERVICE_SOCK_ADDR $_PING
|
|
26
podman.spec
26
podman.spec
@ -29,7 +29,7 @@
|
|||||||
%global git_gvproxy https://%{import_path_gvproxy}
|
%global git_gvproxy https://%{import_path_gvproxy}
|
||||||
%global commit_gvproxy aab0ac9367fc5142f5857c36ac2352bcb3c60ab7
|
%global commit_gvproxy aab0ac9367fc5142f5857c36ac2352bcb3c60ab7
|
||||||
|
|
||||||
%global built_tag v4.4.0
|
%global built_tag v4.4.1
|
||||||
%global built_tag_strip %(b=%{built_tag}; echo ${b:1})
|
%global built_tag_strip %(b=%{built_tag}; echo ${b:1})
|
||||||
%global gen_version %(b=%{built_tag_strip}; echo ${b/-/"~"})
|
%global gen_version %(b=%{built_tag_strip}; echo ${b/-/"~"})
|
||||||
|
|
||||||
@ -38,7 +38,7 @@ Epoch: 5
|
|||||||
Version: %{gen_version}
|
Version: %{gen_version}
|
||||||
License: ASL 2.0 and BSD and ISC and MIT and MPLv2.0
|
License: ASL 2.0 and BSD and ISC and MIT and MPLv2.0
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
ExclusiveArch: %{golang_arches}
|
ExclusiveArch: %{golang_arches_future}
|
||||||
Summary: Manage Pods, Containers and Container Images
|
Summary: Manage Pods, Containers and Container Images
|
||||||
URL: https://%{name}.io/
|
URL: https://%{name}.io/
|
||||||
# All SourceN files fetched from upstream
|
# All SourceN files fetched from upstream
|
||||||
@ -78,6 +78,9 @@ Requires: containers-common-extra >= 4:1-66
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
Recommends: %{name}-gvproxy = %{epoch}:%{version}-%{release}
|
Recommends: %{name}-gvproxy = %{epoch}:%{version}-%{release}
|
||||||
|
Provides: %{name}-quadlet
|
||||||
|
Obsoletes: %{name}-quadlet <= 5:4.4.0-1
|
||||||
|
Provides: %{name}-quadlet = %{epoch}:%{version}-%{release}
|
||||||
# vendored libraries
|
# vendored libraries
|
||||||
# awk '{print "Provides: bundled(golang("$1")) = "$2}' go.mod | sort | uniq | sed -e 's/-/_/g' -e '/bundled(golang())/d' -e '/bundled(golang(go\|module\|replace\|require))/d'
|
# awk '{print "Provides: bundled(golang("$1")) = "$2}' go.mod | sort | uniq | sed -e 's/-/_/g' -e '/bundled(golang())/d' -e '/bundled(golang(go\|module\|replace\|require))/d'
|
||||||
Provides: bundled(golang(github.com/Azure/go_ansiterm)) = v0.0.0_20210617225240_d185dfc1b5a1
|
Provides: bundled(golang(github.com/Azure/go_ansiterm)) = v0.0.0_20210617225240_d185dfc1b5a1
|
||||||
@ -437,19 +440,13 @@ cp -pav test/system %{buildroot}/%{_datadir}/%{name}/test/
|
|||||||
#define license tag if not already defined
|
#define license tag if not already defined
|
||||||
%{!?_licensedir:%global license %doc}
|
%{!?_licensedir:%global license %doc}
|
||||||
|
|
||||||
# PACKIT PACKIT PACKIT PACKIT PACKIT PACKIT PACKIT PACKIT PACKIT PACKIT
|
|
||||||
# These files will be installed by unreleased versions of %%{name} and upstream is
|
|
||||||
# not comfy with a patch using packit's fix-spec-files action so let's remove the file here.
|
|
||||||
# The packager will need to revisit this section on every upstream release.
|
|
||||||
# See: https://github.com/containers/podman/pull/15457#discussion_r955423853
|
|
||||||
rm -f %{buildroot}%{_datadir}/user-tmpfiles.d/%{name}-docker.conf
|
|
||||||
|
|
||||||
%files -f %{name}.file-list
|
%files -f %{name}.file-list
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%doc README.md CONTRIBUTING.md install.md transfer.md
|
%doc README.md CONTRIBUTING.md install.md transfer.md
|
||||||
%{_bindir}/%{name}
|
%{_bindir}/%{name}
|
||||||
%dir %{_libexecdir}/%{name}
|
%dir %{_libexecdir}/%{name}
|
||||||
%{_libexecdir}/%{name}/rootlessport
|
%{_libexecdir}/%{name}/rootlessport
|
||||||
|
%{_libexecdir}/%{name}/quadlet
|
||||||
%{_datadir}/bash-completion/completions/%{name}
|
%{_datadir}/bash-completion/completions/%{name}
|
||||||
# By "owning" the site-functions dir, we don't need to Require zsh
|
# By "owning" the site-functions dir, we don't need to Require zsh
|
||||||
%dir %{_datadir}/zsh/site-functions
|
%dir %{_datadir}/zsh/site-functions
|
||||||
@ -459,14 +456,15 @@ rm -f %{buildroot}%{_datadir}/user-tmpfiles.d/%{name}-docker.conf
|
|||||||
%{_unitdir}/%{name}*
|
%{_unitdir}/%{name}*
|
||||||
%{_userunitdir}/%{name}*
|
%{_userunitdir}/%{name}*
|
||||||
%{_tmpfilesdir}/%{name}.conf
|
%{_tmpfilesdir}/%{name}.conf
|
||||||
%if 0%{?fedora} >= 36
|
%{_systemdgeneratordir}/%{name}-system-generator
|
||||||
|
%{_systemdusergeneratordir}/%{name}-user-generator
|
||||||
%{_modulesloaddir}/%{name}-iptables.conf
|
%{_modulesloaddir}/%{name}-iptables.conf
|
||||||
%endif
|
|
||||||
|
|
||||||
%files docker
|
%files docker
|
||||||
%{_bindir}/docker
|
%{_bindir}/docker
|
||||||
%{_mandir}/man1/docker*.1*
|
%{_mandir}/man1/docker*.1*
|
||||||
%{_tmpfilesdir}/%{name}-docker.conf
|
%{_tmpfilesdir}/%{name}-docker.conf
|
||||||
|
%{_user_tmpfilesdir}/%{name}-docker.conf
|
||||||
|
|
||||||
%files remote
|
%files remote
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
@ -494,11 +492,5 @@ rm -f %{buildroot}%{_datadir}/user-tmpfiles.d/%{name}-docker.conf
|
|||||||
%dir %{_libexecdir}/%{name}
|
%dir %{_libexecdir}/%{name}
|
||||||
%{_libexecdir}/%{name}/gvproxy
|
%{_libexecdir}/%{name}/gvproxy
|
||||||
|
|
||||||
%files quadlet
|
|
||||||
%license LICENSE
|
|
||||||
%{_libexecdir}/%{name}/quadlet
|
|
||||||
%{_systemdgeneratordir}/%{name}-system-generator
|
|
||||||
%{_systemdusergeneratordir}/%{name}-user-generator
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
%autochangelog
|
%autochangelog
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (dnsname-18822f9a4fb35d1349eb256f4cd2bfd372474d84.tar.gz) = de371722fbf18cd23b31485ee7ba36bb41d0d9a932d15e50872989c3ca1ff7246da63143c3725d81089fadda3821a54c18b22150d9d16005b07df6824f5f71f8
|
SHA512 (dnsname-18822f9a4fb35d1349eb256f4cd2bfd372474d84.tar.gz) = de371722fbf18cd23b31485ee7ba36bb41d0d9a932d15e50872989c3ca1ff7246da63143c3725d81089fadda3821a54c18b22150d9d16005b07df6824f5f71f8
|
||||||
SHA512 (gvisor-tap-vsock-aab0ac9367fc5142f5857c36ac2352bcb3c60ab7.tar.gz) = e138125f0fad46f84afebad5769d4428cb29f24ce34e209b21689dc4409487bf2e946c9eb6551297baf36286c9be9a5310a77df4884563cfe247113980f18291
|
SHA512 (gvisor-tap-vsock-aab0ac9367fc5142f5857c36ac2352bcb3c60ab7.tar.gz) = e138125f0fad46f84afebad5769d4428cb29f24ce34e209b21689dc4409487bf2e946c9eb6551297baf36286c9be9a5310a77df4884563cfe247113980f18291
|
||||||
SHA512 (v4.4.0.tar.gz) = 5813c78647ca8ebb809eccaebaa54f4570ef5cea66678bdde5dc5e7a1df77119b56a8acdc0886a45d905419c16a26467f7deb21e6515f2f35b3295baedaa1cd3
|
SHA512 (v4.4.1.tar.gz) = 33a22b7941f4f6715baa1cd2d5b29a4e2e95264c5239877122448f71e1408d8c393bcd2cdaef9516a580eede911c84f1cfea9d7b4c9d287a2737986fdc604e2c
|
||||||
|
Loading…
Reference in New Issue
Block a user