New upstream version 0.44.
- Fix incorrect use of File::Temp->tempfile (RHBZ#953066). - Tidy up the spec file. - po4a-build.conf.5 and po4a-runtime.7 man pages are no longer installed in the English version for some (unknown) reason.
This commit is contained in:
parent
005c3cf828
commit
5e27395240
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/po4a-0.42.tar.gz
|
||||
/po4a-0.44.tar.gz
|
||||
|
88
po4a-0.44-use-tempfile-correctly.patch
Normal file
88
po4a-0.44-use-tempfile-correctly.patch
Normal file
@ -0,0 +1,88 @@
|
||||
diff -ur po4a-0.44.old/lib/Locale/Po4a/Po.pm po4a-0.44/lib/Locale/Po4a/Po.pm
|
||||
--- po4a-0.44.old/lib/Locale/Po4a/Po.pm 2012-10-21 00:03:24.000000000 +0100
|
||||
+++ po4a-0.44/lib/Locale/Po4a/Po.pm 2013-04-17 11:26:54.749652129 +0100
|
||||
@@ -572,7 +572,8 @@
|
||||
|
||||
if (-e $filename) {
|
||||
my ($tmp_filename);
|
||||
- (undef,$tmp_filename)=File::Temp->tempfile($filename."XXXX",
|
||||
+ my $basename = basename($filename);
|
||||
+ (undef,$tmp_filename)=File::Temp::tempfile($basename."XXXX",
|
||||
DIR => "/tmp",
|
||||
OPEN => 0,
|
||||
UNLINK => 0);
|
||||
diff -ur po4a-0.44.old/lib/Locale/Po4a/Wml.pm po4a-0.44/lib/Locale/Po4a/Wml.pm
|
||||
--- po4a-0.44.old/lib/Locale/Po4a/Wml.pm 2012-10-21 00:03:24.000000000 +0100
|
||||
+++ po4a-0.44/lib/Locale/Po4a/Wml.pm 2013-04-17 11:27:43.904492845 +0100
|
||||
@@ -81,7 +81,7 @@
|
||||
sub read {
|
||||
my ($self,$filename)=@_;
|
||||
my $tmp_filename;
|
||||
- (undef,$tmp_filename)=File::Temp->tempfile("po4aXXXX",
|
||||
+ (undef,$tmp_filename)=File::Temp::tempfile("po4aXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => ".xml",
|
||||
OPEN => 0,
|
||||
diff -ur po4a-0.44.old/po4a po4a-0.44/po4a
|
||||
--- po4a-0.44.old/po4a 2012-10-21 00:03:24.000000000 +0100
|
||||
+++ po4a-0.44/po4a 2013-04-17 11:26:05.938810267 +0100
|
||||
@@ -1209,7 +1209,7 @@
|
||||
chdir $po4a_opts{"srcdir"}
|
||||
if (defined $po4a_opts{"srcdir"});
|
||||
if ($po4a_opts{"split"}) {
|
||||
- (undef,$pot_filename)=File::Temp->tempfile("po4aXXXX",
|
||||
+ (undef,$pot_filename)=File::Temp::tempfile("po4aXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => ".pot",
|
||||
OPEN => 0,
|
||||
@@ -1239,7 +1239,7 @@
|
||||
# Create a temporary POT, and check if the old one needs to be
|
||||
# updated (unless --force was specified).
|
||||
unless ($po4a_opts{"force"}) {
|
||||
- (undef,$tmp_file)=File::Temp->tempfile("po4aXXXX",
|
||||
+ (undef,$tmp_file)=File::Temp::tempfile("po4aXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => ".pot",
|
||||
OPEN => 0,
|
||||
@@ -1270,7 +1270,7 @@
|
||||
# Generate a complete .po
|
||||
foreach my $lang (sort keys %po_filename) {
|
||||
my $tmp_bigpo;
|
||||
- (undef,$tmp_bigpo)=File::Temp->tempfile("po4aXXXX",
|
||||
+ (undef,$tmp_bigpo)=File::Temp::tempfile("po4aXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => "-$lang.po",
|
||||
OPEN => 0,
|
||||
@@ -1336,7 +1336,7 @@
|
||||
my $tmp_file;
|
||||
# Create a temporary PO, and check if the old one needs to be
|
||||
# updated (unless --force was specified).
|
||||
- (undef,$tmp_file)=File::Temp->tempfile("po4aXXXX",
|
||||
+ (undef,$tmp_file)=File::Temp::tempfile("po4aXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => ".po",
|
||||
OPEN => 0,
|
||||
diff -ur po4a-0.44.old/po4a-updatepo po4a-0.44/po4a-updatepo
|
||||
--- po4a-0.44.old/po4a-updatepo 2012-10-21 00:03:24.000000000 +0100
|
||||
+++ po4a-0.44/po4a-updatepo 2013-04-17 11:26:05.938810267 +0100
|
||||
@@ -248,7 +248,7 @@
|
||||
if $_ eq '-' && !-e '-'} @pofiles;
|
||||
|
||||
my ($pot_filename);
|
||||
-(undef,$pot_filename)=File::Temp->tempfile("po4a-updatepoXXXX",
|
||||
+(undef,$pot_filename)=File::Temp::tempfile("po4a-updatepoXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => ".pot",
|
||||
OPEN => 0,
|
||||
diff -ur po4a-0.44.old/scripts/msguntypot po4a-0.44/scripts/msguntypot
|
||||
--- po4a-0.44.old/scripts/msguntypot 2012-10-21 00:03:24.000000000 +0100
|
||||
+++ po4a-0.44/scripts/msguntypot 2013-04-17 11:26:05.939810264 +0100
|
||||
@@ -195,7 +195,7 @@
|
||||
|
||||
# Get all po files and report differences in them
|
||||
my ($pofile);
|
||||
-(undef,$pofile)=File::Temp->tempfile("po4aXXXX",
|
||||
+(undef,$pofile)=File::Temp::tempfile("po4aXXXX",
|
||||
DIR => "/tmp",
|
||||
SUFFIX => ".po",
|
||||
OPEN => 0,
|
21
po4a.spec
21
po4a.spec
@ -1,12 +1,14 @@
|
||||
Name: po4a
|
||||
Version: 0.42
|
||||
Release: 3%{?dist}
|
||||
Version: 0.44
|
||||
Release: 1%{?dist}
|
||||
Summary: A tool maintaining translations anywhere
|
||||
Group: Applications/System
|
||||
License: GPL+
|
||||
URL: http://alioth.debian.org/projects/po4a/
|
||||
|
||||
Source0: http://alioth.debian.org/frs/download.php/3723/%{name}-%{version}.tar.gz
|
||||
Patch0: 0001-Remove-defined-anachronism.patch
|
||||
# Patch sent upstream on 2013-04-17.
|
||||
Patch1: po4a-0.44-use-tempfile-correctly.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(Module::Build)
|
||||
@ -44,6 +46,7 @@ tools on areas where they were not expected like documentation.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%{__perl} ./Build.PL installdirs=vendor
|
||||
@ -62,7 +65,6 @@ find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc README* COPYING TODO
|
||||
%{_bindir}/po4a*
|
||||
%{_bindir}/msguntypot
|
||||
@ -70,8 +72,8 @@ find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
|
||||
%{_mandir}/man1/po4a*.1*
|
||||
%{_mandir}/man1/msguntypot.1*
|
||||
%{_mandir}/man3/Locale::Po4a::*.3*
|
||||
%{_mandir}/man5/po4a-build.conf*.5*
|
||||
%{_mandir}/man7/po4a-runtime.7*
|
||||
#%{_mandir}/man5/po4a-build.conf*.5*
|
||||
#%{_mandir}/man7/po4a-runtime.7*
|
||||
%{_mandir}/man7/po4a.7*
|
||||
%{_mandir}/*/man1/po4a*.1*
|
||||
%{_mandir}/*/man1/msguntypot.1*
|
||||
@ -81,6 +83,13 @@ find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
|
||||
%{_mandir}/*/man7/po4a-runtime.7*
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2013 Richard W.M. Jones <rjones@redhat.com> - 0.44-1
|
||||
- New upstream version 0.44.
|
||||
- Fix incorrect use of File::Temp->tempfile (RHBZ#953066).
|
||||
- Tidy up the spec file.
|
||||
- po4a-build.conf.5 and po4a-runtime.7 man pages are no longer
|
||||
installed in the English version for some (unknown) reason.
|
||||
|
||||
* Mon Mar 11 2013 Ralf Corsépius <corsepiu@fedoraproject.org> - 0.42-3
|
||||
- Add 0001-Remove-defined-anachronism.patch.
|
||||
- Modernize spec.
|
||||
|
Loading…
Reference in New Issue
Block a user