Upstream update.
- Remove 0001-Remove-defined-anachronism.patch, po4a-0.44-use-tempfile-correctly.patch. - Reflect upstream URL having changed. - Reflect Source0-URL having changed.
This commit is contained in:
parent
06cd4bab9d
commit
5baa145e51
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/po4a-0.44.tar.gz
|
/po4a-0.45.tar.gz
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
From 1df9c6543540b033edb37ead08f02b82b1ef71df Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Ralf=20Cors=C3=A9pius?= <corsepiu@fedoraproject.org>
|
|
||||||
Date: Mon, 11 Mar 2013 12:51:08 +0100
|
|
||||||
Subject: [PATCH] Remove 'defined' anachronism
|
|
||||||
|
|
||||||
---
|
|
||||||
lib/Locale/Po4a/Sgml.pm | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/Locale/Po4a/Sgml.pm b/lib/Locale/Po4a/Sgml.pm
|
|
||||||
index 3e9f2a6..a8165b9 100644
|
|
||||||
--- a/lib/Locale/Po4a/Sgml.pm
|
|
||||||
+++ b/lib/Locale/Po4a/Sgml.pm
|
|
||||||
@@ -366,7 +366,7 @@ sub parse_file {
|
|
||||||
# - protect entities from expansion (ie "&release;")
|
|
||||||
my $origfile="";
|
|
||||||
my $i=0;
|
|
||||||
- while (defined(@{$self->{TT}{doc_in}}) && $i < @{$self->{TT}{doc_in}}) {
|
|
||||||
+ while (@{$self->{TT}{doc_in}} && $i < @{$self->{TT}{doc_in}}) {
|
|
||||||
$origfile .= ${$self->{TT}{doc_in}}[$i];
|
|
||||||
$i+=2;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.8.1.4
|
|
||||||
|
|
@ -1,88 +0,0 @@
|
|||||||
diff -ur po4a-0.44.old/lib/Locale/Po4a/Po.pm po4a-0.44/lib/Locale/Po4a/Po.pm
|
|
||||||
--- po4a-0.44.old/lib/Locale/Po4a/Po.pm 2012-10-21 00:03:24.000000000 +0100
|
|
||||||
+++ po4a-0.44/lib/Locale/Po4a/Po.pm 2013-04-17 11:26:54.749652129 +0100
|
|
||||||
@@ -572,7 +572,8 @@
|
|
||||||
|
|
||||||
if (-e $filename) {
|
|
||||||
my ($tmp_filename);
|
|
||||||
- (undef,$tmp_filename)=File::Temp->tempfile($filename."XXXX",
|
|
||||||
+ my $basename = basename($filename);
|
|
||||||
+ (undef,$tmp_filename)=File::Temp::tempfile($basename."XXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
OPEN => 0,
|
|
||||||
UNLINK => 0);
|
|
||||||
diff -ur po4a-0.44.old/lib/Locale/Po4a/Wml.pm po4a-0.44/lib/Locale/Po4a/Wml.pm
|
|
||||||
--- po4a-0.44.old/lib/Locale/Po4a/Wml.pm 2012-10-21 00:03:24.000000000 +0100
|
|
||||||
+++ po4a-0.44/lib/Locale/Po4a/Wml.pm 2013-04-17 11:27:43.904492845 +0100
|
|
||||||
@@ -81,7 +81,7 @@
|
|
||||||
sub read {
|
|
||||||
my ($self,$filename)=@_;
|
|
||||||
my $tmp_filename;
|
|
||||||
- (undef,$tmp_filename)=File::Temp->tempfile("po4aXXXX",
|
|
||||||
+ (undef,$tmp_filename)=File::Temp::tempfile("po4aXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => ".xml",
|
|
||||||
OPEN => 0,
|
|
||||||
diff -ur po4a-0.44.old/po4a po4a-0.44/po4a
|
|
||||||
--- po4a-0.44.old/po4a 2012-10-21 00:03:24.000000000 +0100
|
|
||||||
+++ po4a-0.44/po4a 2013-04-17 11:26:05.938810267 +0100
|
|
||||||
@@ -1209,7 +1209,7 @@
|
|
||||||
chdir $po4a_opts{"srcdir"}
|
|
||||||
if (defined $po4a_opts{"srcdir"});
|
|
||||||
if ($po4a_opts{"split"}) {
|
|
||||||
- (undef,$pot_filename)=File::Temp->tempfile("po4aXXXX",
|
|
||||||
+ (undef,$pot_filename)=File::Temp::tempfile("po4aXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => ".pot",
|
|
||||||
OPEN => 0,
|
|
||||||
@@ -1239,7 +1239,7 @@
|
|
||||||
# Create a temporary POT, and check if the old one needs to be
|
|
||||||
# updated (unless --force was specified).
|
|
||||||
unless ($po4a_opts{"force"}) {
|
|
||||||
- (undef,$tmp_file)=File::Temp->tempfile("po4aXXXX",
|
|
||||||
+ (undef,$tmp_file)=File::Temp::tempfile("po4aXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => ".pot",
|
|
||||||
OPEN => 0,
|
|
||||||
@@ -1270,7 +1270,7 @@
|
|
||||||
# Generate a complete .po
|
|
||||||
foreach my $lang (sort keys %po_filename) {
|
|
||||||
my $tmp_bigpo;
|
|
||||||
- (undef,$tmp_bigpo)=File::Temp->tempfile("po4aXXXX",
|
|
||||||
+ (undef,$tmp_bigpo)=File::Temp::tempfile("po4aXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => "-$lang.po",
|
|
||||||
OPEN => 0,
|
|
||||||
@@ -1336,7 +1336,7 @@
|
|
||||||
my $tmp_file;
|
|
||||||
# Create a temporary PO, and check if the old one needs to be
|
|
||||||
# updated (unless --force was specified).
|
|
||||||
- (undef,$tmp_file)=File::Temp->tempfile("po4aXXXX",
|
|
||||||
+ (undef,$tmp_file)=File::Temp::tempfile("po4aXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => ".po",
|
|
||||||
OPEN => 0,
|
|
||||||
diff -ur po4a-0.44.old/po4a-updatepo po4a-0.44/po4a-updatepo
|
|
||||||
--- po4a-0.44.old/po4a-updatepo 2012-10-21 00:03:24.000000000 +0100
|
|
||||||
+++ po4a-0.44/po4a-updatepo 2013-04-17 11:26:05.938810267 +0100
|
|
||||||
@@ -248,7 +248,7 @@
|
|
||||||
if $_ eq '-' && !-e '-'} @pofiles;
|
|
||||||
|
|
||||||
my ($pot_filename);
|
|
||||||
-(undef,$pot_filename)=File::Temp->tempfile("po4a-updatepoXXXX",
|
|
||||||
+(undef,$pot_filename)=File::Temp::tempfile("po4a-updatepoXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => ".pot",
|
|
||||||
OPEN => 0,
|
|
||||||
diff -ur po4a-0.44.old/scripts/msguntypot po4a-0.44/scripts/msguntypot
|
|
||||||
--- po4a-0.44.old/scripts/msguntypot 2012-10-21 00:03:24.000000000 +0100
|
|
||||||
+++ po4a-0.44/scripts/msguntypot 2013-04-17 11:26:05.939810264 +0100
|
|
||||||
@@ -195,7 +195,7 @@
|
|
||||||
|
|
||||||
# Get all po files and report differences in them
|
|
||||||
my ($pofile);
|
|
||||||
-(undef,$pofile)=File::Temp->tempfile("po4aXXXX",
|
|
||||||
+(undef,$pofile)=File::Temp::tempfile("po4aXXXX",
|
|
||||||
DIR => "/tmp",
|
|
||||||
SUFFIX => ".po",
|
|
||||||
OPEN => 0,
|
|
24
po4a.spec
24
po4a.spec
@ -1,14 +1,11 @@
|
|||||||
Name: po4a
|
Name: po4a
|
||||||
Version: 0.44
|
Version: 0.45
|
||||||
Release: 13%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A tool maintaining translations anywhere
|
Summary: A tool maintaining translations anywhere
|
||||||
License: GPL+
|
License: GPL+
|
||||||
URL: http://alioth.debian.org/projects/po4a/
|
URL: https://po4a.alioth.debian.org/
|
||||||
|
|
||||||
Source0: http://alioth.debian.org/frs/download.php/file/3786/%{name}-%{version}.tar.gz
|
Source0: http://alioth.debian.org/frs/download.php/file/3942/%{name}-%{version}.tar.gz
|
||||||
Patch0: 0001-Remove-defined-anachronism.patch
|
|
||||||
# Patch sent upstream on 2013-04-17.
|
|
||||||
Patch1: po4a-0.44-use-tempfile-correctly.patch
|
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: perl(Locale::gettext) >= 1.01
|
BuildRequires: perl(Locale::gettext) >= 1.01
|
||||||
@ -49,8 +46,6 @@ tools on areas where they were not expected like documentation.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
chmod +x scripts/*
|
chmod +x scripts/*
|
||||||
|
|
||||||
@ -85,8 +80,8 @@ find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
|
|||||||
%{_mandir}/man1/po4a*.1*
|
%{_mandir}/man1/po4a*.1*
|
||||||
%{_mandir}/man1/msguntypot.1*
|
%{_mandir}/man1/msguntypot.1*
|
||||||
%{_mandir}/man3/Locale::Po4a::*.3*
|
%{_mandir}/man3/Locale::Po4a::*.3*
|
||||||
#%{_mandir}/man5/po4a-build.conf*.5*
|
%{_mandir}/man5/po4a-build.conf*.5*
|
||||||
#%{_mandir}/man7/po4a-runtime.7*
|
%{_mandir}/man7/po4a-runtime.7*
|
||||||
%{_mandir}/man7/po4a.7*
|
%{_mandir}/man7/po4a.7*
|
||||||
%{_mandir}/*/man1/po4a*.1*
|
%{_mandir}/*/man1/po4a*.1*
|
||||||
%{_mandir}/*/man1/msguntypot.1*
|
%{_mandir}/*/man1/msguntypot.1*
|
||||||
@ -96,6 +91,13 @@ find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
|
|||||||
%{_mandir}/*/man7/po4a-runtime.7*
|
%{_mandir}/*/man7/po4a-runtime.7*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 10 2014 Ralf Corsépius <corsepiu@fedoraproject.org> - 0.45-1
|
||||||
|
- Upstream update.
|
||||||
|
- Remove 0001-Remove-defined-anachronism.patch,
|
||||||
|
po4a-0.44-use-tempfile-correctly.patch.
|
||||||
|
- Reflect upstream URL having changed.
|
||||||
|
- Reflect Source0-URL having changed.
|
||||||
|
|
||||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-13
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-13
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user