- Upstream update.

- Reflect upstream having changed to Module::Build.
- Remove po4a-0.40.1.diff.
This commit is contained in:
Ralf Corsépius 2010-12-08 08:14:41 +01:00
parent b224c60800
commit 49b50bc276
4 changed files with 15 additions and 62 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
po4a-v0.40.1.tar.gz
/po4a-0.41.tar.gz

View File

@ -1,41 +0,0 @@
diff -Naur po4a-v0.40.1.orig/t/compare-po.pl po4a-v0.40.1/t/compare-po.pl
--- po4a-v0.40.1.orig/t/compare-po.pl 1970-01-01 01:00:00.000000000 +0100
+++ po4a-v0.40.1/t/compare-po.pl 2010-10-15 09:39:48.404737104 +0200
@@ -0,0 +1,37 @@
+#! /usr/bin/perl
+# Remove header entry of two PO files and compare them
+
+my $f1 = shift(@ARGV);
+my $f2 = shift(@ARGV);
+
+open IN1, "<", $f1 or die "Unable to read 1st file: $!\n";
+open IN2, "<", $f2 or die "Unable to read 2nd file: $!\n";
+my $inMsgstr = 0;
+my $lineno = 0;
+while (<IN1>) {
+ $lineno ++;
+ if (m/^msgstr/) {
+ $inMsgstr = 1;
+ } elsif ($inMsgstr == 1 && $_ !~ /^"/) {
+ last;
+ }
+}
+$inMsgstr = 0;
+while (<IN2>) {
+ if (m/^msgstr/) {
+ $inMsgstr = 1;
+ } elsif ($inMsgstr == 1 && $_ !~ /^"/) {
+ last;
+ }
+}
+
+# Now compare lines
+while (<IN1>) {
+ $lineno ++;
+ my $l2 = <IN2> or die "Unexpected EOF found when reading $f2\n";
+ $_ eq $l2 or die "Files $f1 and $f2 differ at line $lineno:\n-$_+$l2\n";
+}
+close IN1;
+die "EOF expected at 2nd file\n" unless eof(IN2);
+close IN2;
+exit 0;

View File

@ -1,13 +1,11 @@
Name: po4a
Version: 0.40.1
Version: 0.41
Release: 1%{?dist}
Summary: A tool maintaining translations anywhere
Group: Applications/System
# Nothing in the source tree specifies a version of the GPL.
License: GPL+
URL: http://alioth.debian.org/projects/po4a/
Source0: http://alioth.debian.org/frs/download.php/3341/%{name}-v%{version}.tar.gz
Patch0: %{name}-%{version}.diff
Source0: http://alioth.debian.org/frs/download.php/3472/%{name}-%{version}.tar.gz
BuildArch: noarch
BuildRequires: perl(Module::Build)
@ -43,26 +41,17 @@ more interestingly, the maintenance of translations) using gettext
tools on areas where they were not expected like documentation.
%prep
%setup -q -n %{name}-v%{version}
%patch0 -p1
# Get rid of /usr/bin/env
sed -i -e 's,#! /usr/bin/env perl,#!/usr/bin/perl,' \
po4a po4a-gettextize po4a-translate po4a-updatepo po4a-normalize scripts/msguntypot
%setup -q -n %{name}-%{version}
%build
# Propagate %%{_prefix}
sed -i -e 's,^prefix =.*$,prefix = %{_prefix},' po/bin/Makefile
# Install to vendor dirs
sed -i -e 's,perl Build.PL,perl Build.PL --installdirs vendor,' Makefile
make
%{__perl} ./Build.PL installdirs=vendor
./Build
%install
make install DESTDIR=%{buildroot}
find %{buildroot} -type f \( -name .packlist -or -name perllocal.pod \
-or \( -name '*.bs' -a -empty \) \) -exec rm -f {} \;
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
./Build install destdir=$RPM_BUILD_ROOT create_packlist=0
find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
%{_fixperms} %{buildroot}
%{_fixperms} $RPM_BUILD_ROOT/*
%find_lang %{name}
@ -93,6 +82,11 @@ rm -rf %{buildroot}
%{_mandir}/*/man7/po4a-runtime.7*
%changelog
* Wed Dec 08 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 0.41-1
- Upstream update.
- Reflect upstream having changed to Module::Build.
- Remove po4a-0.40.1.diff.
* Fri Oct 15 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 0.40.1-1
- Upstream update.
- Add po4a-v0.40.1.diff (add missing file t/compare-po.pl)

View File

@ -1 +1 @@
669cb97bf9d7ef8ff4fb7af13124bfcb po4a-v0.40.1.tar.gz
93b3137502a749bdc3a059466f2a19d2 po4a-0.41.tar.gz