import pmix-2.2.4rc1-1.el8
This commit is contained in:
parent
f04ceb285f
commit
c6590a1205
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/pmix-2.1.1.tar.bz2
|
||||
SOURCES/pmix-2.2.4rc1.tar.bz2
|
||||
|
@ -1 +1 @@
|
||||
cb55b25d99d11587f7eaa4700fef4ba666d55843 SOURCES/pmix-2.1.1.tar.bz2
|
||||
4ec1caef72ac81cfcca2fa1c49bc13cfefacb7ec SOURCES/pmix-2.2.4rc1.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9be66d9..b3f4a3d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -176,7 +176,6 @@ AS_IF([test "$pmix_debug" = "1"],
|
||||
|
||||
LT_INIT()
|
||||
LT_LANG([C])
|
||||
-LT_LANG([C++])
|
||||
|
||||
############################################################################
|
||||
# Setup the core
|
@ -1,14 +1,11 @@
|
||||
Name: pmix
|
||||
Version: 2.1.1
|
||||
Version: 2.2.4rc1
|
||||
Release: 1%{?dist}
|
||||
Summary: Process Management Interface Exascale (PMIx)
|
||||
License: BSD
|
||||
URL: https://pmix.github.io/pmix/
|
||||
URL: https://pmix.org/
|
||||
Source0: https://github.com/pmix/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
|
||||
|
||||
# Remove configure check for C++ since requires only C
|
||||
Patch0: pmix_remove_cxx_lang.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: environment(modules)
|
||||
@ -52,7 +49,6 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
echo touching lexer sources to recompile them ...
|
||||
find src -name \*.l -print -exec touch --no-create {} \;
|
||||
@ -64,6 +60,8 @@ find src -name \*.l -print -exec touch --no-create {} \;
|
||||
--sysconfdir=%{_sysconfdir}/%{name} \
|
||||
--disable-static \
|
||||
--disable-silent-rules \
|
||||
--enable-pmix-binaries \
|
||||
--with-tests-examples \
|
||||
--enable-shared \
|
||||
--enable-pmi-backward-compatibility \
|
||||
--with-munge
|
||||
@ -84,11 +82,13 @@ install -d -m 0755 %{buildroot}%{_libdir}/%{name}/lib
|
||||
mv %{buildroot}%{_libdir}/libpmi.so* %{buildroot}%{_libdir}/%{name}/lib
|
||||
mv %{buildroot}%{_libdir}/libpmi2.so* %{buildroot}%{_libdir}/%{name}/lib
|
||||
|
||||
# move man pages to build root
|
||||
install -d -m 0755 %{buildroot}%{_mandir}/man3
|
||||
install -d -m 0755 %{buildroot}%{_mandir}/man7
|
||||
mv man/man3/*.3 %{buildroot}%{_mandir}/man3/
|
||||
mv man/man7/*.7 %{buildroot}%{_mandir}/man7/
|
||||
# set up pmix self-test infra for install
|
||||
install -d -m 0755 %{buildroot}%{_datadir}/%{name}/test
|
||||
for f in pmix_client pmix_regex
|
||||
do
|
||||
mv test/.libs/$f %{buildroot}%{_datadir}/%{name}/$f
|
||||
done
|
||||
mv test/.libs/pmix_test %{buildroot}%{_datadir}/%{name}/test/pmix_test
|
||||
|
||||
# install pmi/pmix environment module file
|
||||
install -d -m 0755 %{buildroot}%{_modulesdir}/pmi
|
||||
@ -148,13 +148,17 @@ EOF
|
||||
%license LICENSE
|
||||
%doc README
|
||||
%dir %{_datadir}/%{name}
|
||||
%dir %{_datadir}/%{name}/test
|
||||
%dir %{_libdir}/%{name}
|
||||
%dir %{_libdir}/%{name}/lib
|
||||
%dir %{_modulesdir}/pmi
|
||||
%dir %{_sysconfdir}/%{name}
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/*.conf
|
||||
%{_datadir}/%{name}/*.txt
|
||||
%{_datadir}/%{name}/pmix_*
|
||||
%{_datadir}/%{name}/test/pmix_test
|
||||
%{_libdir}/libpmix.so.*
|
||||
%{_libdir}/libmca_common_dstore.so.*
|
||||
%{_libdir}/%{name}/*.so
|
||||
%{_libdir}/%{name}/lib/*.so.*
|
||||
%{_modulesdir}/pmi/*
|
||||
@ -163,12 +167,25 @@ EOF
|
||||
%{_datadir}/%{name}/*.supp
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/libpmix.so
|
||||
%{_libdir}/libmca_common_dstore.so
|
||||
%{_libdir}/%{name}/lib/*.so
|
||||
%{_libdir}/%{name}/lib/pkgconfig/*.pc
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_mandir}/man[37]/*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 03 2020 Honggang Li <honli@redhat.com> - 2.2.4rc1-1
|
||||
- Update to 2.2.4rc1
|
||||
- Related: rhbz#1840596
|
||||
|
||||
* Mon Apr 20 2020 Honggang Li <honli@redhat.com> - 2.2.3-1
|
||||
- Update to 2.2.3
|
||||
- Add pmix-devel into CRB repository
|
||||
- Related: rhbz#1816198, rhbz#1822520
|
||||
|
||||
* Wed Mar 20 2019 Jarod Wilson <jarod@redhat.com> - 2.1.1-2
|
||||
- Add the --with-tests-examples flag to be able to better verify functionality
|
||||
- Related: rhbz#1682374
|
||||
|
||||
* Fri Mar 16 2018 Philip Kovacs <pkdevel@yahoo.com> - 2.1.1-1
|
||||
- Update to 2.1.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user