Add patch to remove unneeded check for C++
This commit is contained in:
parent
aba8286515
commit
c1bd7917d5
@ -1,11 +1,14 @@
|
|||||||
Name: pmix
|
Name: pmix
|
||||||
Version: 2.1.0
|
Version: 2.1.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Process Management Interface Exascale (PMIx)
|
Summary: Process Management Interface Exascale (PMIx)
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://pmix.github.io/pmix/
|
URL: https://pmix.github.io/pmix/
|
||||||
Source0: https://github.com/pmix/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
|
Source0: https://github.com/pmix/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
|
# Remove configure check for C++ since requires only C
|
||||||
|
Patch0: pmix_remove_cxx_lang.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: environment(modules)
|
BuildRequires: environment(modules)
|
||||||
@ -49,6 +52,7 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
echo touching lexer sources to recompile them ...
|
echo touching lexer sources to recompile them ...
|
||||||
find src -name \*.l -print -exec touch --no-create {} \;
|
find src -name \*.l -print -exec touch --no-create {} \;
|
||||||
@ -165,6 +169,9 @@ EOF
|
|||||||
%{_mandir}/man[37]/*
|
%{_mandir}/man[37]/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 18 2018 Philip Kovacs <pkdevel@yahoo.com> - 2.1.0-3
|
||||||
|
- Add patch to remove unneeded check for C++
|
||||||
|
|
||||||
* Thu Feb 15 2018 Philip Kovacs <pkdevel@yahoo.com> - 2.1.0-2
|
* Thu Feb 15 2018 Philip Kovacs <pkdevel@yahoo.com> - 2.1.0-2
|
||||||
- Rebuild for libevent soname bump
|
- Rebuild for libevent soname bump
|
||||||
|
|
||||||
|
12
pmix_remove_cxx_lang.patch
Normal file
12
pmix_remove_cxx_lang.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 9be66d9..b3f4a3d 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -176,7 +176,6 @@ AS_IF([test "$pmix_debug" = "1"],
|
||||||
|
|
||||||
|
LT_INIT()
|
||||||
|
LT_LANG([C])
|
||||||
|
-LT_LANG([C++])
|
||||||
|
|
||||||
|
############################################################################
|
||||||
|
# Setup the core
|
Loading…
Reference in New Issue
Block a user