Update to 3.1.4rc1
This commit is contained in:
parent
4a4de9d2d6
commit
6b7dd8b570
5
.rpmlint
Normal file
5
.rpmlint
Normal file
@ -0,0 +1,5 @@
|
|||||||
|
from Config import *
|
||||||
|
addFilter("W: no-documentation")
|
||||||
|
addFilter("W: no-manual-page-for-binary")
|
||||||
|
addFilter("W: shared-lib-calls-exit")
|
||||||
|
addFilter("W: spelling-error")
|
24
pmix.spec
24
pmix.spec
@ -1,16 +1,12 @@
|
|||||||
|
%global name_version %{name}-%{version}rc1
|
||||||
|
|
||||||
Name: pmix
|
Name: pmix
|
||||||
Version: 3.1.3
|
Version: 3.1.4
|
||||||
Release: 1%{?dist}
|
Release: 0.1.rc1%{?dist}
|
||||||
Summary: Process Management Interface Exascale (PMIx)
|
Summary: Process Management Interface Exascale (PMIx)
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://pmix.github.io/pmix/
|
URL: https://pmix.github.io/pmix/
|
||||||
Source0: https://github.com/pmix/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
|
Source0: https://github.com/pmix/%{name}/releases/download/v%{version}/%{name_version}.tar.bz2
|
||||||
|
|
||||||
# Remove configure check for C++ since requires only C
|
|
||||||
Patch0: pmix_remove_cxx_lang.patch
|
|
||||||
# Fix pointer casts/derefs in test suite
|
|
||||||
Patch1: pmix_pointer_casts_1.patch
|
|
||||||
Patch2: pmix_pointer_casts_2.patch
|
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -59,16 +55,13 @@ based starters (e.g., mpirun).
|
|||||||
* pevent - inject an event into the system
|
* pevent - inject an event into the system
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name_version}
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
echo touching lexer sources to recompile them ...
|
echo touching lexer sources to recompile them ...
|
||||||
find src -name \*.l -print -exec touch --no-create {} \;
|
find src -name \*.l -print -exec touch --no-create {} \;
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{_builddir}/%{name}-%{version}/autogen.pl
|
%{_builddir}/%{name_version}/autogen.pl
|
||||||
%configure \
|
%configure \
|
||||||
--prefix=%{_prefix} \
|
--prefix=%{_prefix} \
|
||||||
--sysconfdir=%{_sysconfdir}/%{name} \
|
--sysconfdir=%{_sysconfdir}/%{name} \
|
||||||
@ -158,6 +151,9 @@ EOF
|
|||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 19 2019 Philip Kovacs <pkdevel@yahoo.com> - 3.1.4-0.1.rc1
|
||||||
|
- Update to 3.1.4rc1
|
||||||
|
|
||||||
* Sat Jul 13 2019 Philip Kovacs <pkdevel@yahoo.com> - 3.1.3-1
|
* Sat Jul 13 2019 Philip Kovacs <pkdevel@yahoo.com> - 3.1.3-1
|
||||||
- Update to 3.1.3
|
- Update to 3.1.3
|
||||||
|
|
||||||
|
@ -1,59 +0,0 @@
|
|||||||
commit 3a7defdec3049b204e602f6fd9d5c5a71bf1df7d
|
|
||||||
Author: Philip Kovacs <pkdevel@yahoo.com>
|
|
||||||
Date: Tue Jul 9 02:25:53 2019 -0400
|
|
||||||
|
|
||||||
fix incorrect pointer casts/derefs
|
|
||||||
|
|
||||||
Signed-off-by: Philip Kovacs <pkdevel@yahoo.com>
|
|
||||||
|
|
||||||
diff --git a/test/test_server.c b/test/test_server.c
|
|
||||||
index aa897fb5..d0ab53ce 100644
|
|
||||||
--- a/test/test_server.c
|
|
||||||
+++ b/test/test_server.c
|
|
||||||
@@ -187,7 +187,7 @@ static void server_unpack_procs(char *buf, size_t size)
|
|
||||||
char *nspace;
|
|
||||||
|
|
||||||
while ((size_t)(ptr - buf) < size) {
|
|
||||||
- ns_count = (size_t)*ptr;
|
|
||||||
+ ns_count = *(size_t *)ptr;
|
|
||||||
ptr += sizeof(size_t);
|
|
||||||
|
|
||||||
for (i = 0; i < ns_count; i++) {
|
|
||||||
@@ -201,10 +201,10 @@ static void server_unpack_procs(char *buf, size_t size)
|
|
||||||
nspace = ptr;
|
|
||||||
ptr += PMIX_MAX_NSLEN+1;
|
|
||||||
|
|
||||||
- ntasks = (size_t)*ptr;
|
|
||||||
+ ntasks = *(size_t *)ptr;
|
|
||||||
ptr += sizeof(size_t);
|
|
||||||
|
|
||||||
- ltasks = (size_t)*ptr;
|
|
||||||
+ ltasks = *(size_t *)ptr;
|
|
||||||
ptr += sizeof(size_t);
|
|
||||||
|
|
||||||
PMIX_LIST_FOREACH(tmp, server_nspace, server_nspace_t) {
|
|
||||||
@@ -226,7 +226,7 @@ static void server_unpack_procs(char *buf, size_t size)
|
|
||||||
}
|
|
||||||
size_t i;
|
|
||||||
for (i = 0; i < ltasks; i++) {
|
|
||||||
- int rank = (int)*ptr;
|
|
||||||
+ int rank = *(int *)ptr;
|
|
||||||
ptr += sizeof(int);
|
|
||||||
if (ns_item->task_map[rank] >= 0) {
|
|
||||||
continue;
|
|
||||||
@@ -651,13 +651,13 @@ static void server_unpack_dmdx(char *buf, int *sender, pmix_proc_t *proc)
|
|
||||||
{
|
|
||||||
char *ptr = buf;
|
|
||||||
|
|
||||||
- *sender = (int)*ptr;
|
|
||||||
+ *sender = *(int *)ptr;
|
|
||||||
ptr += sizeof(int);
|
|
||||||
|
|
||||||
memcpy(proc->nspace, ptr, PMIX_MAX_NSLEN +1);
|
|
||||||
ptr += PMIX_MAX_NSLEN +1;
|
|
||||||
|
|
||||||
- proc->rank = (int)*ptr;
|
|
||||||
+ proc->rank = *(int *)ptr;
|
|
||||||
ptr += sizeof(int);
|
|
||||||
}
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/test/test_server.c b/test/test_server.c
|
|
||||||
index 981a6604..ee91afd9 100644
|
|
||||||
--- a/test/test_server.c
|
|
||||||
+++ b/test/test_server.c
|
|
||||||
@@ -195,7 +195,7 @@ static void server_unpack_procs(char *buf, size_t size)
|
|
||||||
size_t ltasks, ntasks;
|
|
||||||
int server_id;
|
|
||||||
|
|
||||||
- server_id = *ptr;
|
|
||||||
+ server_id = *(int *)ptr;
|
|
||||||
ptr += sizeof(int);
|
|
||||||
|
|
||||||
nspace = ptr;
|
|
@ -1,12 +0,0 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 3cbd07e8..4bab86e6 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -201,7 +201,6 @@ AS_IF([test "$pmix_debug" = "1"],
|
|
||||||
|
|
||||||
LT_INIT()
|
|
||||||
LT_LANG([C])
|
|
||||||
-LT_LANG([C++])
|
|
||||||
|
|
||||||
############################################################################
|
|
||||||
# Setup the core
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pmix-3.1.3.tar.bz2) = 2d026bd83bfe692974b95496be26b35f07a689a8949acfc89f654a7f32d5c3aaf7c1988eeca539c007d2702557eb097d4822f41f7100387e4b452beda6e661a0
|
SHA512 (pmix-3.1.4rc1.tar.bz2) = 8d21fd9830f50a433af9ee9b2502d0a768723b041fa2a419f3cabd9a97482dfa7726451c8fc9ba8add5a42785869b8e705d3a934cd4f63dca0ca989163dc9706
|
||||||
|
Loading…
Reference in New Issue
Block a user