22 lines
1.1 KiB
Diff
22 lines
1.1 KiB
Diff
diff -up pmdk-1.11.1/src/Makefile.orig pmdk-1.11.1/src/Makefile
|
|
--- pmdk-1.11.1/src/Makefile.orig 2022-01-13 18:51:59.452875151 -0500
|
|
+++ pmdk-1.11.1/src/Makefile 2022-01-13 18:54:25.780482444 -0500
|
|
@@ -188,7 +188,7 @@ install: all pkg-config
|
|
install -d $(PMREORDER_DESTDIR)
|
|
install -p -m 0644 $(PMREORDER_FILES) $(PMREORDER_DESTDIR)
|
|
@echo "#!/bin/sh" > $(PMREORDER_SRC)/pmreorder
|
|
- @echo "exec python3 $(PMREORDER_ROOTDIR)/pmreorder.py $(SRCVERSION) \$$*" >> $(PMREORDER_SRC)/pmreorder
|
|
+ @echo "exec /usr/libexec/platform-python $(PMREORDER_ROOTDIR)/pmreorder.py $(SRCVERSION) \$$*" >> $(PMREORDER_SRC)/pmreorder
|
|
install -d $(PMREORDER_BIN)
|
|
install -p $(PMREORDER_SRC)/pmreorder $(PMREORDER_BIN)
|
|
$(RM) $(PKG_CONFIG_FILES)
|
|
diff -up pmdk-1.11.1/src/test/RUNTESTS.py.orig pmdk-1.11.1/src/test/RUNTESTS.py
|
|
--- pmdk-1.11.1/src/test/RUNTESTS.py.orig 2022-01-13 18:52:09.080401838 -0500
|
|
+++ pmdk-1.11.1/src/test/RUNTESTS.py 2022-01-13 18:54:46.129368430 -0500
|
|
@@ -1,4 +1,4 @@
|
|
-#!/usr/bin/env python3
|
|
+#!/usr/libexec/platform-python
|
|
# SPDX-License-Identifier: BSD-3-Clause
|
|
# Copyright 2019-2021, Intel Corporation
|
|
|