pmdk/SOURCES/pmdk-use-platform-python.patch

22 lines
1.1 KiB
Diff

diff -up pmdk-1.9.2/src/Makefile.orig pmdk-1.9.2/src/Makefile
--- pmdk-1.9.2/src/Makefile.orig 2021-01-06 16:53:52.717410291 -0500
+++ pmdk-1.9.2/src/Makefile 2021-01-06 16:53:52.718410294 -0500
@@ -186,7 +186,7 @@ install: all pkg-config
install -d $(PMREORDER_DESTDIR)
install -p -m 0644 $(PMREORDER_FILES) $(PMREORDER_DESTDIR)
@echo "#!/bin/sh" > $(PMREORDER_SRC)/pmreorder
- @echo "exec python3 $(PMREORDER_ROOTDIR)/pmreorder.py $(SRCVERSION) \$$*" >> $(PMREORDER_SRC)/pmreorder
+ @echo "exec /usr/libexec/platform-python $(PMREORDER_ROOTDIR)/pmreorder.py $(SRCVERSION) \$$*" >> $(PMREORDER_SRC)/pmreorder
install -d $(PMREORDER_BIN)
install -p $(PMREORDER_SRC)/pmreorder $(PMREORDER_BIN)
$(RM) $(PKG_CONFIG_FILES)
diff -up pmdk-1.9.2/src/test/RUNTESTS.py.orig pmdk-1.9.2/src/test/RUNTESTS.py
--- pmdk-1.9.2/src/test/RUNTESTS.py.orig 2021-01-06 16:54:37.937567105 -0500
+++ pmdk-1.9.2/src/test/RUNTESTS.py 2021-01-06 16:54:37.938567109 -0500
@@ -1,4 +1,4 @@
-#!/usr/bin/env python3
+#!/usr/libexec/platform-python
# SPDX-License-Identifier: BSD-3-Clause
# Copyright 2019-2020, Intel Corporation