77 lines
2.4 KiB
Diff
77 lines
2.4 KiB
Diff
From 1de4e487fb7457871301a898cae724531bd0233d Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
|
|
Date: Mon, 25 Dec 2023 13:29:25 +0000
|
|
Subject: [PATCH] meson: Fix PLY_ENABLE_SYSTEMD_INTEGRATION define
|
|
|
|
---
|
|
meson.build | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 522abb8d..26789060 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -46,58 +46,59 @@ if get_option('systemd-integration')
|
|
)
|
|
systemd_ask_password_agent = find_program('systemd-tty-ask-password-agent')
|
|
endif
|
|
|
|
if get_option('upstart-monitoring')
|
|
dbus_dep = dependency('dbus-1')
|
|
curses_dep = dependency('curses')
|
|
endif
|
|
|
|
# Logo
|
|
plymouth_logo_file = get_option('logo')
|
|
use_fallback_logo = plymouth_logo_file == ''
|
|
if use_fallback_logo
|
|
plymouth_logo_file = get_option('prefix') / get_option('datadir') / 'plymouth' / 'bizcom.png'
|
|
endif
|
|
|
|
# Global C flags
|
|
add_project_arguments([
|
|
'-D_GNU_SOURCE',
|
|
'-include', 'config.h',
|
|
],
|
|
language: 'c'
|
|
)
|
|
|
|
# config.h
|
|
conf = configuration_data()
|
|
conf.set_quoted('BOOT_TTY', get_option('boot-tty'))
|
|
conf.set_quoted('SHUTDOWN_TTY', get_option('shutdown-tty'))
|
|
conf.set_quoted('RELEASE_FILE', get_option('release-file'))
|
|
conf.set('HAVE_UDEV', libudev_dep.found())
|
|
+conf.set('PLY_ENABLE_SYSTEMD_INTEGRATION', get_option('systemd-integration'))
|
|
conf.set('PLY_ENABLE_TRACING', get_option('tracing'))
|
|
conf.set_quoted('PLYMOUTH_RUNTIME_DIR', plymouth_runtime_dir)
|
|
conf.set_quoted('PLYMOUTH_THEME_PATH', plymouth_theme_path)
|
|
conf.set_quoted('PLYMOUTH_RUNTIME_THEME_PATH', plymouth_runtime_theme_path)
|
|
conf.set_quoted('PLYMOUTH_PLUGIN_PATH', plymouth_plugin_path)
|
|
conf.set_quoted('PLYMOUTH_POLICY_DIR', plymouth_policy_dir)
|
|
conf.set_quoted('PLYMOUTH_CONF_DIR', plymouth_conf_dir)
|
|
conf.set_quoted('PLYMOUTH_TIME_DIRECTORY', plymouth_time_dir)
|
|
conf.set('HAVE_NCURSESW_TERM_H', get_option('upstart-monitoring')? cc.has_header('ncursesw/term.h') : false)
|
|
conf.set('HAVE_NCURSES_TERM_H', get_option('upstart-monitoring')? cc.has_header('ncurses/term.h') : false)
|
|
config_file = configure_file(
|
|
output: 'config.h',
|
|
configuration: conf,
|
|
)
|
|
config_h_inc = include_directories('.')
|
|
|
|
# Subdirectories
|
|
subdir('images')
|
|
subdir('po')
|
|
subdir('src')
|
|
subdir('themes')
|
|
subdir('scripts')
|
|
if get_option('systemd-integration')
|
|
subdir('systemd-units')
|
|
endif
|
|
if get_option('docs')
|
|
subdir('docs')
|
|
endif
|
|
--
|
|
2.43.0
|
|
|