diff --git a/plymouth.spec b/plymouth.spec
index 7dd7d28..a805a1b 100644
--- a/plymouth.spec
+++ b/plymouth.spec
@@ -239,6 +239,9 @@ Plymouth. It features a small spinner on a dark background.
 # Change the default theme
 sed -i -e 's/spinner/bgrt/g' src/plymouthd.defaults
 
+%if 0%{?rhel} > 9
+find -type f -exec sed -i -e 's/Cantarell/Red Hat Text/g' {} \;
+%endif
 
 %build
 %meson -Dtracing=true  \
@@ -263,10 +266,6 @@ cp %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/charge
 cp $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/glow/{box,bullet,entry,lock}.png $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/charge
 %endif
 
-%if 0%{?rhel} > 9
-find -type f -exec sed -i -e 's/Cantarell/Red Hat Text/g' {} \;
-%endif
-
 # Drop glow, it's not very Fedora-y
 rm -rf $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/glow