import plotnetcfg-0.4.1-18.el9

This commit is contained in:
CentOS Sources 2022-03-01 06:10:46 -05:00 committed by Stepan Oksanichenko
parent f45a7cc5a7
commit 52b846eecf
2 changed files with 35 additions and 3 deletions

View File

@ -0,0 +1,27 @@
From c6868e91438ed81257b939f0a36c1abeda207c26 Mon Sep 17 00:00:00 2001
Message-Id: <c6868e91438ed81257b939f0a36c1abeda207c26.1645111732.git.jbenc@redhat.com>
From: Jiri Benc <jbenc@redhat.com>
Date: Thu, 17 Feb 2022 16:28:06 +0100
Subject: [PATCH] Pass LDFLAGS to the linker
Signed-off-by: Jiri Benc <jbenc@redhat.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 0423f3198c09..54d7aa552f1b 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ plotnetcfg: args.o ethtool.o frontend.o handler.o if.o label.o main.o match.o ne
handlers/bridge.o handlers/master.o handlers/openvswitch.o handlers/veth.o \
handlers/vlan.o \
frontends/dot.o frontends/json.o
- gcc -o $@ $+ $(libs)
+ gcc $(LDFLAGS) -o $@ $+ $(libs)
args.o: args.c args.h
ethtool.o: ethtool.c ethtool.h
--
2.34.1

View File

@ -3,12 +3,13 @@
Name: plotnetcfg
Version: 0.4.1
Release: 17%{?dist}
Release: 18%{?dist}
Summary: A tool to plot network configuration
License: GPLv2+
URL: https://github.com/jbenc/plotnetcfg
Source0: https://github.com/jbenc/plotnetcfg/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
Patch0: 0001-Pass-LDFLAGS-to-the-linker.patch
BuildRequires: make
BuildRequires: gcc, jansson-devel
@ -19,10 +20,11 @@ plotnetcfg is a tool that output a diagram of network configuration on the
host in a form suitable for graphviz.
%prep
%setup -q -n %{name}-%{commit}
%autosetup -n %{name}-%{commit}
%build
make %{?_smp_mflags} CFLAGS="%{optflags}"
%set_build_flags
make %{?_smp_mflags} CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}"
%install
%make_install
@ -35,6 +37,9 @@ make %{?_smp_mflags} CFLAGS="%{optflags}"
%{_mandir}/man8/*
%changelog
* Thu Feb 17 2022 Jiri Benc <jbenc@redhat.com> - 0.4.1-18
- Fixed build flags [2044887]
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.4.1-17
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688