RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/plexus-sec-dispatcher#2e4944168ff26f4ba074d3f55180d74d5eff06b6
This commit is contained in:
parent
bd4a0e7c2e
commit
f85c9e1a41
2
.gitignore
vendored
2
.gitignore
vendored
@ -0,0 +1,2 @@
|
||||
plexus-sec-dispatcher-1.4.tar.bz2
|
||||
/LICENSE-2.0.txt
|
32
plexus-sec-dispatcher-pom.patch
Normal file
32
plexus-sec-dispatcher-pom.patch
Normal file
@ -0,0 +1,32 @@
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 1eb2158..7e7ac5d 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -25,25 +25,17 @@
|
||||
<plugins>
|
||||
<plugin>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
- <artifactId>plexus-maven-plugin</artifactId>
|
||||
+ <artifactId>plexus-component-metadata</artifactId>
|
||||
<version>1.3.5</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<goals>
|
||||
- <goal>descriptor</goal>
|
||||
+ <goal>generate-metadata</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
<plugin>
|
||||
- <artifactId>maven-compiler-plugin
|
||||
- </artifactId>
|
||||
- <configuration>
|
||||
- <source>1.4</source>
|
||||
- <target>1.4</target>
|
||||
- </configuration>
|
||||
- </plugin>
|
||||
- <plugin>
|
||||
<groupId>org.codehaus.modello</groupId>
|
||||
<artifactId>modello-maven-plugin</artifactId>
|
||||
<configuration>
|
153
plexus-sec-dispatcher.spec
Normal file
153
plexus-sec-dispatcher.spec
Normal file
@ -0,0 +1,153 @@
|
||||
Name: plexus-sec-dispatcher
|
||||
Version: 1.4
|
||||
Release: 31%{?dist}
|
||||
Summary: Plexus Security Dispatcher Component
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/codehaus-plexus/plexus-sec-dispatcher
|
||||
BuildArch: noarch
|
||||
|
||||
# svn export http://svn.sonatype.org/spice/tags/plexus-sec-dispatcher-1.4/
|
||||
# tar jcf plexus-sec-dispatcher-1.4.tar.bz2 plexus-sec-dispatcher-1.4/
|
||||
Source0: %{name}-%{version}.tar.bz2
|
||||
Source1: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||
|
||||
# Removed maven-compiler-plugin configuration version in the pom as annotations isn't available in version 1.4.
|
||||
Patch0: %{name}-pom.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.codehaus.modello:modello-maven-plugin)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-component-metadata)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-container-default)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
|
||||
BuildRequires: mvn(org.sonatype.plexus:plexus-cipher)
|
||||
BuildRequires: mvn(org.sonatype.spice:spice-parent:pom:)
|
||||
|
||||
%description
|
||||
Plexus Security Dispatcher Component
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
cp %{SOURCE1} .
|
||||
|
||||
%mvn_file : plexus/%{name}
|
||||
|
||||
%build
|
||||
%mvn_build
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%license LICENSE-2.0.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE-2.0.txt
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-31
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 1.4-30
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-29
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-28
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jul 31 2018 Michael Simacek <msimacek@redhat.com> - 1.4-26
|
||||
- Include license file
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-24
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Apr 21 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-19
|
||||
- Cleanup spec file
|
||||
|
||||
* Wed Apr 1 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-18
|
||||
- Update upstream URL
|
||||
|
||||
* Tue Oct 14 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-17
|
||||
- Update to current packaging guidelines
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Jun 2 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-15
|
||||
- Rebuild to regenerete Maven metadata
|
||||
|
||||
* Thu May 29 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-14
|
||||
- Use .mfiles generated during build
|
||||
|
||||
* Mon Mar 17 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-13
|
||||
- Add missing BR: modello
|
||||
|
||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4-12
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Apr 10 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-10
|
||||
- Remove unneeded BR: plexus-container-default
|
||||
|
||||
* Thu Feb 7 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.4-9
|
||||
- Remove unneeded R: spice-parent, resolves: rhbz#908584
|
||||
- Remove RPM bug workaround
|
||||
|
||||
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 1.4-8
|
||||
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||
- Replace maven BuildRequires with maven-local
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue May 22 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4-6
|
||||
- Replace plexus-maven-plugin with plexus-component-metadata
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Jun 23 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4-4
|
||||
- Fixes according to new guidelines
|
||||
- Add spice-parent to Requires
|
||||
- Versionless jars & javadocs
|
||||
- Use maven3 to build
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Jun 04 2010 Hui Wang <huwang@redhat.com> - 1.4-2
|
||||
- Fixed url
|
||||
|
||||
* Fri May 21 2010 Hui Wang <huwang@redhat.com> - 1.4-1
|
||||
- Initial version of the package
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (plexus-sec-dispatcher-1.4.tar.bz2) = 4aaebb01d2f053819f2c736bbc0a1038825ba2ddc21f2dc7a833ff3f1dbabd5a18cae88ed5fc74527c38271704b798f927036626e2e3a09a5e803276a90e2108
|
||||
SHA512 (LICENSE-2.0.txt) = 98f6b79b778f7b0a15415bd750c3a8a097d650511cb4ec8115188e115c47053fe700f578895c097051c9bc3dfb6197c2b13a15de203273e1a3218884f86e90e8
|
Loading…
Reference in New Issue
Block a user