Import from Fedora
This commit is contained in:
commit
cdd5d2e446
1
.fmf/version
Normal file
1
.fmf/version
Normal file
@ -0,0 +1 @@
|
||||
1
|
7
.gitignore
vendored
Normal file
7
.gitignore
vendored
Normal file
@ -0,0 +1,7 @@
|
||||
/results_*
|
||||
/*.src.rpm
|
||||
|
||||
/plexus-build-api-0.0.6.tar.gz
|
||||
/sonatype-sisu-build-api-plexus-build-api-0.0.7-0-g883ea67.tar.gz
|
||||
/LICENSE-2.0.txt
|
||||
/plexus-build-api-0.0.7.tar.gz
|
54
0000-Port-to-plexus-utils-3.3.0.patch
Normal file
54
0000-Port-to-plexus-utils-3.3.0.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From b31cf07a664173c8fa11309859dcb9f6929da578 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Wed, 23 Oct 2019 15:18:54 +0200
|
||||
Subject: [PATCH] Port to plexus-utils 3.3.0
|
||||
|
||||
---
|
||||
.../org/sonatype/plexus/build/incremental/EmptyScanner.java | 3 +++
|
||||
.../build/incremental/test/TestIncrementalBuildContext.java | 4 ++++
|
||||
2 files changed, 7 insertions(+)
|
||||
|
||||
diff --git a/src/main/java/org/sonatype/plexus/build/incremental/EmptyScanner.java b/src/main/java/org/sonatype/plexus/build/incremental/EmptyScanner.java
|
||||
index 7cce37d..2cca716 100644
|
||||
--- a/src/main/java/org/sonatype/plexus/build/incremental/EmptyScanner.java
|
||||
+++ b/src/main/java/org/sonatype/plexus/build/incremental/EmptyScanner.java
|
||||
@@ -14,6 +14,7 @@ See the Apache License Version 2.0 for the specific language governing permissio
|
||||
package org.sonatype.plexus.build.incremental;
|
||||
|
||||
import java.io.File;
|
||||
+import java.util.Comparator;
|
||||
|
||||
import org.codehaus.plexus.util.Scanner;
|
||||
|
||||
@@ -54,4 +55,6 @@ public class EmptyScanner implements Scanner {
|
||||
return basedir;
|
||||
}
|
||||
|
||||
+public void setFilenameComparator(Comparator comparator) {
|
||||
+}
|
||||
}
|
||||
diff --git a/src/test/java/org/sonatype/plexus/build/incremental/test/TestIncrementalBuildContext.java b/src/test/java/org/sonatype/plexus/build/incremental/test/TestIncrementalBuildContext.java
|
||||
index 14c1e26..01a9fba 100644
|
||||
--- a/src/test/java/org/sonatype/plexus/build/incremental/test/TestIncrementalBuildContext.java
|
||||
+++ b/src/test/java/org/sonatype/plexus/build/incremental/test/TestIncrementalBuildContext.java
|
||||
@@ -18,6 +18,7 @@ import java.io.FileOutputStream;
|
||||
import java.io.IOException;
|
||||
import java.io.OutputStream;
|
||||
import java.util.ArrayList;
|
||||
+import java.util.Comparator;
|
||||
import java.util.HashSet;
|
||||
import java.util.Iterator;
|
||||
import java.util.List;
|
||||
@@ -66,6 +67,9 @@ public class TestIncrementalBuildContext implements BuildContext {
|
||||
public File getBasedir() {
|
||||
return basedir;
|
||||
}
|
||||
+
|
||||
+ public void setFilenameComparator(Comparator comparator) {
|
||||
+ }
|
||||
}
|
||||
|
||||
private final Set changedFiles;
|
||||
--
|
||||
2.21.0
|
||||
|
7
gating.yaml
Normal file
7
gating.yaml
Normal file
@ -0,0 +1,7 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_contexts:
|
||||
- osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build./plans/javapackages.functional}
|
7
plans/javapackages.fmf
Normal file
7
plans/javapackages.fmf
Normal file
@ -0,0 +1,7 @@
|
||||
summary: Run javapackages-specific tests
|
||||
discover:
|
||||
how: fmf
|
||||
url: https://src.fedoraproject.org/tests/javapackages
|
||||
ref: c9s
|
||||
execute:
|
||||
how: tmt
|
18
plexus-build-api0-migration-to-component-metadata.patch
Normal file
18
plexus-build-api0-migration-to-component-metadata.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -Naur plexus-build-api-0.0.7.orig/pom.xml plexus-build-api-0.0.7/pom.xml
|
||||
--- plexus-build-api-0.0.7.orig/pom.xml 2011-02-11 17:37:00.000000000 +0100
|
||||
+++ plexus-build-api-0.0.7/pom.xml 2011-07-27 14:48:31.508448776 +0200
|
||||
@@ -46,12 +46,11 @@
|
||||
<plugins>
|
||||
<plugin>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
- <artifactId>plexus-maven-plugin</artifactId>
|
||||
- <version>1.3.4</version>
|
||||
+ <artifactId>plexus-component-metadata</artifactId>
|
||||
<executions>
|
||||
<execution>
|
||||
<goals>
|
||||
- <goal>descriptor</goal>
|
||||
+ <goal>generate-metadata</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
237
plexus-build-api0.spec
Normal file
237
plexus-build-api0.spec
Normal file
@ -0,0 +1,237 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
Name: plexus-build-api0
|
||||
Version: 0.0.7
|
||||
Release: 49%{?dist}
|
||||
Summary: Plexus Build API
|
||||
License: Apache-2.0
|
||||
URL: https://github.com/codehaus-plexus/plexus-build-api
|
||||
BuildArch: noarch
|
||||
ExclusiveArch: %{java_arches} noarch
|
||||
|
||||
Source0: https://github.com/codehaus-plexus/plexus-build-api/archive/refs/tags/plexus-build-api-0.0.7.tar.gz
|
||||
Source1: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||
|
||||
# Forwarded upstream: https://github.com/sonatype/sisu-build-api/pull/2
|
||||
Patch: %{name}-migration-to-component-metadata.patch
|
||||
Patch: 0000-Port-to-plexus-utils-3.3.0.patch
|
||||
|
||||
%if %{with bootstrap}
|
||||
BuildRequires: javapackages-bootstrap
|
||||
%else
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-component-metadata)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-container-default)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
|
||||
%endif
|
||||
|
||||
%description
|
||||
Plexus Build API
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
|
||||
%description javadoc
|
||||
API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n plexus-build-api-plexus-build-api-%{version}
|
||||
cp -p %{SOURCE1} .
|
||||
|
||||
|
||||
%pom_remove_parent
|
||||
# From upstream commit: https://github.com/codehaus-plexus/plexus-build-api/commit/6566292a7d85e275b824857bdf92d6504bc4824e
|
||||
%pom_xpath_set "pom:plugin[pom:artifactId='maven-compiler-plugin']/pom:configuration/*" 1.8
|
||||
|
||||
%mvn_file : plexus/%{name}
|
||||
|
||||
# Install plexus-build-api-tests as well
|
||||
%mvn_package :
|
||||
|
||||
%build
|
||||
%mvn_build
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%license LICENSE-2.0.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE-2.0.txt
|
||||
|
||||
%changelog
|
||||
* Fri Nov 29 2024 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-48
|
||||
- Update javapackages test plan to f42
|
||||
|
||||
* Wed Jul 24 2024 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-47
|
||||
- Install license files in licensedir instead of docdir
|
||||
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-46
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Fri May 31 2024 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-45
|
||||
- Switch to a newer patch macro syntax
|
||||
|
||||
* Fri Feb 23 2024 Jiri Vanek <jvanek@redhat.com> - 0.0.7-44
|
||||
- bump of release for for java-21-openjdk as system jdk
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-43
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-42
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Fri Sep 01 2023 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-41
|
||||
- Convert License tag to SPDX format
|
||||
|
||||
* Mon Aug 21 2023 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-40
|
||||
- Rename plexus-build-api to plexus-build-api0
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-39
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-38
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-37
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Feb 05 2022 Jiri Vanek <jvanek@redhat.com> - 0.0.7-36
|
||||
- Rebuilt for java-17-openjdk as system jdk
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-35
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Tue Nov 02 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-34
|
||||
- Set explicit Java compiler source/target levels to 1.8
|
||||
|
||||
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-33
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon May 17 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-32
|
||||
- Bootstrap build
|
||||
- Non-bootstrap build
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-31
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-30
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jul 16 2020 Mat Booth <mat.booth@redhat.com> - 0.0.7-29
|
||||
- Unecessary restriction on plexus-util, with the patch it's actually still
|
||||
source compatible with older versions
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 0.0.7-28
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Nov 25 2019 Fabio Valentini <decathorpe@gmail.com> - 0.0.7-26
|
||||
- Remove unnecessary dependency on parent POM.
|
||||
|
||||
* Wed Nov 13 2019 Fabio Valentini <decathorpe@gmail.com> - 0.0.7-25
|
||||
- Explicitly specify maven compiler source and target versions.
|
||||
|
||||
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-22
|
||||
- Mass rebuild for javapackages-tools 201902
|
||||
|
||||
* Thu Oct 17 2019 Fabio Valentini <decathorpe@gmail.com> - 0.0.7-24
|
||||
- Port to plexus-utils 3.3.0.
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-21
|
||||
- Mass rebuild for javapackages-tools 201901
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.0.7-20
|
||||
- Escape macros in %%changelog
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.7-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Apr 8 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-14
|
||||
- Update to current packaging guidelines
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon May 26 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-12
|
||||
- Remove BuildRequires on maven-surefire-provider-junit4
|
||||
|
||||
* Wed May 21 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.0.7-11
|
||||
- Use .mfiles generated during build
|
||||
|
||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.0.7-10
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 0.0.7-7
|
||||
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||
- Replace maven BuildRequires with maven-local
|
||||
|
||||
* Mon Nov 26 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - error: source 0 defined multiple times
|
||||
- Install license files
|
||||
- Resolves: rhbz#880200
|
||||
|
||||
* Thu Nov 22 2012 Jaromir Capik <jcapik@redhat.com> - 0.0.7-5
|
||||
- Migration to plexus-containers-container-default
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Nov 04 2011 Jaromir Capik <jcapik@redhat.com> - 0.0.7-2
|
||||
- Migration from plexus-maven-plugin to plexus-containers-component-metadata
|
||||
|
||||
* Tue Aug 2 2011 Alexander Kurtakov <akurtako@redhat.com> 0.0.7-1
|
||||
- Update to latest upstream version.
|
||||
|
||||
* Thu Jun 23 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.0.6-7
|
||||
- Add spice-parent to Requires
|
||||
|
||||
* Fri Jun 3 2011 Alexander Kurtakov <akurtako@redhat.com> 0.0.6-6
|
||||
- Build with maven.
|
||||
- Fix requires.
|
||||
- Guidelines fixes.
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed May 26 2010 Hui Wang <huwnag@redhat.com> 0.0.6-3
|
||||
- Add missing requires
|
||||
|
||||
* Wed May 26 2010 Hui Wang <huwnag@redhat.com> 0.0.6-2
|
||||
- Change JPP-%%{name}.pom to JPP.plexus-%%{name}.pom
|
||||
|
||||
* Wed May 19 2010 Hui Wang <huwang@redhat.com> 0.0.6-1
|
||||
- Initial version of the package
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (plexus-build-api-0.0.7.tar.gz) = dde7b2be1d993e2be6aaaefeafdb6108198a49c021298857ece2a6c82f1b112c4af6c204409e9efd7e11b07ed94235f5e9f9e643133d8a57507d7860ad70d94a
|
||||
SHA512 (LICENSE-2.0.txt) = 98f6b79b778f7b0a15415bd750c3a8a097d650511cb4ec8115188e115c47053fe700f578895c097051c9bc3dfb6197c2b13a15de203273e1a3218884f86e90e8
|
Loading…
Reference in New Issue
Block a user