import pki-core-10.7.1-2.module+el8.1.0+3386+52d02a00
This commit is contained in:
commit
10e2275f98
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/pki-10.7.1.tar.gz
|
1
.pki-core.metadata
Normal file
1
.pki-core.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
06d1fc23b21fe71bdf2594bfdcadaa2539b68351 SOURCES/pki-10.7.1.tar.gz
|
27
SOURCES/0001-Fixed-TPS-installation-issue.patch
Normal file
27
SOURCES/0001-Fixed-TPS-installation-issue.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 2f8adb82218a30abc2a7434974f69e56d92d2649 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Endi S. Dewata" <edewata@redhat.com>
|
||||||
|
Date: Thu, 13 Jun 2019 16:09:54 -0500
|
||||||
|
Subject: [PATCH] Fixed TPS installation issue
|
||||||
|
|
||||||
|
The TPSConfigurator.setupAdmin() has been modified to call the
|
||||||
|
parent method first to create the admin user.
|
||||||
|
---
|
||||||
|
base/tps/src/org/dogtagpki/server/tps/TPSConfigurator.java | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/base/tps/src/org/dogtagpki/server/tps/TPSConfigurator.java b/base/tps/src/org/dogtagpki/server/tps/TPSConfigurator.java
|
||||||
|
index b9fc43f9c..32714e9f0 100644
|
||||||
|
--- a/base/tps/src/org/dogtagpki/server/tps/TPSConfigurator.java
|
||||||
|
+++ b/base/tps/src/org/dogtagpki/server/tps/TPSConfigurator.java
|
||||||
|
@@ -152,6 +152,8 @@ public class TPSConfigurator extends Configurator {
|
||||||
|
@Override
|
||||||
|
public void setupAdmin(AdminSetupRequest request, AdminSetupResponse response) throws Exception {
|
||||||
|
|
||||||
|
+ super.setupAdmin(request, response);
|
||||||
|
+
|
||||||
|
logger.debug("Adding all profiles to TPS admin user");
|
||||||
|
|
||||||
|
CMSEngine engine = CMS.getCMSEngine();
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
28
SOURCES/0001-Fixed-cloning-issue.patch
Normal file
28
SOURCES/0001-Fixed-cloning-issue.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 1ea28de6409c624b6588987855f97d50c18f3ade Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Endi S. Dewata" <edewata@redhat.com>
|
||||||
|
Date: Thu, 13 Jun 2019 13:21:20 -0500
|
||||||
|
Subject: [PATCH] Fixed cloning issue
|
||||||
|
|
||||||
|
The setupReplication and reindexData fields have been removed
|
||||||
|
from ConfigurationRequest so they should not be set anymore
|
||||||
|
in set_cloning_parameters().
|
||||||
|
---
|
||||||
|
base/server/python/pki/server/deployment/pkihelper.py | 2 --
|
||||||
|
1 file changed, 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/base/server/python/pki/server/deployment/pkihelper.py b/base/server/python/pki/server/deployment/pkihelper.py
|
||||||
|
index 9d75893ff..4bc224aff 100644
|
||||||
|
--- a/base/server/python/pki/server/deployment/pkihelper.py
|
||||||
|
+++ b/base/server/python/pki/server/deployment/pkihelper.py
|
||||||
|
@@ -3429,8 +3429,6 @@ class ConfigClient:
|
||||||
|
if self.mdict['pki_clone_replication_clone_port']:
|
||||||
|
data.cloneReplicationPort = \
|
||||||
|
self.mdict['pki_clone_replication_clone_port']
|
||||||
|
- data.setupReplication = self.mdict['pki_clone_setup_replication']
|
||||||
|
- data.reindexData = self.mdict['pki_clone_reindex_data']
|
||||||
|
|
||||||
|
def set_hierarchy_parameters(self, data):
|
||||||
|
if self.subsystem == "CA":
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
1743
SPECS/pki-core.spec
Normal file
1743
SPECS/pki-core.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user