Update to 1.5.3
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
3cc928cc3f
commit
5e84d79447
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
|||||||
/pkgconf-1.4.1.tar.xz
|
/pkgconf-1.4.1.tar.xz
|
||||||
/pkgconf-1.4.2.tar.xz
|
/pkgconf-1.4.2.tar.xz
|
||||||
/pkgconf-1.5.1.tar.xz
|
/pkgconf-1.5.1.tar.xz
|
||||||
|
/pkgconf-1.5.3.tar.xz
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From fb08ae2bd21c0f25d719d1914a07f19cef1a3619 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Graham Ollis <plicease@cpan.org>
|
|
||||||
Date: Mon, 25 Jun 2018 06:36:57 -0400
|
|
||||||
Subject: [PATCH] environment variables for system paths should override
|
|
||||||
compiled-in defaults
|
|
||||||
|
|
||||||
---
|
|
||||||
libpkgconf/client.c | 14 +++++++++-----
|
|
||||||
1 file changed, 9 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libpkgconf/client.c b/libpkgconf/client.c
|
|
||||||
index 796014d..f4155b3 100644
|
|
||||||
--- a/libpkgconf/client.c
|
|
||||||
+++ b/libpkgconf/client.c
|
|
||||||
@@ -96,11 +96,15 @@ pkgconf_client_init(pkgconf_client_t *client, pkgconf_error_handler_func_t error
|
|
||||||
pkgconf_client_set_buildroot_dir(client, NULL);
|
|
||||||
pkgconf_client_set_prefix_varname(client, NULL);
|
|
||||||
|
|
||||||
- pkgconf_path_copy_list(&client->filter_libdirs, &personality->filter_libdirs);
|
|
||||||
- pkgconf_path_copy_list(&client->filter_includedirs, &personality->filter_includedirs);
|
|
||||||
-
|
|
||||||
- pkgconf_path_build_from_environ("PKG_CONFIG_SYSTEM_LIBRARY_PATH", NULL, &client->filter_libdirs, false);
|
|
||||||
- pkgconf_path_build_from_environ("PKG_CONFIG_SYSTEM_INCLUDE_PATH", NULL, &client->filter_includedirs, false);
|
|
||||||
+ if(getenv("PKG_CONFIG_SYSTEM_LIBRARY_PATH") == NULL)
|
|
||||||
+ pkgconf_path_copy_list(&client->filter_libdirs, &personality->filter_libdirs);
|
|
||||||
+ else
|
|
||||||
+ pkgconf_path_build_from_environ("PKG_CONFIG_SYSTEM_LIBRARY_PATH", NULL, &client->filter_libdirs, false);
|
|
||||||
+
|
|
||||||
+ if(getenv("PKG_CONFIG_SYSTEM_INCLUDE_PATH") == NULL)
|
|
||||||
+ pkgconf_path_copy_list(&client->filter_includedirs, &personality->filter_includedirs);
|
|
||||||
+ else
|
|
||||||
+ pkgconf_path_build_from_environ("PKG_CONFIG_SYSTEM_INCLUDE_PATH", NULL, &client->filter_includedirs, false);
|
|
||||||
|
|
||||||
/* GCC uses these environment variables to define system include paths, so we should check them. */
|
|
||||||
#ifdef __HAIKU__
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
13
pkgconf.spec
13
pkgconf.spec
@ -16,8 +16,8 @@
|
|||||||
%global pkgconf_libdirs %{_libdir}/pkgconfig:%{_datadir}/pkgconfig
|
%global pkgconf_libdirs %{_libdir}/pkgconfig:%{_datadir}/pkgconfig
|
||||||
|
|
||||||
Name: pkgconf
|
Name: pkgconf
|
||||||
Version: 1.5.1
|
Version: 1.5.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Package compiler and linker metadata toolkit
|
Summary: Package compiler and linker metadata toolkit
|
||||||
|
|
||||||
License: ISC
|
License: ISC
|
||||||
@ -27,9 +27,6 @@ Source0: https://distfiles.dereferenced.org/%{name}/%{name}-%{version}.ta
|
|||||||
# Simple wrapper script to offer platform versions of pkgconfig
|
# Simple wrapper script to offer platform versions of pkgconfig
|
||||||
Source1: platform-pkg-config.in
|
Source1: platform-pkg-config.in
|
||||||
|
|
||||||
# From: https://git.dereferenced.org/pkgconf/pkgconf/pulls/1
|
|
||||||
Patch0001: 0001-environment-variables-for-system-paths.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
|
||||||
@ -39,7 +36,7 @@ BuildRequires: automake
|
|||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
|
|
||||||
# For unit tests
|
# For unit tests
|
||||||
BuildRequires: %{_bindir}/kyua
|
BuildRequires: kyua
|
||||||
BuildRequires: atf-tests
|
BuildRequires: atf-tests
|
||||||
|
|
||||||
# pkgconf uses libpkgconf internally
|
# pkgconf uses libpkgconf internally
|
||||||
@ -158,6 +155,7 @@ rm -rf %{buildroot}%{_datadir}/aclocal
|
|||||||
%{_bindir}/%{name}
|
%{_bindir}/%{name}
|
||||||
%{_mandir}/man1/%{name}.1*
|
%{_mandir}/man1/%{name}.1*
|
||||||
%{_mandir}/man5/pc.5*
|
%{_mandir}/man5/pc.5*
|
||||||
|
%{_mandir}/man5/%{name}-personality.5*
|
||||||
|
|
||||||
%files -n lib%{name}
|
%files -n lib%{name}
|
||||||
%license COPYING
|
%license COPYING
|
||||||
@ -182,6 +180,9 @@ rm -rf %{buildroot}%{_datadir}/aclocal
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jul 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.5.3-1
|
||||||
|
- Update to 1.5.3
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.1-3
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
#!/bin/bash
|
#!/bin/sh
|
||||||
|
|
||||||
# Simple wrapper to tell pkgconf to behave as a platform-specific version of pkg-config
|
# Simple wrapper to tell pkgconf to behave as a platform-specific version of pkg-config
|
||||||
# Platform: @TARGET_PLATFORM@
|
# Platform: @TARGET_PLATFORM@
|
||||||
@ -7,6 +7,4 @@ export PKG_CONFIG_LIBDIR="${PKG_CONFIG_LIBDIR:-@PKGCONF_LIBDIRS@}"
|
|||||||
export PKG_CONFIG_SYSTEM_LIBRARY_PATH="${PKG_CONFIG_SYSTEM_LIBRARY_PATH:-@PKGCONF_SYSLIBDIR@}"
|
export PKG_CONFIG_SYSTEM_LIBRARY_PATH="${PKG_CONFIG_SYSTEM_LIBRARY_PATH:-@PKGCONF_SYSLIBDIR@}"
|
||||||
export PKG_CONFIG_SYSTEM_INCLUDE_PATH="${PKG_CONFIG_SYSTEM_INCLUDE_PATH:-@PKGCONF_SYSINCDIR@}"
|
export PKG_CONFIG_SYSTEM_INCLUDE_PATH="${PKG_CONFIG_SYSTEM_INCLUDE_PATH:-@PKGCONF_SYSINCDIR@}"
|
||||||
|
|
||||||
pkgconf $@
|
exec pkgconf "$@"
|
||||||
|
|
||||||
exit $?
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pkgconf-1.5.1.tar.xz) = a2e7a675fed6600fd38d90a98fa8295e1b79b4dd018f544ca777caf8cf6687029d0925ef33a08dd7815d5d3cad835bb9b70ab3161b6e083965fa60652661955a
|
SHA512 (pkgconf-1.5.3.tar.xz) = 565c5caa4fb4cf358c42d2e1f709088810d275b26cdf313140575752fc6ea0bc6d6fd93dd8ee9fbb78b7b39044e5c6df9065acb5963189ea99916bea24a7b371
|
||||||
|
Loading…
Reference in New Issue
Block a user