- fix vector loads in VMX (ppc64le) (#1572540)
This commit is contained in:
parent
c9755055a9
commit
f794a1f177
12
pixman-0.34.0-vmx.patch
Normal file
12
pixman-0.34.0-vmx.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up pixman-0.34.0/pixman/pixman-vmx.c.orig pixman-0.34.0/pixman/pixman-vmx.c
|
||||
--- pixman-0.34.0/pixman/pixman-vmx.c.orig 2018-04-27 12:10:14.411696502 +0200
|
||||
+++ pixman-0.34.0/pixman/pixman-vmx.c 2018-04-27 12:27:41.174290224 +0200
|
||||
@@ -227,7 +227,7 @@ do \
|
||||
#define COMPUTE_SHIFT_MASKC(dest, source, mask)
|
||||
|
||||
# define LOAD_VECTOR(source) \
|
||||
- v ## source = *((typeof(v ## source)*)source);
|
||||
+ v ## source = (typeof(v ## source))vec_xl(0, source);
|
||||
|
||||
# define LOAD_VECTORS(dest, source) \
|
||||
LOAD_VECTOR(source); \
|
11
pixman.spec
11
pixman.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: pixman
|
||||
Version: 0.34.0
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
Summary: Pixel manipulation library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -15,6 +15,9 @@ URL: http://cgit.freedesktop.org/pixman/
|
||||
# if no revision specified, makes a new one from HEAD.
|
||||
Source0: http://xorg.freedesktop.org/archive/individual/lib/%{name}-%{version}.tar.bz2
|
||||
Source1: make-pixman-snapshot.sh
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1572540
|
||||
# fix vector loads in VMX (ppc64le)
|
||||
Patch0: pixman-0.34.0-vmx.patch
|
||||
|
||||
BuildRequires: automake autoconf libtool
|
||||
|
||||
@ -31,14 +34,13 @@ Requires: pkgconfig
|
||||
Development library for pixman.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
%ifarch %{arm}
|
||||
--disable-arm-iwmmxt --disable-arm-iwmmxt2 \
|
||||
%endif
|
||||
--disable-vmx \
|
||||
--disable-static
|
||||
|
||||
make %{?_smp_mflags} V=1
|
||||
@ -66,6 +68,9 @@ make check %{?_smp_mflags} V=1
|
||||
%{_libdir}/pkgconfig/pixman-1.pc
|
||||
|
||||
%changelog
|
||||
* Fri May 04 2018 Dan Horák <dan[at]danny.cz> - 0.34.0-8
|
||||
- fix vector loads in VMX (ppc64le) (#1572540)
|
||||
|
||||
* Thu Apr 26 2018 Adam Jackson <ajax@redhat.com> - 0.34.0-7
|
||||
- Enable %%check
|
||||
- --disable-vmx to fix %%check failures with gcc8
|
||||
|
Loading…
Reference in New Issue
Block a user