* Wed May 30 2012 Soren Sandmann <ssp@redhat.com> - 0.26.0-1
- update to 0.26.0 - patch to add missing emms instructions - reenable iwmmxt since configure should now detect if it can't built
This commit is contained in:
parent
8fb783921d
commit
ed841d4f7b
45
emms.patch
Normal file
45
emms.patch
Normal file
@ -0,0 +1,45 @@
|
||||
commit da6193b1fcc1dfab27f4c36917864f2f2c41cf3e
|
||||
Author: Matt Turner <mattst88@gmail.com>
|
||||
Date: Sun May 27 13:01:57 2012 -0400
|
||||
|
||||
mmx: add missing _mm_empty calls
|
||||
|
||||
Fixes spurious test failures on x86-32.
|
||||
|
||||
diff --git a/pixman/pixman-mmx.c b/pixman/pixman-mmx.c
|
||||
index bb125bf..6e292c6 100644
|
||||
--- a/pixman/pixman-mmx.c
|
||||
+++ b/pixman/pixman-mmx.c
|
||||
@@ -2232,6 +2232,8 @@ mmx_composite_src_x888_0565 (pixman_implementation_t *imp,
|
||||
w--;
|
||||
}
|
||||
}
|
||||
+
|
||||
+ _mm_empty ();
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -3542,6 +3544,7 @@ mmx_fetch_x8r8g8b8 (pixman_iter_t *iter, const uint32_t *mask)
|
||||
w--;
|
||||
}
|
||||
|
||||
+ _mm_empty ();
|
||||
return iter->buffer;
|
||||
}
|
||||
|
||||
@@ -3585,6 +3588,7 @@ mmx_fetch_r5g6b5 (pixman_iter_t *iter, const uint32_t *mask)
|
||||
w--;
|
||||
}
|
||||
|
||||
+ _mm_empty ();
|
||||
return iter->buffer;
|
||||
}
|
||||
|
||||
@@ -3630,6 +3634,7 @@ mmx_fetch_a8 (pixman_iter_t *iter, const uint32_t *mask)
|
||||
w--;
|
||||
}
|
||||
|
||||
+ _mm_empty ();
|
||||
return iter->buffer;
|
||||
}
|
||||
|
14
pixman.spec
14
pixman.spec
@ -2,8 +2,8 @@
|
||||
%define gitrev 8ff7213f39edc1b2b8b60d6b0cc5d5f14ca1928d
|
||||
|
||||
Name: pixman
|
||||
Version: 0.25.6
|
||||
Release: 2%{?dist}
|
||||
Version: 0.26.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Pixel manipulation library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -16,6 +16,8 @@ URL: http://cgit.freedesktop.org/pixman/
|
||||
Source0: http://xorg.freedesktop.org/archive/individual/lib/%{name}-%{version}.tar.bz2
|
||||
Source1: make-pixman-snapshot.sh
|
||||
|
||||
Patch0: emms.patch
|
||||
|
||||
# BuildRequires: automake autoconf libtool pkgconfig
|
||||
|
||||
%description
|
||||
@ -32,9 +34,10 @@ Development library for pixman.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .emms
|
||||
|
||||
%build
|
||||
%configure --disable-static --disable-arm-iwmmxt
|
||||
%configure --disable-static
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -58,6 +61,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
%{_libdir}/pkgconfig/pixman-1.pc
|
||||
|
||||
%changelog
|
||||
* Wed May 30 2012 Soren Sandmann <ssp@redhat.com> - 0.26.0-1
|
||||
- update to 0.26.0
|
||||
- patch to add missing emms instructions
|
||||
- reenable iwmmxt since configure should now detect if it can't built
|
||||
|
||||
* Tue May 15 2012 Dennis Gilmore <dennis@ausil.us> - 0.25.6-2
|
||||
- rely on runtime cpu detection for arm optimisations
|
||||
- disable failing to build iwmmxt
|
||||
|
Loading…
Reference in New Issue
Block a user