Enable make check but don't (currently) fail the build on failure, Include COPYING as per packaging guidelines, Minor spec cleanups
This commit is contained in:
parent
d052601092
commit
a19fcdfa29
@ -1,30 +0,0 @@
|
||||
From 8487dfbcd056eff066939dc253fcf361b391592a Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Bogusz <qboosh@pld-linux.org>
|
||||
Date: Tue, 12 Nov 2013 12:59:42 -0800
|
||||
Subject: [PATCH] Fix the SSSE3 CPUID detection.
|
||||
|
||||
SSSE3 is detected by bit 9 of ECX, but we were checking bit 9 of EDX
|
||||
which is APIC leading to SSSE3 routines being called on CPUs without
|
||||
SSSE3.
|
||||
|
||||
Reviewed-by: Matt Turner <mattst88@gmail.com>
|
||||
---
|
||||
pixman/pixman-x86.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pixman/pixman-x86.c b/pixman/pixman-x86.c
|
||||
index 6527760..05297c4 100644
|
||||
--- a/pixman/pixman-x86.c
|
||||
+++ b/pixman/pixman-x86.c
|
||||
@@ -170,7 +170,7 @@ detect_cpu_features (void)
|
||||
features |= X86_SSE;
|
||||
if (d & (1 << 26))
|
||||
features |= X86_SSE2;
|
||||
- if (d & (1 << 9))
|
||||
+ if (c & (1 << 9))
|
||||
features |= X86_SSSE3;
|
||||
|
||||
/* Check for AMD specific features */
|
||||
--
|
||||
1.8.3.1
|
||||
|
19
pixman.spec
19
pixman.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: pixman
|
||||
Version: 0.32.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Pixel manipulation library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -15,9 +15,8 @@ URL: http://cgit.freedesktop.org/pixman/
|
||||
# if no revision specified, makes a new one from HEAD.
|
||||
Source0: http://xorg.freedesktop.org/archive/individual/lib/%{name}-%{version}.tar.bz2
|
||||
Source1: make-pixman-snapshot.sh
|
||||
Patch0: 0001-Fix-the-SSSE3-CPUID-detection.patch
|
||||
|
||||
BuildRequires: automake autoconf libtool pkgconfig
|
||||
BuildRequires: automake autoconf libtool
|
||||
|
||||
%description
|
||||
Pixman is a pixel manipulation library for X and cairo.
|
||||
@ -45,17 +44,20 @@ make %{?_smp_mflags} V=1
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
find %{buildroot} -type f -name "*.la" -delete
|
||||
|
||||
%check
|
||||
make check %{?_smp_mflags} V=1 ||:
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_libdir}/libpixman-1*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%dir %{_includedir}/pixman-1
|
||||
%{_includedir}/pixman-1/pixman.h
|
||||
%{_includedir}/pixman-1/pixman-version.h
|
||||
@ -63,6 +65,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
%{_libdir}/pkgconfig/pixman-1.pc
|
||||
|
||||
%changelog
|
||||
* Fri Jul 11 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.32.6-2
|
||||
- Enable make check but don't (currently) fail the build on failure
|
||||
- Include COPYING as per packaging guidelines
|
||||
- Minor spec cleanups
|
||||
|
||||
* Sun Jul 06 2014 Soren Sandmann <soren.sandmann@gmail.com> 0.32.6-1
|
||||
- pixman 0.32.6
|
||||
- drop SSSE3 patch
|
||||
|
Loading…
Reference in New Issue
Block a user