Backport fix for CVE-2022-44638

This commit is contained in:
José Expósito 2023-10-04 12:55:03 +02:00 committed by root
parent 950ed82d78
commit 34161868d3
3 changed files with 36 additions and 1 deletions

1
.pixman.metadata Normal file
View File

@ -0,0 +1 @@
c625853be8a5369cece57ab7dba558ff739a6332 pixman-0.40.0.tar.xz

View File

@ -0,0 +1,29 @@
From a1f88e842e0216a5b4df1ab023caebe33c101395 Mon Sep 17 00:00:00 2001
From: Matt Turner <mattst88@gmail.com>
Date: Wed, 2 Nov 2022 12:07:32 -0400
Subject: [PATCH] Avoid integer overflow leading to out-of-bounds write
Thanks to Maddie Stone and Google's Project Zero for discovering this
issue, providing a proof-of-concept, and a great analysis.
Closes: https://gitlab.freedesktop.org/pixman/pixman/-/issues/63
---
pixman/pixman-trap.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pixman/pixman-trap.c b/pixman/pixman-trap.c
index 91766fd..7560405 100644
--- a/pixman/pixman-trap.c
+++ b/pixman/pixman-trap.c
@@ -74,7 +74,7 @@ pixman_sample_floor_y (pixman_fixed_t y,
if (f < Y_FRAC_FIRST (n))
{
- if (pixman_fixed_to_int (i) == 0x8000)
+ if (pixman_fixed_to_int (i) == 0xffff8000)
{
f = 0; /* saturate */
}
--
2.41.0

View File

@ -3,7 +3,7 @@
Name: pixman
Version: 0.40.0
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Pixel manipulation library
License: MIT
@ -15,6 +15,8 @@ URL: https://gitlab.freedesktop.org/pixman/pixman
Source0: https://xorg.freedesktop.org/archive/individual/lib/%{name}-%{version}.tar.xz
Source1: make-pixman-snapshot.sh
Patch0: 0001-Avoid-integer-overflow-leading-to-out-of-bounds-writ.patch
BuildRequires: gcc
BuildRequires: meson
@ -64,6 +66,9 @@ sed -i 's/120/600/' test/meson.build
%{_libdir}/pkgconfig/pixman-1.pc
%changelog
* Wed Oct 04 2023 José Expósito <jexposit@redhat.com> - 0.40.0-6
- Backport fix for CVE-2022-44638
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.40.0-5
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688