import pipewire-0.2.7-1.el8

This commit is contained in:
CentOS Sources 2020-04-28 05:38:46 -04:00 committed by Andrew Lukoshko
parent f86214004e
commit 565cf8ac20
5 changed files with 15 additions and 152 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/0.2.5.tar.gz
SOURCES/pipewire-0.2.7.tar.gz

View File

@ -1 +1 @@
c8d918824f9b85318b1610a74480081a96c32392 SOURCES/0.2.5.tar.gz
37f8801423a63303a76b8a416c90fba65d41e826 SOURCES/pipewire-0.2.7.tar.gz

View File

@ -1,25 +0,0 @@
From c26d938f18d4c92ec515e82037eda42b0e2999ef Mon Sep 17 00:00:00 2001
From: Jan Grulich <jgrulich@redhat.com>
Date: Wed, 2 Jan 2019 10:05:40 +0100
Subject: [PATCH 1/2] Avoid invalid conversion error with C++ compilators
---
src/pipewire/utils.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/pipewire/utils.h b/src/pipewire/utils.h
index 2ce9fdde..7262ff42 100644
--- a/src/pipewire/utils.h
+++ b/src/pipewire/utils.h
@@ -58,7 +58,7 @@ pw_spa_pod_copy(const struct spa_pod *pod)
return NULL;
size = SPA_POD_SIZE(pod);
- if ((c = malloc(size)) == NULL)
+ if ((c = (struct spa_pod *) malloc(size)) == NULL)
return NULL;
return (struct spa_pod *) memcpy(c, pod, size);
--
2.19.2

View File

@ -1,110 +0,0 @@
From 5fb074785ec5ee8f7a9f162766dd4462ebf0a149 Mon Sep 17 00:00:00 2001
From: Wim Taymans <wtaymans@redhat.com>
Date: Fri, 30 Nov 2018 16:58:47 +0100
Subject: [PATCH 2/2] Revert "meson: Use feature for GStreamer and make it
auto"
This reverts commit 795b352cbaf68ce6f05ab9e9d46d4eff39ffee14.
---
meson.build | 31 +++++++++++--------------------
meson_options.txt | 4 ++--
src/daemon/meson.build | 3 ++-
src/meson.build | 2 +-
4 files changed, 16 insertions(+), 24 deletions(-)
diff --git a/meson.build b/meson.build
index 3c3b6dfb..d54f0d42 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('pipewire', 'c',
version : '0.2.5',
- meson_version : '>= 0.47.0',
+ meson_version : '>= 0.45.0',
default_options : [ 'warning_level=1',
'c_std=gnu99',
'buildtype=debugoptimized' ])
@@ -161,25 +161,16 @@ dl_lib = cc.find_library('dl', required : false)
pthread_lib = dependency('threads')
dbus_dep = dependency('dbus-1')
-if not get_option('gstreamer').disabled()
- build_gst = true
- glib_dep = [dependency('glib-2.0', version : '>=2.32.0', required: get_option('gstreamer'))]
- gobject_dep = [dependency('gobject-2.0', required: get_option('gstreamer'))]
- gmodule_dep = [dependency('gmodule-2.0', required: get_option('gstreamer'))]
- gio_dep = [dependency('gio-2.0', required: get_option('gstreamer')), dependency('gio-unix-2.0', required: get_option('gstreamer'))]
- gst_dep = [dependency('gstreamer-1.0', required: get_option('gstreamer')),
- dependency('gstreamer-plugins-base-1.0', required: get_option('gstreamer')),
- dependency('gstreamer-video-1.0', required: get_option('gstreamer')),
- dependency('gstreamer-audio-1.0', required: get_option('gstreamer')),
- dependency('gstreamer-allocators-1.0', required: get_option('gstreamer')),]
- foreach dep: glib_dep + gobject_dep + gio_dep + gst_dep
- if build_gst and not dep.found()
- build_gst = false
- message('@0@ not found, disabling GStreamer'.format(dep))
- endif
- endforeach
-else
- build_gst = false
+if get_option('gstreamer')
+ glib_dep = dependency('glib-2.0', version : '>=2.32.0')
+ gobject_dep = dependency('gobject-2.0')
+ gmodule_dep = dependency('gmodule-2.0')
+ gio_dep = [dependency('gio-2.0'), dependency('gio-unix-2.0')]
+ gst_dep = [dependency('gstreamer-1.0'),
+ dependency('gstreamer-plugins-base-1.0'),
+ dependency('gstreamer-video-1.0'),
+ dependency('gstreamer-audio-1.0'),
+ dependency('gstreamer-allocators-1.0'),]
endif
subdir('spa')
diff --git a/meson_options.txt b/meson_options.txt
index 5ea74ff0..3d21b2b4 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -8,8 +8,8 @@ option('man',
value: false)
option('gstreamer',
description: 'Build GStreamer plugins',
- type: 'feature',
- value: 'auto')
+ type: 'boolean',
+ value: false)
option('systemd',
description: 'Enable systemd integration',
type: 'boolean',
diff --git a/src/daemon/meson.build b/src/daemon/meson.build
index f2a327fb..4a7d9536 100644
--- a/src/daemon/meson.build
+++ b/src/daemon/meson.build
@@ -13,11 +13,12 @@ pipewire_c_args = [
'-DG_LOG_DOMAIN=g_log_domain_pipewire',
]
+conf_config = configuration_data()
conf_install_dir = join_paths(get_option('sysconfdir'), 'pipewire')
configure_file(input : 'pipewire.conf.in',
output : 'pipewire.conf',
- copy : true,
+ configuration : conf_config,
install_dir : conf_install_dir)
diff --git a/src/meson.build b/src/meson.build
index 723e2c69..0ad7778d 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -6,6 +6,6 @@ subdir('tools')
subdir('modules')
subdir('examples')
-if build_gst
+if get_option('gstreamer')
subdir('gst')
endif
--
2.19.2

View File

@ -14,7 +14,7 @@
Name: pipewire
Summary: Media Sharing Server
Version: 0.2.5
Version: 0.2.7
Release: 1%{?snap:.%{snap}git%{shortcommit}}%{?dist}
License: LGPLv2+
URL: https://pipewire.org/
@ -23,12 +23,10 @@ URL: https://pipewire.org/
# cd pipewire; git reset --hard %{gitcommit}; ./autogen.sh; make; make distcheck
Source0: pipewire-%{version}-%{gitrel}-g%{shortcommit}.tar.gz
%else
Source0: https://github.com/PipeWire/pipewire/archive/%{version}.tar.gz
Source0: https://github.com/PipeWire/pipewire/archive/%{version}/pipewire-%{version}.tar.gz
%endif
## upstream patches
Patch0: 0001-Avoid-invalid-conversion-error-with-C-compilators.patch
Patch1: 0002-Revert-meson-Use-feature-for-GStreamer-and-make-it-a.patch
## upstreamable patches
@ -70,7 +68,7 @@ systems.
%package libs
Summary: Libraries for PipeWire clients
License: LGPLv2+
Requires: %{name}%{?_isa} = %{version}-%{release}
Recommends: %{name}%{?_isa} = %{version}-%{release}
%description libs
This package contains the runtime libraries for any application that wishes
@ -79,7 +77,6 @@ to interface with a PipeWire media server.
%package devel
Summary: Headers and libraries for PipeWire client development
License: LGPLv2+
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description devel
Headers and libraries for developing applications that can communicate with
@ -104,11 +101,8 @@ This package contains command line utilities for the PipeWire media server.
%prep
%setup -q -T -b0 -n %{name}-%{version}%{?gitrel:-%{gitrel}-g%{shortcommit}}
%patch0 -p1 -b .0000
%patch1 -p1 -b .0001
%build
%meson -D docs=true -D man=true -D gstreamer=true -D systemd=true
%meson -D docs=true -D man=true -D gstreamer=enabled -D systemd=true
%meson_build
%install
@ -126,7 +120,7 @@ getent passwd pipewire >/dev/null || \
useradd -r -g pipewire -d %{_localstatedir}/run/pipewire -s /sbin/nologin -c "PipeWire System Daemon" pipewire
exit 0
%ldconfig_scriptlets
%ldconfig_scriptlets libs
%files
%license LICENSE GPL LGPL
@ -136,17 +130,18 @@ exit 0
%{_userunitdir}/sockets.target.wants/pipewire.socket
%endif
%{_bindir}/pipewire
%{_libdir}/libpipewire-%{apiversion}.so.*
%{_libdir}/gstreamer-1.0/libgstpipewire.*
%{_libdir}/pipewire-%{apiversion}/
%{_libdir}/spa/
%{_mandir}/man1/pipewire.1*
%dir %{_sysconfdir}/pipewire/
%{_sysconfdir}/pipewire/pipewire.conf
%{_mandir}/man5/pipewire.conf.5*
%files libs
%license LICENSE GPL LGPL
%doc README
%dir %{_sysconfdir}/pipewire/
%{_libdir}/gstreamer-1.0/libgstpipewire.*
%{_libdir}/libpipewire-%{apiversion}.so.*
%files devel
%{_libdir}/libpipewire-%{apiversion}.so
@ -161,13 +156,16 @@ exit 0
%files utils
%{_bindir}/pipewire-monitor
%{_bindir}/pipewire-cli
%{_mandir}/man5/pipewire.conf.5*
%{_mandir}/man1/pipewire-monitor.1*
%{_mandir}/man1/pipewire-cli.1*
%{_bindir}/spa-monitor
%{_bindir}/spa-inspect
%changelog
* Fri Oct 18 2019 David King <dking@redhat.com> - 0.2.7-1
- Rebase to 0.2.7 (#1748331)
* Fri Jan 11 2019 Wim Taymans <wtaymans@redhat.com> - 0.2.5-1
- Update to 0.2.5
- Revert patch that requires too new meson