import pinfo-0.6.10-18.el8
This commit is contained in:
commit
68d74cf237
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/pinfo-0.6.10.tar.bz2
|
1
.pinfo.metadata
Normal file
1
.pinfo.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
24c8cf74b7443614c8f4a23e2557853732045dfa SOURCES/pinfo-0.6.10.tar.bz2
|
27
SOURCES/0001-Make-sure-sbrk-is-defined-in-unistd.patch
Normal file
27
SOURCES/0001-Make-sure-sbrk-is-defined-in-unistd.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From b0fdc30500ddd271ec263b5b1c2eacf86ff73461 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "bas@zoetekouw.net" <bas@zoetekouw.net>
|
||||||
|
Date: Mon, 7 Aug 2017 22:58:43 +0200
|
||||||
|
Subject: [PATCH] Make sure sbrk() is defined in unistd
|
||||||
|
|
||||||
|
---
|
||||||
|
src/common_includes.h | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/common_includes.h b/src/common_includes.h
|
||||||
|
index a4593d3..fb3148c 100644
|
||||||
|
--- a/src/common_includes.h
|
||||||
|
+++ b/src/common_includes.h
|
||||||
|
@@ -22,6 +22,10 @@
|
||||||
|
#ifndef __COMMON_INCLUDES_H
|
||||||
|
#define __COMMON_INCLUDES_H
|
||||||
|
|
||||||
|
+/* make sure unistd.h defines sbrk() */
|
||||||
|
+#define _DEFAULT_SOURCE 1
|
||||||
|
+#define _BSD_SOURCE 1
|
||||||
|
+
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <string.h>
|
||||||
|
#include <strings.h>
|
||||||
|
--
|
||||||
|
2.14.4
|
||||||
|
|
26
SOURCES/pinfo-0.6.10-man.patch
Normal file
26
SOURCES/pinfo-0.6.10-man.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff --git a/doc/pinfo.1.in b/doc/pinfo.1.in
|
||||||
|
index 1882e7a..1a4da77 100644
|
||||||
|
--- a/doc/pinfo.1.in
|
||||||
|
+++ b/doc/pinfo.1.in
|
||||||
|
@@ -72,6 +72,10 @@ synonym for -r.
|
||||||
|
.BR --apropos
|
||||||
|
\- if this is set, apropos is called when no man or info page could be found.
|
||||||
|
.P
|
||||||
|
+.BR "-p",
|
||||||
|
+.BR --plain-apropos
|
||||||
|
+\- if this is set, call only apropos.
|
||||||
|
+.P
|
||||||
|
.BR "-c",
|
||||||
|
.BR --cut-man-headers
|
||||||
|
\- if this is set, man parsing code will try to cut out the repeated man
|
||||||
|
@@ -82,6 +86,10 @@ headers. Use with care. ;)
|
||||||
|
cut empty lines from manual pages. This option enables auto cutting of every
|
||||||
|
repeated newline in a manual page.
|
||||||
|
.P
|
||||||
|
+.BR "-d",
|
||||||
|
+.BR --dont-handle-without-tag-table
|
||||||
|
+\- don't display texinfo pages without tag table.
|
||||||
|
+.P
|
||||||
|
.BR "-t",
|
||||||
|
.BR "--force-manual-tag-table" \-
|
||||||
|
forces manual detection of tag table. This allows you to view info pages,
|
12
SOURCES/pinfo-0.6.9-infopath.patch
Normal file
12
SOURCES/pinfo-0.6.9-infopath.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up pinfo-0.6.9/src/datatypes.c.infopath pinfo-0.6.9/src/datatypes.c
|
||||||
|
--- pinfo-0.6.9/src/datatypes.c.infopath 2006-03-09 21:54:53.000000000 +0100
|
||||||
|
+++ pinfo-0.6.9/src/datatypes.c 2008-09-04 15:14:20.000000000 +0200
|
||||||
|
@@ -31,7 +31,7 @@ char *ftpviewer = "lynx";
|
||||||
|
char *maileditor = "mail";
|
||||||
|
char *printutility = "lpr";
|
||||||
|
char *manlinks = "1:8:2:3:4:5:6:7:9:n:l:p:o:3X11:3Xt:3X:3x";
|
||||||
|
-char *configuredinfopath = ".:/usr/share/info:/usr/info:/usr/local/share/info:/usr/local/info:/opt/info";
|
||||||
|
+char *configuredinfopath = "/usr/share/info:/usr/info:/usr/local/share/info:/usr/local/info:/opt/info:.";
|
||||||
|
char *ignoredmacros = 0;
|
||||||
|
char *rcfile = NULL;
|
||||||
|
|
30
SOURCES/pinfo-0.6.9-infosuff.patch
Normal file
30
SOURCES/pinfo-0.6.9-infosuff.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
--- pinfo-0.6.9/src/filehandling_functions.c.infosuff 2006-03-16 16:15:02.000000000 +0100
|
||||||
|
+++ pinfo-0.6.9/src/filehandling_functions.c 2006-09-18 14:32:32.000000000 +0200
|
||||||
|
@@ -94,6 +94,7 @@
|
||||||
|
/* iterate over all files in the directory */
|
||||||
|
while ((dp = readdir(dir)) != NULL)
|
||||||
|
{
|
||||||
|
+ int info_suffix;
|
||||||
|
/* use strcat rather than strdup, because xmalloc handles all
|
||||||
|
* malloc errors */
|
||||||
|
char *thisfile = xmalloc(strlen(dp->d_name)+1);
|
||||||
|
@@ -101,7 +102,9 @@
|
||||||
|
|
||||||
|
/* strip suffixes (so "gcc.info.gz" -> "gcc") */
|
||||||
|
strip_compression_suffix(thisfile);
|
||||||
|
+ info_suffix = strlen(thisfile);
|
||||||
|
strip_info_suffix(thisfile);
|
||||||
|
+ info_suffix -= strlen(thisfile);
|
||||||
|
|
||||||
|
/* compare this file with the file we're looking for */
|
||||||
|
if (strcmp(thisfile,bname) == 0)
|
||||||
|
@@ -110,7 +113,8 @@
|
||||||
|
matched++;
|
||||||
|
/* put it in the buffer */
|
||||||
|
strncat(Buf, thisfile, 1023-strlen(Buf));
|
||||||
|
- strncat(Buf, ".info", 1023-strlen(Buf));
|
||||||
|
+ if (info_suffix)
|
||||||
|
+ strncat(Buf, ".info", 1023-strlen(Buf));
|
||||||
|
|
||||||
|
/* clean up, and exit the loop */
|
||||||
|
xfree(thisfile);
|
39
SOURCES/pinfo-0.6.9-mansection.patch
Normal file
39
SOURCES/pinfo-0.6.9-mansection.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- pinfo-0.6.9/src/manual.c.mansection 2006-03-16 15:14:30.000000000 +0100
|
||||||
|
+++ pinfo-0.6.9/src/manual.c 2007-02-23 14:52:30.000000000 +0100
|
||||||
|
@@ -167,16 +167,29 @@
|
||||||
|
}
|
||||||
|
i = len;
|
||||||
|
/* find the beginning of the last token */
|
||||||
|
- for (i = len - 1;(i > 0) &&(!isspace(name1[i])); i--);
|
||||||
|
-
|
||||||
|
- /* if we've found space, then we move to the first nonspace character */
|
||||||
|
- if (i > 0)
|
||||||
|
- i++;
|
||||||
|
+ for (i = len - 1;(i >= 0) &&(!isspace(name1[i])); i--)
|
||||||
|
+ ;
|
||||||
|
+ i++;
|
||||||
|
|
||||||
|
/* filename->name */
|
||||||
|
- strcpy(manualhistory[0].name, &name1[i]);
|
||||||
|
+ snprintf(manualhistory[0].name, 256, "%s", &name1[i]);
|
||||||
|
+
|
||||||
|
/* section unknown */
|
||||||
|
- strcpy(manualhistory[0].sect, "");
|
||||||
|
+ manualhistory[0].sect[0] = 0;
|
||||||
|
+
|
||||||
|
+ /* try to find section */
|
||||||
|
+ if (i > 1) {
|
||||||
|
+ for (i--; (i >= 0) && isspace(name1[i]); i--)
|
||||||
|
+ ;
|
||||||
|
+ if (i >= 0) {
|
||||||
|
+ name1[i + 1] = 0;
|
||||||
|
+ for (; (i >= 0) && !isspace(name1[i]); i--)
|
||||||
|
+ ;
|
||||||
|
+ i++;
|
||||||
|
+ snprintf(manualhistory[0].sect, 32, "%s", &name1[i]);
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
/* selected unknown */
|
||||||
|
manualhistory[0].selected = -1;
|
||||||
|
/* pos=0 */
|
22
SOURCES/pinfo-0.6.9-nogroup.patch
Normal file
22
SOURCES/pinfo-0.6.9-nogroup.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- pinfo-0.6.9/src/utils.c.nogroup 2006-03-16 15:14:30.000000000 +0100
|
||||||
|
+++ pinfo-0.6.9/src/utils.c 2007-01-19 13:45:53.000000000 +0100
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
char *safe_user = "nobody";
|
||||||
|
-char *safe_group = "nogroup";
|
||||||
|
+char *safe_group = "nobody";
|
||||||
|
|
||||||
|
#ifndef HAVE_CURS_SET
|
||||||
|
void
|
||||||
|
--- pinfo-0.6.9/src/pinforc.in.nogroup 2007-01-19 13:42:14.000000000 +0100
|
||||||
|
+++ pinfo-0.6.9/src/pinforc.in 2007-01-19 13:45:35.000000000 +0100
|
||||||
|
@@ -91,7 +91,7 @@
|
||||||
|
PRINTUTILITY=lpr
|
||||||
|
MANLINKS=1:8:2:3:4:5:6:7:9:n:p:o:3X11:3Xt:3x:3X
|
||||||
|
SAFE-USER=nobody
|
||||||
|
-SAFE-GROUP=nogroup
|
||||||
|
+SAFE-GROUP=nobody
|
||||||
|
#
|
||||||
|
# Remember, HIGHLIGHTREGEXP may be slow (thus it's commented by default)
|
||||||
|
#
|
16
SOURCES/pinfo-0.6.9-xdg.patch
Normal file
16
SOURCES/pinfo-0.6.9-xdg.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up pinfo-0.6.9/src/pinforc.in.xdg pinfo-0.6.9/src/pinforc.in
|
||||||
|
--- pinfo-0.6.9/src/pinforc.in.xdg 2006-03-09 20:44:37.000000000 +0100
|
||||||
|
+++ pinfo-0.6.9/src/pinforc.in 2007-10-03 18:35:21.000000000 +0200
|
||||||
|
@@ -85,9 +85,9 @@ QUIT-CONFIRM-DEFAULT=no
|
||||||
|
CLEAR-SCREEN-AT-EXIT=true
|
||||||
|
CALL-READLINE-HISTORY=true
|
||||||
|
STDERR-REDIRECTION="2> /dev/null"
|
||||||
|
-HTTPVIEWER=lynx
|
||||||
|
-FTPVIEWER=lynx
|
||||||
|
-MAILEDITOR=clear; mail
|
||||||
|
+HTTPVIEWER=xdg-open
|
||||||
|
+FTPVIEWER=xdg-open
|
||||||
|
+MAILEDITOR=xdg-email
|
||||||
|
PRINTUTILITY=lpr
|
||||||
|
MANLINKS=1:8:2:3:4:5:6:7:9:n:p:o:3X11:3Xt:3x:3X
|
||||||
|
SAFE-USER=nobody
|
320
SPECS/pinfo.spec
Normal file
320
SPECS/pinfo.spec
Normal file
@ -0,0 +1,320 @@
|
|||||||
|
Summary: An info file viewer
|
||||||
|
Name: pinfo
|
||||||
|
Version: 0.6.10
|
||||||
|
Release: 18%{?dist}
|
||||||
|
Group: System Environment/Base
|
||||||
|
License: GPLv2
|
||||||
|
URL: http://pinfo.alioth.debian.org
|
||||||
|
Source: http://alioth.debian.org/frs/download.php/3351/pinfo-0.6.10.tar.bz2
|
||||||
|
Patch1: pinfo-0.6.9-xdg.patch
|
||||||
|
Patch2: pinfo-0.6.9-infosuff.patch
|
||||||
|
Patch3: pinfo-0.6.9-nogroup.patch
|
||||||
|
Patch4: pinfo-0.6.9-mansection.patch
|
||||||
|
Patch5: pinfo-0.6.9-infopath.patch
|
||||||
|
Patch6: pinfo-0.6.10-man.patch
|
||||||
|
Patch7: 0001-Make-sure-sbrk-is-defined-in-unistd.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildRequires: ncurses-devel
|
||||||
|
BuildRequires: automake gettext-devel libtool texinfo
|
||||||
|
Requires: xdg-utils
|
||||||
|
# for /sbin/install-info
|
||||||
|
Requires(post): info
|
||||||
|
Requires(preun): info
|
||||||
|
|
||||||
|
%description
|
||||||
|
Pinfo is an info file (or man page) viewer with a user interface
|
||||||
|
similar to the Lynx Web browser's interface. Pinfo supports searching
|
||||||
|
using regular expressions, and is based on the ncurses library.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1 -b .xdg
|
||||||
|
%patch2 -p1 -b .infosuff
|
||||||
|
%patch3 -p1 -b .nogroup
|
||||||
|
%patch4 -p1 -b .mansection
|
||||||
|
%patch5 -p1 -b .infopath
|
||||||
|
%patch6 -p1 -b .man
|
||||||
|
%patch7 -p1 -b .sbrk
|
||||||
|
|
||||||
|
%build
|
||||||
|
./autogen.sh
|
||||||
|
%configure --without-readline
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
|
# These symbolic links conflict with actual binaries in perl-pmtools (bz 437612)
|
||||||
|
# ln -sf pinfo $RPM_BUILD_ROOT%{_bindir}/pman
|
||||||
|
# ln -sf pinfo.1 $RPM_BUILD_ROOT%{_mandir}/man1/pman.1
|
||||||
|
|
||||||
|
# This file should not be packaged
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc AUTHORS COPYING ChangeLog* NEWS README TECHSTUFF
|
||||||
|
%config(noreplace) %{_sysconfdir}/pinforc
|
||||||
|
%{_bindir}/pinfo
|
||||||
|
# %{_bindir}/pman
|
||||||
|
%{_infodir}/pinfo.info*
|
||||||
|
%{_mandir}/man1/pinfo.1*
|
||||||
|
# %{_mandir}/man1/pman.1*
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/install-info %{_infodir}/pinfo.info.gz %{_infodir}/dir &> /dev/null
|
||||||
|
:
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ $1 = 0 ]; then
|
||||||
|
/sbin/install-info --delete %{_infodir}/pinfo.info.gz %{_infodir}/dir &> /dev/null
|
||||||
|
fi
|
||||||
|
:
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jul 23 2018 Lukas Nykryn <lnykryn@redhat.com> - 0.6.10-18
|
||||||
|
- fix missing declaration of function 'sbrk'
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.6.10-11
|
||||||
|
- Rebuilt for Fedora 23 Change
|
||||||
|
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Sep 06 2012 Lukáš Nykrýn <lnykryn@redhat.com> - 0.6.10-6
|
||||||
|
- Add -p and -d to manpage (#854900)
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Sep 29 2010 jkeating - 0.6.10-2
|
||||||
|
- Rebuilt for gcc bug 634757
|
||||||
|
|
||||||
|
* Tue Sep 21 2010 Miroslav Lichvar <mlichvar@redhat.com> 0.6.10-1
|
||||||
|
- update to 0.6.10
|
||||||
|
|
||||||
|
* Thu Jan 07 2010 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-12
|
||||||
|
- fix source URL
|
||||||
|
|
||||||
|
* Thu Sep 24 2009 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-11
|
||||||
|
- suppress install-info errors (#515995)
|
||||||
|
- mark config as noreplace
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.9-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.9-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-8
|
||||||
|
- modify default search path for info pages so that current
|
||||||
|
directory is searched last (#458633)
|
||||||
|
|
||||||
|
* Tue Apr 1 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.9-7
|
||||||
|
- drop symbolic links to avoid file conflict with perl-pmtools (bz 437612)
|
||||||
|
|
||||||
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.9-6
|
||||||
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
* Wed Oct 03 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-5
|
||||||
|
- use xdg-utils instead of htmlview (#312471)
|
||||||
|
|
||||||
|
* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-4
|
||||||
|
- update license tag
|
||||||
|
|
||||||
|
* Fri Feb 23 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-3
|
||||||
|
- save section of first man page to history (#208738)
|
||||||
|
- remove dot from summary
|
||||||
|
|
||||||
|
* Fri Jan 19 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-2
|
||||||
|
- use correct group when dropping group privileges (#221107)
|
||||||
|
- open also files without .info suffix
|
||||||
|
- make scriptlets safer
|
||||||
|
- make sure readline support isn't compiled in
|
||||||
|
|
||||||
|
* Tue Sep 12 2006 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-1.fc6
|
||||||
|
- update to 0.6.9
|
||||||
|
- package locale files
|
||||||
|
|
||||||
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6.8-11.2.2
|
||||||
|
- rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.8-11.2.1
|
||||||
|
- bump again for double-long bug on ppc(64)
|
||||||
|
|
||||||
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.8-11.2
|
||||||
|
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||||
|
|
||||||
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Apr 22 2005 Mike A. Harris <mharris@redhat.com> 0.6.8-11
|
||||||
|
- Work around an idiotic bug in rpm (#118780) by using multiple Requires
|
||||||
|
lines instead of the Requires(foo,bar) syntax that rpm documentation
|
||||||
|
states is valid. This fixes reported pinfo kickstart issue (#155700)
|
||||||
|
|
||||||
|
* Thu Mar 3 2005 Mike A. Harris <mharris@redhat.com> 0.6.8-10
|
||||||
|
- Rebuilt with gcc 4 for FC4
|
||||||
|
- Replaced Prereq: with Requires(post,preun)
|
||||||
|
|
||||||
|
* Thu Dec 23 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-9
|
||||||
|
- Replaced pinfo-0.6.0-mkstemp.patch with updated pinfo-0.6.8-mkstemp.patch
|
||||||
|
to fix an additional insecure tempnam() usage detected by our buildsystem
|
||||||
|
|
||||||
|
* Thu Dec 23 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-8
|
||||||
|
- Added pinfo-0.6.8.memcorruption.patch and pinfo-0.6.8.memleak.patch by
|
||||||
|
Sami Farin to fix a couple pinfo bugs reported in (#138770)
|
||||||
|
|
||||||
|
* Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 0.6.8-7
|
||||||
|
- use htmlviewer as the browser, since lynx might not be installed (bz #123349)
|
||||||
|
|
||||||
|
* Wed Sep 22 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-6
|
||||||
|
- Bump release and rebuild in rawhide for FC3
|
||||||
|
|
||||||
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Sat Jan 10 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-3
|
||||||
|
- Added RPM_OPT_FLAGS to CFLAGS as it wasn't being used (#109197)
|
||||||
|
|
||||||
|
* Fri Oct 31 2003 Mike A. Harris <mharris@redhat.com> 0.6.8-2
|
||||||
|
- Updated package URL to current project homepage (#101214)
|
||||||
|
|
||||||
|
* Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de> 0.6.8-1
|
||||||
|
- Updated to 0.6.8
|
||||||
|
|
||||||
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Sun May 18 2003 Mike A. Harris <mharris@redhat.com> 0.6.7-1
|
||||||
|
- Updated to 0.6.7
|
||||||
|
- Dropped already included patch pinfo-0.6.6-0.6.6p1.patch
|
||||||
|
|
||||||
|
* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 0.6.6-4
|
||||||
|
- Added pinfo-0.6.6-0.6.6p1.patch to fix bug (#78504)
|
||||||
|
|
||||||
|
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Dec 11 2002 Karsten Hopp <karsten@redhat.de> 0.6.6-2
|
||||||
|
- add missing Prereq
|
||||||
|
|
||||||
|
* Tue Nov 12 2002 Mike A. Harris <mharris@redhat.com> 0.6.6-1
|
||||||
|
- Updated to 0.6.6
|
||||||
|
- Corrected typos in description field
|
||||||
|
|
||||||
|
* Tue Nov 12 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-9
|
||||||
|
- Now how ironic is *this* one?... The info documentation on pinfo has been
|
||||||
|
missing from our packages. Mass rebuild tests caught this. Fixed now.
|
||||||
|
- Added post/preun scripts for updating info dir db with install-info
|
||||||
|
|
||||||
|
* Sat Oct 5 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-8
|
||||||
|
- All-arch rebuild
|
||||||
|
- Added _sysconfdir where appropriate
|
||||||
|
|
||||||
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.6.4-7
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Sun May 26 2002 Tim Powers <timp@redhat.com> 0.6.4-6
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Wed May 22 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-5
|
||||||
|
- Bumped release to rebuild in rawhide
|
||||||
|
|
||||||
|
* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-4
|
||||||
|
- Bumped release to rebuild in rawhide
|
||||||
|
|
||||||
|
* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 0.6.4-3
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Sun Dec 23 2001 Mike A. Harris <mharris@redhat.com> 0.6.4-2
|
||||||
|
- Bumped release to rebuild in rawhide
|
||||||
|
|
||||||
|
* Sun Dec 23 2001 Mike A. Harris <mharris@redhat.com> 0.6.4-1
|
||||||
|
- Updated to 0.6.4
|
||||||
|
|
||||||
|
* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.6.3-1
|
||||||
|
- Updated to 0.6.3
|
||||||
|
|
||||||
|
* Sat Jul 21 2001 Mike A. Harris <mharris@redhat.com> 0.6.1-2
|
||||||
|
- Add buildprereq on ncurses-devel
|
||||||
|
|
||||||
|
* Thu Jun 21 2001 Mike A. Harris <mharris@redhat.com> 0.6.1-1
|
||||||
|
- Updated to 0.6.1
|
||||||
|
- s/Copyright/License/ spec tag
|
||||||
|
|
||||||
|
* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
- move to the same group as the info and man packages
|
||||||
|
|
||||||
|
* Mon Aug 7 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
- add pman(1) links, per documentation
|
||||||
|
|
||||||
|
* Wed Aug 2 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
- fix possible crash due to use of tempnam()
|
||||||
|
|
||||||
|
* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
- update to 0.6.0
|
||||||
|
|
||||||
|
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||||
|
- automatic rebuild
|
||||||
|
|
||||||
|
* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
- spec file cleanups
|
||||||
|
|
||||||
|
* Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
- rebuild for main distribution
|
||||||
|
- use %%makeinstall
|
||||||
|
|
||||||
|
* Wed May 17 2000 Tim Powers <timp@redhat.com>
|
||||||
|
- updated to 0.5.9
|
||||||
|
- use %%configure and %%{_prefix} where possible
|
||||||
|
|
||||||
|
* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
|
||||||
|
- changed group
|
||||||
|
|
||||||
|
* Sun Aug 8 1999 Tim Powers <timp@redhat.com>
|
||||||
|
- rebuilt to be included in Powertools
|
Loading…
Reference in New Issue
Block a user