pinfo was removed due to minimization efforts prior to public launch
This commit is contained in:
parent
db12178bbf
commit
59e6fc6e3f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +0,0 @@
|
|||||||
pinfo-0.6.10.tar.bz2
|
|
||||||
/v0.6.13.tar.gz
|
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
|||||||
|
pinfo was removed due to minimization efforts prior to public launch
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/doc/pinfo.1.in b/doc/pinfo.1.in
|
|
||||||
index 1882e7a..1a4da77 100644
|
|
||||||
--- a/doc/pinfo.1.in
|
|
||||||
+++ b/doc/pinfo.1.in
|
|
||||||
@@ -72,6 +72,10 @@ synonym for -r.
|
|
||||||
.BR --apropos
|
|
||||||
\- if this is set, apropos is called when no man or info page could be found.
|
|
||||||
.P
|
|
||||||
+.BR "-p",
|
|
||||||
+.BR --plain-apropos
|
|
||||||
+\- if this is set, call only apropos.
|
|
||||||
+.P
|
|
||||||
.BR "-c",
|
|
||||||
.BR --cut-man-headers
|
|
||||||
\- if this is set, man parsing code will try to cut out the repeated man
|
|
||||||
@@ -82,6 +86,10 @@ headers. Use with care. ;)
|
|
||||||
cut empty lines from manual pages. This option enables auto cutting of every
|
|
||||||
repeated newline in a manual page.
|
|
||||||
.P
|
|
||||||
+.BR "-d",
|
|
||||||
+.BR --dont-handle-without-tag-table
|
|
||||||
+\- don't display texinfo pages without tag table.
|
|
||||||
+.P
|
|
||||||
.BR "-t",
|
|
||||||
.BR "--force-manual-tag-table" \-
|
|
||||||
forces manual detection of tag table. This allows you to view info pages,
|
|
@ -1,22 +0,0 @@
|
|||||||
From 16dba5978146b6d3a540ac7c8f415eda49280847 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bas Zoetekouw <bas.zoetekouw@surfnet.nl>
|
|
||||||
Date: Thu, 23 Jul 2020 20:11:24 +0200
|
|
||||||
Subject: [PATCH] fix use of global variabel
|
|
||||||
|
|
||||||
---
|
|
||||||
src/parse_config.h | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/parse_config.h b/src/parse_config.h
|
|
||||||
index 2dffa4f..4e68bb4 100644
|
|
||||||
--- a/src/parse_config.h
|
|
||||||
+++ b/src/parse_config.h
|
|
||||||
@@ -85,7 +85,7 @@ typedef struct colours
|
|
||||||
colours;
|
|
||||||
#endif /* HAVE_CURSES_COLOR */
|
|
||||||
|
|
||||||
-int use_manual;
|
|
||||||
+extern int use_manual;
|
|
||||||
|
|
||||||
int parse_config (void);
|
|
||||||
int parse_line (char *line);
|
|
@ -1,63 +0,0 @@
|
|||||||
From fc67ceacd81f0c74fcab85447c23a532ae482827 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sergei Trofimovich <slyich@gmail.com>
|
|
||||||
Date: Thu, 11 Nov 2021 18:59:57 +0000
|
|
||||||
Subject: [PATCH 1/2] src/utils.c: suppres unused parameter warning
|
|
||||||
|
|
||||||
utils.c:372:62: error: unused parameter 'completions' [-Werror=unused-parameter]
|
|
||||||
372 | getstring_with_completion(char *prompt, const char * const * completions)
|
|
||||||
| ~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~
|
|
||||||
---
|
|
||||||
src/utils.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/utils.c b/src/utils.c
|
|
||||||
index 2e4139c..34c9b88 100644
|
|
||||||
--- a/src/utils.c
|
|
||||||
+++ b/src/utils.c
|
|
||||||
@@ -394,7 +394,7 @@ getstring_with_completion(char *prompt, const char * const * completions)
|
|
||||||
curs_set(0);
|
|
||||||
|
|
||||||
#else
|
|
||||||
-
|
|
||||||
+ (void)completions; /* unused */
|
|
||||||
move(maxy - 1, 0);
|
|
||||||
buf = readlinewrapper(prompt);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.39.1
|
|
||||||
|
|
||||||
From ab604fdb67296dad27f3a25f3c9aabdd2fb8c3fa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sergei Trofimovich <slyich@gmail.com>
|
|
||||||
Date: Thu, 11 Nov 2021 19:02:24 +0000
|
|
||||||
Subject: [PATCH 2/2] src/video.c: use %ld to print longs
|
|
||||||
|
|
||||||
ncurses-6.3 added printf()-stype attribute annotations for gcc-like
|
|
||||||
compilers that can now detect argument mismatches:
|
|
||||||
|
|
||||||
video.c:114:26: error: format '%d' expects argument of type 'int',
|
|
||||||
but argument 3 has type 'long unsigned int' [-Werror=format=]
|
|
||||||
114 | printw(_("Viewing line %d/%d, 100%%"), lines, lines);
|
|
||||||
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
|
|
||||||
---
|
|
||||||
src/video.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/video.c b/src/video.c
|
|
||||||
index f6b444a..195d781 100644
|
|
||||||
--- a/src/video.c
|
|
||||||
+++ b/src/video.c
|
|
||||||
@@ -109,9 +109,9 @@ showscreen(char **message, unsigned long lines, unsigned long pos, long cursor,
|
|
||||||
mymvhline(maxy - 1, 0, ' ', maxx);
|
|
||||||
move(maxy - 1, 0);
|
|
||||||
if ((pos < lines - 1) &&(lines > pos + maxy - 2))
|
|
||||||
- printw(_("Viewing line %d/%d, %d%%"), pos + maxy - 2, lines,((pos + maxy - 2) * 100) / lines);
|
|
||||||
+ printw(_("Viewing line %ld/%ld, %ld%%"), pos + maxy - 2, lines,((pos + maxy - 2) * 100) / lines);
|
|
||||||
else
|
|
||||||
- printw(_("Viewing line %d/%d, 100%%"), lines, lines);
|
|
||||||
+ printw(_("Viewing line %ld/%ld, 100%%"), lines, lines);
|
|
||||||
info_add_highlights(pos, cursor, lines, column, message);
|
|
||||||
attrset(normal);
|
|
||||||
move(0, 0);
|
|
||||||
--
|
|
||||||
2.39.1
|
|
||||||
|
|
@ -1,22 +0,0 @@
|
|||||||
--- pinfo-0.6.9/src/utils.c.nogroup 2006-03-16 15:14:30.000000000 +0100
|
|
||||||
+++ pinfo-0.6.9/src/utils.c 2007-01-19 13:45:53.000000000 +0100
|
|
||||||
@@ -32,7 +32,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
char *safe_user = "nobody";
|
|
||||||
-char *safe_group = "nogroup";
|
|
||||||
+char *safe_group = "nobody";
|
|
||||||
|
|
||||||
#ifndef HAVE_DECL_CURS_SET
|
|
||||||
void
|
|
||||||
--- pinfo-0.6.9/src/pinforc.in.nogroup 2007-01-19 13:42:14.000000000 +0100
|
|
||||||
+++ pinfo-0.6.9/src/pinforc.in 2007-01-19 13:45:35.000000000 +0100
|
|
||||||
@@ -91,7 +91,7 @@
|
|
||||||
PRINTUTILITY=lpr
|
|
||||||
MANLINKS=1:8:2:3:4:5:6:7:9:n:p:o:3X11:3Xt:3x:3X
|
|
||||||
SAFE-USER=nobody
|
|
||||||
-SAFE-GROUP=nogroup
|
|
||||||
+SAFE-GROUP=nobody
|
|
||||||
#
|
|
||||||
# Remember, HIGHLIGHTREGEXP may be slow (thus it's commented by default)
|
|
||||||
#
|
|
@ -1,40 +0,0 @@
|
|||||||
From 23c169877fda839f0634b2d193eaf26de290f141 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bas Zoetekouw <bas.zoetekouw@surfnet.nl>
|
|
||||||
Date: Thu, 23 Jul 2020 20:39:04 +0200
|
|
||||||
Subject: [PATCH] workaround false positie in gcc-10 stringop-overflow checks
|
|
||||||
|
|
||||||
---
|
|
||||||
src/utils.c | 8 +++-----
|
|
||||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/utils.c b/src/utils.c
|
|
||||||
index cb2fe76..2e4139c 100644
|
|
||||||
--- a/src/utils.c
|
|
||||||
+++ b/src/utils.c
|
|
||||||
@@ -848,10 +848,9 @@ char *
|
|
||||||
make_tempfile()
|
|
||||||
{
|
|
||||||
char *filename;
|
|
||||||
- size_t len;
|
|
||||||
|
|
||||||
/* TODO: fix hardcoded /tmp */
|
|
||||||
- char tmpfile_template[] = "/tmp/pinfo.XXXXXX";
|
|
||||||
+ char tmpfile_template[32] = "/tmp/pinfo.XXXXXX";
|
|
||||||
|
|
||||||
/* create a tmpfile */
|
|
||||||
int fd = mkstemp(tmpfile_template);
|
|
||||||
@@ -864,9 +863,8 @@ make_tempfile()
|
|
||||||
}
|
|
||||||
|
|
||||||
/* allocate a new string and copy the filename there */
|
|
||||||
- len = strlen(tmpfile_template)+1;
|
|
||||||
- filename = xmalloc(len+1); /* guarenteerd to be set to \0's */
|
|
||||||
- strncpy(filename, tmpfile_template, len);
|
|
||||||
+ filename = xmalloc(33); /* guarenteerd to be set to \0's */
|
|
||||||
+ strncpy(filename, tmpfile_template, 32);
|
|
||||||
|
|
||||||
/* close the file */
|
|
||||||
close(fd);
|
|
||||||
--
|
|
||||||
2.39.1
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up pinfo-0.6.9/src/datatypes.c.infopath pinfo-0.6.9/src/datatypes.c
|
|
||||||
--- pinfo-0.6.9/src/datatypes.c.infopath 2006-03-09 21:54:53.000000000 +0100
|
|
||||||
+++ pinfo-0.6.9/src/datatypes.c 2008-09-04 15:14:20.000000000 +0200
|
|
||||||
@@ -31,7 +31,7 @@ char *ftpviewer = "lynx";
|
|
||||||
char *maileditor = "mail";
|
|
||||||
char *printutility = "lpr";
|
|
||||||
char *manlinks = "1:8:2:3:4:5:6:7:9:n:l:p:o:3X11:3Xt:3X:3x";
|
|
||||||
-char *configuredinfopath = ".:/usr/share/info:/usr/info:/usr/local/share/info:/usr/local/info:/opt/info";
|
|
||||||
+char *configuredinfopath = "/usr/share/info:/usr/info:/usr/local/share/info:/usr/local/info:/opt/info:.";
|
|
||||||
char *ignoredmacros = 0;
|
|
||||||
char *rcfile = NULL;
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
diff -up pinfo-0.6.9/src/pinforc.in.xdg pinfo-0.6.9/src/pinforc.in
|
|
||||||
--- pinfo-0.6.9/src/pinforc.in.xdg 2006-03-09 20:44:37.000000000 +0100
|
|
||||||
+++ pinfo-0.6.9/src/pinforc.in 2007-10-03 18:35:21.000000000 +0200
|
|
||||||
@@ -85,9 +85,9 @@ QUIT-CONFIRM-DEFAULT=no
|
|
||||||
CLEAR-SCREEN-AT-EXIT=true
|
|
||||||
CALL-READLINE-HISTORY=true
|
|
||||||
STDERR-REDIRECTION="2> /dev/null"
|
|
||||||
-HTTPVIEWER=lynx
|
|
||||||
-FTPVIEWER=lynx
|
|
||||||
-MAILEDITOR=clear; mail
|
|
||||||
+HTTPVIEWER=xdg-open
|
|
||||||
+FTPVIEWER=xdg-open
|
|
||||||
+MAILEDITOR=xdg-email
|
|
||||||
PRINTUTILITY=lpr
|
|
||||||
MANLINKS=1:8:2:3:4:5:6:7:9:n:p:o:3X11:3Xt:3x:3X
|
|
||||||
SAFE-USER=nobody
|
|
@ -1,38 +0,0 @@
|
|||||||
Defining _XOPEN_SOURCE on its own hides definitions in other headers
|
|
||||||
(which is already mentioned in upstream commit f49941a). One way to
|
|
||||||
deal with this is to define _DEFAULT_SOURCE in addition to
|
|
||||||
_XOPEN_SOURCE, which is what this commit implements.
|
|
||||||
|
|
||||||
This is one way to avoid an implicit function declaration in the
|
|
||||||
built-in mmap test that autoconf provides. It includes <unistd.h> and
|
|
||||||
expects that to provide a declaration of getpagesize because the
|
|
||||||
earlier check for HAVE_GETPAGESIZE succeeded. Without addressing the
|
|
||||||
implicit function declaration, the outcome of this check will change
|
|
||||||
with future compilers which no longer support them by default.
|
|
||||||
|
|
||||||
Submitted upstream: <https://github.com/baszoetekouw/pinfo/pull/35>
|
|
||||||
|
|
||||||
|
|
||||||
diff --git a/macros/wchar.m4 b/macros/wchar.m4
|
|
||||||
index 2dc3d3a940f6c6fd..a7d6e967024df594 100644
|
|
||||||
--- a/macros/wchar.m4
|
|
||||||
+++ b/macros/wchar.m4
|
|
||||||
@@ -78,7 +78,8 @@ AC_DEFUN([AC_CHECK_WCHAR],[
|
|
||||||
then
|
|
||||||
AC_COMPILE_IFELSE([
|
|
||||||
AC_LANG_PROGRAM(
|
|
||||||
- [[
|
|
||||||
+ [[
|
|
||||||
+ #define _DEFAULT_SOURCE
|
|
||||||
#define _XOPEN_SOURCE 600
|
|
||||||
#include <wchar.h>
|
|
||||||
]],
|
|
||||||
@@ -87,7 +88,7 @@ AC_DEFUN([AC_CHECK_WCHAR],[
|
|
||||||
[
|
|
||||||
dnl if found, set variables and print result
|
|
||||||
have_wcwidth=true
|
|
||||||
- wchar_flags="$wchar_flags -D_XOPEN_SOURCE=600"
|
|
||||||
+ wchar_flags="$wchar_flags -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600"
|
|
||||||
AC_MSG_RESULT([with -D_XOPEN_SOURCE=600])
|
|
||||||
],
|
|
||||||
[ ]
|
|
349
pinfo.spec
349
pinfo.spec
@ -1,349 +0,0 @@
|
|||||||
Name: pinfo
|
|
||||||
Version: 0.6.13
|
|
||||||
Release: 4%{?dist}
|
|
||||||
Summary: An info file viewer
|
|
||||||
License: GPL-2.0-only
|
|
||||||
|
|
||||||
URL: https://github.com/baszoetekouw/pinfo
|
|
||||||
Source: %{url}/archive/refs/tags/v%{version}.tar.gz
|
|
||||||
|
|
||||||
Patch1: pinfo-0.6.9-infopath.patch
|
|
||||||
Patch2: pinfo-0.6.9-xdg.patch
|
|
||||||
Patch3: pinfo-0.6.10-man.patch
|
|
||||||
Patch4: pinfo-0.6.13-fnocommon.patch
|
|
||||||
Patch5: pinfo-0.6.13-gccwarn.patch
|
|
||||||
Patch6: pinfo-0.6.13-nogroup.patch
|
|
||||||
Patch7: pinfo-0.6.13-stringop-overflow.patch
|
|
||||||
Patch8: pinfo-configure-c99.patch
|
|
||||||
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: gcc
|
|
||||||
BuildRequires: gettext-devel
|
|
||||||
BuildRequires: libtool
|
|
||||||
BuildRequires: make
|
|
||||||
BuildRequires: ncurses-devel
|
|
||||||
BuildRequires: texinfo
|
|
||||||
|
|
||||||
Requires: xdg-utils
|
|
||||||
|
|
||||||
%description
|
|
||||||
Pinfo is an info file (or man page) viewer with a user interface
|
|
||||||
similar to the Lynx Web browser's interface. Pinfo supports searching
|
|
||||||
using regular expressions, and is based on the ncurses library.
|
|
||||||
|
|
||||||
%prep
|
|
||||||
%autosetup -p1
|
|
||||||
|
|
||||||
%build
|
|
||||||
./autogen.sh
|
|
||||||
%configure --without-readline
|
|
||||||
%make_build
|
|
||||||
|
|
||||||
%install
|
|
||||||
%make_install
|
|
||||||
|
|
||||||
# This file should not be packaged
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
|
||||||
|
|
||||||
%find_lang %{name}
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
|
||||||
%license COPYING
|
|
||||||
%doc AUTHORS NEWS README.md TECHSTUFF
|
|
||||||
%config(noreplace) %{_sysconfdir}/pinforc
|
|
||||||
%{_bindir}/pinfo
|
|
||||||
%{_infodir}/pinfo.info*
|
|
||||||
%{_mandir}/man1/pinfo.1*
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.13-4
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Apr 27 2023 Florian Weimer <fweimer@redhat.com> - 0.6.13-3
|
|
||||||
- Port configure script to C99
|
|
||||||
|
|
||||||
* Tue Mar 14 2023 Lukáš Zaoral <lzaoral@redhat.com> - 0.6.13-2
|
|
||||||
- migrated to SPDX license
|
|
||||||
- cleaned-up the specfile
|
|
||||||
|
|
||||||
* Thu Jan 26 2023 Lukáš Zaoral <lzaoral@redhat.com> - 0.6.13-1
|
|
||||||
- Update to v0.6.13
|
|
||||||
|
|
||||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-31
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-30
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-29
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-28
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-27
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-26
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
||||||
|
|
||||||
* Mon Feb 24 2020 Than Ngo <than@redhat.com> - 0.6.10-25
|
|
||||||
- Fixed FTBFS
|
|
||||||
|
|
||||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-24
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-23
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Mar 01 2019 Lukas Nykryn <lnykryn@redhat.com> - 0.6.10-22
|
|
||||||
- fix ftbfs
|
|
||||||
|
|
||||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-21
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Jul 31 2018 Florian Weimer <fweimer@redhat.com> - 0.6.10-20
|
|
||||||
- Rebuild with fixed binutils
|
|
||||||
|
|
||||||
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.10-19
|
|
||||||
- Replace obsolete scriptlets
|
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-18
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-17
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-16
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-15
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-14
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-13
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-12
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.6.10-11
|
|
||||||
- Rebuilt for Fedora 23 Change
|
|
||||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
|
||||||
|
|
||||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-10
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-9
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-8
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-7
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Sep 06 2012 Lukáš Nykrýn <lnykryn@redhat.com> - 0.6.10-6
|
|
||||||
- Add -p and -d to manpage (#854900)
|
|
||||||
|
|
||||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-5
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-4
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Sep 29 2010 jkeating - 0.6.10-2
|
|
||||||
- Rebuilt for gcc bug 634757
|
|
||||||
|
|
||||||
* Tue Sep 21 2010 Miroslav Lichvar <mlichvar@redhat.com> 0.6.10-1
|
|
||||||
- update to 0.6.10
|
|
||||||
|
|
||||||
* Thu Jan 07 2010 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-12
|
|
||||||
- fix source URL
|
|
||||||
|
|
||||||
* Thu Sep 24 2009 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-11
|
|
||||||
- suppress install-info errors (#515995)
|
|
||||||
- mark config as noreplace
|
|
||||||
|
|
||||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.9-10
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.9-9
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-8
|
|
||||||
- modify default search path for info pages so that current
|
|
||||||
directory is searched last (#458633)
|
|
||||||
|
|
||||||
* Tue Apr 1 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.9-7
|
|
||||||
- drop symbolic links to avoid file conflict with perl-pmtools (bz 437612)
|
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.9-6
|
|
||||||
- Autorebuild for GCC 4.3
|
|
||||||
|
|
||||||
* Wed Oct 03 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-5
|
|
||||||
- use xdg-utils instead of htmlview (#312471)
|
|
||||||
|
|
||||||
* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-4
|
|
||||||
- update license tag
|
|
||||||
|
|
||||||
* Fri Feb 23 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-3
|
|
||||||
- save section of first man page to history (#208738)
|
|
||||||
- remove dot from summary
|
|
||||||
|
|
||||||
* Fri Jan 19 2007 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-2
|
|
||||||
- use correct group when dropping group privileges (#221107)
|
|
||||||
- open also files without .info suffix
|
|
||||||
- make scriptlets safer
|
|
||||||
- make sure readline support isn't compiled in
|
|
||||||
|
|
||||||
* Tue Sep 12 2006 Miroslav Lichvar <mlichvar@redhat.com> 0.6.9-1.fc6
|
|
||||||
- update to 0.6.9
|
|
||||||
- package locale files
|
|
||||||
|
|
||||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6.8-11.2.2
|
|
||||||
- rebuild
|
|
||||||
|
|
||||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.8-11.2.1
|
|
||||||
- bump again for double-long bug on ppc(64)
|
|
||||||
|
|
||||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.8-11.2
|
|
||||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
|
||||||
|
|
||||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
|
||||||
- rebuilt
|
|
||||||
|
|
||||||
* Fri Apr 22 2005 Mike A. Harris <mharris@redhat.com> 0.6.8-11
|
|
||||||
- Work around an idiotic bug in rpm (#118780) by using multiple Requires
|
|
||||||
lines instead of the Requires(foo,bar) syntax that rpm documentation
|
|
||||||
states is valid. This fixes reported pinfo kickstart issue (#155700)
|
|
||||||
|
|
||||||
* Thu Mar 3 2005 Mike A. Harris <mharris@redhat.com> 0.6.8-10
|
|
||||||
- Rebuilt with gcc 4 for FC4
|
|
||||||
- Replaced Prereq: with Requires(post,preun)
|
|
||||||
|
|
||||||
* Thu Dec 23 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-9
|
|
||||||
- Replaced pinfo-0.6.0-mkstemp.patch with updated pinfo-0.6.8-mkstemp.patch
|
|
||||||
to fix an additional insecure tempnam() usage detected by our buildsystem
|
|
||||||
|
|
||||||
* Thu Dec 23 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-8
|
|
||||||
- Added pinfo-0.6.8.memcorruption.patch and pinfo-0.6.8.memleak.patch by
|
|
||||||
Sami Farin to fix a couple pinfo bugs reported in (#138770)
|
|
||||||
|
|
||||||
* Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 0.6.8-7
|
|
||||||
- use htmlviewer as the browser, since lynx might not be installed (bz #123349)
|
|
||||||
|
|
||||||
* Wed Sep 22 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-6
|
|
||||||
- Bump release and rebuild in rawhide for FC3
|
|
||||||
|
|
||||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
|
||||||
- rebuilt
|
|
||||||
|
|
||||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
|
||||||
- rebuilt
|
|
||||||
|
|
||||||
* Sat Jan 10 2004 Mike A. Harris <mharris@redhat.com> 0.6.8-3
|
|
||||||
- Added RPM_OPT_FLAGS to CFLAGS as it wasn't being used (#109197)
|
|
||||||
|
|
||||||
* Fri Oct 31 2003 Mike A. Harris <mharris@redhat.com> 0.6.8-2
|
|
||||||
- Updated package URL to current project homepage (#101214)
|
|
||||||
|
|
||||||
* Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de> 0.6.8-1
|
|
||||||
- Updated to 0.6.8
|
|
||||||
|
|
||||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
|
||||||
- rebuilt
|
|
||||||
|
|
||||||
* Sun May 18 2003 Mike A. Harris <mharris@redhat.com> 0.6.7-1
|
|
||||||
- Updated to 0.6.7
|
|
||||||
- Dropped already included patch pinfo-0.6.6-0.6.6p1.patch
|
|
||||||
|
|
||||||
* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 0.6.6-4
|
|
||||||
- Added pinfo-0.6.6-0.6.6p1.patch to fix bug (#78504)
|
|
||||||
|
|
||||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
|
||||||
- rebuilt
|
|
||||||
|
|
||||||
* Wed Dec 11 2002 Karsten Hopp <karsten@redhat.de> 0.6.6-2
|
|
||||||
- add missing Prereq
|
|
||||||
|
|
||||||
* Tue Nov 12 2002 Mike A. Harris <mharris@redhat.com> 0.6.6-1
|
|
||||||
- Updated to 0.6.6
|
|
||||||
- Corrected typos in description field
|
|
||||||
|
|
||||||
* Tue Nov 12 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-9
|
|
||||||
- Now how ironic is *this* one?... The info documentation on pinfo has been
|
|
||||||
missing from our packages. Mass rebuild tests caught this. Fixed now.
|
|
||||||
- Added post/preun scripts for updating info dir db with install-info
|
|
||||||
|
|
||||||
* Sat Oct 5 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-8
|
|
||||||
- All-arch rebuild
|
|
||||||
- Added _sysconfdir where appropriate
|
|
||||||
|
|
||||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.6.4-7
|
|
||||||
- automated rebuild
|
|
||||||
|
|
||||||
* Sun May 26 2002 Tim Powers <timp@redhat.com> 0.6.4-6
|
|
||||||
- automated rebuild
|
|
||||||
|
|
||||||
* Wed May 22 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-5
|
|
||||||
- Bumped release to rebuild in rawhide
|
|
||||||
|
|
||||||
* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.6.4-4
|
|
||||||
- Bumped release to rebuild in rawhide
|
|
||||||
|
|
||||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 0.6.4-3
|
|
||||||
- automated rebuild
|
|
||||||
|
|
||||||
* Sun Dec 23 2001 Mike A. Harris <mharris@redhat.com> 0.6.4-2
|
|
||||||
- Bumped release to rebuild in rawhide
|
|
||||||
|
|
||||||
* Sun Dec 23 2001 Mike A. Harris <mharris@redhat.com> 0.6.4-1
|
|
||||||
- Updated to 0.6.4
|
|
||||||
|
|
||||||
* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.6.3-1
|
|
||||||
- Updated to 0.6.3
|
|
||||||
|
|
||||||
* Sat Jul 21 2001 Mike A. Harris <mharris@redhat.com> 0.6.1-2
|
|
||||||
- Add buildprereq on ncurses-devel
|
|
||||||
|
|
||||||
* Thu Jun 21 2001 Mike A. Harris <mharris@redhat.com> 0.6.1-1
|
|
||||||
- Updated to 0.6.1
|
|
||||||
- s/Copyright/License/ spec tag
|
|
||||||
|
|
||||||
* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
|
|
||||||
- move to the same group as the info and man packages
|
|
||||||
|
|
||||||
* Mon Aug 7 2000 Nalin Dahyabhai <nalin@redhat.com>
|
|
||||||
- add pman(1) links, per documentation
|
|
||||||
|
|
||||||
* Wed Aug 2 2000 Nalin Dahyabhai <nalin@redhat.com>
|
|
||||||
- fix possible crash due to use of tempnam()
|
|
||||||
|
|
||||||
* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
|
|
||||||
- update to 0.6.0
|
|
||||||
|
|
||||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
|
||||||
- automatic rebuild
|
|
||||||
|
|
||||||
* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
|
|
||||||
- spec file cleanups
|
|
||||||
|
|
||||||
* Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
|
|
||||||
- rebuild for main distribution
|
|
||||||
- use %%makeinstall
|
|
||||||
|
|
||||||
* Wed May 17 2000 Tim Powers <timp@redhat.com>
|
|
||||||
- updated to 0.5.9
|
|
||||||
- use %%configure and %%{_prefix} where possible
|
|
||||||
|
|
||||||
* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
|
|
||||||
- changed group
|
|
||||||
|
|
||||||
* Sun Aug 8 1999 Tim Powers <timp@redhat.com>
|
|
||||||
- rebuilt to be included in Powertools
|
|
Loading…
Reference in New Issue
Block a user