import pidgin-2.13.0-4.el8
This commit is contained in:
commit
e5230d1b26
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
||||
SOURCES/pidgin-2.13.0.tar.bz2
|
||||
SOURCES/purple-fedora-prefs.xml
|
2
.pidgin.metadata
Normal file
2
.pidgin.metadata
Normal file
@ -0,0 +1,2 @@
|
||||
122f0a48ba63cd7f2bc2962c497df045ce29ef71 SOURCES/pidgin-2.13.0.tar.bz2
|
||||
280a2d02ea4329a5125e44e5ace0937598e3240c SOURCES/purple-fedora-prefs.xml
|
33
SOURCES/pidgin-2.10.1-fix-msn-ft-crashes.patch
Normal file
33
SOURCES/pidgin-2.10.1-fix-msn-ft-crashes.patch
Normal file
@ -0,0 +1,33 @@
|
||||
----------------------------------------------------------------------
|
||||
Revision: 9d51cb9fbcc04d21597eed0381f4d06c53facc44
|
||||
Parent: 17326b88b85d2f13939a71ca80d4a617f0527f9a
|
||||
Author: Cristi Posoiu
|
||||
Date: 06/03/11 02:55:31
|
||||
Branch: im.pidgin.pidgin
|
||||
|
||||
Changelog:
|
||||
|
||||
Fix up some cases of file transfers never finishing. This will help certain
|
||||
instances of Yahoo file transfers not working, but not all. Fixes #12472.
|
||||
|
||||
Changes against parent 17326b88b85d2f13939a71ca80d4a617f0527f9a
|
||||
|
||||
patched libpurple/ft.c
|
||||
|
||||
============================================================
|
||||
--- libpurple/ft.c 2b8633b159e16099b858dd21ed122e9c3811a9d5
|
||||
+++ libpurple/ft.c ffba61c0a50c9d5f866f8b1f0dec16cf13bbd65c
|
||||
@@ -1100,9 +1100,11 @@ purple_xfer_write(PurpleXfer *xfer, cons
|
||||
r = write(xfer->fd, buffer, s);
|
||||
if (r < 0 && errno == EAGAIN)
|
||||
r = 0;
|
||||
- if ((purple_xfer_get_bytes_sent(xfer)+r) >= purple_xfer_get_size(xfer))
|
||||
- purple_xfer_set_completed(xfer, TRUE);
|
||||
}
|
||||
+ if (r >= 0 && (purple_xfer_get_bytes_sent(xfer)+r) >= purple_xfer_get_size(xfer) &&
|
||||
+ !purple_xfer_is_completed(xfer))
|
||||
+ purple_xfer_set_completed(xfer, TRUE);
|
||||
+
|
||||
|
||||
return r;
|
||||
}
|
16
SOURCES/pidgin-2.10.11-do-not-disable-wall.patch
Normal file
16
SOURCES/pidgin-2.10.11-do-not-disable-wall.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 51471b1..6b59976 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1227,11 +1227,6 @@ AC_ARG_ENABLE(fortify, [AC_HELP_STRING([--disable-fortify], [compile without FOR
|
||||
|
||||
DEBUG_CFLAGS="$DEBUG_CFLAGS -DPURPLE_DISABLE_DEPRECATED -DPIDGIN_DISABLE_DEPRECATED -DFINCH_DISABLE_DEPRECATED -DGNT_DISABLE_DEPRECATED"
|
||||
if test "x$GCC" = "xyes"; then
|
||||
- dnl We enable -Wall later.
|
||||
- dnl If it's set after the warning CFLAGS in the compiler invocation, it counteracts the -Wno... flags.
|
||||
- dnl This leads to warnings we don't want.
|
||||
- CFLAGS=`echo $CFLAGS |$sedpath 's/-Wall//'`
|
||||
-
|
||||
dnl ENABLE WARNINGS SUPPORTED BY THE VERSION OF GCC IN USE
|
||||
dnl
|
||||
dnl Future Possibilities
|
17
SOURCES/pidgin-2.10.11-purple-remote-python3.patch
Normal file
17
SOURCES/pidgin-2.10.11-purple-remote-python3.patch
Normal file
@ -0,0 +1,17 @@
|
||||
Actually make things work in python3.
|
||||
|
||||
Author: Jan Synacek <jsynacek@redhat.com>
|
||||
|
||||
Index: pidgin-2.13.0/libpurple/purple-remote
|
||||
===================================================================
|
||||
--- pidgin-2.13.0.orig/libpurple/purple-remote
|
||||
+++ pidgin-2.13.0/libpurple/purple-remote
|
||||
@@ -14,7 +14,7 @@ import sys
|
||||
import xml.dom.minidom
|
||||
|
||||
sys.stdin = codecs.getwriter('utf-8')(sys.stdin);
|
||||
-sys.stdout = codecs.getwriter('utf-8')(sys.stdout);
|
||||
+sys.stdout = codecs.getwriter('utf-8')(sys.stdout.detach());
|
||||
|
||||
xml.dom.minidom.Element.all = xml.dom.minidom.Element.getElementsByTagName
|
||||
|
12
SOURCES/pidgin-2.10.9-valgrind.patch
Normal file
12
SOURCES/pidgin-2.10.9-valgrind.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/libpurple/Makefile.am 2014-02-02 22:29:17.000000000 +0100
|
||||
+++ b/libpurple/Makefile.am 2014-09-15 08:47:31.352256368 +0200
|
||||
@@ -284,8 +284,7 @@
|
||||
|
||||
noinst_HEADERS= \
|
||||
internal.h \
|
||||
- media/backend-fs2.h \
|
||||
- valgrind.h
|
||||
+ media/backend-fs2.h
|
||||
|
||||
libpurpleincludedir=$(includedir)/libpurple
|
||||
libpurpleinclude_HEADERS = \
|
70
SOURCES/pidgin-2.13.0-drop-aim-gadu-gadu.patch
Normal file
70
SOURCES/pidgin-2.13.0-drop-aim-gadu-gadu.patch
Normal file
@ -0,0 +1,70 @@
|
||||
From c1c61bc305a222aaa75d3d6803d08225552f0eed Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Tue, 9 Oct 2018 18:33:11 +0200
|
||||
Subject: [PATCH] Drop AIM and Gadu-Gadu
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1026505
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1500403
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1579978
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
libpurple/protocols/oscar/Makefile.am | 8 ++------
|
||||
2 files changed, 4 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f973af051bcb..e477f47a78af 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1189,7 +1189,7 @@ if test "x$STATIC_PRPLS" != "x" -a "x$DYNAMIC_PRPLS" = "xall"; then
|
||||
fi
|
||||
|
||||
if test "x$STATIC_PRPLS" = "xall" ; then
|
||||
- STATIC_PRPLS="bonjour gg irc jabber novell oscar sametime silc simple zephyr"
|
||||
+ STATIC_PRPLS="bonjour irc jabber novell oscar sametime silc simple zephyr"
|
||||
fi
|
||||
if test "x$have_meanwhile" != "xyes" ; then
|
||||
STATIC_PRPLS=`echo $STATIC_PRPLS | $sedpath 's/sametime//'`
|
||||
@@ -1260,7 +1260,7 @@ AC_DEFINE_UNQUOTED(STATIC_PROTO_INIT, $extern_init static void static_proto_init
|
||||
|
||||
AC_ARG_WITH(dynamic_prpls, [AC_HELP_STRING([--with-dynamic-prpls], [specify which protocols to build dynamically])], [DYNAMIC_PRPLS=`echo $withval | $sedpath 's/,/ /g'`])
|
||||
if test "x$DYNAMIC_PRPLS" = "xall" ; then
|
||||
- DYNAMIC_PRPLS="bonjour gg irc jabber novell oscar sametime silc simple zephyr"
|
||||
+ DYNAMIC_PRPLS="bonjour irc jabber novell oscar sametime silc simple zephyr"
|
||||
fi
|
||||
if test "x$have_meanwhile" != "xyes"; then
|
||||
DYNAMIC_PRPLS=`echo $DYNAMIC_PRPLS | $sedpath 's/sametime//'`
|
||||
diff --git a/libpurple/protocols/oscar/Makefile.am b/libpurple/protocols/oscar/Makefile.am
|
||||
index d7663b025b59..75d80f746728 100644
|
||||
--- a/libpurple/protocols/oscar/Makefile.am
|
||||
+++ b/libpurple/protocols/oscar/Makefile.am
|
||||
@@ -51,25 +51,21 @@ OSCARSOURCES = \
|
||||
|
||||
AM_CFLAGS = $(st)
|
||||
|
||||
-libaim_la_LDFLAGS = -module -avoid-version
|
||||
libicq_la_LDFLAGS = -module -avoid-version
|
||||
if STATIC_OSCAR
|
||||
|
||||
st = -DPURPLE_STATIC_PRPL
|
||||
noinst_LTLIBRARIES = liboscar.la
|
||||
-liboscar_la_SOURCES = $(OSCARSOURCES) libaim.c libicq.c
|
||||
+liboscar_la_SOURCES = $(OSCARSOURCES) libicq.c
|
||||
liboscar_la_CFLAGS = $(AM_CFLAGS)
|
||||
|
||||
else
|
||||
|
||||
st =
|
||||
-pkg_LTLIBRARIES = liboscar.la libaim.la libicq.la
|
||||
+pkg_LTLIBRARIES = liboscar.la libicq.la
|
||||
liboscar_la_SOURCES = $(OSCARSOURCES)
|
||||
liboscar_la_LIBADD = $(GLIB_LIBS)
|
||||
|
||||
-libaim_la_SOURCES = libaim.c
|
||||
-libaim_la_LIBADD = liboscar.la
|
||||
-
|
||||
libicq_la_SOURCES = libicq.c
|
||||
libicq_la_LIBADD = liboscar.la
|
||||
|
||||
--
|
||||
2.14.4
|
||||
|
@ -0,0 +1,33 @@
|
||||
diff -urN pidgin-2.5.2.orig/pidgin/gtksound.c pidgin-2.5.2/pidgin/gtksound.c
|
||||
--- pidgin-2.5.2.orig/pidgin/gtksound.c 2008-07-13 22:05:38.000000000 -0400
|
||||
+++ pidgin-2.5.2/pidgin/gtksound.c 2008-11-22 13:36:54.000000000 -0500
|
||||
@@ -298,6 +298,9 @@
|
||||
purple_prefs_add_bool(PIDGIN_PREFS_ROOT "/sound/mute", FALSE);
|
||||
purple_prefs_add_path(PIDGIN_PREFS_ROOT "/sound/command", "");
|
||||
purple_prefs_add_string(PIDGIN_PREFS_ROOT "/sound/method", "automatic");
|
||||
+#ifndef USE_GSTREAMER
|
||||
+ purple_prefs_add_bool(PIDGIN_PREFS_ROOT "/sound/rhel4migrated", FALSE);
|
||||
+#endif
|
||||
purple_prefs_add_int(PIDGIN_PREFS_ROOT "/sound/volume", 50);
|
||||
|
||||
#ifdef USE_GSTREAMER
|
||||
@@ -433,6 +436,19 @@
|
||||
return;
|
||||
}
|
||||
|
||||
+#ifndef USE_GSTREAMER
|
||||
+ /* RHEL4 migration code */
|
||||
+ if (!purple_prefs_get_bool(PIDGIN_PREFS_ROOT "/sound/rhel4migrated")) {
|
||||
+ purple_prefs_set_bool(PIDGIN_PREFS_ROOT "/sound/rhel4migrated", TRUE);
|
||||
+ if(!strcmp(method, "automatic") ||
|
||||
+ !strcmp(method, "esd") ||
|
||||
+ !strcmp(method, "arts")) {
|
||||
+ purple_prefs_set_string(PIDGIN_PREFS_ROOT "/sound/method", "custom");
|
||||
+ purple_prefs_set_path(PIDGIN_PREFS_ROOT "/sound/command", "aplay %s");
|
||||
+ }
|
||||
+ }
|
||||
+#endif
|
||||
+
|
||||
#ifndef _WIN32
|
||||
if (!strcmp(method, "custom")) {
|
||||
const char *sound_cmd;
|
2106
SPECS/pidgin.spec
Normal file
2106
SPECS/pidgin.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user