50 lines
2.5 KiB
Diff
50 lines
2.5 KiB
Diff
From 3ead67239419632eecb83f0f101ead2021ee6c14 Mon Sep 17 00:00:00 2001
|
|
From: Ralf Habacker <ralf.habacker@freenet.de>
|
|
Date: Fri, 1 Mar 2019 22:32:01 +0100
|
|
Subject: [PATCH] Fix #77609: Tests from mailparse extension fails
|
|
|
|
Add installed php extensions to temporary created ini file
|
|
|
|
In php extensions configured with phpize, a temporarily generated
|
|
php.ini is used for testing, but currently contains no installed
|
|
PHP extensions, which is required by the mailparse extension,
|
|
for example.
|
|
|
|
Installed extensions must be added with their absolute path,
|
|
because the extension_dir parameter is already occupied.
|
|
|
|
See https://bugs.php.net/bug.php?id=77609
|
|
---
|
|
Makefile.global | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile.global b/Makefile.global
|
|
index 5728060e3cb6..377cae179fd5 100644
|
|
--- a/Makefile.global
|
|
+++ b/Makefile.global
|
|
@@ -83,20 +83,21 @@ PHP_TEST_SHARED_EXTENSIONS = ` \
|
|
. $$i; $(top_srcdir)/build/shtool echo -n -- " -d $(ZEND_EXT_TYPE)=$(top_builddir)/modules/$$dlname"; \
|
|
done; \
|
|
fi`
|
|
-PHP_DEPRECATED_DIRECTIVES_REGEX = '^(magic_quotes_(gpc|runtime|sybase)?|(zend_)?extension(_debug)?(_ts)?)[\t\ ]*='
|
|
+PHP_FILTERED_DIRECTIVES_REGEX = '^(magic_quotes_(gpc|runtime|sybase)?|zend_extension(_debug)?(_ts)?)[\t\ ]*='
|
|
+PHP_EXTENSION_PATH_FIX_REGEX = "/^extension *= *[^/]/s,extension *= *,extension=$(EXTENSION_DIR)/,g"
|
|
|
|
test: all
|
|
@if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
|
|
INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
|
|
if test "$$INI_FILE"; then \
|
|
- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
|
|
+ $(EGREP) -h -v $(PHP_FILTERED_DIRECTIVES_REGEX) "$$INI_FILE" | $(SED) $(PHP_EXTENSION_PATH_FIX_REGEX) > $(top_builddir)/tmp-php.ini; \
|
|
else \
|
|
echo > $(top_builddir)/tmp-php.ini; \
|
|
fi; \
|
|
INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
|
|
if test "$$INI_SCANNED_PATH"; then \
|
|
INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
|
|
- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
|
|
+ $(EGREP) -h -v $(PHP_FILTERED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini | $(SED) $(PHP_EXTENSION_PATH_FIX_REGEX) >> $(top_builddir)/tmp-php.ini; \
|
|
fi; \
|
|
TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
|
|
TEST_PHP_SRCDIR=$(top_srcdir) \
|