update to 7.2.5RC1
This commit is contained in:
parent
5a4411f412
commit
f8a6a31d9a
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@ php-7.1.*.xz
|
||||
/php-7.2.3.tar.xz
|
||||
/php-7.2.4RC1.tar.xz
|
||||
/php-7.2.4.tar.xz
|
||||
/php-7.2.5RC1.tar.xz
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 4072b2787074ee8e247a6639585b49e10c5a55fe Mon Sep 17 00:00:00 2001
|
||||
From: "Christoph M. Becker" <cmbecker69@gmx.de>
|
||||
Date: Tue, 20 Mar 2018 16:35:39 +0100
|
||||
Subject: [PATCH] Fix #76113: mbstring does not build with Oniguruma 6.8.1
|
||||
|
||||
As of Oniguruma 6.8.1, the regex structure has been moved from the
|
||||
public `oniguruma.h` to the private `regint.h`. Thus, it is no longer
|
||||
possible to directly access the struct's members, and actually, there
|
||||
is no need to, since there are respective accessor functions available
|
||||
at least of 2.3.1.
|
||||
---
|
||||
NEWS | 2 ++
|
||||
ext/mbstring/php_mbregex.c | 2 +-
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ext/mbstring/php_mbregex.c b/ext/mbstring/php_mbregex.c
|
||||
index a5a6cd0..7a70c63 100644
|
||||
--- a/ext/mbstring/php_mbregex.c
|
||||
+++ b/ext/mbstring/php_mbregex.c
|
||||
@@ -452,7 +452,7 @@ static php_mb_regex_t *php_mbregex_compile_pattern(const char *pattern, int patl
|
||||
OnigUChar err_str[ONIG_MAX_ERROR_MESSAGE_LEN];
|
||||
|
||||
rc = zend_hash_str_find_ptr(&MBREX(ht_rc), (char *)pattern, patlen);
|
||||
- if (!rc || rc->options != options || rc->enc != enc || rc->syntax != syntax) {
|
||||
+ if (!rc || onig_get_options(rc) != options || onig_get_encoding(rc) != enc || onig_get_syntax(rc) != syntax) {
|
||||
if ((err_code = onig_new(&retval, (OnigUChar *)pattern, (OnigUChar *)(pattern + patlen), options, enc, syntax, &err_info)) != ONIG_NORMAL) {
|
||||
onig_error_code_to_str(err_str, err_code, &err_info);
|
||||
php_error_docref(NULL, E_WARNING, "mbregex compile err: %s", err_str);
|
||||
--
|
||||
2.1.4
|
||||
|
11
php.spec
11
php.spec
@ -58,13 +58,13 @@
|
||||
%global with_lmdb 0
|
||||
%endif
|
||||
|
||||
%global upver 7.2.4
|
||||
#global rcver RC1
|
||||
%global upver 7.2.5
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -110,7 +110,6 @@ Patch46: php-7.2.4-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-upstream.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -710,7 +709,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .upstream
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1552,6 +1550,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 7.2.5~RC1-1
|
||||
- update to 7.2.5RC1
|
||||
|
||||
* Tue Apr 3 2018 Remi Collet <remi@remirepo.net> - 7.2.4-2
|
||||
- add upstream patch for oniguruma 6.8.1, FTBFS #1562583
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (php-7.2.4.tar.xz) = d1d0720f0d4bb28f7ce0ec7c859b14c1e74e9d0e7c73de6988d5ce737d7ccb7308c0a7a2651ee012c630be2cd53e6531505df0a03f0efbb6359176b446982244
|
||||
SHA512 (php-7.2.5RC1.tar.xz) = ed1c894a9785d1efe52eb743dacb84f1d504e8d393dee48cc6cda3a54bd13a65e2c3afd8cd5327b25bcab6228c8b4396839418f41d369956b4c9a536b392a2dc
|
||||
|
Loading…
Reference in New Issue
Block a user