update to 5.3.6

This commit is contained in:
remi 2011-03-17 19:25:10 +01:00
parent 34628d1ab8
commit f47a10f1b6
7 changed files with 141 additions and 152 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
php-5.3.3.tar.bz2
/php-5.3.4.tar.bz2
/php-5.3.5.tar.bz2
/php-5.3.6.tar.bz2

View File

@ -1,14 +0,0 @@
--- php/php-src/branches/PHP_5_3/ext/intl/formatter/formatter_attr.c 2010/12/10 00:37:31 306153
+++ php/php-src/branches/PHP_5_3/ext/intl/formatter/formatter_attr.c 2010/12/10 00:47:51 306154
@@ -311,6 +311,11 @@
RETURN_FALSE;
}
+
+ if (symbol >= UNUM_FORMAT_SYMBOL_COUNT || symbol < 0) {
+ intl_error_set( NULL, U_ILLEGAL_ARGUMENT_ERROR, "numfmt_set_symbol: invalid symbol value", 0 TSRMLS_CC );
+ RETURN_FALSE;
+ }
/* Fetch the object. */
FORMATTER_METHOD_FETCH_OBJECT;

View File

@ -1,112 +0,0 @@
diff -up php5.3-201004081030/configure.in.gnusrc php5.3-201004081030/configure.in
--- php5.3-201004081030/configure.in.gnusrc 2010-03-19 00:36:53.000000000 +0100
+++ php5.3-201004081030/configure.in 2010-04-08 14:32:20.000000000 +0200
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
+
dnl Setting up the PHP version based on the information above.
dnl -------------------------------------------------------------------------
diff -up php5.3-201004081030/ext/interbase/interbase.c.gnusrc php5.3-201004081030/ext/interbase/interbase.c
--- php5.3-201004081030/ext/interbase/interbase.c.gnusrc 2010-01-03 10:36:55.000000000 +0100
+++ php5.3-201004081030/ext/interbase/interbase.c 2010-04-08 14:32:20.000000000 +0200
@@ -24,7 +24,6 @@
#include "config.h"
#endif
-#define _GNU_SOURCE
#include "php.h"
diff -up php5.3-201004081030/ext/pdo_firebird/firebird_driver.c.gnusrc php5.3-201004081030/ext/pdo_firebird/firebird_driver.c
--- php5.3-201004081030/ext/pdo_firebird/firebird_driver.c.gnusrc 2010-01-12 14:36:12.000000000 +0100
+++ php5.3-201004081030/ext/pdo_firebird/firebird_driver.c 2010-04-08 14:32:20.000000000 +0200
@@ -22,7 +22,6 @@
#include "config.h"
#endif
-#define _GNU_SOURCE
#include "php.h"
#ifdef ZEND_ENGINE_2
diff -up php5.3-201004081030/ext/standard/file.c.gnusrc php5.3-201004081030/ext/standard/file.c
--- php5.3-201004081030/ext/standard/file.c.gnusrc 2010-03-19 00:36:53.000000000 +0100
+++ php5.3-201004081030/ext/standard/file.c 2010-04-08 14:32:20.000000000 +0200
@@ -113,9 +113,6 @@ php_file_globals file_globals;
#endif
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
-# ifndef _GNU_SOURCE
-# define _GNU_SOURCE
-# endif
# include <fnmatch.h>
#endif
diff -up php5.3-201004081030/main/php.h.gnusrc php5.3-201004081030/main/php.h
--- php5.3-201004081030/main/php.h.gnusrc 2010-03-12 12:36:33.000000000 +0100
+++ php5.3-201004081030/main/php.h 2010-04-08 14:32:20.000000000 +0200
@@ -30,6 +30,7 @@
#define PHP_HAVE_STREAMS
#define YYDEBUG 0
+#include "php_config.h"
#include "php_version.h"
#include "zend.h"
#include "zend_qsort.h"
diff -up php5.3-201004081030/main/streams/memory.c.gnusrc php5.3-201004081030/main/streams/memory.c
--- php5.3-201004081030/main/streams/memory.c.gnusrc 2010-01-03 10:36:58.000000000 +0100
+++ php5.3-201004081030/main/streams/memory.c 2010-04-08 14:32:20.000000000 +0200
@@ -18,7 +18,6 @@
/* $Id: memory.c 293036 2010-01-03 09:23:27Z sebastian $ */
-#define _GNU_SOURCE
#include "php.h"
PHPAPI int php_url_decode(char *str, int len);
diff -up php5.3-201004081030/Zend/zend_language_parser.c.gnusrc php5.3-201004081030/Zend/zend_language_parser.c
--- php5.3-201004081030/Zend/zend_language_parser.c.gnusrc 2010-04-08 12:41:33.000000000 +0200
+++ php5.3-201004081030/Zend/zend_language_parser.c 2010-04-08 14:32:20.000000000 +0200
@@ -366,6 +366,8 @@
#include "zend_API.h"
#include "zend_constants.h"
+#include <string.h>
+
#define YYERROR_VERBOSE
#define YYSTYPE znode
--- php5.3-201009271630/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2010-09-27 00:34:59.000000000 +0200
+++ php5.3-201009271630/ext/zlib/zlib_fopen_wrapper.c 2010-09-27 19:30:28.542859456 +0200
@@ -19,8 +19,6 @@
/* $Id: zlib_fopen_wrapper.c 303772 2010-09-26 20:46:54Z pajoye $ */
-#define _GNU_SOURCE
-
#include "php.h"
#include "php_zlib.h"
#include "fopen_wrappers.h"
--- php5.3-201011110530/main/streams/cast.c.gnusrc 2010-11-05 20:36:08.000000000 +0100
+++ php5.3-201011110530/main/streams/cast.c 2010-11-11 07:52:00.335566018 +0100
@@ -18,7 +18,6 @@
/* $Id: cast.c 305108 2010-11-05 18:53:48Z cataphract $ */
-#define _GNU_SOURCE
#include "php.h"
#include "php_globals.h"
#include "php_network.h"
--- php5.3-201011270530/main/streams/streams.c.gnusrc 2010-11-15 20:35:42.000000000 +0100
+++ php5.3-201011270530/main/streams/streams.c 2010-11-27 08:26:48.836691759 +0100
@@ -21,7 +21,6 @@
/* $Id: streams.c 305379 2010-11-15 18:22:52Z cataphract $ */
-#define _GNU_SOURCE
#include "php.h"
#include "php_globals.h"
#include "php_network.h"

View File

@ -1,8 +1,8 @@
diff -up php-5.3.5/configure.in.aconf26x php-5.3.5/configure.in
--- php-5.3.5/configure.in.aconf26x 2011-01-07 18:10:08.377183393 +0100
+++ php-5.3.5/configure.in 2011-01-07 18:10:14.204214101 +0100
diff -up php-5.3.6/configure.in.aconf26x php-5.3.6/configure.in
--- php-5.3.6/configure.in.aconf26x 2011-03-17 17:53:52.309552690 +0100
+++ php-5.3.6/configure.in 2011-03-17 17:55:00.223777508 +0100
@@ -1,7 +1,7 @@
## $Id: configure.in 307133 2011-01-05 16:35:33Z johannes $ -*- autoconf -*-
## $Id: configure.in 309329 2011-03-17 07:48:29Z johannes $ -*- autoconf -*-
dnl ## Process this file with autoconf to produce a configure script.
-divert(1)
@ -46,9 +46,9 @@ diff -up php-5.3.5/configure.in.aconf26x php-5.3.5/configure.in
dnl ## In diversion 5 we check which extensions should be compiled.
dnl ## All of these are normally in the extension directories.
diff -up php-5.3.5/ext/standard/config.m4.aconf26x php-5.3.5/ext/standard/config.m4
--- php-5.3.5/ext/standard/config.m4.aconf26x 2010-06-17 12:22:03.000000000 +0200
+++ php-5.3.5/ext/standard/config.m4 2011-01-07 18:09:09.790922608 +0100
diff -up php-5.3.6/ext/standard/config.m4.aconf26x php-5.3.6/ext/standard/config.m4
--- php-5.3.6/ext/standard/config.m4.aconf26x 2010-06-17 12:22:03.000000000 +0200
+++ php-5.3.6/ext/standard/config.m4 2011-03-17 17:52:45.793450887 +0100
@@ -1,6 +1,6 @@
dnl $Id: config.m4 300511 2010-06-17 10:22:03Z pajoye $ -*- autoconf -*-
@ -66,9 +66,9 @@ diff -up php-5.3.5/ext/standard/config.m4.aconf26x php-5.3.5/ext/standard/config
dnl
dnl Check if there is a support means of creating a new process
diff -up php-5.3.5/scripts/phpize.m4.aconf26x php-5.3.5/scripts/phpize.m4
--- php-5.3.5/scripts/phpize.m4.aconf26x 2010-11-02 10:58:08.000000000 +0100
+++ php-5.3.5/scripts/phpize.m4 2011-01-07 18:09:09.791922611 +0100
diff -up php-5.3.6/scripts/phpize.m4.aconf26x php-5.3.6/scripts/phpize.m4
--- php-5.3.6/scripts/phpize.m4.aconf26x 2010-11-02 10:58:08.000000000 +0100
+++ php-5.3.6/scripts/phpize.m4 2011-03-17 17:52:45.793450887 +0100
@@ -1,6 +1,6 @@
dnl This file becomes configure.in for self-contained extensions.

115
php-5.3.6-gnusrc.patch Normal file
View File

@ -0,0 +1,115 @@
diff -up php-5.3.6RC1/configure.in.gnusrc php-5.3.6RC1/configure.in
--- php-5.3.6RC1/configure.in.gnusrc 2011-02-16 21:20:33.000000000 +0100
+++ php-5.3.6RC1/configure.in 2011-02-17 16:25:13.602809269 +0100
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
+
dnl Setting up the PHP version based on the information above.
dnl -------------------------------------------------------------------------
diff -up php-5.3.6RC1/ext/interbase/interbase.c.gnusrc php-5.3.6RC1/ext/interbase/interbase.c
--- php-5.3.6RC1/ext/interbase/interbase.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
+++ php-5.3.6RC1/ext/interbase/interbase.c 2011-02-17 16:25:13.603809213 +0100
@@ -24,7 +24,6 @@
#include "config.h"
#endif
-#define _GNU_SOURCE
#include "php.h"
diff -up php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c
--- php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
+++ php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c 2011-02-17 16:25:13.604809156 +0100
@@ -22,7 +22,6 @@
#include "config.h"
#endif
-#define _GNU_SOURCE
#include "php.h"
#ifdef ZEND_ENGINE_2
diff -up php-5.3.6RC1/ext/standard/file.c.gnusrc php-5.3.6RC1/ext/standard/file.c
--- php-5.3.6RC1/ext/standard/file.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
+++ php-5.3.6RC1/ext/standard/file.c 2011-02-17 16:25:13.605809100 +0100
@@ -113,9 +113,6 @@ php_file_globals file_globals;
#endif
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
-# ifndef _GNU_SOURCE
-# define _GNU_SOURCE
-# endif
# include <fnmatch.h>
#endif
diff -up php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c
--- php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
+++ php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c 2011-02-17 16:26:19.531428121 +0100
@@ -19,8 +19,6 @@
/* $Id: zlib_fopen_wrapper.c 306939 2011-01-01 02:19:59Z felipe $ */
-#define _GNU_SOURCE
-
#include "php.h"
#include "php_zlib.h"
#include "fopen_wrappers.h"
diff -up php-5.3.6RC1/main/php.h.gnusrc php-5.3.6RC1/main/php.h
--- php-5.3.6RC1/main/php.h.gnusrc 2011-01-01 03:19:59.000000000 +0100
+++ php-5.3.6RC1/main/php.h 2011-02-17 16:25:13.606809044 +0100
@@ -30,6 +30,7 @@
#define PHP_HAVE_STREAMS
#define YYDEBUG 0
+#include "php_config.h"
#include "php_version.h"
#include "zend.h"
#include "zend_qsort.h"
diff -up php-5.3.6RC1/main/streams/cast.c.gnusrc php-5.3.6RC1/main/streams/cast.c
--- php-5.3.6RC1/main/streams/cast.c.gnusrc 2011-01-20 07:32:59.000000000 +0100
+++ php-5.3.6RC1/main/streams/cast.c 2011-02-17 16:26:47.495972650 +0100
@@ -18,7 +18,6 @@
/* $Id: cast.c 307611 2011-01-20 06:32:59Z pajoye $ */
-#define _GNU_SOURCE
#include "php.h"
#include "php_globals.h"
#include "php_network.h"
diff -up php-5.3.6RC1/main/streams/memory.c.gnusrc php-5.3.6RC1/main/streams/memory.c
--- php-5.3.6RC1/main/streams/memory.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
+++ php-5.3.6RC1/main/streams/memory.c 2011-02-17 16:25:56.276628691 +0100
@@ -18,7 +18,6 @@
/* $Id: memory.c 306939 2011-01-01 02:19:59Z felipe $ */
-#define _GNU_SOURCE
#include "php.h"
PHPAPI int php_url_decode(char *str, int len);
diff -up php-5.3.6RC1/main/streams/streams.c.gnusrc php-5.3.6RC1/main/streams/streams.c
--- php-5.3.6RC1/main/streams/streams.c.gnusrc 2011-02-01 19:10:35.000000000 +0100
+++ php-5.3.6RC1/main/streams/streams.c 2011-02-17 16:27:06.428980279 +0100
@@ -21,7 +21,6 @@
/* $Id: streams.c 307922 2011-02-01 18:10:35Z cataphract $ */
-#define _GNU_SOURCE
#include "php.h"
#include "php_globals.h"
#include "php_network.h"
diff -up php-5.3.6RC1/Zend/zend_language_parser.c.gnusrc php-5.3.6RC1/Zend/zend_language_parser.c
--- php-5.3.6RC1/Zend/zend_language_parser.c.gnusrc 2011-02-16 21:30:44.000000000 +0100
+++ php-5.3.6RC1/Zend/zend_language_parser.c 2011-02-17 16:25:13.608808931 +0100
@@ -366,6 +366,8 @@
#include "zend_API.h"
#include "zend_constants.h"
+#include <string.h>
+
#define YYERROR_VERBOSE
#define YYSTYPE znode

View File

@ -36,8 +36,8 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.3.5
Release: 6%{?dist}
Version: 5.3.6
Release: 1%{?dist}
License: PHP
Group: Development/Languages
URL: http://www.php.net/
@ -52,14 +52,14 @@ Source6: php-fpm.init
Source7: php-fpm.logrotate
# Build fixes
Patch1: php-5.3.4-gnusrc.patch
Patch1: php-5.3.6-gnusrc.patch
Patch2: php-5.3.0-install.patch
Patch3: php-5.2.4-norpath.patch
Patch4: php-5.3.0-phpize64.patch
Patch5: php-5.2.0-includedir.patch
Patch6: php-5.2.4-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.3.5-aconf26x.patch
Patch8: php-5.3.6-aconf26x.patch
# Fixes for extension modules
Patch20: php-4.3.11-shutdown.patch
@ -72,10 +72,6 @@ Patch42: php-5.3.1-systzdata-v7.patch
# See http://bugs.php.net/53436
Patch43: php-5.3.4-phpize.patch
# Security patch from upstream SVN
# http://svn.php.net/viewvc?view=revision&revision=306154
Patch50: php-5.3.4-cve.patch
# Fixes for tests
Patch61: php-5.0.4-tests-wddx.patch
@ -266,7 +262,7 @@ databases.
%package mysql
Summary: A module for PHP applications that use MySQL databases
Group: Development/Languages
Requires: php-common%{?_isa} = %{version}-%{release}, php-pdo%{?_isa}
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-mysqli, php-mysqli%{?_isa}
Provides: php-pdo_mysql, php-pdo_mysql%{?_isa}
@ -283,7 +279,7 @@ this package and the php package.
%package pgsql
Summary: A PostgreSQL database module for PHP
Group: Development/Languages
Requires: php-common%{?_isa} = %{version}-%{release}, php-pdo
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_pgsql, php-pdo_pgsql%{?_isa}
Obsoletes: mod_php3-pgsql, stronghold-php-pgsql
@ -314,7 +310,7 @@ communication.
%package odbc
Group: Development/Languages
Requires: php-common%{?_isa} = %{version}-%{release}, php-pdo
Requires: php-pdo%{?_isa} = %{version}-%{release}
Summary: A module for PHP applications that use ODBC databases
Provides: php_database
Provides: php-pdo_odbc, php-pdo_odbc%{?_isa}
@ -344,7 +340,7 @@ support to PHP for using the SOAP web services protocol.
Summary: A module for PHP applications that use Interbase/Firebird databases
Group: Development/Languages
BuildRequires: firebird-devel
Requires: php-common%{?_isa} = %{version}-%{release}, php-pdo
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-firebird, php-firebird%{?_isa}
Provides: php-pdo_firebird, php-pdo_firebird%{?_isa}
@ -461,7 +457,7 @@ support for using the tidy library to PHP.
%package mssql
Summary: MSSQL database module for PHP
Group: Development/Languages
Requires: php-common%{?_isa} = %{version}-%{release}, php-pdo
Requires: php-pdo%{?_isa} = %{version}-%{release}
BuildRequires: freetds-devel
Provides: php-pdo_dblib, php-pdo_dblib%{?_isa}
@ -543,8 +539,6 @@ support for using the enchant library to PHP.
%patch42 -p1 -b .systzdata
%patch43 -p0 -b .headers
%patch50 -p4 -b .cve
%patch61 -p1 -b .tests-wddx
# Prevent %%doc confusion over LICENSE files
@ -1049,6 +1043,11 @@ fi
%files enchant -f files.enchant
%changelog
* Thu Mar 17 2011 Remi Collet <Fedora@famillecollet.com> 5.3.6-1
- update to 5.3.6
http://www.php.net/ChangeLog-5.php#5.3.6
- fix php-pdo arch specific requires
* Tue Mar 15 2011 Joe Orton <jorton@redhat.com> - 5.3.5-6
- disable zip extension per "No Bundled Libraries" policy (#551513)

View File

@ -1 +1 @@
8aaf20c95e91f25c5b6a591e5d6d61b9 php-5.3.5.tar.bz2
2286f5a82a6e8397955a0025c1c2ad98 php-5.3.6.tar.bz2