* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 5.3.0-6
- rebuilt with new openssl
This commit is contained in:
parent
c06f75931e
commit
f28264e196
29
php-5.3.0-openssl.patch
Normal file
29
php-5.3.0-openssl.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
diff -up php-5.3.0/ext/openssl/openssl.c.openssl php-5.3.0/ext/openssl/openssl.c
|
||||||
|
--- php-5.3.0/ext/openssl/openssl.c.openssl 2009-04-20 11:44:29.000000000 +0200
|
||||||
|
+++ php-5.3.0/ext/openssl/openssl.c 2009-08-25 18:16:30.000000000 +0200
|
||||||
|
@@ -502,8 +502,13 @@ inline static int php_openssl_safe_mode_
|
||||||
|
static char default_ssl_conf_filename[MAXPATHLEN];
|
||||||
|
|
||||||
|
struct php_x509_request { /* {{{ */
|
||||||
|
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||||
|
+ LHASH_OF(CONF_VALUE) * global_config; /* Global SSL config */
|
||||||
|
+ LHASH_OF(CONF_VALUE) * req_config; /* SSL config for this request */
|
||||||
|
+#else
|
||||||
|
LHASH * global_config; /* Global SSL config */
|
||||||
|
LHASH * req_config; /* SSL config for this request */
|
||||||
|
+#endif
|
||||||
|
const EVP_MD * md_alg;
|
||||||
|
const EVP_MD * digest;
|
||||||
|
char * section_name,
|
||||||
|
@@ -680,7 +685,11 @@ static time_t asn1_time_to_time_t(ASN1_U
|
||||||
|
}
|
||||||
|
/* }}} */
|
||||||
|
|
||||||
|
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||||
|
+static inline int php_openssl_config_check_syntax(const char * section_label, const char * config_filename, const char * section, LHASH_OF(CONF_VALUE) * config TSRMLS_DC) /* {{{ */
|
||||||
|
+#else
|
||||||
|
static inline int php_openssl_config_check_syntax(const char * section_label, const char * config_filename, const char * section, LHASH * config TSRMLS_DC) /* {{{ */
|
||||||
|
+#endif
|
||||||
|
{
|
||||||
|
X509V3_CTX ctx;
|
||||||
|
|
4
php.spec
4
php.spec
@ -31,6 +31,7 @@ Patch4: php-5.3.0-phpize64.patch
|
|||||||
Patch5: php-5.2.0-includedir.patch
|
Patch5: php-5.2.0-includedir.patch
|
||||||
Patch6: php-5.2.4-embed.patch
|
Patch6: php-5.2.4-embed.patch
|
||||||
Patch7: php-5.3.0-recode.patch
|
Patch7: php-5.3.0-recode.patch
|
||||||
|
Patch8: php-5.3.0-openssl.patch
|
||||||
|
|
||||||
# Fixes for extension modules
|
# Fixes for extension modules
|
||||||
Patch20: php-4.3.11-shutdown.patch
|
Patch20: php-4.3.11-shutdown.patch
|
||||||
@ -425,6 +426,7 @@ support for using the enchant library to PHP.
|
|||||||
%patch5 -p1 -b .includedir
|
%patch5 -p1 -b .includedir
|
||||||
%patch6 -p1 -b .embed
|
%patch6 -p1 -b .embed
|
||||||
%patch7 -p1 -b .recode
|
%patch7 -p1 -b .recode
|
||||||
|
%patch8 -p1 -b .openssl
|
||||||
|
|
||||||
%patch20 -p1 -b .shutdown
|
%patch20 -p1 -b .shutdown
|
||||||
%patch21 -p1 -b .macropen
|
%patch21 -p1 -b .macropen
|
||||||
@ -843,7 +845,7 @@ rm files.* macros.php
|
|||||||
%files enchant -f files.enchant
|
%files enchant -f files.enchant
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 5.3.0-6
|
* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 5.3.0-6
|
||||||
- rebuilt with new openssl
|
- rebuilt with new openssl
|
||||||
|
|
||||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-5
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-5
|
||||||
|
Loading…
Reference in New Issue
Block a user