diff --git a/.cvsignore b/.cvsignore
index 30407f6..75b032d 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1,9 +1 @@
-php-4.2.2.tar.gz
-php_manual_de.tar.bz2
-php_manual_en.tar.bz2
-php_manual_es.tar.bz2
-php_manual_fr.tar.bz2
-php_manual_it.tar.bz2
-php_manual_ja.tar.bz2
-php_manual_ko.tar.bz2
-php_manual_pt_BR.tar.bz2
+php-4.3.3.tar.bz2
diff --git a/php-4.3.1-odbc.patch b/php-4.3.1-odbc.patch
new file mode 100644
index 0000000..4480c3a
--- /dev/null
+++ b/php-4.3.1-odbc.patch
@@ -0,0 +1,14 @@
+
+Make sure odbc.so is linked against -lodbc etc.
+
+--- php-4.3.1/ext/odbc/config.m4.odbc 2002-11-12 17:31:39.000000000 +0000
++++ php-4.3.1/ext/odbc/config.m4 2003-05-16 09:54:22.000000000 +0100
+@@ -429,6 +429,8 @@
+ ODBC_TYPE=unixODBC
+ AC_DEFINE(HAVE_UNIXODBC,1,[ ])
+ AC_MSG_RESULT(yes)
++ ODBC_SHARED_LIBADD="-lodbc -lodbcpsql"
++ PHP_SUBST(ODBC_SHARED_LIBADD)
+ else
+ AC_MSG_RESULT(no)
+ fi
diff --git a/php-4.3.3-install.patch b/php-4.3.3-install.patch
new file mode 100644
index 0000000..93115cf
--- /dev/null
+++ b/php-4.3.3-install.patch
@@ -0,0 +1,11 @@
+--- php-4.3.3/sapi/apache2handler/config.m4.install
++++ php-4.3.3/sapi/apache2handler/config.m4
+@@ -59,7 +59,7 @@
+ fi
+
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+- if test -z `$APXS -q SYSCONFDIR`; then
++ if true; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -i -n php4"
diff --git a/php.conf b/php.conf
index ff04976..3816bc9 100644
--- a/php.conf
+++ b/php.conf
@@ -6,13 +6,9 @@
LoadModule php4_module modules/libphp4.so
#
-# Cause the PHP interpreter handle files with a .php extension.
+# Cause the PHP interpreter to handle files with a .php extension.
#
-
- SetOutputFilter PHP
- SetInputFilter PHP
- LimitRequestBody 524288
-
+AddType application/x-httpd-php .php
#
# Add index.php to the list of files that will be served as directory
diff --git a/php.spec b/php.spec
index 548ef29..8e41b4a 100644
--- a/php.spec
+++ b/php.spec
@@ -1,65 +1,49 @@
%define contentdir /var/www
-%define manual_langs de en es fr it ja ko pt_BR
-# For those wanting to recompile with Oracle libraries
-# rpm --rebuild --define 'oracle 1' php4.2.1-x.src.rpm
-#
+# "rpm --define 'oracle 1' ..." to enable Oracle support
%{!?oracle:%define oracle 0}
+# "rpmbuild --define 'mssql 1' ..." to enable mssql support
+%{!?mssql:%define mssql 0}
+
Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
Name: php
-Version: 4.2.2
-Release: 17.2
+Version: 4.3.3
+Release: 6
License: The PHP License
Group: Development/Languages
URL: http://www.php.net/
-Source0: http://www.php.net/distributions/php-%{version}.tar.gz
-Source1: http://www.php.net/distributions/manual/php_manual_de.tar.bz2
-Source2: http://www.php.net/distributions/manual/php_manual_en.tar.bz2
-Source3: http://www.php.net/distributions/manual/php_manual_es.tar.bz2
-Source4: http://www.php.net/distributions/manual/php_manual_fr.tar.bz2
-Source5: http://www.php.net/distributions/manual/php_manual_it.tar.bz2
-Source6: http://www.php.net/distributions/manual/php_manual_ja.tar.bz2
-Source7: http://www.php.net/distributions/manual/php_manual_ko.tar.bz2
-Source8: http://www.php.net/distributions/manual/php_manual_pt_BR.tar.bz2
+Source0: http://www.php.net/distributions/php-%{version}.tar.bz2
Source50: php.conf
-# Patch to get around a dumb assumption that size_t is always 4 bytes
-Patch0: php-4.2.1-64bit-iconv.patch
Patch1: php-4.2.1-ldap-TSRM.patch
-Patch2: php-4.2.1-php.ini-dist.patch
-# use -DUCD_COMPATIBLE to make net-snmp backwards-compatible
-Patch3: php-4.2.1-snmp.patch
-# Fix for #67853
-Patch4: php-4.2.2-cookies.patch
-Patch5: php-4.2.2-apache2.patch
-Patch6: php-4.1.2-missing-vars.patch
-Patch9: php-4.2.2-lib64.patch
-Patch10: php-4.2.2-inidir.patch
-Patch11: php-4.2.2-openssl097.patch
-Patch12: php-4.2.2-snmp.patch
-Patch13: php-4.2.2-sockets.patch
-Patch14: php-4.2.2-exit.patch
-Patch15: php-4.2.2-pgsql.patch
+Patch2: php-4.3.1-config.patch
+Patch3: php-4.2.2-lib64.patch
+Patch4: php-4.2.2-cxx.patch
+Patch5: php-4.3.3-install.patch
+Patch6: php-4.3.1-tests.patch
+Patch7: php-4.3.2-libtool15.patch
+Patch8: php-4.3.3-miscfix.patch
-# Security fixes
-Patch30: php-4.2.2-mailsec.patch
-Patch31: php-4.2.2-wrap.patch
-Patch32: php-4.2.2-sessid.patch
+# Fixes for extension modules
+Patch20: php-4.2.2-apache2.patch
+Patch21: php-4.3.1-odbc.patch
+Patch22: php-4.3.2-db4.patch
+
+# Functional changes
+Patch30: php-4.3.1-dlopen.patch
-# Where are we going to build the install set to?
-#
BuildRoot: %{_tmppath}/%{name}-root
BuildRequires: bzip2-devel, curl-devel >= 7.9, db4-devel, expat-devel, freetype-devel
-BuildRequires: gd-devel >= 1.8.4, gdbm-devel, gmp-devel, pspell-devel
-BuildRequires: httpd-devel >= 2.0.40-6, libjpeg-devel, libpng-devel, pam-devel
-BuildRequires: libstdc++-devel, libxml2-devel, ncurses-devel, openssl-devel
-BuildRequires: zlib-devel
-BuildRequires: bzip2, fileutils, perl
-Obsoletes: php-dbg, mod_php, php3, phpfi
+BuildRequires: gd-devel >= 1.8.4, gdbm-devel, gmp-devel, aspell-devel >= 0.50.0
+BuildRequires: httpd-devel >= 2.0.46-1, libjpeg-devel, libpng-devel, pam-devel
+BuildRequires: libstdc++-devel, ncurses-devel, openssl-devel
+BuildRequires: zlib-devel, pcre-devel
+BuildRequires: bzip2, fileutils, perl, libtool >= 1.4.3
+Obsoletes: php-dbg, mod_php, php3, phpfi, php-manual
# Enforce Apache module ABI compatibility
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
@@ -113,17 +97,6 @@ services over the Internet. PHP is an HTML-embedded scripting
language. If you need LDAP support for PHP applications, you will
need to install this package in addition to the php package.
-%package manual
-Obsoletes: mod_php3-manual
-Group: Documentation
-Summary: The PHP manual, in HTML format.
-Requires: php = %{version}-%{release}
-
-%description manual
-The php-manual package provides comprehensive documentation for the
-PHP HTML-embedded scripting language, in HTML format. PHP is an
-HTML-embedded scripting language.
-
%package mysql
Summary: A module for PHP applications that use MySQL databases.
Group: Development/Languages
@@ -184,11 +157,25 @@ The php-oci8 package contains a dynamic shared object that will add
support for accessing OCI8 databases to PHP.
%endif
+%if %{mssql}
+%package mssql
+Group: Development/Languages
+Requires: php = %{version}-%{release}, freetds
+Summary: A module for PHP applications that use MSSQL databases.
+Provides: php_database
+BuildRequires: freetds-devel
+
+%description mssql
+The mssql package contains a dynamic shared object that will add
+support for accessing MSSQL databases to PHP.
+%endif
+
%package snmp
Summary: A module for PHP applications that query SNMP-managed devices.
Group: Development/Languages
Requires: php = %{version}-%{release}
-BuildRequires: net-snmp-devel
+BuildRequires: net-snmp-devel, elfutils-devel
+# elfutils-devel requirement workaround for #103982
%description snmp
The php-snmp package contains a dynamic shared object that will add
@@ -196,27 +183,42 @@ support for querying SNMP devices to PHP. PHP is an HTML-embeddable
scripting language. If you need SNMP support for PHP applications, you
will need to install this package and the php package.
+%package domxml
+Summary: A module for PHP applications which manipulate XML data
+Group: Development/Languages
+Requires: php = %{version}-%{release}
+BuildRequires: libxslt-devel >= 1.0.18-1, libxml2-devel >= 2.4.14-1
+
+%description domxml
+The php-domxml package contains a dynamic shared object that will add
+support for manipulating XML data as a DOM tree to PHP.
+
+%package xmlrpc
+Summary: A module for PHP applications which use the XML-RPC protocol
+Group: Development/Languages
+Requires: php = %{version}-%{release}
+BuildRequires: expat-devel
+
+%description xmlrpc
+The php-xmlrpc package contains a dynamic shared object that will add
+support for the XML-RPC protocol to PHP.
+
%prep
%setup -q
-%patch0 -p1
%patch1 -p1
-%patch2 -p1 -b .conf
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1 -b .apache2
-%patch6 -p1
-%patch9 -p1 -b .lib64
-%patch10 -p1 -b .inidir
-%patch11 -p1 -b .ossl097
-%patch12 -p1 -b .snmp
-%patch13 -p1 -b .sockets
-%patch14 -p1 -b .exit
-%patch15 -p1 -b .pgsql
+%patch2 -p1 -b .config
+%patch3 -p1 -b .lib64
+%patch4 -p1 -b .cxx
+%patch5 -p1 -b .install
+%patch6 -p1 -b .tests
+%patch7 -p1 -b .libtool15
+%patch8 -p1 -b .miscfix
-# Security fixes
-%patch30 -p1 -b .mailsec
-%patch31 -p1 -b .wrap
-%patch32 -p1 -b .sessid
+## %patch20 -p1 -b .ap2
+%patch21 -p1 -b .odbc
+%patch22 -p1 -b .db4
+
+%patch30 -p1 -b .dlopen
# Prevent %doc confusion over LICENSE & Zend/LICENSE
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -225,19 +227,26 @@ cp Zend/LICENSE Zend/ZEND_LICENSE
mkdir build-cgi build-apache
# Use correct libdir
-perl -pi -e 's|\$\(prefix\)/lib|%{_libdir}|' pear/Makefile.in
perl -pi -e 's|%{_prefix}/lib|%{_libdir}|' php.ini-dist
+# Remove bogus test; position of read position after fopen(, "a+")
+# is not defined by C standard, so don't presume anything.
+rm -f ext/standard/tests/file/bug21131.phpt
+
+# Tests that fail.
+rm -f ext/standard/tests/file/bug22414.phpt \
+ ext/session/tests/019.phpt \
+ ext/standard/tests/math/pow.phpt \
+ ext/standard/tests/math/round.phpt \
+ ext/standard/tests/math/abs.phpt \
+ ext/iconv/tests/bug16069.phpt
+
%build
CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
-# Add the Kerberos library path to the default LDFLAGS so that the IMAP checks
-# will be able to find the GSSAPI libraries.
-LDFLAGS="-L/usr/kerberos/%{_lib}"; export LDFLAGS
-
# Configure may or may not catch these (mostly second-order) dependencies.
-LIBS="-lttf -lfreetype -lpng -ljpeg -lz -lnsl"; export LIBS
+LIBS="-lfreetype -lpng -ljpeg -lz -lnsl"; export LIBS
# Install extension modules in %{_libdir}/php4.
EXTENSION_DIR=%{_libdir}/php4; export EXTENSION_DIR
@@ -245,16 +254,23 @@ EXTENSION_DIR=%{_libdir}/php4; export EXTENSION_DIR
# This pulls the static /usr/lib/libc-client.a into the IMAP extension module.
IMAP_SHARED_LIBADD=-lc-client ; export IMAP_SHARED_LIBADD
+if pkg-config openssl; then
+ CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
+ LIBS="$LIBS `pkg-config --libs openssl`"
+fi
+
# pull latest ltmain.sh, AC_PROG_LIBTOOL
libtoolize --force --copy
# force aclocal run during buildconf
touch acinclude.m4
# Regenerate configure scripts (patches change config.m4's)
-./buildconf
+./buildconf --force
# Shell function to configure and build a PHP tree.
build() {
+# bison-1.875-2 seems to produce a broken parser; workaround.
+mkdir Zend && cp ../Zend/zend_{language,ini}_parser.[ch] Zend
ln -sf ../configure
%configure \
--cache-file=../config.cache \
@@ -266,15 +282,13 @@ ln -sf ../configure
--disable-rpath \
--enable-inline-optimization \
--with-bz2 \
- --with-db3 \
+ --with-db4=%{_prefix} \
--with-curl \
- --with-dom=%{_prefix} \
--with-exec-dir=%{_bindir} \
--with-freetype-dir=%{_prefix} \
--with-png-dir=%{_prefix} \
--with-gd \
--enable-gd-native-ttf \
- --with-ttf \
--with-gdbm \
--with-gettext \
--with-ncurses \
@@ -287,6 +301,10 @@ ln -sf ../configure
--with-regex=system \
--with-xml \
--with-expat-dir=%{_prefix} \
+ --with-dom=shared,%{_prefix} \
+ --with-dom-xslt=%{_prefix} --with-dom-exslt=%{_prefix} \
+ --with-xmlrpc=shared \
+ --with-pcre=%{_prefix} \
--with-zlib \
--with-layout=GNU \
--enable-bcmath \
@@ -306,11 +324,14 @@ ln -sf ../configure
--with-pear=/usr/share/pear \
--with-imap=shared \
--with-imap-ssl \
- --with-kerberos=/usr/kerberos \
+ --with-kerberos \
--with-ldap=shared \
--with-mysql=shared,%{_prefix} \
%if %{oracle}
--with-oci8=shared \
+%endif
+%if %{mssql}
+ --with-mssql=shared \
%endif
--with-pgsql=shared \
--with-snmp=shared,%{_prefix} \
@@ -320,25 +341,22 @@ ln -sf ../configure
--enable-memory-limit \
--enable-bcmath \
--enable-shmop \
- --enable-versioning \
--enable-calendar \
--enable-dbx \
--enable-dio \
--enable-mcal \
+ --enable-mbstring --enable-mbstr-enc-trans \
+ --enable-mbregex \
$*
-# Fixup the config_vars to not include the '-a' on lines which call apxs.
-# FIXME: redundant with INSTALL_IT setting below?
-cat config_vars.mk > config_vars.mk.old
-awk '/^INSTALL_IT.*apxs.*-a -n/ {sub("-a -n ","-n ");} {print $0;}' \
- config_vars.mk.old > config_vars.mk
-
make %{?_smp_mflags}
}
# Build standalone /usr/bin/php
pushd build-cgi
build --enable-force-cgi-redirect
+NO_INTERACTION=1 REPORT_EXIT_STATUS=1 \
+make test || true
popd
# Build Apache module
@@ -354,11 +372,9 @@ pushd build-cgi
make install INSTALL_ROOT=$RPM_BUILD_ROOT
popd
-### TODO: only configure shared modules for the one of the two builds
-# Install the Apache tree, overwriting the shared modules from before.
-# INSTALL_IT=echo prevents "apxs -a -i" from trying to modify httpd.conf
+# Install the Apache module
pushd build-apache
-make install INSTALL_ROOT=$RPM_BUILD_ROOT INSTALL_IT="echo "
+make install-sapi INSTALL_ROOT=$RPM_BUILD_ROOT
popd
# Install the default configuration file and icons
@@ -375,27 +391,10 @@ install -m 755 build-apache/libs/libphp4.so $RPM_BUILD_ROOT%{_libdir}/httpd/modu
install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf.d
install -m 644 $RPM_SOURCE_DIR/php.conf $RPM_BUILD_ROOT/etc/httpd/conf.d
-# Manuals -- we'll place English (en) in the location where the only version
-# of the manual was before, and langify the rest.
-# Hence we don't specify %lang(en) in the files section for the manual rpm
-#
-for lang in %{manual_langs} ; do
- if test x${lang} = xen ; then
- target_lang=""
- else
- target_lang=${lang}
- fi
- mkdir -p $RPM_BUILD_ROOT%{contentdir}/manual/mod/mod_php4/${target_lang}
- bzip2 -dc $RPM_SOURCE_DIR/php_manual_${lang}.tar.bz2 | tar -x -C $RPM_BUILD_ROOT%{contentdir}/manual/mod/mod_php4/${target_lang} -f -
-done
-
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php.d
-%if %{oracle}
-ocimod=oci8
-%endif
# Generate files lists and stub .ini files for each subpackage
-for mod in pgsql mysql odbc imap ldap snmp ${ocimod}; do
+for mod in pgsql mysql odbc imap ldap snmp domxml xmlrpc %{!?oracle:oci8} %{!?mssql:mssql}; do
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${mod}.ini < 4.2.2-17.2
-- fix to apply CAN-2003-0442 patch
+%files domxml -f files.domxml
-* Wed Jun 11 2003 Joe Orton 4.2.2-17.1
-- add bug fixes for #82967, #84460, #84828, #85820, #91019, #91279
-- add security fix for CAN-2003-0442
+%files xmlrpc -f files.xmlrpc
+
+%changelog
+* Mon Oct 20 2003 Joe Orton 4.3.3-6
+- use bundled libgd (#107407)
+- remove manual: up-to-date manual sources are no longer DFSG-free;
+ it's too big; it's on the web anyway; #91292, #105804, #107384
+
+* Wed Oct 15 2003 Joe Orton 4.3.3-5
+- add php-xmlrpc subpackage (#107138)
+
+* Mon Oct 13 2003 Joe Orton 4.3.3-4
+- drop recode support, symbols collide with MySQL
+
+* Sun Oct 12 2003 Joe Orton 4.3.3-3
+- split domxml extension into php-domxml subpackage
+- enable xslt and xml support in domxml extension (#106042)
+- fix httpd-devel build requirement (#104341)
+- enable recode extension (#106755)
+- add workaround for #103982
+
+* Sun Sep 7 2003 Joe Orton 4.3.3-2
+- don't use --enable-versioning, it depends on libtool being
+ broken (#103690)
+
+* Sun Sep 7 2003 Joe Orton 4.3.3-1
+- update to 4.3.3
+- add libtool build prereq (#103388)
+- switch to apache2handler
+
+* Mon Jul 28 2003 Joe Orton 4.3.2-8
+- rebuild
+
+* Tue Jul 22 2003 Nalin Dahyabhai 4.3.2-7
+- rebuild
+
+* Tue Jul 8 2003 Joe Orton 4.3.2-6
+- use system pcre library
+
+* Mon Jun 9 2003 Joe Orton 4.3.2-5
+- enable mbstring and mbregex (#81336)
+- fix use of libtool 1.5
+
+* Wed Jun 04 2003 Elliot Lee
+- rebuilt
+
+* Tue Jun 3 2003 Joe Orton 4.3.2-3
+- add lib64 and domxml fixes
+
+* Tue Jun 3 2003 Frank Dauer
+- added conditional support for mssql module (#92149)
+
+* Fri May 30 2003 Joe Orton 4.3.2-2
+- update the -tests and -lib64 patches
+- fixes for db4 detection
+- require aspell-devel >= 0.50.0 for pspell compatibility
+
+* Thu May 29 2003 Joe Orton 4.3.2-1
+- update to 4.3.2
+
+* Fri May 16 2003 Joe Orton 4.3.1-3
+- link odbc module correctly
+- patch so that php -n doesn't scan inidir
+- run tests using php -n, avoid loading system modules
+
+* Wed May 14 2003 Joe Orton 4.3.1-2
+- workaround broken parser produced by bison-1.875
+
+* Tue May 6 2003 Joe Orton 4.3.1-1
+- update to 4.3.1; run test suite
+- open extension modules with RTLD_NOW rather than _LAZY
+
+* Tue May 6 2003 Joe Orton 4.2.2-19
+- patch for gd 2.x API changes in gd extension
+
+* Thu May 1 2003 Joe Orton 4.2.2-18
+- rebuild to use aspell (#89925)
+- patch to work round conditional AC_PROG_CXX break in autoconf 2.57
+- fix dba build against db >= 4.1
* Mon Feb 24 2003 Joe Orton 4.2.2-17
- restrict SNMP patch to minimal changes, fixing segv on startup (#84607)
@@ -645,444 +714,3 @@ rm files.*
- Minor patch to get around a 64 bitism
- Added in the dgb debugging hooks
-===============================================================================
- Ditched the 4.1.1 sources for 4.2.1
-===============================================================================
-
-* Sun Apr 14 2002 Philip Copeland 4.1.2-6
-- %post for mysql has zlib in it?!? Bad cut/paste. Fixed.
-- Added missing trigger entries to php.ini-dist
-- Bumped release number.
-
-* Sat Apr 13 2002 Philip Copeland 4.1.2-6
-- Oh joyous. buildconf doesn't correctly rebuild a
- configure script, consequently we get lex checking errors
- Strictly speaking this is autoconf's fault. Tweeked.
-
-* Sun Apr 07 2002 Philip Copeland 4.1.2-6
-- Added in hook for the rather useful dbg addin
- http://dd.cron.ru/dbg/
- May not be able to provide a dbg rpm accomplyment
- to php for the official release but at least it'll
- make it easy to drop in at a later date.
-
-* Mon Mar 25 2002 Philip Copeland 4.1.2-5
-- Accepted patches from Konstantin Riabitsev
- for the php.ini file which fix this damnable .dll/.so
- mess.
-- Fixes for the modules. Every dll name is now prepended by php_,
- so the modules were NEVER enabled. Also, there is no longer
- php_mysql.dll or php_odbc.dll. Added workarounds for that.
-- Jumped a number (-4) because of intresting after effects
- in the build system.
-
-* Tue Mar 12 2002 Philip Copeland 4.1.2-3
-- Fix for crashing bug (#60855)
-
-* Tue Mar 05 2002 Philip Copeland 4.1.2-2
-- Forgot the -with-png-dir=%{_prefix} config
- option (#55248)
-
-* Mon Mar 04 2002 Philip Copeland 4.1.2-2
-- Minor patch for figuring out where the blasted
- mysql.sock named socket lives. (grumble)
-- Added in --enable-exif. It's there for people who
- asked for it but I ain't supporting it if it
- breaks.
-- Tweak the default php.ini file to turn off file upload by default
- and to tweak the default path for loadable modules
-
-* Thu Feb 28 2002 Philip Copeland 4.1.2-1
-- Jumped to 4.1.2 for security...
-
-* Wed Feb 13 2002 Philip Copeland 4.1.1-4
-- Added multibyte input/ouput support
- --enable-mbstring
- --enable-mbstr-enc-trans
-- Added in a couple of BuildReq's
-- Because db1,2,3 are ditched in the next RHAT release and only
- db4 exists, I've purposly NOT put in the db4-devel BuildReq
- as thers no way to differentiate this build for a 7.X and
- the new release.
-
-* Fri Feb 08 2002 Philip Copeland 4.1.1-3
-- Added calendar, dbx, dio and mcal support into the build
- --enable-calendar
- --enable-dbx
- --enable-dio
- --enable-mcal
-
-* Thu Feb 07 2002 Philip Copeland 4.1.1-2
-- Reformatted the spec file to be something more pretty to read
-- Some wassak upstream changed the default php.ini file to
- winblows format (.dll) which broke the extension munching
- altered the post scripts to accomodate (#59195)
-- Added in --enable-gd-native-ttf (#55199)
-
-* Mon Jan 29 2002 Philip Copeland 4.1.1-1
-- Added in patch for DOM(xml)
-
-* Mon Jan 28 2002 Philip Copeland 4.1.1-0
-- Rather than write a new spec file, borrowed the one from 4.0.6-13
- Initial build of 4.1.1 (note db2 is now obsoleted)
- Added --enable-memory-limit
-
-===============================================================================
- Ditched the 4.0.x sources for 4.1.1
-===============================================================================
-
-* Wed Dec 5 2001 Philip Copeland 4.0.6-13
-- Minor tweak to the configure script to allow it to search fo the libxml
- installation in both */include/libxml/tree.h and
- include/libxml2/libxml/tree.h
-
-* Tue Nov 20 2001 Nalin Dahyabhai 4.0.6-12
-- rebuild for Raw Hide, building snmp again
-
-* Tue Nov 20 2001 Nalin Dahyabhai 4.0.6-11
-- don't build the snmp module
-- don't activate the module for Apache when we install it into the buildroot
-
-* Mon Nov 19 2001 Nalin Dahyabhai
-- link the IMAP module with c-client.a
-
-* Fri Nov 16 2001 Nalin Dahyabhai 4.0.6-10
-- use shared expat for XML support, add buildprereq on expat-devel
-- update to latest manuals from the web site
-- %{_datadir}/php -> %{_datadir}/pear
-- miscellaneous cleanups
-
-* Tue Nov 13 2001 Nalin Dahyabhai
-- remove explicit dependency on krb5-libs
-
-* Fri Nov 9 2001 Nalin Dahyabhai
-- enable transparent session id support, configure freetype and gmp extensions
- (suggestion and patch Jason Costomiris)
-
-* Mon Sep 17 2001 Tim Powers 4.0.6-9
-- rebuilt against newer posgresql libs
-
-* Wed Sep 12 2001 Tim Powers
-- rebuild with new gcc and binutils
-
-* Mon Aug 27 2001 Nalin Dahyabhai
-- add patch from pzb at scyld.com to fix the ZVAL_TRUE and ZVAL_FALSE macros
- (#52501)
-
-* Fri Aug 17 2001 Nalin Dahyabhai
-- enable bzip2 extension
-- enable curl extension
-- enable use of mm
-- clean up use of libtool (#51958)
-
-* Fri Aug 10 2001 Tim Powers
-- only english in php-manuals, space constraints
-
-* Thu Aug 9 2001 Nalin Dahyabhai
-- include %{_libdir}/%{name}/build instead of %{_libdir}/%{name}4/build (#51141)
-
-* Mon Aug 6 2001 Nalin Dahyabhai
-- add build deps on pam-devel, pspell-devel, gdbm-devel (#49878)
-- add some conditional logic if %%{oracle} is defined (from Antony Nguyen)
-
-* Mon Jul 9 2001 Nalin Dahyabhai
-- don't obsolete subpackages we ended up not merging
-
-* Mon Jul 2 2001 Nalin Dahyabhai
-- cleanups
-- add manuals in multiple languages (using ko instead of kr for Korean)
-- merge all of the manuals into a single -manual subpackage
-- use libtool to install binary files which libtool builds
-- don't strip any binaries; let the buildroot policies take care of it
-
-* Thu Jun 28 2001 Nalin Dahyabhai
-- update to 4.0.6 (preliminary)
-
-* Mon Jun 25 2001 Nalin Dahyabhai
-- enable ttf in the build because the gd support needs it
-- add -lfreetype to the LIBS for the same reason
-
-* Wed Jun 6 2001 Nalin Dahyabhai
-- rebuild in new environment
-
-* Wed May 16 2001 Nalin Dahyabhai
-- actually use two source trees to build things
-- add %%post and %%postun scriptlets to run ldconfig
-
-* Tue May 15 2001 Nalin Dahyabhai
-- quote part of the AC_ADD_LIBRARY macro to make newer autoconf happy
-
-* Mon May 14 2001 Nalin Dahyabhai
-- fix error in %%install
-- depend on the imap-devel which supplies linkage.c
-- modify trigger to disable php versions less than 4.0.0 instead of 3.0.15
-- enable DOM support via libxml2 (suggested by Sylvain Bergé)
-- build the OpenSSL extension again
-
-* Mon May 7 2001 Nalin Dahyabhai
-- enable pspell extensions
-- update to 4.0.5
-
-* Mon Apr 30 2001 Nalin Dahyabhai
-- build the ODBC extension
-
-* Mon Apr 30 2001 Bill Nottingham
-- build on ia64
-
-* Fri Mar 2 2001 Nalin Dahyabhai
-- rebuild in new environment
-
-* Fri Feb 23 2001 Nalin Dahyabhai
-- obsolete the old phpfi (PHP 2.x) package
-
-* Thu Feb 8 2001 Nalin Dahyabhai
-- add a commented-out curl extension to the config file (part of #24933)
-- fix the PEAR-installation-directory-not-being-eval'ed problem (#24938)
-- find the right starting point for multipart form data (#24933)
-
-* Tue Jan 30 2001 Nalin Dahyabhai
-- aaarrgh, the fix breaks something else, aaarrgh; revert it (#24933)
-- terminate variable names at the right place (#24933)
-
-* Sat Jan 20 2001 Nalin Dahyabhai
-- tweak the fix some more
-
-* Thu Jan 18 2001 Nalin Dahyabhai
-- extract stas's fix for quoting problems from CVS for testing
-- tweak the fix, ask the PHP folks about the tweak
-- tweak the fix some more
-
-* Wed Jan 17 2001 Nalin Dahyabhai
-- merge mod_php into the main php package (#22906)
-
-* Fri Dec 29 2000 Nalin Dahyabhai
-- try to fix a quoting problem
-
-* Wed Dec 20 2000 Nalin Dahyabhai
-- update to 4.0.4 to get a raft of bug fixes
-- enable sockets
-- enable wddx
-
-* Fri Nov 3 2000 Nalin Dahyabhai
-- rebuild in updated environment
-
-* Thu Nov 2 2000 Nalin Dahyabhai
-- add more commented-out modules to the default config file (#19276)
-
-* Wed Nov 1 2000 Nalin Dahyabhai
-- fix not-using-gd problem (#20137)
-
-* Tue Oct 17 2000 Nalin Dahyabhai
-- update to 4.0.3pl1 to get some bug fixes
-
-* Sat Oct 14 2000 Nalin Dahyabhai
-- build for errata
-
-* Wed Oct 11 2000 Nalin Dahyabhai
-- update to 4.0.3 to get security fixes integrated
-- patch around problems configuring without Oracle support
-- add TSRM to include path when building individual modules
-
-* Fri Sep 8 2000 Nalin Dahyabhai
-- rebuild in new environment
-- enable OpenSSL support
-
-* Wed Sep 6 2000 Nalin Dahyabhai
-- update to 4.0.2, and move the peardir settings to configure (#17171)
-- require %%{version}-%%{release} for subpackages
-- add db2-devel and db3-devel prereqs (#17168)
-
-* Wed Aug 23 2000 Nalin Dahyabhai
-- rebuild in new environment (new imap-devel)
-
-* Wed Aug 16 2000 Nalin Dahyabhai
-- fix summary and descriptions to match the specspo package
-
-* Wed Aug 9 2000 Nalin Dahyabhai
-- hard-code the path to apxs in build_ext() (#15799)
-
-* Tue Aug 1 2000 Nalin Dahyabhai
-- add "." to the include path again, which is the default
-
-* Wed Jul 19 2000 Nalin Dahyabhai
-- enable PEAR and add it to the include path
-- add the beginnings of a -devel subpackage
-
-* Wed Jul 12 2000 Prospector
-- automatic rebuild
-
-* Fri Jul 7 2000 Nalin Dahyabhai
-- tweaks to post and postun from Bill Peck
-
-* Thu Jul 6 2000 Nalin Dahyabhai
-- fixes from Nils for building the MySQL client
-- change back to requiring %{version} instead of %{version}-%{release}
-
-* Sat Jul 1 2000 Nalin Dahyabhai
-- update to 4.0.1pl2
-- enable MySQL client
-- move the php.ini file to %{_sysconfdir}
-
-* Fri Jun 30 2000 Nils Philippsen
-- build_ext defines HAVE_PGSQL so pgsql.so in fact contains symbols
-- post/un scripts tweak php.ini correctly now
-
-* Thu Jun 28 2000 Nalin Dahyabhai
-- update to 4.0.1
-- refresh manual
-
-* Tue Jun 26 2000 Nalin Dahyabhai
-- rebuild against new krb5 package
-
-* Mon Jun 19 2000 Nalin Dahyabhai
-- rebuild against new db3 package
-
-* Sat Jun 17 2000 Nalin Dahyabhai
-- Fix syntax error in post and preun scripts.
-- Disable IMAP, LDAP, PgSql in the standalone version because it picks up
- the extensions.
-
-* Fri Jun 16 2000 Nalin Dahyabhai
-- Unexclude the Sparc arch.
-- Exclude the ia64 arch until we get a working Postgres build.
-- Stop stripping extensions as aggressively.
-- Start linking the IMAP module to libpam again.
-- Work around extension loading problems.
-- Reintroduce file-editing post and preun scripts for the mod_php extensions
- until we come up with a better way to do it.
-
-* Mon Jun 5 2000 Nalin Dahyabhai
-- ExcludeArch: sparc for now
-
-* Sun Jun 4 2000 Nalin Dahyabhai
-- add Obsoletes: phpfi, because their content handler names are the same
-- add standalone binary, rename module packages to mod_php
-- FHS fixes
-
-* Tue May 23 2000 Nalin Dahyabhai
-- change license from "GPL" to "PHP"
-- add URL: tag
-- disable mysql support by default (license not specified)
-
-* Mon May 22 2000 Nalin Dahyabhai
-- update to PHP 4.0.0
-- nuke the -mysql subpackage (php comes with a bundled mysql client lib now)
-
-* Tue May 16 2000 Nalin Dahyabhai
-- link IMAP module against GSS-API and PAM to get dependencies right
-- change most of the Requires to Prereqs, because the post edits config files
-- move the PHP *Apache* module back to the right directory
-- fix broken postun trigger that broke the post
-- change most of the postuns to preuns in case php gets removed before subpkgs
-
-* Thu May 11 2000 Trond Eivind Glomsrĝd
-- rebuilt against new postgres libraries
-
-* Tue May 09 2000 Preston Brown
-- php3 .so modules moved to /usr/lib/php3 from /usr/lib/apache (was incorrect)
-
-* Mon Apr 10 2000 Nalin Dahyabhai
-- make subpackages require php = %{version} (bug #10671)
-
-* Thu Apr 06 2000 Nalin Dahyabhai
-- update to 3.0.16
-
-* Fri Mar 03 2000 Cristian Gafton
-- fixed the post script to work when upgrading a package
-- add triggere to fix the older packages
-
-* Tue Feb 29 2000 Nalin Dahyabhai
-- update to 3.0.15
-- add build-time dependency for openldap-devel
-- enable db,ftp,shm,sem support to fix bug #9648
-
-* Fri Feb 25 2000 Nalin Dahyabhai
-- add dependency for imap subpackage
-- rebuild against Apache 1.3.12
-
-* Thu Feb 24 2000 Preston Brown
-- don't include old, outdated manual. package one from the php distribution.
-
-* Tue Feb 01 2000 Cristian Gafton
-- rebuild to fix dependency problem
-
-* Fri Jan 14 2000 Preston Brown
-- added commented out mysql module, thanks to Jason Duerstock
- (jason@sdi.cluephone.com). Uncomment to build if you have mysql installed.
-
-* Thu Jan 13 2000 Preston Brown
-- rely on imap-devel, don't include imap in src.rpm (#5099).
-- xml enabled (#5393)
-
-* Tue Nov 02 1999 Preston Brown
-- added post/postun sections to modify httpd.conf (#5259)
-- removed old obsolete faq and gif (#5260)
-- updated manual.tar.gz package (#5261)
-
-* Thu Oct 07 1999 Matt Wilson
-- rebuilt for sparc glibc brokenness
-
-* Fri Sep 24 1999 Preston Brown
-- --with-apxs --> --with-apxs=/usr/sbin/apxs (# 5094)
-- ldap support (# 5097)
-
-* Thu Sep 23 1999 Preston Brown
-- fix cmdtuples for postgresql, I had it slightly wrong
-
-* Tue Aug 31 1999 Bill Nottingham
-- subpackages must obsolete old stuff...
-
-* Sun Aug 29 1999 Preston Brown
-- added -DHAVE_PGCMDTUPLES for postgresql module (bug # 4767)
-
-* Fri Aug 27 1999 Preston Brown
-- name change to php to follow real name of package
-- fix up references to php3 to refer to php
-- upgrade to 3.0.12
-- fixed typo in pgsql postun script (bug # 4686)
-
-* Mon Jun 14 1999 Preston Brown
-- upgraded to 3.0.9
-- fixed postgresql module and made separate package
-- separated manual into separate documentation package
-
-* Mon May 24 1999 Preston Brown
-- upgraded to 3.0.8, which fixes problems with glibc 2.1.
-- took some ideas grom Gomez's RPM.
-
-* Tue May 04 1999 Preston Brown
-- hacked in imap support in an ugly way until imap gets an official
- shared library implementation
-
-* Fri Apr 16 1999 Preston Brown
-- pick up php3.ini
-
-* Wed Mar 24 1999 Preston Brown
-- build against apache 1.3.6
-
-* Sun Mar 21 1999 Cristian Gafton
-- auto rebuild in the new build environment (release 2)
-
-* Mon Mar 08 1999 Preston Brown
-- upgraded to 3.0.7.
-
-* Wed Feb 24 1999 Preston Brown
-- Injected new description and group.
-
-* Sun Feb 07 1999 Preston Brown
-- upgrade to php 3.0.6, built against apache 1.3.4
-
-* Mon Oct 12 1998 Cristian Gafton
-- rebuild for apache 1.3.3
-
-* Thu Oct 08 1998 Preston Brown
-- updated to 3.0.5, fixes nasty bugs in 3.0.4.
-
-* Sun Sep 27 1998 Cristian Gafton
-- updated to 3.0.4 and recompiled for apache 1.3.2
-
-* Thu Sep 03 1998 Preston Brown
-- improvements; builds with apache-devel package installed.
-
-* Tue Sep 01 1998 Preston Brown
-- Made initial cut for PHP3.
diff --git a/sources b/sources
index 1f18f88..8ad25e4 100644
--- a/sources
+++ b/sources
@@ -1,9 +1 @@
-2c3c803152878c799cdf551d56bd142b php-4.2.2.tar.gz
-2951f28410e6a74c41f2a1d568c81c0b php_manual_de.tar.bz2
-63d25c475df35ae0e279a15f9252f7de php_manual_en.tar.bz2
-7b94a81ad20199e73219bff05107e048 php_manual_es.tar.bz2
-b0458e075f8aac862c7e32215d6b5de7 php_manual_fr.tar.bz2
-887d121e823cd7dc41f7235712076774 php_manual_it.tar.bz2
-939865a1d77f888a2d6e5e25169b9493 php_manual_ja.tar.bz2
-d16d938fc90fac7593c1cdde8a71c171 php_manual_ko.tar.bz2
-a800dbc899eefb5880cac59dfa9d6433 php_manual_pt_BR.tar.bz2
+1171d96104e2ff2cff9e19789a4a1536 php-4.3.3.tar.bz2