5.6.21RC1
This commit is contained in:
parent
6b11536543
commit
efcccf32c9
1
.gitignore
vendored
1
.gitignore
vendored
@ -68,3 +68,4 @@ php-5.5.*.xz
|
||||
/php-5.6.19-strip.tar.xz
|
||||
/php-5.6.20RC1-strip.tar.xz
|
||||
/php-5.6.20-strip.tar.xz
|
||||
/php-5.6.21RC1-strip.tar.xz
|
||||
|
@ -1,58 +0,0 @@
|
||||
From 657494235eafe048e9fa6a19dcdb3c73a0cbe6ec Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <fedora@famillecollet.com>
|
||||
Date: Thu, 27 Sep 2012 13:45:32 +0200
|
||||
Subject: [PATCH] Fixed bug #63171, script hangs if odbc call during timeout
|
||||
|
||||
---
|
||||
ext/odbc/php_odbc.c | 21 ++++++++++++++-------
|
||||
1 file changed, 14 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/ext/odbc/php_odbc.c b/ext/odbc/php_odbc.c
|
||||
index 52d46b2..2169e65 100644
|
||||
--- a/ext/odbc/php_odbc.c
|
||||
+++ b/ext/odbc/php_odbc.c
|
||||
@@ -431,7 +431,8 @@ static void _free_odbc_result(zend_rsrc_list_entry *rsrc TSRMLS_DC)
|
||||
efree(res->values);
|
||||
res->values = NULL;
|
||||
}
|
||||
- if (res->stmt) {
|
||||
+ /* If aborted via timer expiration, don't try to call any unixODBC function */
|
||||
+ if (res->stmt && !(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
|
||||
#if defined(HAVE_SOLID) || defined(HAVE_SOLID_30) || defined(HAVE_SOLID_35)
|
||||
SQLTransact(res->conn_ptr->henv, res->conn_ptr->hdbc,
|
||||
(SQLUSMALLINT) SQL_COMMIT);
|
||||
@@ -484,9 +485,12 @@ static void _close_odbc_conn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
|
||||
}
|
||||
}
|
||||
|
||||
- safe_odbc_disconnect(conn->hdbc);
|
||||
- SQLFreeConnect(conn->hdbc);
|
||||
- SQLFreeEnv(conn->henv);
|
||||
+ /* If aborted via timer expiration, don't try to call any unixODBC function */
|
||||
+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
|
||||
+ safe_odbc_disconnect(conn->hdbc);
|
||||
+ SQLFreeConnect(conn->hdbc);
|
||||
+ SQLFreeEnv(conn->henv);
|
||||
+ }
|
||||
efree(conn);
|
||||
ODBCG(num_links)--;
|
||||
}
|
||||
@@ -512,9 +516,12 @@ static void _close_odbc_pconn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
|
||||
}
|
||||
}
|
||||
|
||||
- safe_odbc_disconnect(conn->hdbc);
|
||||
- SQLFreeConnect(conn->hdbc);
|
||||
- SQLFreeEnv(conn->henv);
|
||||
+ /* If aborted via timer expiration, don't try to call any unixODBC function */
|
||||
+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
|
||||
+ safe_odbc_disconnect(conn->hdbc);
|
||||
+ SQLFreeConnect(conn->hdbc);
|
||||
+ SQLFreeEnv(conn->henv);
|
||||
+ }
|
||||
free(conn);
|
||||
|
||||
ODBCG(num_links)--;
|
||||
--
|
||||
1.7.10
|
||||
|
17
php.spec
17
php.spec
@ -64,16 +64,16 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
#global rcver RC1
|
||||
%global rcver RC1
|
||||
%global rpmrel 1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.20
|
||||
Version: 5.6.21
|
||||
%if 0%{?rcver:1}
|
||||
Release: 0.%{rpmrel}.%{rcver}%{?dist}.1
|
||||
Release: 0.%{rpmrel}.%{rcver}%{?dist}
|
||||
%else
|
||||
Release: %{rpmrel}%{?dist}.1
|
||||
Release: %{rpmrel}%{?dist}
|
||||
%endif
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
@ -108,10 +108,6 @@ Patch6: php-5.6.3-embed.patch
|
||||
Patch7: php-5.3.0-recode.patch
|
||||
Patch8: php-5.6.17-libdb.patch
|
||||
|
||||
# Fixes for extension modules
|
||||
# https://bugs.php.net/63171 no odbc call during timeout
|
||||
Patch21: php-5.4.7-odbctimer.patch
|
||||
|
||||
# Functional changes
|
||||
Patch40: php-5.4.0-dlopen.patch
|
||||
Patch42: php-5.6.13-systzdata-v12.patch
|
||||
@ -716,8 +712,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%patch7 -p1 -b .recode
|
||||
%patch8 -p1 -b .libdb
|
||||
|
||||
%patch21 -p1 -b .odbctimer
|
||||
|
||||
%patch40 -p1 -b .dlopen
|
||||
%patch42 -p1 -b .systzdata
|
||||
%patch43 -p1 -b .headers
|
||||
@ -1486,6 +1480,9 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 18 2016 Remi Collet <remi@fedoraproject.org> 5.6.21-0.1.RC1
|
||||
- update to 5.6.21RC1
|
||||
|
||||
* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.20-1.1
|
||||
- rebuild for ICU 57.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user