update to 5.3.1 (but FTBFS...)
This commit is contained in:
parent
0c27299bfb
commit
da991dabd3
@ -1 +1 @@
|
||||
php-5.3.0.tar.bz2
|
||||
php-5.3.1.tar.bz2
|
||||
|
@ -1,115 +0,0 @@
|
||||
diff -up php-5.3.0RC3/configure.in.gnusrc php-5.3.0RC3/configure.in
|
||||
--- php-5.3.0RC3/configure.in.gnusrc 2009-06-10 20:18:43.000000000 +0200
|
||||
+++ php-5.3.0RC3/configure.in 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||
|
||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||
+
|
||||
dnl Setting up the PHP version based on the information above.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php-5.3.0RC3/ext/interbase/interbase.c.gnusrc php-5.3.0RC3/ext/interbase/interbase.c
|
||||
--- php-5.3.0RC3/ext/interbase/interbase.c.gnusrc 2008-12-31 12:15:38.000000000 +0100
|
||||
+++ php-5.3.0RC3/ext/interbase/interbase.c 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
|
||||
diff -up php-5.3.0RC3/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.0RC3/ext/pdo_firebird/firebird_driver.c
|
||||
--- php-5.3.0RC3/ext/pdo_firebird/firebird_driver.c.gnusrc 2009-04-18 20:56:11.000000000 +0200
|
||||
+++ php-5.3.0RC3/ext/pdo_firebird/firebird_driver.c 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
#ifdef ZEND_ENGINE_2
|
||||
diff -up php-5.3.0RC3/ext/standard/file.c.gnusrc php-5.3.0RC3/ext/standard/file.c
|
||||
--- php-5.3.0RC3/ext/standard/file.c.gnusrc 2009-05-24 18:01:47.000000000 +0200
|
||||
+++ php-5.3.0RC3/ext/standard/file.c 2009-06-12 07:40:44.000000000 +0200
|
||||
@@ -123,9 +123,6 @@ php_file_globals file_globals;
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
|
||||
-# ifndef _GNU_SOURCE
|
||||
-# define _GNU_SOURCE
|
||||
-# endif
|
||||
# include <fnmatch.h>
|
||||
#endif
|
||||
|
||||
diff -up php-5.3.0RC3/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.0RC3/ext/zlib/zlib_fopen_wrapper.c
|
||||
--- php-5.3.0RC3/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-01-20 16:41:23.000000000 +0100
|
||||
+++ php-5.3.0RC3/ext/zlib/zlib_fopen_wrapper.c 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
|
||||
/* $Id: zlib_fopen_wrapper.c,v 1.46.2.1.2.4.2.3 2009/01/20 15:41:23 felipe Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
-
|
||||
#include "php.h"
|
||||
#include "php_zlib.h"
|
||||
#include "fopen_wrappers.h"
|
||||
diff -up php-5.3.0RC3/main/php.h.gnusrc php-5.3.0RC3/main/php.h
|
||||
--- php-5.3.0RC3/main/php.h.gnusrc 2008-12-31 12:15:47.000000000 +0100
|
||||
+++ php-5.3.0RC3/main/php.h 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -30,6 +30,7 @@
|
||||
#define PHP_HAVE_STREAMS
|
||||
#define YYDEBUG 0
|
||||
|
||||
+#include "php_config.h"
|
||||
#include "php_version.h"
|
||||
#include "zend.h"
|
||||
#include "zend_qsort.h"
|
||||
diff -up php-5.3.0RC3/main/streams/cast.c.gnusrc php-5.3.0RC3/main/streams/cast.c
|
||||
--- php-5.3.0RC3/main/streams/cast.c.gnusrc 2009-04-20 10:28:44.000000000 +0200
|
||||
+++ php-5.3.0RC3/main/streams/cast.c 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: cast.c,v 1.12.2.1.2.1.2.6 2009/04/20 08:28:44 pajoye Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.3.0RC3/main/streams/memory.c.gnusrc php-5.3.0RC3/main/streams/memory.c
|
||||
--- php-5.3.0RC3/main/streams/memory.c.gnusrc 2009-05-16 22:27:36.000000000 +0200
|
||||
+++ php-5.3.0RC3/main/streams/memory.c 2009-06-12 07:41:07.000000000 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: memory.c,v 1.8.2.6.2.17.2.4 2009/05/16 20:27:36 lbarnaud Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
|
||||
PHPAPI int php_url_decode(char *str, int len);
|
||||
diff -up php-5.3.0RC3/main/streams/streams.c.gnusrc php-5.3.0RC3/main/streams/streams.c
|
||||
--- php-5.3.0RC3/main/streams/streams.c.gnusrc 2009-05-17 16:58:10.000000000 +0200
|
||||
+++ php-5.3.0RC3/main/streams/streams.c 2009-06-12 07:40:53.000000000 +0200
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
/* $Id: streams.c,v 1.82.2.6.2.18.2.28 2009/05/17 14:58:10 lbarnaud Exp $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.3.0RC3/Zend/zend_language_parser.c.gnusrc php-5.3.0RC3/Zend/zend_language_parser.c
|
||||
--- php-5.3.0RC3/Zend/zend_language_parser.c.gnusrc 2009-06-10 20:23:36.000000000 +0200
|
||||
+++ php-5.3.0RC3/Zend/zend_language_parser.c 2009-06-12 07:38:08.000000000 +0200
|
||||
@@ -366,6 +366,8 @@
|
||||
#include "zend_API.h"
|
||||
#include "zend_constants.h"
|
||||
|
||||
+#include <string.h>
|
||||
+
|
||||
|
||||
#define YYERROR_VERBOSE
|
||||
#define YYSTYPE znode
|
114
php-5.3.1-gnusrc.patch
Normal file
114
php-5.3.1-gnusrc.patch
Normal file
@ -0,0 +1,114 @@
|
||||
diff -up php5.3-200908150630/configure.in.gnusrc php5.3-200908150630/configure.in
|
||||
--- php5.3-200908150630/configure.in.gnusrc 2009-08-12 00:34:39.000000000 +0200
|
||||
+++ php5.3-200908150630/configure.in 2009-08-15 08:46:09.000000000 +0200
|
||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||
|
||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||
+
|
||||
dnl Setting up the PHP version based on the information above.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php5.3-200908150630/ext/interbase/interbase.c.gnusrc php5.3-200908150630/ext/interbase/interbase.c
|
||||
--- php5.3-200908150630/ext/interbase/interbase.c.gnusrc 2009-07-17 14:23:09.000000000 +0200
|
||||
+++ php5.3-200908150630/ext/interbase/interbase.c 2009-08-15 08:46:09.000000000 +0200
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
|
||||
diff -up php5.3-200908150630/ext/pdo_firebird/firebird_driver.c.gnusrc php5.3-200908150630/ext/pdo_firebird/firebird_driver.c
|
||||
--- php5.3-200908150630/ext/pdo_firebird/firebird_driver.c.gnusrc 2009-07-17 14:22:08.000000000 +0200
|
||||
+++ php5.3-200908150630/ext/pdo_firebird/firebird_driver.c 2009-08-15 08:46:09.000000000 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
#ifdef ZEND_ENGINE_2
|
||||
diff -up php5.3-200908150630/ext/standard/file.c.gnusrc php5.3-200908150630/ext/standard/file.c
|
||||
--- php5.3-200908150630/ext/standard/file.c.gnusrc 2009-07-17 14:20:59.000000000 +0200
|
||||
+++ php5.3-200908150630/ext/standard/file.c 2009-08-15 08:46:09.000000000 +0200
|
||||
@@ -123,9 +123,6 @@ php_file_globals file_globals;
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
|
||||
-# ifndef _GNU_SOURCE
|
||||
-# define _GNU_SOURCE
|
||||
-# endif
|
||||
# include <fnmatch.h>
|
||||
#endif
|
||||
|
||||
diff -up php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c.gnusrc php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c
|
||||
--- php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-07-17 14:20:18.000000000 +0200
|
||||
+++ php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c 2009-08-15 08:47:43.000000000 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
|
||||
/* $Id: zlib_fopen_wrapper.c 274034 2009-01-20 15:41:23Z felipe $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
-
|
||||
#include "php.h"
|
||||
#include "php_zlib.h"
|
||||
#include "fopen_wrappers.h"
|
||||
diff -up php5.3-200908150630/main/php.h.gnusrc php5.3-200908150630/main/php.h
|
||||
--- php5.3-200908150630/main/php.h.gnusrc 2009-07-17 14:23:41.000000000 +0200
|
||||
+++ php5.3-200908150630/main/php.h 2009-08-15 08:46:09.000000000 +0200
|
||||
@@ -30,6 +30,7 @@
|
||||
#define PHP_HAVE_STREAMS
|
||||
#define YYDEBUG 0
|
||||
|
||||
+#include "php_config.h"
|
||||
#include "php_version.h"
|
||||
#include "zend.h"
|
||||
#include "zend_qsort.h"
|
||||
diff -up php5.3-200908150630/main/streams/cast.c.gnusrc php5.3-200908150630/main/streams/cast.c
|
||||
--- php5.3-200908150630/main/streams/cast.c.gnusrc 2009-07-17 14:23:41.000000000 +0200
|
||||
+++ php5.3-200908150630/main/streams/cast.c 2009-08-15 08:48:09.000000000 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: cast.c 279036 2009-04-20 08:28:44Z pajoye $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php5.3-200908150630/main/streams/streams.c.gnusrc php5.3-200908150630/main/streams/streams.c
|
||||
--- php5.3-200908150630/main/streams/streams.c.gnusrc 2009-07-17 14:23:40.000000000 +0200
|
||||
+++ php5.3-200908150630/main/streams/streams.c 2009-08-15 08:49:04.000000000 +0200
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
/* $Id: streams.c 280678 2009-05-17 14:58:10Z lbarnaud $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php5.3-200908150630/Zend/zend_language_parser.c.gnusrc php5.3-200908150630/Zend/zend_language_parser.c
|
||||
--- php5.3-200908150630/Zend/zend_language_parser.c.gnusrc 2009-08-15 08:36:38.000000000 +0200
|
||||
+++ php5.3-200908150630/Zend/zend_language_parser.c 2009-08-15 08:46:09.000000000 +0200
|
||||
@@ -366,6 +366,8 @@
|
||||
#include "zend_API.h"
|
||||
#include "zend_constants.h"
|
||||
|
||||
+#include <string.h>
|
||||
+
|
||||
|
||||
#define YYERROR_VERBOSE
|
||||
#define YYSTYPE znode
|
||||
--- php-5.3.1RC2/main/streams/memory.c.gnusrc 2009-10-09 19:45:03.000000000 +0200
|
||||
+++ php-5.3.1RC2/main/streams/memory.c 2009-10-21 17:31:50.000000000 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: memory.c 289437 2009-10-09 17:45:03Z pajoye $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
|
||||
PHPAPI int php_url_decode(char *str, int len);
|
29
php.spec
29
php.spec
@ -5,15 +5,16 @@
|
||||
%global pdover 20080721
|
||||
# Extension version
|
||||
%global fileinfover 1.0.5-dev
|
||||
%global pharver 2.0.0-dev
|
||||
%global pharver 2.0.1
|
||||
%global zipver 1.9.1
|
||||
%global jsonver 1.2.1
|
||||
|
||||
%define httpd_mmn %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.3.0
|
||||
Release: 7%{?dist}
|
||||
Version: 5.3.1
|
||||
Release: 1%{?dist}
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -24,14 +25,13 @@ Source2: php.ini
|
||||
Source3: macros.php
|
||||
|
||||
# Build fixes
|
||||
Patch1: php-5.3.0-gnusrc.patch
|
||||
Patch1: php-5.3.1-gnusrc.patch
|
||||
Patch2: php-5.3.0-install.patch
|
||||
Patch3: php-5.2.4-norpath.patch
|
||||
Patch4: php-5.3.0-phpize64.patch
|
||||
Patch5: php-5.2.0-includedir.patch
|
||||
Patch6: php-5.2.4-embed.patch
|
||||
Patch7: php-5.3.0-recode.patch
|
||||
Patch8: php-5.3.0-openssl.patch
|
||||
# Filed upstream: http://bugs.php.net/50209
|
||||
Patch9: php-5.3.0-libedit.patch
|
||||
|
||||
@ -90,6 +90,7 @@ Group: Development/Languages
|
||||
Summary: Thread-safe PHP interpreter for use with the Apache HTTP Server
|
||||
Requires: php-common = %{version}-%{release}
|
||||
Requires: httpd-mmn = %{httpd_mmn}
|
||||
BuildRequires: libtool-ltdl-devel
|
||||
|
||||
%description zts
|
||||
The php-zts package contains a module for use with the Apache HTTP
|
||||
@ -108,6 +109,7 @@ Provides: php-spl, php-tokenizer, php-openssl, php-pcre
|
||||
Provides: php-zlib, php-json, php-zip, php-fileinfo
|
||||
Obsoletes: php-openssl, php-pecl-zip, php-pecl-json, php-json, php-pecl-phar, php-pecl-Fileinfo
|
||||
# For obsoleted pecl extension
|
||||
Provides: php-pecl-json = %{jsonver}, php-pecl(json) = %{jsonver}
|
||||
Provides: php-pecl-zip = %{zipver}, php-pecl(zip) = %{zipver}
|
||||
Provides: php-pecl-phar = %{pharver}, php-pecl(phar) = %{pharver}
|
||||
Provides: php-pecl-Fileinfo = %{fileinfover}, php-pecl(Fileinfo) = %{fileinfover}
|
||||
@ -428,7 +430,6 @@ support for using the enchant library to PHP.
|
||||
%patch5 -p1 -b .includedir
|
||||
%patch6 -p1 -b .embed
|
||||
%patch7 -p1 -b .recode
|
||||
%patch8 -p1 -b .openssl
|
||||
%patch9 -p1 -b .libedit
|
||||
|
||||
%patch20 -p1 -b .shutdown
|
||||
@ -499,6 +500,12 @@ if test "$ver" != "%{zipver}"; then
|
||||
: Update the zipver macro and rebuild.
|
||||
exit 1
|
||||
fi
|
||||
ver=$(sed -n '/#define PHP_JSON_VERSION /{s/.* "//;s/".*$//;p}' ext/json/php_json.h)
|
||||
if test "$ver" != "%{jsonver}"; then
|
||||
: Error: Upstream JSON version is now ${ver}, expecting %{jsonver}.
|
||||
: Update the jsonver macro and rebuild.
|
||||
exit 1
|
||||
fi
|
||||
|
||||
|
||||
%build
|
||||
@ -706,6 +713,7 @@ install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf.d
|
||||
install -m 644 $RPM_SOURCE_DIR/php.conf $RPM_BUILD_ROOT/etc/httpd/conf.d
|
||||
|
||||
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php.d
|
||||
#install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d
|
||||
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
|
||||
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
|
||||
|
||||
@ -787,10 +795,13 @@ rm files.* macros.php
|
||||
%defattr(-,root,root)
|
||||
%doc CODING_STANDARDS CREDITS EXTENSIONS INSTALL LICENSE NEWS README*
|
||||
%doc Zend/ZEND_* TSRM_LICENSE regex_COPYRIGHT
|
||||
%doc php.ini-*
|
||||
%config(noreplace) %{_sysconfdir}/php.ini
|
||||
%dir %{_sysconfdir}/php.d
|
||||
#dir %{_sysconfdir}/php-zts.d
|
||||
%dir %{_libdir}/php
|
||||
%dir %{_libdir}/php/modules
|
||||
#dir %{_libdir}/php/modules-zts
|
||||
%dir %{_localstatedir}/lib/php
|
||||
%dir %{_libdir}/php/pear
|
||||
%dir %{_datadir}/php
|
||||
@ -849,6 +860,12 @@ rm files.* macros.php
|
||||
%files enchant -f files.enchant
|
||||
|
||||
%changelog
|
||||
* Fri Nov 20 2009 Remi Collet <Fedora@famillecollet.com> 5.3.1-1
|
||||
- update to 5.3.1
|
||||
- remove openssl patch (merged upstream)
|
||||
- add provides for php-pecl-json
|
||||
- add prod/devel php.ini in doc
|
||||
|
||||
* Tue Nov 17 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 5.3.0-7
|
||||
- use libedit instead of readline to resolve licensing issues
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user