update to 8.2.0RC3
bump API/ABI new random extension add dependency on libselinux
This commit is contained in:
parent
2d463a7153
commit
d489ea0802
2
.gitignore
vendored
2
.gitignore
vendored
@ -46,3 +46,5 @@ php-7.*.xz.asc
|
||||
/php-8.1.11RC1.tar.xz.asc
|
||||
/php-8.1.11.tar.xz
|
||||
/php-8.1.11.tar.xz.asc
|
||||
/php-8.2.0RC3.tar.xz
|
||||
/php-8.2.0RC3.tar.xz.asc
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up ./build/gen_stub.php.syslib ./build/gen_stub.php
|
||||
--- ./build/gen_stub.php.syslib 2020-06-25 08:11:51.782046813 +0200
|
||||
+++ ./build/gen_stub.php 2020-06-25 08:13:11.188860368 +0200
|
||||
@@ -1075,6 +1075,12 @@ function initPhpParser() {
|
||||
@@ -3265,6 +3265,12 @@ function initPhpParser() {
|
||||
}
|
||||
|
||||
$isInitialized = true;
|
||||
@ -11,6 +11,6 @@ diff -up ./build/gen_stub.php.syslib ./build/gen_stub.php
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
$version = "4.13.0";
|
||||
$version = "4.15.1";
|
||||
$phpParserDir = __DIR__ . "/PHP-Parser-$version";
|
||||
if (!is_dir($phpParserDir)) {
|
23
php.spec
23
php.spec
@ -7,8 +7,8 @@
|
||||
#
|
||||
|
||||
# API/ABI check
|
||||
%global apiver 20210902
|
||||
%global zendver 20210902
|
||||
%global apiver 20220829
|
||||
%global zendver 20220829
|
||||
%global pdover 20170320
|
||||
|
||||
# we don't want -z defs linker flag
|
||||
@ -18,7 +18,7 @@
|
||||
%global _hardened_build 1
|
||||
|
||||
# version used for php embedded library soname
|
||||
%global embed_version 8.1
|
||||
%global embed_version 8.2
|
||||
|
||||
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
|
||||
|
||||
@ -64,8 +64,8 @@
|
||||
%bcond_with imap
|
||||
%bcond_without lmdb
|
||||
|
||||
%global upver 8.1.11
|
||||
#global rcver RC1
|
||||
%global upver 8.2.0
|
||||
%global rcver RC3
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -109,7 +109,7 @@ Patch8: php-8.1.0-libdb.patch
|
||||
|
||||
# Functional changes
|
||||
# Use system nikic/php-parser
|
||||
Patch41: php-8.1.0-parser.patch
|
||||
Patch41: php-8.2.0-parser.patch
|
||||
# use system tzdata
|
||||
Patch42: php-8.1.0-systzdata-v22.patch
|
||||
# See http://bugs.php.net/53436
|
||||
@ -236,6 +236,7 @@ The php-dbg package contains the interactive PHP debugger.
|
||||
Summary: PHP FastCGI Process Manager
|
||||
BuildRequires: libacl-devel
|
||||
BuildRequires: pkgconfig(libsystemd) >= 209
|
||||
BuildRequires: pkgconfig(libselinux)
|
||||
Requires: php-common%{?_isa} = %{version}-%{release}
|
||||
%{?systemd_requires}
|
||||
# To ensure correct /var/lib/php/session ownership:
|
||||
@ -286,6 +287,7 @@ Provides: php-libxml, php-libxml%{?_isa}
|
||||
Provides: php-openssl, php-openssl%{?_isa}
|
||||
Provides: php-phar, php-phar%{?_isa}
|
||||
Provides: php-pcre, php-pcre%{?_isa}
|
||||
Provides: php-random, php-random%{?_isa}
|
||||
Provides: php-reflection, php-reflection%{?_isa}
|
||||
Provides: php-session, php-session%{?_isa}
|
||||
Provides: php-sockets, php-sockets%{?_isa}
|
||||
@ -318,7 +320,7 @@ Requires: zlib-devel%{?_isa}
|
||||
Provides: php-zts-devel = %{version}-%{release}
|
||||
Provides: php-zts-devel%{?_isa} = %{version}-%{release}
|
||||
%endif
|
||||
Recommends: php-nikic-php-parser4 >= 4.13.0
|
||||
Recommends: php-nikic-php-parser4 >= 4.15.1
|
||||
|
||||
|
||||
%description devel
|
||||
@ -1015,6 +1017,7 @@ pushd build-fpm
|
||||
build --enable-fpm \
|
||||
--with-fpm-acl \
|
||||
--with-fpm-systemd \
|
||||
--with-fpm-selinux \
|
||||
--libdir=%{_libdir}/php \
|
||||
--without-mysqli \
|
||||
--disable-pdo \
|
||||
@ -1540,6 +1543,12 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Sep 28 2022 Remi Collet <remi@remirepo.net> - 8.2.0~RC3-4
|
||||
- update to 8.2.0RC3
|
||||
- bump API/ABI
|
||||
- new random extension
|
||||
- add dependency on libselinux
|
||||
|
||||
* Wed Sep 28 2022 Remi Collet <remi@remirepo.net> - 8.1.11-1
|
||||
- Update to 8.1.11 - http://www.php.net/releases/8_1_11.php
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-8.1.11.tar.xz) = 2a9eb4642b4077077f6551ca9a40fd2c48272cc1ee443117362331259efbec88bad0141b09f7a9ff710cde044f9463e1e668f7066b2429ea4274dec7291725cc
|
||||
SHA512 (php-8.1.11.tar.xz.asc) = 50b797f3a78a18782d4c22d8db96b2d59a1f43ad691f1f47dab72e02701b141b03ecfbb035887d23a76014e25db516cef5166f722929460cfc8737fde36ddc1b
|
||||
SHA512 (php-8.2.0RC3.tar.xz) = f0efde3cc30563d1e30a72f368b1dca483d8fe7ebd65c54ee86212d9476f260aed993bd62a2685f50c53a599174b91cb2f0d10f1e83fc68b4403f715a7045f35
|
||||
SHA512 (php-8.2.0RC3.tar.xz.asc) = a95fa260b49342463ea508e965c2a97b46ca1dd8dbe4e4ea5e2b38bd469860ebe19fe6e931679da2405c4f400431e1336e040ff8a8e533973a144a31f8d978d4
|
||||
|
Loading…
Reference in New Issue
Block a user