* Wed Nov 15 2006 Joe Orton <jorton@redhat.com> 5.2.0-3
- update to 5.2.0 (#213837) - php-xml provides php-domxml (#215656) - fix php-pdo-abi provide (#214281)
This commit is contained in:
parent
ad20b87667
commit
cf65b89834
@ -9,3 +9,4 @@ php-5.1.1
|
||||
php-5.1.2.tar.gz
|
||||
php-5.1.3.tar.gz
|
||||
php-5.1.4.tar.gz
|
||||
php-5.2.0.tar.gz
|
||||
|
@ -1,85 +1,14 @@
|
||||
|
||||
Remove 7K of April's Fool.
|
||||
|
||||
--- php-5.1.3/ext/standard/basic_functions.c.easter
|
||||
+++ php-5.1.3/ext/standard/basic_functions.c
|
||||
@@ -202,7 +202,6 @@
|
||||
PHP_FE(phpcredits, NULL)
|
||||
PHP_FE(php_logo_guid, NULL)
|
||||
PHP_FE(php_real_logo_guid, NULL)
|
||||
- PHP_FE(php_egg_logo_guid, NULL)
|
||||
PHP_FE(zend_logo_guid, NULL)
|
||||
PHP_FE(php_sapi_name, NULL)
|
||||
PHP_FE(php_uname, NULL)
|
||||
--- php-5.1.3/ext/standard/info.h.easter
|
||||
+++ php-5.1.3/ext/standard/info.h
|
||||
@@ -51,7 +51,6 @@
|
||||
#endif /* HAVE_CREDITS_DEFS */
|
||||
|
||||
#define PHP_LOGO_GUID "PHPE9568F34-D428-11d2-A769-00AA001ACF42"
|
||||
-#define PHP_EGG_LOGO_GUID "PHPE9568F36-D428-11d2-A769-00AA001ACF42"
|
||||
#define ZEND_LOGO_GUID "PHPE9568F35-D428-11d2-A769-00AA001ACF42"
|
||||
#define PHP_CREDITS_GUID "PHPB8B5F2A0-3C92-11d3-A3A9-4C7B08C10000"
|
||||
|
||||
@@ -62,7 +61,6 @@
|
||||
PHP_FUNCTION(php_logo_guid);
|
||||
PHP_FUNCTION(php_real_logo_guid);
|
||||
PHP_FUNCTION(zend_logo_guid);
|
||||
-PHP_FUNCTION(php_egg_logo_guid);
|
||||
PHP_FUNCTION(php_sapi_name);
|
||||
PHP_FUNCTION(php_uname);
|
||||
PHP_FUNCTION(php_ini_scanned_files);
|
||||
--- php-5.1.3/ext/standard/info.c.easter
|
||||
+++ php-5.1.3/ext/standard/info.c
|
||||
@@ -1046,21 +1046,7 @@
|
||||
*/
|
||||
PHPAPI char *php_logo_guid()
|
||||
{
|
||||
- char *logo_guid;
|
||||
-
|
||||
- time_t the_time;
|
||||
- struct tm *ta, tmbuf;
|
||||
-
|
||||
- the_time = time(NULL);
|
||||
- ta = php_localtime_r(&the_time, &tmbuf);
|
||||
-
|
||||
- if ((ta->tm_mon==3) && (ta->tm_mday==1)) {
|
||||
- logo_guid = PHP_EGG_LOGO_GUID;
|
||||
- } else {
|
||||
- logo_guid = PHP_LOGO_GUID;
|
||||
- }
|
||||
-
|
||||
- return estrdup(logo_guid);
|
||||
+ return estrdup(PHP_LOGO_GUID);
|
||||
|
||||
}
|
||||
/* }}} */
|
||||
@@ -1091,18 +1077,6 @@
|
||||
}
|
||||
/* }}} */
|
||||
|
||||
-/* {{{ proto string php_egg_logo_guid(void)
|
||||
- Return the special ID used to request the PHP logo in phpinfo screens*/
|
||||
-PHP_FUNCTION(php_egg_logo_guid)
|
||||
-{
|
||||
- if (ZEND_NUM_ARGS() != 0) {
|
||||
- WRONG_PARAM_COUNT;
|
||||
- }
|
||||
-
|
||||
- RETURN_STRINGL(PHP_EGG_LOGO_GUID, sizeof(PHP_EGG_LOGO_GUID)-1, 1);
|
||||
-}
|
||||
-/* }}} */
|
||||
-
|
||||
/* {{{ proto string zend_logo_guid(void)
|
||||
Return the special ID used to request the Zend logo in phpinfo screens*/
|
||||
PHP_FUNCTION(zend_logo_guid)
|
||||
--- php-5.1.3/main/logos.h.easter
|
||||
+++ php-5.1.3/main/logos.h
|
||||
@@ -492,385 +492,3 @@
|
||||
--- php-5.2.0/main/logos.h.easter
|
||||
+++ php-5.2.0/main/logos.h
|
||||
@@ -491,386 +491,3 @@
|
||||
102, 63, 251, 220, 139, 16, 65, 26, 16, 112,
|
||||
21, 116, 187, 251, 221, 240, 142, 119, 188, 3,
|
||||
1, 0, 59, 0 };
|
||||
|
||||
-unsigned char php_egg_logo[] = {
|
||||
-
|
||||
-static const unsigned char php_egg_logo[] = {
|
||||
- 71, 73, 70, 56, 57, 97, 120, 0, 67, 0,
|
||||
- 247, 0, 0, 0, 255, 0, 107, 114, 178, 0,
|
||||
- 0, 0, 31, 31, 31, 255, 255, 255, 106, 113,
|
||||
@ -461,8 +390,8 @@ Remove 7K of April's Fool.
|
||||
- 7, 4, 129, 5, 84, 208, 62, 158, 185, 154,
|
||||
- 8, 177, 5, 80, 208, 153, 172, 25, 155, 178,
|
||||
- 57, 155, 180, 41, 148, 1, 1, 0, 59, 0 };
|
||||
--- php-5.1.3/main/php_logos.c.easter
|
||||
+++ php-5.1.3/main/php_logos.c
|
||||
--- php-5.2.0/main/php_logos.c.easter
|
||||
+++ php-5.2.0/main/php_logos.c
|
||||
@@ -56,7 +56,6 @@
|
||||
return FAILURE;
|
||||
|
||||
@ -471,3 +400,86 @@ Remove 7K of April's Fool.
|
||||
php_register_info_logo(ZEND_LOGO_GUID , "image/gif", zend_logo , sizeof(zend_logo));
|
||||
|
||||
return SUCCESS;
|
||||
--- php-5.2.0/ext/standard/basic_functions.c.easter
|
||||
+++ php-5.2.0/ext/standard/basic_functions.c
|
||||
@@ -1742,10 +1742,6 @@
|
||||
ZEND_END_ARG_INFO()
|
||||
|
||||
static
|
||||
-ZEND_BEGIN_ARG_INFO(arginfo_php_egg_logo_guid, 0)
|
||||
-ZEND_END_ARG_INFO()
|
||||
-
|
||||
-static
|
||||
ZEND_BEGIN_ARG_INFO(arginfo_zend_logo_guid, 0)
|
||||
ZEND_END_ARG_INFO()
|
||||
|
||||
@@ -3116,7 +3112,6 @@
|
||||
PHP_FE(phpcredits, arginfo_phpcredits)
|
||||
PHP_FE(php_logo_guid, arginfo_php_logo_guid)
|
||||
PHP_FE(php_real_logo_guid, arginfo_php_real_logo_guid)
|
||||
- PHP_FE(php_egg_logo_guid, arginfo_php_egg_logo_guid)
|
||||
PHP_FE(zend_logo_guid, arginfo_zend_logo_guid)
|
||||
PHP_FE(php_sapi_name, arginfo_php_sapi_name)
|
||||
PHP_FE(php_uname, arginfo_php_uname)
|
||||
--- php-5.2.0/ext/standard/info.c.easter
|
||||
+++ php-5.2.0/ext/standard/info.c
|
||||
@@ -1046,21 +1046,7 @@
|
||||
*/
|
||||
PHPAPI char *php_logo_guid()
|
||||
{
|
||||
- char *logo_guid;
|
||||
-
|
||||
- time_t the_time;
|
||||
- struct tm *ta, tmbuf;
|
||||
-
|
||||
- the_time = time(NULL);
|
||||
- ta = php_localtime_r(&the_time, &tmbuf);
|
||||
-
|
||||
- if ((ta->tm_mon==3) && (ta->tm_mday==1)) {
|
||||
- logo_guid = PHP_EGG_LOGO_GUID;
|
||||
- } else {
|
||||
- logo_guid = PHP_LOGO_GUID;
|
||||
- }
|
||||
-
|
||||
- return estrdup(logo_guid);
|
||||
+ return estrdup(PHP_LOGO_GUID);
|
||||
|
||||
}
|
||||
/* }}} */
|
||||
@@ -1091,18 +1077,6 @@
|
||||
}
|
||||
/* }}} */
|
||||
|
||||
-/* {{{ proto string php_egg_logo_guid(void)
|
||||
- Return the special ID used to request the PHP logo in phpinfo screens*/
|
||||
-PHP_FUNCTION(php_egg_logo_guid)
|
||||
-{
|
||||
- if (ZEND_NUM_ARGS() != 0) {
|
||||
- WRONG_PARAM_COUNT;
|
||||
- }
|
||||
-
|
||||
- RETURN_STRINGL(PHP_EGG_LOGO_GUID, sizeof(PHP_EGG_LOGO_GUID)-1, 1);
|
||||
-}
|
||||
-/* }}} */
|
||||
-
|
||||
/* {{{ proto string zend_logo_guid(void)
|
||||
Return the special ID used to request the Zend logo in phpinfo screens*/
|
||||
PHP_FUNCTION(zend_logo_guid)
|
||||
--- php-5.2.0/ext/standard/info.h.easter
|
||||
+++ php-5.2.0/ext/standard/info.h
|
||||
@@ -51,7 +51,6 @@
|
||||
#endif /* HAVE_CREDITS_DEFS */
|
||||
|
||||
#define PHP_LOGO_GUID "PHPE9568F34-D428-11d2-A769-00AA001ACF42"
|
||||
-#define PHP_EGG_LOGO_GUID "PHPE9568F36-D428-11d2-A769-00AA001ACF42"
|
||||
#define ZEND_LOGO_GUID "PHPE9568F35-D428-11d2-A769-00AA001ACF42"
|
||||
#define PHP_CREDITS_GUID "PHPB8B5F2A0-3C92-11d3-A3A9-4C7B08C10000"
|
||||
|
||||
@@ -62,7 +61,6 @@
|
||||
PHP_FUNCTION(php_logo_guid);
|
||||
PHP_FUNCTION(php_real_logo_guid);
|
||||
PHP_FUNCTION(zend_logo_guid);
|
||||
-PHP_FUNCTION(php_egg_logo_guid);
|
||||
PHP_FUNCTION(php_sapi_name);
|
||||
PHP_FUNCTION(php_uname);
|
||||
PHP_FUNCTION(php_ini_scanned_files);
|
||||
|
@ -6,30 +6,19 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
- passed to run-tests.php to ensure it's passed when running each test case
|
||||
- in cases where the PHP executable is run by a test case
|
||||
|
||||
--- php-5.1.1/ext/xml/tests/bug32001.phpt.tests-dashn
|
||||
+++ php-5.1.1/ext/xml/tests/bug32001.phpt
|
||||
@@ -159,7 +159,7 @@
|
||||
|
||||
if (XML_SAX_IMPL == 'libxml') {
|
||||
$php = getenv('TEST_PHP_EXECUTABLE');
|
||||
- preg_match("/^libxml2 Version.*\$/im", `$php -i`, $match);
|
||||
+ preg_match("/^libxml2 Version.*\$/im", `$php -i -n`, $match);
|
||||
echo $match[0], "\n";
|
||||
} else {
|
||||
echo "libxml2 Version => NONE\n";
|
||||
--- php-5.1.1/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||
+++ php-5.1.1/ext/standard/tests/file/proc_open01.phpt
|
||||
@@ -9,7 +9,7 @@
|
||||
die("no php executable defined");
|
||||
}
|
||||
$proc = proc_open(
|
||||
- $php,
|
||||
+ $php . " -n",
|
||||
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
||||
$pipes
|
||||
);
|
||||
--- php-5.1.1/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||
+++ php-5.1.1/ext/standard/tests/file/bug26938.phpt
|
||||
--- php-5.2.0/Makefile.global.tests-dashn
|
||||
+++ php-5.2.0/Makefile.global
|
||||
@@ -79,7 +79,7 @@
|
||||
TEST_PHP_EXECUTABLE=$(top_builddir)/$(SAPI_CLI_PATH) \
|
||||
TEST_PHP_SRCDIR=$(top_srcdir) \
|
||||
CC="$(CC)" \
|
||||
- $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php $(TESTS); \
|
||||
+ $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php -n $(TESTS); \
|
||||
else \
|
||||
echo "ERROR: Cannot run tests without CLI sapi."; \
|
||||
fi
|
||||
--- php-5.2.0/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||
+++ php-5.2.0/ext/standard/tests/file/bug26938.phpt
|
||||
@@ -5,7 +5,7 @@
|
||||
$out = array();
|
||||
$status = -1;
|
||||
@ -39,8 +28,19 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
--- php-5.1.1/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||
+++ php-5.1.1/ext/standard/tests/file/bug26615.phpt
|
||||
--- php-5.2.0/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||
+++ php-5.2.0/ext/standard/tests/file/proc_open01.phpt
|
||||
@@ -9,7 +9,7 @@
|
||||
die("no php executable defined");
|
||||
}
|
||||
$proc = proc_open(
|
||||
- $php,
|
||||
+ $php . " -n",
|
||||
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
||||
$pipes
|
||||
);
|
||||
--- php-5.2.0/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||
+++ php-5.2.0/ext/standard/tests/file/bug26615.phpt
|
||||
@@ -6,7 +6,7 @@
|
||||
<?php
|
||||
$out = array();
|
||||
|
@ -9,19 +9,6 @@
|
||||
MAJOR_VERSION=5
|
||||
MINOR_VERSION=1
|
||||
RELEASE_VERSION=4
|
||||
--- php-5.1.4/Zend/zend_alloc.h.gnusrc
|
||||
+++ php-5.1.4/Zend/zend_alloc.h
|
||||
@@ -125,10 +125,7 @@
|
||||
|
||||
#else
|
||||
|
||||
-#undef _GNU_SOURCE
|
||||
-#define _GNU_SOURCE
|
||||
#include <string.h>
|
||||
-#undef _GNU_SOURCE
|
||||
|
||||
/* Standard wrapper macros */
|
||||
#define emalloc(size) malloc(size)
|
||||
--- php-5.1.4/ext/standard/file.c.gnusrc
|
||||
+++ php-5.1.4/ext/standard/file.c
|
||||
@@ -118,7 +118,6 @@
|
||||
|
22
php.spec
22
php.spec
@ -1,11 +1,11 @@
|
||||
%define contentdir /var/www
|
||||
%define apiver 20041225
|
||||
%define pdover 20060409
|
||||
%define pdover 20060511
|
||||
|
||||
Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
|
||||
Name: php
|
||||
Version: 5.1.6
|
||||
Release: 4
|
||||
Version: 5.2.0
|
||||
Release: 3
|
||||
License: The PHP License v3.01
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -15,12 +15,10 @@ Source50: php.conf
|
||||
Source51: php.ini
|
||||
|
||||
Patch1: php-5.1.4-gnusrc.patch
|
||||
Patch2: php-5.1.4-warnings.patch
|
||||
Patch5: php-4.3.3-install.patch
|
||||
Patch6: php-5.0.4-norpath.patch
|
||||
Patch7: php-4.3.2-libtool15.patch
|
||||
Patch13: php-5.0.2-phpize64.patch
|
||||
Patch14: php-5.1.6-ecalloc.patch
|
||||
Patch15: php-5.1.6-curl716.patch
|
||||
|
||||
# Fixes for extension modules
|
||||
@ -138,7 +136,7 @@ Summary: A database access abstraction module for PHP applications
|
||||
Group: Development/Languages
|
||||
Requires: php = %{version}-%{release}
|
||||
Obsoletes: php-pecl-pdo-sqlite, php-pecl-pdo
|
||||
Provides: php-pdo-abi = %{pdoabi}
|
||||
Provides: php-pdo-abi = %{pdover}
|
||||
|
||||
%description pdo
|
||||
The php-pdo package contains a dynamic shared object that will add
|
||||
@ -222,7 +220,7 @@ Summary: A module for PHP applications which use XML
|
||||
Group: Development/Languages
|
||||
Requires: php = %{version}-%{release}
|
||||
Obsoletes: php-domxml, php-dom
|
||||
Provides: php-dom, php-xsl
|
||||
Provides: php-dom, php-xsl, php-domxml
|
||||
BuildRequires: libxslt-devel >= 1.0.18-1, libxml2-devel >= 2.4.14-1
|
||||
|
||||
%description xml
|
||||
@ -290,12 +288,10 @@ support for using the DBA database abstraction layer to PHP.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .gnusrc
|
||||
%patch2 -p1 -b .warnings
|
||||
%patch5 -p1 -b .install
|
||||
%patch6 -p1 -b .norpath
|
||||
%patch7 -p1 -b .libtool15
|
||||
%patch13 -p1 -b .phpize64
|
||||
%patch14 -p1 -b .ecalloc
|
||||
%patch15 -p1 -b .curl716
|
||||
|
||||
%patch21 -p1 -b .odbc
|
||||
@ -349,8 +345,7 @@ cat `aclocal --print-ac-dir`/libtool.m4 > build/libtool.m4
|
||||
./buildconf --force
|
||||
|
||||
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
|
||||
CPPFLAGS="-DLDAP_DEPRECATED=1"
|
||||
export CFLAGS CPPFLAGS
|
||||
export CFLAGS
|
||||
|
||||
# Install extension modules in %{_libdir}/php/modules.
|
||||
EXTENSION_DIR=%{_libdir}/php/modules; export EXTENSION_DIR
|
||||
@ -610,6 +605,11 @@ rm files.*
|
||||
%files pdo -f files.pdo
|
||||
|
||||
%changelog
|
||||
* Wed Nov 15 2006 Joe Orton <jorton@redhat.com> 5.2.0-3
|
||||
- update to 5.2.0 (#213837)
|
||||
- php-xml provides php-domxml (#215656)
|
||||
- fix php-pdo-abi provide (#214281)
|
||||
|
||||
* Tue Oct 31 2006 Joseph Orton <jorton@redhat.com> 5.1.6-4
|
||||
- rebuild for curl soname bump
|
||||
- add build fix for curl 7.16 API
|
||||
|
Loading…
Reference in New Issue
Block a user