* Thu May 18 2006 Joe Orton <jorton@redhat.com> 5.1.4-5
- provide mod_php (#187891) - provide php-cli (#192196) - use correct LDAP fix (#181518) - define _GNU_SOURCE in php_config.h and leave it defined - drop (circular) dependency on php-pear
This commit is contained in:
parent
6905bc8b00
commit
cf2850d002
127
php-5.1.4-gnusrc.patch
Normal file
127
php-5.1.4-gnusrc.patch
Normal file
@ -0,0 +1,127 @@
|
|||||||
|
--- php-5.1.4/configure.in.gnusrc
|
||||||
|
+++ php-5.1.4/configure.in
|
||||||
|
@@ -39,6 +39,8 @@
|
||||||
|
|
||||||
|
AC_CONFIG_HEADER(main/php_config.h)
|
||||||
|
|
||||||
|
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||||
|
+
|
||||||
|
MAJOR_VERSION=5
|
||||||
|
MINOR_VERSION=1
|
||||||
|
RELEASE_VERSION=4
|
||||||
|
--- php-5.1.4/Zend/zend_alloc.h.gnusrc
|
||||||
|
+++ php-5.1.4/Zend/zend_alloc.h
|
||||||
|
@@ -125,10 +125,7 @@
|
||||||
|
|
||||||
|
#else
|
||||||
|
|
||||||
|
-#undef _GNU_SOURCE
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include <string.h>
|
||||||
|
-#undef _GNU_SOURCE
|
||||||
|
|
||||||
|
/* Standard wrapper macros */
|
||||||
|
#define emalloc(size) malloc(size)
|
||||||
|
--- php-5.1.4/ext/session/mod_files.c.gnusrc
|
||||||
|
+++ php-5.1.4/ext/session/mod_files.c
|
||||||
|
@@ -18,6 +18,7 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
+#include "php_config.h"
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
#include <sys/stat.h>
|
||||||
|
--- php-5.1.4/ext/posix/posix.c.gnusrc
|
||||||
|
+++ php-5.1.4/ext/posix/posix.c
|
||||||
|
@@ -18,9 +18,7 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#ifdef HAVE_CONFIG_H
|
||||||
|
-#include "config.h"
|
||||||
|
-#endif
|
||||||
|
+#include "php_config.h"
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include <unistd.h>
|
||||||
|
--- php-5.1.4/ext/standard/file.c.gnusrc
|
||||||
|
+++ php-5.1.4/ext/standard/file.c
|
||||||
|
@@ -118,7 +118,6 @@
|
||||||
|
|
||||||
|
#ifdef HAVE_FNMATCH
|
||||||
|
#ifndef _GNU_SOURCE
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#endif
|
||||||
|
#include <fnmatch.h>
|
||||||
|
#endif
|
||||||
|
--- php-5.1.4/ext/interbase/interbase.c.gnusrc
|
||||||
|
+++ php-5.1.4/ext/interbase/interbase.c
|
||||||
|
@@ -24,7 +24,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
--- php-5.1.4/ext/zlib/zlib_fopen_wrapper.c.gnusrc
|
||||||
|
+++ php-5.1.4/ext/zlib/zlib_fopen_wrapper.c
|
||||||
|
@@ -19,7 +19,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_zlib.h"
|
||||||
|
--- php-5.1.4/ext/pdo_firebird/firebird_driver.c.gnusrc
|
||||||
|
+++ php-5.1.4/ext/pdo_firebird/firebird_driver.c
|
||||||
|
@@ -22,7 +22,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_ini.h"
|
||||||
|
--- php-5.1.4/main/php.h.gnusrc
|
||||||
|
+++ php-5.1.4/main/php.h
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#define PHP_HAVE_STREAMS
|
||||||
|
#define YYDEBUG 0
|
||||||
|
|
||||||
|
+#include "php_config.h"
|
||||||
|
#include "php_version.h"
|
||||||
|
#include "zend.h"
|
||||||
|
#include "zend_qsort.h"
|
||||||
|
--- php-5.1.4/main/streams/memory.c.gnusrc
|
||||||
|
+++ php-5.1.4/main/streams/memory.c
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
/* Memory streams use a dynamic memory buffer to emulate a stream.
|
||||||
|
--- php-5.1.4/main/streams/streams.c.gnusrc
|
||||||
|
+++ php-5.1.4/main/streams/streams.c
|
||||||
|
@@ -21,7 +21,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
--- php-5.1.4/main/streams/cast.c.gnusrc
|
||||||
|
+++ php-5.1.4/main/streams/cast.c
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
22
php.spec
22
php.spec
@ -4,7 +4,7 @@
|
|||||||
Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
|
Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.1.4
|
Version: 5.1.4
|
||||||
Release: 3
|
Release: 5
|
||||||
License: The PHP License v3.01
|
License: The PHP License v3.01
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://www.php.net/
|
URL: http://www.php.net/
|
||||||
@ -13,7 +13,8 @@ Source0: http://www.php.net/distributions/php-%{version}.tar.gz
|
|||||||
Source50: php.conf
|
Source50: php.conf
|
||||||
Source51: php.ini
|
Source51: php.ini
|
||||||
|
|
||||||
Patch4: php-4.2.2-cxx.patch
|
Patch1: php-5.1.4-gnusrc.patch
|
||||||
|
Patch2: php-5.1.4-warnings.patch
|
||||||
Patch5: php-4.3.3-install.patch
|
Patch5: php-4.3.3-install.patch
|
||||||
Patch6: php-5.0.4-norpath.patch
|
Patch6: php-5.0.4-norpath.patch
|
||||||
Patch7: php-4.3.2-libtool15.patch
|
Patch7: php-4.3.2-libtool15.patch
|
||||||
@ -42,8 +43,10 @@ BuildRequires: bzip2, fileutils, file >= 4.0, perl, libtool >= 1.4.3, gcc-c++
|
|||||||
Obsoletes: php-dbg, mod_php, php3, phpfi, stronghold-php, php-openssl
|
Obsoletes: php-dbg, mod_php, php3, phpfi, stronghold-php, php-openssl
|
||||||
# Enforce Apache module ABI compatibility
|
# Enforce Apache module ABI compatibility
|
||||||
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
|
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
|
||||||
Requires: file >= 4.0, php-pear
|
Requires: file >= 4.0
|
||||||
Provides: php-api = %{apiver}
|
Provides: php-api = %{apiver}
|
||||||
|
Provides: mod_php = %{version}-%{release}
|
||||||
|
Provides: php-cli = %{version}-%{release}
|
||||||
# Provides for all builtin modules:
|
# Provides for all builtin modules:
|
||||||
Provides: php-bz2, php-calendar, php-ctype, php-curl, php-date, php-exif
|
Provides: php-bz2, php-calendar, php-ctype, php-curl, php-date, php-exif
|
||||||
Provides: php-ftp, php-gettext, php-gmp, php-hash, php-iconv, php-libxml
|
Provides: php-ftp, php-gettext, php-gmp, php-hash, php-iconv, php-libxml
|
||||||
@ -259,7 +262,8 @@ support for using the DBA database abstraction layer to PHP.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#patch4 -p1 -b .cxx
|
%patch1 -p1 -b .gnusrc
|
||||||
|
%patch2 -p1 -b .warnings
|
||||||
%patch5 -p1 -b .install
|
%patch5 -p1 -b .install
|
||||||
%patch6 -p1 -b .norpath
|
%patch6 -p1 -b .norpath
|
||||||
%patch7 -p1 -b .libtool15
|
%patch7 -p1 -b .libtool15
|
||||||
@ -308,7 +312,8 @@ cat `aclocal --print-ac-dir`/libtool.m4 > build/libtool.m4
|
|||||||
./buildconf --force
|
./buildconf --force
|
||||||
|
|
||||||
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
|
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
|
||||||
export CFLAGS
|
CPPFLAGS="-DLDAP_DEPRECATED=1"
|
||||||
|
export CFLAGS CPPFLAGS
|
||||||
|
|
||||||
# Install extension modules in %{_libdir}/php/modules.
|
# Install extension modules in %{_libdir}/php/modules.
|
||||||
EXTENSION_DIR=%{_libdir}/php/modules; export EXTENSION_DIR
|
EXTENSION_DIR=%{_libdir}/php/modules; export EXTENSION_DIR
|
||||||
@ -560,6 +565,13 @@ rm files.*
|
|||||||
%files pdo -f files.pdo
|
%files pdo -f files.pdo
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 18 2006 Joe Orton <jorton@redhat.com> 5.1.4-5
|
||||||
|
- provide mod_php (#187891)
|
||||||
|
- provide php-cli (#192196)
|
||||||
|
- use correct LDAP fix (#181518)
|
||||||
|
- define _GNU_SOURCE in php_config.h and leave it defined
|
||||||
|
- drop (circular) dependency on php-pear
|
||||||
|
|
||||||
* Mon May 8 2006 Joe Orton <jorton@redhat.com> 5.1.4-3
|
* Mon May 8 2006 Joe Orton <jorton@redhat.com> 5.1.4-3
|
||||||
- update to 5.1.4
|
- update to 5.1.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user