v7.3.0RC3
This commit is contained in:
parent
ebcc71a35d
commit
bd0c47c8b5
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ php-7.1.*.xz
|
||||
/php-7.2.10.tar.xz
|
||||
/php-7.2.11RC1.tar.xz
|
||||
/php-7.3.0RC2.tar.xz
|
||||
/php-7.3.0RC3.tar.xz
|
||||
|
@ -1,37 +0,0 @@
|
||||
From bbfea4b470f30b3d92ad73e4addf37c3e247052a Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Thu, 4 Oct 2018 11:45:35 +0200
|
||||
Subject: [PATCH] Allow to disable pcre.jit when system library is used as it
|
||||
is for now broken on some arch (s390x...)
|
||||
|
||||
---
|
||||
ext/pcre/config0.m4 | 16 +++++++++-------
|
||||
1 file changed, 9 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/ext/pcre/config0.m4 b/ext/pcre/config0.m4
|
||||
index dd1b7d55aa69..3f7f04d4fc60 100644
|
||||
--- a/ext/pcre/config0.m4
|
||||
+++ b/ext/pcre/config0.m4
|
||||
@@ -47,13 +47,15 @@ PHP_ARG_WITH(pcre-jit,,[ --with-pcre-jit Enable PCRE JIT functionality
|
||||
fi
|
||||
fi
|
||||
|
||||
- PHP_CHECK_LIBRARY(pcre2-8, pcre2_jit_compile_8,
|
||||
- [
|
||||
- AC_DEFINE(HAVE_PCRE_JIT_SUPPORT, 1, [ ])
|
||||
- ],[
|
||||
- ],[
|
||||
- $PCRE2_LIB
|
||||
- ])
|
||||
+ if test "$PHP_PCRE_JIT" != "no"; then
|
||||
+ PHP_CHECK_LIBRARY(pcre2-8, pcre2_jit_compile_8,
|
||||
+ [
|
||||
+ AC_DEFINE(HAVE_PCRE_JIT_SUPPORT, 1, [ ])
|
||||
+ ],[
|
||||
+ ],[
|
||||
+ $PCRE2_LIB
|
||||
+ ])
|
||||
+ fi
|
||||
|
||||
PHP_EVAL_INCLINE($PCRE2_INC)
|
||||
PHP_EVAL_LIBLINE($PCRE2_LIB)
|
9
php.spec
9
php.spec
@ -59,8 +59,8 @@
|
||||
%endif
|
||||
|
||||
%global upver 7.3.0
|
||||
%global rcver RC2
|
||||
%global lower rc2
|
||||
%global rcver RC3
|
||||
%global lower rc3
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -112,7 +112,6 @@ Patch46: php-7.2.4-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: https://github.com/php/php-src/commit/bbfea4b470f30b3d92ad73e4addf37c3e247052a.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -714,7 +713,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .jit
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1559,6 +1557,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 9 2018 Remi Collet <remi@remirepo.net> - 7.3.0~rc3-1
|
||||
- update to 7.3.0RC3
|
||||
|
||||
* Thu Oct 4 2018 Remi Collet <remi@remirepo.net> - 7.3.0~rc2-1
|
||||
- update to 7.3.0RC2
|
||||
- bump API numbers
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (php-7.3.0RC2.tar.xz) = 6fca734a4dfbd8ef85838439bc965f6d6773ba270207222b710ab75a0254f6c68378763274ba5d6cfe60b6ea14c134a64cb3ef607cc2ef86c7010bac1e282498
|
||||
SHA512 (php-7.3.0RC3.tar.xz) = ef441fc7608ee5ef5062b252292656d42644307b5623ebd87104ca10191080ba83d44e5984e8eef987d8bec0f0ab8139b7c2d16577fe6dcc5f02e71ba87f5ed8
|
||||
|
Loading…
Reference in New Issue
Block a user