update to 5.2.9 (bug fixes + security)
This commit is contained in:
parent
966f2388e7
commit
bc3d8326a5
@ -1 +1 @@
|
|||||||
php-5.2.8.tar.bz2
|
php-5.2.9.tar.bz2
|
||||||
|
@ -1,102 +0,0 @@
|
|||||||
--- php-5.2.8/configure.in.gnusrc
|
|
||||||
+++ php-5.2.8/configure.in
|
|
||||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
|
||||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
|
||||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
|
||||||
|
|
||||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
|
||||||
+
|
|
||||||
dnl Setting up the PHP version based on the information above.
|
|
||||||
dnl -------------------------------------------------------------------------
|
|
||||||
|
|
||||||
--- php-5.2.8/ext/interbase/interbase.c.gnusrc
|
|
||||||
+++ php-5.2.8/ext/interbase/interbase.c
|
|
||||||
@@ -24,7 +24,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
--- php-5.2.8/ext/pdo_firebird/firebird_driver.c.gnusrc
|
|
||||||
+++ php-5.2.8/ext/pdo_firebird/firebird_driver.c
|
|
||||||
@@ -22,7 +22,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_ini.h"
|
|
||||||
--- php-5.2.8/ext/standard/file.c.gnusrc
|
|
||||||
+++ php-5.2.8/ext/standard/file.c
|
|
||||||
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
|
||||||
|
|
||||||
#ifdef HAVE_FNMATCH
|
|
||||||
#ifndef _GNU_SOURCE
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#endif
|
|
||||||
#include <fnmatch.h>
|
|
||||||
#endif
|
|
||||||
--- php-5.2.8/ext/zlib/zlib_fopen_wrapper.c.gnusrc
|
|
||||||
+++ php-5.2.8/ext/zlib/zlib_fopen_wrapper.c
|
|
||||||
@@ -19,7 +19,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_zlib.h"
|
|
||||||
--- php-5.2.8/main/php.h.gnusrc
|
|
||||||
+++ php-5.2.8/main/php.h
|
|
||||||
@@ -30,6 +30,7 @@
|
|
||||||
#define PHP_HAVE_STREAMS
|
|
||||||
#define YYDEBUG 0
|
|
||||||
|
|
||||||
+#include "php_config.h"
|
|
||||||
#include "php_version.h"
|
|
||||||
#include "zend.h"
|
|
||||||
#include "zend_qsort.h"
|
|
||||||
--- php-5.2.8/main/streams/cast.c.gnusrc
|
|
||||||
+++ php-5.2.8/main/streams/cast.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
--- php-5.2.8/main/streams/memory.c.gnusrc
|
|
||||||
+++ php-5.2.8/main/streams/memory.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
PHPAPI int php_url_decode(char *str, int len);
|
|
||||||
--- php-5.2.8/main/streams/streams.c.gnusrc
|
|
||||||
+++ php-5.2.8/main/streams/streams.c
|
|
||||||
@@ -21,7 +21,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
--- php-5.2.8/Zend/zend_language_parser.c.gnusrc
|
|
||||||
+++ php-5.2.8/Zend/zend_language_parser.c
|
|
||||||
@@ -356,6 +356,8 @@
|
|
||||||
#include "zend_API.h"
|
|
||||||
#include "zend_constants.h"
|
|
||||||
|
|
||||||
+#include <string.h>
|
|
||||||
+
|
|
||||||
|
|
||||||
#define YYERROR_VERBOSE
|
|
||||||
#define YYSTYPE znode
|
|
113
php-5.2.9-gnusrc.patch
Normal file
113
php-5.2.9-gnusrc.patch
Normal file
@ -0,0 +1,113 @@
|
|||||||
|
diff -up php-5.2.9/configure.in.gnusrc php-5.2.9/configure.in
|
||||||
|
--- php-5.2.9/configure.in.gnusrc 2009-02-25 15:56:50.000000000 +0100
|
||||||
|
+++ php-5.2.9/configure.in 2009-02-27 19:33:40.000000000 +0100
|
||||||
|
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||||
|
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||||
|
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||||
|
|
||||||
|
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||||
|
+
|
||||||
|
dnl Setting up the PHP version based on the information above.
|
||||||
|
dnl -------------------------------------------------------------------------
|
||||||
|
|
||||||
|
diff -up php-5.2.9/ext/interbase/interbase.c.gnusrc php-5.2.9/ext/interbase/interbase.c
|
||||||
|
--- php-5.2.9/ext/interbase/interbase.c.gnusrc 2008-12-31 12:17:38.000000000 +0100
|
||||||
|
+++ php-5.2.9/ext/interbase/interbase.c 2009-02-27 19:33:40.000000000 +0100
|
||||||
|
@@ -24,7 +24,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
diff -up php-5.2.9/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.2.9/ext/pdo_firebird/firebird_driver.c
|
||||||
|
--- php-5.2.9/ext/pdo_firebird/firebird_driver.c.gnusrc 2008-12-31 12:17:41.000000000 +0100
|
||||||
|
+++ php-5.2.9/ext/pdo_firebird/firebird_driver.c 2009-02-27 19:33:40.000000000 +0100
|
||||||
|
@@ -22,7 +22,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_ini.h"
|
||||||
|
diff -up php-5.2.9/ext/standard/file.c.gnusrc php-5.2.9/ext/standard/file.c
|
||||||
|
--- php-5.2.9/ext/standard/file.c.gnusrc 2008-12-31 12:17:44.000000000 +0100
|
||||||
|
+++ php-5.2.9/ext/standard/file.c 2009-02-27 19:33:40.000000000 +0100
|
||||||
|
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
||||||
|
|
||||||
|
#ifdef HAVE_FNMATCH
|
||||||
|
#ifndef _GNU_SOURCE
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#endif
|
||||||
|
#include <fnmatch.h>
|
||||||
|
#endif
|
||||||
|
diff -up php-5.2.9/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.2.9/ext/zlib/zlib_fopen_wrapper.c
|
||||||
|
--- php-5.2.9/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-01-20 16:43:05.000000000 +0100
|
||||||
|
+++ php-5.2.9/ext/zlib/zlib_fopen_wrapper.c 2009-02-27 19:35:38.000000000 +0100
|
||||||
|
@@ -19,8 +19,6 @@
|
||||||
|
|
||||||
|
/* $Id: zlib_fopen_wrapper.c,v 1.46.2.1.2.7 2009/01/20 15:43:05 felipe Exp $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
-
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_zlib.h"
|
||||||
|
#include "fopen_wrappers.h"
|
||||||
|
diff -up php-5.2.9/main/php.h.gnusrc php-5.2.9/main/php.h
|
||||||
|
--- php-5.2.9/main/php.h.gnusrc 2008-12-31 12:17:47.000000000 +0100
|
||||||
|
+++ php-5.2.9/main/php.h 2009-02-27 19:33:40.000000000 +0100
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#define PHP_HAVE_STREAMS
|
||||||
|
#define YYDEBUG 0
|
||||||
|
|
||||||
|
+#include "php_config.h"
|
||||||
|
#include "php_version.h"
|
||||||
|
#include "zend.h"
|
||||||
|
#include "zend_qsort.h"
|
||||||
|
diff -up php-5.2.9/main/streams/cast.c.gnusrc php-5.2.9/main/streams/cast.c
|
||||||
|
--- php-5.2.9/main/streams/cast.c.gnusrc 2008-12-31 12:17:48.000000000 +0100
|
||||||
|
+++ php-5.2.9/main/streams/cast.c 2009-02-27 19:36:07.000000000 +0100
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id: cast.c,v 1.12.2.1.2.3 2008/12/31 11:17:48 sebastian Exp $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
diff -up php-5.2.9/main/streams/memory.c.gnusrc php-5.2.9/main/streams/memory.c
|
||||||
|
--- php-5.2.9/main/streams/memory.c.gnusrc 2008-12-31 12:17:48.000000000 +0100
|
||||||
|
+++ php-5.2.9/main/streams/memory.c 2009-02-27 19:36:40.000000000 +0100
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id: memory.c,v 1.8.2.6.2.20 2008/12/31 11:17:48 sebastian Exp $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
PHPAPI int php_url_decode(char *str, int len);
|
||||||
|
diff -up php-5.2.9/main/streams/streams.c.gnusrc php-5.2.9/main/streams/streams.c
|
||||||
|
--- php-5.2.9/main/streams/streams.c.gnusrc 2009-01-08 20:21:25.000000000 +0100
|
||||||
|
+++ php-5.2.9/main/streams/streams.c 2009-02-27 19:37:04.000000000 +0100
|
||||||
|
@@ -21,7 +21,6 @@
|
||||||
|
|
||||||
|
/* $Id: streams.c,v 1.82.2.6.2.33 2009/01/08 19:21:25 felipe Exp $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
diff -up php-5.2.9/Zend/zend_language_parser.c.gnusrc php-5.2.9/Zend/zend_language_parser.c
|
||||||
|
--- php-5.2.9/Zend/zend_language_parser.c.gnusrc 2009-02-25 16:39:52.000000000 +0100
|
||||||
|
+++ php-5.2.9/Zend/zend_language_parser.c 2009-02-27 19:33:40.000000000 +0100
|
||||||
|
@@ -356,6 +356,8 @@
|
||||||
|
#include "zend_API.h"
|
||||||
|
#include "zend_constants.h"
|
||||||
|
|
||||||
|
+#include <string.h>
|
||||||
|
+
|
||||||
|
|
||||||
|
#define YYERROR_VERBOSE
|
||||||
|
#define YYSTYPE znode
|
9
php.spec
9
php.spec
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.2.8
|
Version: 5.2.9
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
License: PHP
|
License: PHP
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://www.php.net/
|
URL: http://www.php.net/
|
||||||
@ -18,7 +18,7 @@ Source2: php.ini
|
|||||||
Source3: macros.php
|
Source3: macros.php
|
||||||
|
|
||||||
# Build fixes
|
# Build fixes
|
||||||
Patch1: php-5.2.8-gnusrc.patch
|
Patch1: php-5.2.9-gnusrc.patch
|
||||||
Patch2: php-5.2.8-install.patch
|
Patch2: php-5.2.8-install.patch
|
||||||
Patch3: php-5.2.4-norpath.patch
|
Patch3: php-5.2.4-norpath.patch
|
||||||
Patch4: php-5.2.8-phpize64.patch
|
Patch4: php-5.2.8-phpize64.patch
|
||||||
@ -777,6 +777,9 @@ rm files.* macros.php
|
|||||||
%files recode -f files.recode
|
%files recode -f files.recode
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 28 2009 Remi Collet <Fedora@FamilleCollet.com> - 5.2.9-1
|
||||||
|
- update to 5.2.9
|
||||||
|
|
||||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.8-10
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.8-10
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user