- update to 5.5.0beta4
- zend_extension doesn't requires full path - refresh patch for system libzip - drop opcache patch merged upstream - add BuildRequires libvpx-devel for WebP support in php-gd - php-fpm own /usr/share/fpm
This commit is contained in:
parent
26f57a8682
commit
ba9375f409
19
.gitignore
vendored
19
.gitignore
vendored
@ -1,21 +1,8 @@
|
|||||||
clog
|
clog
|
||||||
php.spec~
|
php.spec~
|
||||||
php-5.3*.bz2
|
php-5.3.*.bz2
|
||||||
/php-5.4.4.tar.bz2
|
php-5.4.*.bz2
|
||||||
/php-5.4.5.tar.bz2
|
|
||||||
/php-5.4.6.tar.bz2
|
|
||||||
/php-5.4.7.tar.bz2
|
|
||||||
/php-5.4.8.tar.bz2
|
|
||||||
/php-5.4.9RC1.tar.bz2
|
|
||||||
/php-5.4.9.tar.bz2
|
|
||||||
/php-5.4.10.tar.bz2
|
|
||||||
/php-5.4.11RC1.tar.bz2
|
|
||||||
/php-5.4.11.tar.bz2
|
|
||||||
/php-5.4.12RC1.tar.bz2
|
|
||||||
/php-5.4.12RC2.tar.bz2
|
|
||||||
/php-5.4.12.tar.bz2
|
|
||||||
/php-5.4.13RC1.tar.bz2
|
|
||||||
/php-5.4.13.tar.bz2
|
|
||||||
/php-5.5.0beta1.tar.xz
|
/php-5.5.0beta1.tar.xz
|
||||||
/php-5.5.0beta2.tar.xz
|
/php-5.5.0beta2.tar.xz
|
||||||
/php-5.5.0beta3.tar.xz
|
/php-5.5.0beta3.tar.xz
|
||||||
|
/php-5.5.0beta4.tar.xz
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
; Enable Zend OPcache extension module
|
; Enable Zend OPcache extension module
|
||||||
zend_extension=@EXTPATH@/opcache.so
|
zend_extension=opcache.so
|
||||||
|
|
||||||
; Determines if Zend OPCache is enabled
|
; Determines if Zend OPCache is enabled
|
||||||
opcache.enable=1
|
opcache.enable=1
|
||||||
|
@ -1,149 +0,0 @@
|
|||||||
From af967de2afc584c602c0b6d4d6731e411323d94e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dmitry Stogov <dmitry@zend.com>
|
|
||||||
Date: Wed, 10 Apr 2013 21:41:30 +0400
|
|
||||||
Subject: [PATCH] Allow wilcards in opcache.blacklist_filename
|
|
||||||
|
|
||||||
---
|
|
||||||
ext/opcache/README | 8 +++----
|
|
||||||
ext/opcache/tests/blacklist.phpt | 20 ++++++++++++++++++
|
|
||||||
ext/opcache/tests/opcache-1.blacklist | 5 +++++
|
|
||||||
ext/opcache/tests/opcache-2.blacklist | 1 +
|
|
||||||
ext/opcache/zend_accelerator_blacklist.c | 36 ++++++++++++++++++++++++++++++++
|
|
||||||
5 files changed, 66 insertions(+), 4 deletions(-)
|
|
||||||
create mode 100644 ext/opcache/tests/blacklist.phpt
|
|
||||||
create mode 100644 ext/opcache/tests/opcache-1.blacklist
|
|
||||||
create mode 100644 ext/opcache/tests/opcache-2.blacklist
|
|
||||||
|
|
||||||
diff --git a/ext/opcache/README b/ext/opcache/README
|
|
||||||
index 03386a0..3110012 100644
|
|
||||||
--- a/ext/opcache/README
|
|
||||||
+++ b/ext/opcache/README
|
|
||||||
@@ -151,13 +151,13 @@ opcache.dups_fix (default "0")
|
|
||||||
Enable this hack as a workaround for "Cannot redeclare class" errors.
|
|
||||||
|
|
||||||
opcache.blacklist_filename
|
|
||||||
- The location of the OPcache blacklist file.
|
|
||||||
- The OPcache blacklist file is a text file that holds the names of files
|
|
||||||
+ The location of the OPcache blacklist file (wildcards allowed).
|
|
||||||
+ Each OPcache blacklist file is a text file that holds the names of files
|
|
||||||
that should not be accelerated. The file format is to add each filename
|
|
||||||
to a new line. The filename may be a full path or just a file prefix
|
|
||||||
(i.e., /var/www/x blacklists all the files and directories in /var/www
|
|
||||||
- that start with 'x'). Files are usually triggered by one of the following
|
|
||||||
- three reasons:
|
|
||||||
+ that start with 'x'). Line starting with a ; are ignored (comments).
|
|
||||||
+ Files are usually triggered by one of the following three reasons:
|
|
||||||
1) Directories that contain auto generated code, like Smarty or ZFW cache.
|
|
||||||
2) Code that does not work well when accelerated, due to some delayed
|
|
||||||
compile time evaluation.
|
|
||||||
diff --git a/ext/opcache/tests/blacklist.phpt b/ext/opcache/tests/blacklist.phpt
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..f4a3472
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/ext/opcache/tests/blacklist.phpt
|
|
||||||
@@ -0,0 +1,20 @@
|
|
||||||
+--TEST--
|
|
||||||
+Blacklist (with glob, quote and comments)
|
|
||||||
+--INI--
|
|
||||||
+opcache.enable=1
|
|
||||||
+opcache.enable_cli=1
|
|
||||||
+opcache.blacklist_filename={PWD}/opcache-*.blacklist
|
|
||||||
+--SKIPIF--
|
|
||||||
+<?php require_once('skipif.inc'); ?>
|
|
||||||
+--FILE--
|
|
||||||
+<?php
|
|
||||||
+$conf = opcache_get_configuration();
|
|
||||||
+print_r($conf['blacklist']);
|
|
||||||
+?>
|
|
||||||
+--EXPECT--
|
|
||||||
+Array
|
|
||||||
+(
|
|
||||||
+ [0] => /path/to/foo
|
|
||||||
+ [1] => /path/to/foo2
|
|
||||||
+ [2] => /path/to/bar
|
|
||||||
+)
|
|
||||||
\ No newline at end of file
|
|
||||||
diff --git a/ext/opcache/tests/opcache-1.blacklist b/ext/opcache/tests/opcache-1.blacklist
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..5f498d6
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/ext/opcache/tests/opcache-1.blacklist
|
|
||||||
@@ -0,0 +1,5 @@
|
|
||||||
+; comments are allowed in blacklist file
|
|
||||||
+; and empty line are ignored
|
|
||||||
+
|
|
||||||
+/path/to/foo
|
|
||||||
+"/path/to/foo2"
|
|
||||||
\ No newline at end of file
|
|
||||||
diff --git a/ext/opcache/tests/opcache-2.blacklist b/ext/opcache/tests/opcache-2.blacklist
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..4f6580a
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/ext/opcache/tests/opcache-2.blacklist
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+/path/to/bar
|
|
||||||
diff --git a/ext/opcache/zend_accelerator_blacklist.c b/ext/opcache/zend_accelerator_blacklist.c
|
|
||||||
index 764c950..b09d0e5 100644
|
|
||||||
--- a/ext/opcache/zend_accelerator_blacklist.c
|
|
||||||
+++ b/ext/opcache/zend_accelerator_blacklist.c
|
|
||||||
@@ -36,6 +36,14 @@
|
|
||||||
# define REGEX_MODE (REG_EXTENDED|REG_NOSUB)
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#ifdef HAVE_GLOB
|
|
||||||
+#ifdef PHP_WIN32
|
|
||||||
+#include "win32/glob.h"
|
|
||||||
+#else
|
|
||||||
+#include <glob.h>
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
#define ZEND_BLACKLIST_BLOCK_SIZE 32
|
|
||||||
|
|
||||||
struct _zend_regexp_list {
|
|
||||||
@@ -168,7 +176,11 @@ static inline void zend_accel_blacklist_allocate(zend_blacklist *blacklist)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+#ifdef HAVE_GLOB
|
|
||||||
+static void zend_accel_blacklist_loadone(zend_blacklist *blacklist, char *filename)
|
|
||||||
+#else
|
|
||||||
void zend_accel_blacklist_load(zend_blacklist *blacklist, char *filename)
|
|
||||||
+#endif
|
|
||||||
{
|
|
||||||
char buf[MAXPATHLEN + 1], real_path[MAXPATHLEN + 1];
|
|
||||||
FILE *fp;
|
|
||||||
@@ -238,6 +250,30 @@ void zend_accel_blacklist_load(zend_blacklist *blacklist, char *filename)
|
|
||||||
zend_accel_blacklist_update_regexp(blacklist);
|
|
||||||
}
|
|
||||||
|
|
||||||
+#ifdef HAVE_GLOB
|
|
||||||
+void zend_accel_blacklist_load(zend_blacklist *blacklist, char *filename)
|
|
||||||
+{
|
|
||||||
+ glob_t globbuf;
|
|
||||||
+ int ret, i;
|
|
||||||
+
|
|
||||||
+ memset(&globbuf, 0, sizeof(glob_t));
|
|
||||||
+
|
|
||||||
+ ret = glob(filename, 0, NULL, &globbuf);
|
|
||||||
+#ifdef GLOB_NOMATCH
|
|
||||||
+ if (ret == GLOB_NOMATCH || !globbuf.gl_pathc) {
|
|
||||||
+#else
|
|
||||||
+ if (!globbuf.gl_pathc) {
|
|
||||||
+#endif
|
|
||||||
+ zend_accel_error(ACCEL_LOG_WARNING, "No blacklist file found matching: %s\n", filename);
|
|
||||||
+ } else {
|
|
||||||
+ for(i=0 ; i<globbuf.gl_pathc; i++) {
|
|
||||||
+ zend_accel_blacklist_loadone(blacklist, globbuf.gl_pathv[i]);
|
|
||||||
+ }
|
|
||||||
+ globfree(&globbuf);
|
|
||||||
+ }
|
|
||||||
+}
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
zend_bool zend_accel_blacklist_is_blacklisted(zend_blacklist *blacklist, char *verify_path)
|
|
||||||
{
|
|
||||||
int ret = 0;
|
|
||||||
--
|
|
||||||
1.7.11.5
|
|
||||||
|
|
@ -1,22 +1,14 @@
|
|||||||
diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
|
diff -up php5.5-201304181030/ext/zip/config.m4.systzip php5.5-201304181030/ext/zip/config.m4
|
||||||
--- php-5.4.5RC1/ext/zip/config.m4.systzip 2012-07-04 07:43:14.000000000 +0200
|
--- php5.5-201304181030/ext/zip/config.m4.systzip 2012-12-05 11:40:39.000000000 +0100
|
||||||
+++ php-5.4.5RC1/ext/zip/config.m4 2012-07-07 15:56:41.418171233 +0200
|
+++ php5.5-201304181030/ext/zip/config.m4 2013-04-18 13:17:32.144550036 +0200
|
||||||
@@ -13,65 +13,116 @@
|
@@ -13,65 +13,116 @@ fi
|
||||||
PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
||||||
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
|
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
|
||||||
|
|
||||||
-if test "$PHP_ZIP" != "no"; then
|
|
||||||
+PHP_ARG_WITH(libzip, libzip,
|
+PHP_ARG_WITH(libzip, libzip,
|
||||||
+[ --with-libzip[=DIR] ZIP: use libzip], no, no)
|
+[ --with-libzip[=DIR] ZIP: use libzip], no, no)
|
||||||
|
+
|
||||||
- if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
|
if test "$PHP_ZIP" != "no"; then
|
||||||
- if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
|
|
||||||
- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
|
|
||||||
- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
|
|
||||||
- elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
|
|
||||||
- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
|
|
||||||
- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
|
|
||||||
+if test "$PHP_ZIP" != "no"; then
|
|
||||||
+ if test "$PHP_LIBZIP" != "no"; then
|
+ if test "$PHP_LIBZIP" != "no"; then
|
||||||
+
|
+
|
||||||
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
|
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
|
||||||
@ -32,7 +24,14 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
|
|||||||
+ LIBZIP_CFLAGS=`$PKG_CONFIG libzip --cflags`
|
+ LIBZIP_CFLAGS=`$PKG_CONFIG libzip --cflags`
|
||||||
+ LIBZIP_LIBDIR=`$PKG_CONFIG libzip --variable=libdir`
|
+ LIBZIP_LIBDIR=`$PKG_CONFIG libzip --variable=libdir`
|
||||||
+ AC_MSG_RESULT(from pkgconfig: found in $LIBZIP_LIBDIR)
|
+ AC_MSG_RESULT(from pkgconfig: found in $LIBZIP_LIBDIR)
|
||||||
+
|
|
||||||
|
- if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
|
||||||
|
- if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
|
||||||
|
- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
|
||||||
|
- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
|
||||||
|
- elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
|
||||||
|
- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
|
||||||
|
- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
|
||||||
else
|
else
|
||||||
- AC_MSG_ERROR([Can not find zlib headers under "$PHP_ZLIB_DIR"])
|
- AC_MSG_ERROR([Can not find zlib headers under "$PHP_ZLIB_DIR"])
|
||||||
+ for i in /usr/local /usr; do
|
+ for i in /usr/local /usr; do
|
||||||
@ -43,12 +42,12 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
|
|||||||
+ break
|
+ break
|
||||||
+ fi
|
+ fi
|
||||||
+ done
|
+ done
|
||||||
+ fi
|
fi
|
||||||
+
|
+
|
||||||
+ if test -z "$LIBZIP_LIBDIR"; then
|
+ if test -z "$LIBZIP_LIBDIR"; then
|
||||||
+ AC_MSG_RESULT(not found)
|
+ AC_MSG_RESULT(not found)
|
||||||
+ AC_MSG_ERROR(Please reinstall the libzip distribution)
|
+ AC_MSG_ERROR(Please reinstall the libzip distribution)
|
||||||
fi
|
+ fi
|
||||||
+
|
+
|
||||||
+ dnl Could not think of a simple way to check libzip for overwrite support
|
+ dnl Could not think of a simple way to check libzip for overwrite support
|
||||||
+ PHP_CHECK_LIBRARY(zip, zip_open,
|
+ PHP_CHECK_LIBRARY(zip, zip_open,
|
||||||
@ -160,7 +159,7 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
|
|||||||
lib/zip_fread.c lib/zip_open.c lib/zip_source_filep.c \
|
lib/zip_fread.c lib/zip_open.c lib/zip_source_filep.c \
|
||||||
lib/zip_strerror.c lib/zip_close.c lib/zip_error_get.c \
|
lib/zip_strerror.c lib/zip_close.c lib/zip_error_get.c \
|
||||||
lib/zip_file_error_get.c lib/zip_free.c lib/zip_rename.c \
|
lib/zip_file_error_get.c lib/zip_free.c lib/zip_rename.c \
|
||||||
@@ -98,10 +149,11 @@
|
@@ -98,10 +149,11 @@ yes
|
||||||
lib/zip_source_open.c lib/zip_source_pkware.c lib/zip_source_pop.c \
|
lib/zip_source_open.c lib/zip_source_pkware.c lib/zip_source_pop.c \
|
||||||
lib/zip_source_read.c lib/zip_source_stat.c"
|
lib/zip_source_read.c lib/zip_source_stat.c"
|
||||||
|
|
||||||
@ -176,13 +175,14 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
|
|||||||
|
|
||||||
dnl so we always include the known-good working hack.
|
dnl so we always include the known-good working hack.
|
||||||
PHP_ADD_MAKEFILE_FRAGMENT
|
PHP_ADD_MAKEFILE_FRAGMENT
|
||||||
diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
|
diff -up php5.5-201304181030/ext/zip/php_zip.c.systzip php5.5-201304181030/ext/zip/php_zip.c
|
||||||
--- php-5.4.5RC1/ext/zip/php_zip.c.systzip 2012-07-04 07:43:14.000000000 +0200
|
--- php5.5-201304181030/ext/zip/php_zip.c.systzip 2013-04-10 22:36:34.000000000 +0200
|
||||||
+++ php-5.4.5RC1/ext/zip/php_zip.c 2012-07-07 15:59:12.728676026 +0200
|
+++ php5.5-201304181030/ext/zip/php_zip.c 2013-04-18 13:23:29.997871990 +0200
|
||||||
@@ -29,8 +29,232 @@
|
@@ -30,8 +30,233 @@
|
||||||
#include "ext/standard/php_string.h"
|
|
||||||
#include "ext/pcre/php_pcre.h"
|
#include "ext/pcre/php_pcre.h"
|
||||||
|
#include "ext/standard/php_filestat.h"
|
||||||
#include "php_zip.h"
|
#include "php_zip.h"
|
||||||
|
+
|
||||||
+#if defined(HAVE_LIBZIP)
|
+#if defined(HAVE_LIBZIP)
|
||||||
+#include <zip.h>
|
+#include <zip.h>
|
||||||
+
|
+
|
||||||
@ -412,7 +412,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
|
|||||||
|
|
||||||
/* zip_open is a macro for renaming libzip zipopen, so we need to use PHP_NAMED_FUNCTION */
|
/* zip_open is a macro for renaming libzip zipopen, so we need to use PHP_NAMED_FUNCTION */
|
||||||
static PHP_NAMED_FUNCTION(zif_zip_open);
|
static PHP_NAMED_FUNCTION(zif_zip_open);
|
||||||
@@ -1624,6 +1848,10 @@ static ZIPARCHIVE_METHOD(addEmptyDir)
|
@@ -1631,6 +1856,10 @@ static ZIPARCHIVE_METHOD(addEmptyDir)
|
||||||
}
|
}
|
||||||
|
|
||||||
idx = zip_stat(intern, s, 0, &sb);
|
idx = zip_stat(intern, s, 0, &sb);
|
||||||
@ -423,7 +423,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
|
|||||||
if (idx >= 0) {
|
if (idx >= 0) {
|
||||||
RETVAL_FALSE;
|
RETVAL_FALSE;
|
||||||
} else {
|
} else {
|
||||||
@@ -1846,6 +2074,10 @@ static ZIPARCHIVE_METHOD(addFromString)
|
@@ -1853,6 +2082,10 @@ static ZIPARCHIVE_METHOD(addFromString)
|
||||||
}
|
}
|
||||||
|
|
||||||
cur_idx = zip_name_locate(intern, (const char *)name, 0);
|
cur_idx = zip_name_locate(intern, (const char *)name, 0);
|
||||||
@ -434,7 +434,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
|
|||||||
/* TODO: fix _zip_replace */
|
/* TODO: fix _zip_replace */
|
||||||
if (cur_idx >= 0) {
|
if (cur_idx >= 0) {
|
||||||
if (zip_delete(intern, cur_idx) == -1) {
|
if (zip_delete(intern, cur_idx) == -1) {
|
||||||
@@ -2870,5 +3098,9 @@ static PHP_MINFO_FUNCTION(zip)
|
@@ -2877,5 +3110,9 @@ static PHP_MINFO_FUNCTION(zip)9
|
||||||
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
|
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
|
||||||
- php_info_print_table_row(2, "Libzip version", LIBZIP_VERSION);
|
- php_info_print_table_row(2, "Libzip version", LIBZIP_VERSION);
|
||||||
+#if defined(HAVE_LIBZIP)
|
+#if defined(HAVE_LIBZIP)
|
||||||
@ -445,9 +445,9 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
|
|||||||
|
|
||||||
php_info_print_table_end();
|
php_info_print_table_end();
|
||||||
}
|
}
|
||||||
diff -up php-5.4.5RC1/ext/zip/php_zip.h.systzip php-5.4.5RC1/ext/zip/php_zip.h
|
diff -up php5.5-201304181030/ext/zip/php_zip.h.systzip php5.5-201304181030/ext/zip/php_zip.h
|
||||||
--- php-5.4.5RC1/ext/zip/php_zip.h.systzip 2012-07-04 07:43:14.000000000 +0200
|
--- php5.5-201304181030/ext/zip/php_zip.h.systzip 2013-01-01 11:36:17.000000000 +0100
|
||||||
+++ php-5.4.5RC1/ext/zip/php_zip.h 2012-07-07 15:57:34.845319432 +0200
|
+++ php5.5-201304181030/ext/zip/php_zip.h 2013-04-18 13:17:32.147550046 +0200
|
||||||
@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
|
@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
|
||||||
#include "TSRM.h"
|
#include "TSRM.h"
|
||||||
#endif
|
#endif
|
||||||
@ -460,9 +460,9 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.h.systzip php-5.4.5RC1/ext/zip/php_zip.h
|
|||||||
|
|
||||||
#define PHP_ZIP_VERSION_STRING "1.11.0"
|
#define PHP_ZIP_VERSION_STRING "1.11.0"
|
||||||
|
|
||||||
diff -up php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip php-5.4.5RC1/ext/zip/tests/bug38943.phpt
|
diff -up php5.5-201304181030/ext/zip/tests/bug38943.phpt.systzip php5.5-201304181030/ext/zip/tests/bug38943.phpt
|
||||||
--- php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip 2012-07-04 07:43:14.000000000 +0200
|
--- php5.5-201304181030/ext/zip/tests/bug38943.phpt.systzip 2012-12-05 11:40:39.000000000 +0100
|
||||||
+++ php-5.4.5RC1/ext/zip/tests/bug38943.phpt 2012-07-07 15:56:41.422171242 +0200
|
+++ php5.5-201304181030/ext/zip/tests/bug38943.phpt 2013-04-18 13:17:32.147550046 +0200
|
||||||
@@ -27,7 +27,7 @@ array(1) {
|
@@ -27,7 +27,7 @@ array(1) {
|
||||||
[0]=>
|
[0]=>
|
||||||
int(1)
|
int(1)
|
||||||
@ -472,9 +472,9 @@ diff -up php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip php-5.4.5RC1/ext/zip/t
|
|||||||
["test":"myZip":private]=>
|
["test":"myZip":private]=>
|
||||||
int(0)
|
int(0)
|
||||||
["testp"]=>
|
["testp"]=>
|
||||||
diff -up php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.5RC1/ext/zip/tests/pecl12414.phpt
|
diff -up php5.5-201304181030/ext/zip/tests/pecl12414.phpt.systzip php5.5-201304181030/ext/zip/tests/pecl12414.phpt
|
||||||
--- php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip 2012-07-04 07:43:14.000000000 +0200
|
--- php5.5-201304181030/ext/zip/tests/pecl12414.phpt.systzip 2012-12-05 11:40:39.000000000 +0100
|
||||||
+++ php-5.4.5RC1/ext/zip/tests/pecl12414.phpt 2012-07-07 15:56:41.422171242 +0200
|
+++ php5.5-201304181030/ext/zip/tests/pecl12414.phpt 2013-04-18 13:17:32.148550050 +0200
|
||||||
@@ -5,6 +5,8 @@ Bug #12414 ( extracting files from damag
|
@@ -5,6 +5,8 @@ Bug #12414 ( extracting files from damag
|
||||||
/*$ */
|
/*$ */
|
||||||
if(!extension_loaded('zip')) die('skip');
|
if(!extension_loaded('zip')) die('skip');
|
||||||
@ -484,9 +484,9 @@ diff -up php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.5RC1/ext/zip/
|
|||||||
--FILE--
|
--FILE--
|
||||||
<?php
|
<?php
|
||||||
$filename = 'MYLOGOV2.GFX';
|
$filename = 'MYLOGOV2.GFX';
|
||||||
diff -up php-5.4.5RC1/ext/zip/zip_stream.c.systzip php-5.4.5RC1/ext/zip/zip_stream.c
|
diff -up php5.5-201304181030/ext/zip/zip_stream.c.systzip php5.5-201304181030/ext/zip/zip_stream.c
|
||||||
--- php-5.4.5RC1/ext/zip/zip_stream.c.systzip 2012-07-04 07:43:14.000000000 +0200
|
--- php5.5-201304181030/ext/zip/zip_stream.c.systzip 2012-12-05 11:40:39.000000000 +0100
|
||||||
+++ php-5.4.5RC1/ext/zip/zip_stream.c 2012-07-07 15:56:41.423171244 +0200
|
+++ php5.5-201304181030/ext/zip/zip_stream.c 2013-04-18 13:17:32.149550054 +0200
|
||||||
@@ -6,7 +6,11 @@
|
@@ -6,7 +6,11 @@
|
||||||
#if HAVE_ZIP
|
#if HAVE_ZIP
|
||||||
#ifdef ZEND_ENGINE_2
|
#ifdef ZEND_ENGINE_2
|
48
php.spec
48
php.spec
@ -45,6 +45,9 @@
|
|||||||
|
|
||||||
%global with_dtrace 1
|
%global with_dtrace 1
|
||||||
|
|
||||||
|
# build with system libgd, not yet ready
|
||||||
|
%global with_libgd 0
|
||||||
|
|
||||||
%if 0%{?fedora} < 17 && 0%{?rhel} < 7
|
%if 0%{?fedora} < 17 && 0%{?rhel} < 7
|
||||||
%global with_zip 0
|
%global with_zip 0
|
||||||
%global with_libzip 0
|
%global with_libzip 0
|
||||||
@ -61,12 +64,12 @@
|
|||||||
%global db_devel libdb-devel
|
%global db_devel libdb-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global rcver beta3
|
%global rcver beta4
|
||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.5.0
|
Version: 5.5.0
|
||||||
Release: 0.4.%{rcver}%{?dist}
|
Release: 0.5.%{rcver}%{?dist}
|
||||||
# All files licensed under PHP version 3.01, except
|
# All files licensed under PHP version 3.01, except
|
||||||
# Zend is licensed under Zend
|
# Zend is licensed under Zend
|
||||||
# TSRM is licensed under BSD
|
# TSRM is licensed under BSD
|
||||||
@ -105,15 +108,13 @@ Patch42: php-5.3.1-systzdata-v10.patch
|
|||||||
# See http://bugs.php.net/53436
|
# See http://bugs.php.net/53436
|
||||||
Patch43: php-5.4.0-phpize.patch
|
Patch43: php-5.4.0-phpize.patch
|
||||||
# Use system libzip instead of bundled one
|
# Use system libzip instead of bundled one
|
||||||
Patch44: php-5.4.5-system-libzip.patch
|
Patch44: php-5.5.0-system-libzip.patch
|
||||||
# Use -lldap_r for OpenLDAP
|
# Use -lldap_r for OpenLDAP
|
||||||
Patch45: php-5.4.8-ldap_r.patch
|
Patch45: php-5.4.8-ldap_r.patch
|
||||||
# Make php_config.h constant across builds
|
# Make php_config.h constant across builds
|
||||||
Patch46: php-5.4.9-fixheader.patch
|
Patch46: php-5.4.9-fixheader.patch
|
||||||
# drop "Configure command" from phpinfo output
|
# drop "Configure command" from phpinfo output
|
||||||
Patch47: php-5.4.9-phpinfo.patch
|
Patch47: php-5.4.9-phpinfo.patch
|
||||||
# Allow wildcard il opcache.backlist_filename
|
|
||||||
Patch48: php-5.5.0-opcache.patch
|
|
||||||
|
|
||||||
|
|
||||||
# Fixes for tests
|
# Fixes for tests
|
||||||
@ -558,9 +559,17 @@ Group: Development/Languages
|
|||||||
# libgd is licensed under BSD
|
# libgd is licensed under BSD
|
||||||
License: PHP and BSD
|
License: PHP and BSD
|
||||||
Requires: php-common%{?_isa} = %{version}-%{release}
|
Requires: php-common%{?_isa} = %{version}-%{release}
|
||||||
|
BuildRequires: t1lib-devel
|
||||||
|
%if %{with_libgd}
|
||||||
|
BuildRequires: gd-devel
|
||||||
|
%else
|
||||||
# Required to build the bundled GD library
|
# Required to build the bundled GD library
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, freetype-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: libXpm-devel, t1lib-devel
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: freetype-devel
|
||||||
|
BuildRequires: libXpm-devel
|
||||||
|
BuildRequires: libvpx-devel
|
||||||
|
%endif
|
||||||
|
|
||||||
%description gd
|
%description gd
|
||||||
The php-gd package contains a dynamic shared object that will add
|
The php-gd package contains a dynamic shared object that will add
|
||||||
@ -723,7 +732,6 @@ support for using the enchant library to PHP.
|
|||||||
%endif
|
%endif
|
||||||
%patch46 -p1 -b .fixheader
|
%patch46 -p1 -b .fixheader
|
||||||
%patch47 -p1 -b .phpinfo
|
%patch47 -p1 -b .phpinfo
|
||||||
%patch48 -p1 -b .opcache
|
|
||||||
|
|
||||||
# Prevent %%doc confusion over LICENSE files
|
# Prevent %%doc confusion over LICENSE files
|
||||||
cp Zend/LICENSE Zend/ZEND_LICENSE
|
cp Zend/LICENSE Zend/ZEND_LICENSE
|
||||||
@ -867,6 +875,7 @@ ln -sf ../configure
|
|||||||
--with-freetype-dir=%{_prefix} \
|
--with-freetype-dir=%{_prefix} \
|
||||||
--with-png-dir=%{_prefix} \
|
--with-png-dir=%{_prefix} \
|
||||||
--with-xpm-dir=%{_prefix} \
|
--with-xpm-dir=%{_prefix} \
|
||||||
|
--with-vpx-dir=%{_prefix} \
|
||||||
--enable-gd-native-ttf \
|
--enable-gd-native-ttf \
|
||||||
--with-t1lib=%{_prefix} \
|
--with-t1lib=%{_prefix} \
|
||||||
--without-gdbm \
|
--without-gdbm \
|
||||||
@ -901,7 +910,11 @@ build --libdir=%{_libdir}/php \
|
|||||||
--with-imap=shared --with-imap-ssl \
|
--with-imap=shared --with-imap-ssl \
|
||||||
--enable-mbstring=shared \
|
--enable-mbstring=shared \
|
||||||
--enable-mbregex \
|
--enable-mbregex \
|
||||||
|
%if %{with_libgd}
|
||||||
|
--with-gd=shared,%{_prefix} \
|
||||||
|
%else
|
||||||
--with-gd=shared \
|
--with-gd=shared \
|
||||||
|
%endif
|
||||||
--with-gmp=shared \
|
--with-gmp=shared \
|
||||||
--enable-calendar=shared \
|
--enable-calendar=shared \
|
||||||
--enable-bcmath=shared \
|
--enable-bcmath=shared \
|
||||||
@ -1027,7 +1040,11 @@ build --includedir=%{_includedir}/php-zts \
|
|||||||
--with-imap=shared --with-imap-ssl \
|
--with-imap=shared --with-imap-ssl \
|
||||||
--enable-mbstring=shared \
|
--enable-mbstring=shared \
|
||||||
--enable-mbregex \
|
--enable-mbregex \
|
||||||
|
%if %{with_libgd}
|
||||||
|
--with-gd=shared,%{_prefix} \
|
||||||
|
%else
|
||||||
--with-gd=shared \
|
--with-gd=shared \
|
||||||
|
%endif
|
||||||
--with-gmp=shared \
|
--with-gmp=shared \
|
||||||
--enable-calendar=shared \
|
--enable-calendar=shared \
|
||||||
--enable-bcmath=shared \
|
--enable-bcmath=shared \
|
||||||
@ -1289,10 +1306,8 @@ for mod in pgsql odbc ldap snmp xmlrpc imap \
|
|||||||
fi
|
fi
|
||||||
# some extensions have their own config file
|
# some extensions have their own config file
|
||||||
if [ -f ${ini} ]; then
|
if [ -f ${ini} ]; then
|
||||||
sed -e 's:@EXTPATH@:%{_libdir}/php/modules:' \
|
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
|
||||||
${ini} >$RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
|
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
|
||||||
sed -e 's:@EXTPATH@:%{_libdir}/php-zts/modules:' \
|
|
||||||
${ini} >$RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
|
|
||||||
else
|
else
|
||||||
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini} <<EOF
|
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini} <<EOF
|
||||||
; Enable ${mod} extension module
|
; Enable ${mod} extension module
|
||||||
@ -1499,6 +1514,7 @@ fi
|
|||||||
%attr(770,apache,root) %dir %{_localstatedir}/log/php-fpm
|
%attr(770,apache,root) %dir %{_localstatedir}/log/php-fpm
|
||||||
%dir /run/php-fpm
|
%dir /run/php-fpm
|
||||||
%{_mandir}/man8/php-fpm.8*
|
%{_mandir}/man8/php-fpm.8*
|
||||||
|
%dir %{_datadir}/fpm
|
||||||
%{_datadir}/fpm/status.html
|
%{_datadir}/fpm/status.html
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -1559,6 +1575,14 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 25 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.5.beta4
|
||||||
|
- update to 5.5.0beta4
|
||||||
|
- zend_extension doesn't requires full path
|
||||||
|
- refresh patch for system libzip
|
||||||
|
- drop opcache patch merged upstream
|
||||||
|
- add BuildRequires libvpx-devel for WebP support in php-gd
|
||||||
|
- php-fpm own /usr/share/fpm
|
||||||
|
|
||||||
* Thu Apr 11 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.4.beta3
|
* Thu Apr 11 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.4.beta3
|
||||||
- update to 5.5.0beta3
|
- update to 5.5.0beta3
|
||||||
- allow wildcard in opcache.blacklist_filename and provide
|
- allow wildcard in opcache.blacklist_filename and provide
|
||||||
|
Loading…
Reference in New Issue
Block a user