* Wed Sep 14 2005 Joe Orton <jorton@redhat.com> 5.0.5-3
- update to 5.0.5 - add fix for upstream #34435 - devel: require autoconf, automake (#159283) - pear: update to HTTP-1.3.6, Mail-1.1.8, Net_SMTP-1.2.7, XML_RPC-1.4.1
This commit is contained in:
parent
e6c3d5afe0
commit
b3bd894c98
15
.cvsignore
15
.cvsignore
@ -1,15 +1,4 @@
|
||||
php-5.0.3.tar.gz
|
||||
php-5.0.4.tar.gz
|
||||
*.rpm
|
||||
i386
|
||||
DB-1.7.5.tgz
|
||||
php-4.3.9.tar.gz
|
||||
php-4.3.10.tar.gz
|
||||
php-4.3.11.tar.gz
|
||||
DB-1.7.5.tgz
|
||||
Mail-1.1.4.tgz
|
||||
HTTP-1.3.5.tgz
|
||||
Net_Socket-1.0.6.tgz
|
||||
XML_Parser-1.2.6.tgz
|
||||
Net_SMTP-1.2.6.tgz
|
||||
DB-1.7.6.tgz
|
||||
*.tgz
|
||||
*.tar.gz
|
||||
|
@ -1,25 +1,25 @@
|
||||
|
||||
Install phpize into libdir.
|
||||
|
||||
--- php-5.0.2/scripts/Makefile.frag.phpize64
|
||||
+++ php-5.0.2/scripts/Makefile.frag
|
||||
--- php-5.0.5/scripts/Makefile.frag.phpize64
|
||||
+++ php-5.0.5/scripts/Makefile.frag
|
||||
@@ -4,7 +4,7 @@
|
||||
#
|
||||
|
||||
phpincludedir = $(includedir)/php
|
||||
-phpbuilddir = $(prefix)/lib/php/build
|
||||
-phpbuilddir = $(libdir)/build
|
||||
+phpbuilddir = $(libdir)/php/build
|
||||
|
||||
BUILD_FILES = \
|
||||
scripts/phpize.m4 \
|
||||
--- php-5.0.2/scripts/phpize.in.phpize64
|
||||
+++ php-5.0.2/scripts/phpize.in
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
--- php-5.0.5/scripts/phpize.in.phpize64
|
||||
+++ php-5.0.5/scripts/phpize.in
|
||||
@@ -3,7 +3,7 @@
|
||||
# Variable declaration
|
||||
prefix='@prefix@'
|
||||
-phpdir="$prefix/lib/php/build"
|
||||
exec_prefix="`eval echo @exec_prefix@`"
|
||||
-phpdir="`eval echo @libdir@`/build"
|
||||
+phpdir="@libdir@/php/build"
|
||||
includedir="$prefix/include/php"
|
||||
includedir="`eval echo @includedir@`/php"
|
||||
builddir="`pwd`"
|
||||
|
||||
|
@ -6,19 +6,19 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
- passed to run-tests.php to ensure it's passed when running each test case
|
||||
- in cases where the PHP executable is run by a test case
|
||||
|
||||
--- php-5.0.4/ext/xml/tests/bug32001.phpt.tests
|
||||
+++ php-5.0.4/ext/xml/tests/bug32001.phpt
|
||||
@@ -151,7 +151,7 @@
|
||||
new testcase("GB2312", 1),
|
||||
--- php-5.0.5/ext/xml/tests/bug32001.phpt.tests-dashn
|
||||
+++ php-5.0.5/ext/xml/tests/bug32001.phpt
|
||||
@@ -155,7 +155,7 @@
|
||||
);
|
||||
|
||||
-preg_match("/^libxml2 Version.*\$/im", `$_ENV[TEST_PHP_EXECUTABLE] -i`, $match);
|
||||
+preg_match("/^libxml2 Version.*\$/im", `$_ENV[TEST_PHP_EXECUTABLE] -i -n`, $match);
|
||||
|
||||
echo $match[0], "\n";
|
||||
|
||||
--- php-5.0.4/ext/standard/tests/file/proc_open01.phpt.tests
|
||||
+++ php-5.0.4/ext/standard/tests/file/proc_open01.phpt
|
||||
if (XML_SAX_IMPL == 'libxml') {
|
||||
- preg_match("/^libxml2 Version.*\$/im", `$_ENV[TEST_PHP_EXECUTABLE] -i`, $match);
|
||||
+ preg_match("/^libxml2 Version.*\$/im", `$_ENV[TEST_PHP_EXECUTABLE] -i -n`, $match);
|
||||
echo $match[0], "\n";
|
||||
} else {
|
||||
echo "libxml2 Version => NONE\n";
|
||||
--- php-5.0.5/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||
+++ php-5.0.5/ext/standard/tests/file/proc_open01.phpt
|
||||
@@ -9,7 +9,7 @@
|
||||
die("no php executable defined");
|
||||
}
|
||||
@ -28,8 +28,8 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
||||
$pipes
|
||||
);
|
||||
--- php-5.0.4/ext/standard/tests/file/bug26938.phpt.tests
|
||||
+++ php-5.0.4/ext/standard/tests/file/bug26938.phpt
|
||||
--- php-5.0.5/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||
+++ php-5.0.5/ext/standard/tests/file/bug26938.phpt
|
||||
@@ -5,7 +5,7 @@
|
||||
$out = array();
|
||||
$status = -1;
|
||||
@ -39,8 +39,8 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
--- php-5.0.4/ext/standard/tests/file/bug26615.phpt.tests
|
||||
+++ php-5.0.4/ext/standard/tests/file/bug26615.phpt
|
||||
--- php-5.0.5/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||
+++ php-5.0.5/ext/standard/tests/file/bug26615.phpt
|
||||
@@ -4,7 +4,7 @@
|
||||
<?php
|
||||
$out = array();
|
||||
@ -50,8 +50,8 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
print_r($out);
|
||||
?>
|
||||
--EXPECT--
|
||||
--- php-5.0.4/tests/lang/bug21800.phpt.tests
|
||||
+++ php-5.0.4/tests/lang/bug21800.phpt
|
||||
--- php-5.0.5/tests/lang/bug21800.phpt.tests-dashn
|
||||
+++ php-5.0.5/tests/lang/bug21800.phpt
|
||||
@@ -5,7 +5,7 @@
|
||||
--FILE--
|
||||
<?php
|
||||
@ -61,8 +61,8 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
if ($fh !== false) {
|
||||
fwrite($fh, "<?php echo ':test:'; ?>\n\n");
|
||||
fclose($fh);
|
||||
--- php-5.0.4/Makefile.global.tests
|
||||
+++ php-5.0.4/Makefile.global
|
||||
--- php-5.0.5/Makefile.global.tests-dashn
|
||||
+++ php-5.0.5/Makefile.global
|
||||
@@ -51,11 +51,11 @@
|
||||
install-su: install-pear install-tester
|
||||
|
||||
|
@ -2,8 +2,8 @@
|
||||
The wddx tests presume that "2040-06-12T04:32:12" cannot be parsed;
|
||||
that's only true on platforms with a 32-bit time_t.
|
||||
|
||||
--- php-5.0.4/ext/wddx/tests/001.phpt.wddxtests
|
||||
+++ php-5.0.4/ext/wddx/tests/001.phpt
|
||||
--- php-5.0.5/ext/wddx/tests/001.phpt.tests-wddx
|
||||
+++ php-5.0.5/ext/wddx/tests/001.phpt
|
||||
@@ -18,7 +18,7 @@
|
||||
["aDateTime2"]=>
|
||||
int(329632332)
|
||||
@ -13,13 +13,13 @@ that's only true on platforms with a 32-bit time_t.
|
||||
["aBoolean"]=>
|
||||
bool(true)
|
||||
["anArray"]=>
|
||||
--- php-5.0.4/ext/wddx/tests/wddx.xml.wddxtests
|
||||
+++ php-5.0.4/ext/wddx/tests/wddx.xml
|
||||
--- php-5.0.5/ext/wddx/tests/wddx.xml.tests-wddx
|
||||
+++ php-5.0.5/ext/wddx/tests/wddx.xml
|
||||
@@ -20,7 +20,7 @@
|
||||
<dateTime>1980-06-12T04:32:12+00</dateTime>
|
||||
</var>
|
||||
<var name='aDateTime3'>
|
||||
- <dateTime>2040-06-12T04:32:12</dateTime>
|
||||
- <dateTime>2040-06-12T04:32:12+00</dateTime>
|
||||
+ <dateTime>NotADateTime</dateTime>
|
||||
</var>
|
||||
<var name='aBoolean'>
|
||||
|
34
php.spec
34
php.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
|
||||
Name: php
|
||||
Version: 5.0.4
|
||||
Release: 11
|
||||
Version: 5.0.5
|
||||
Release: 3
|
||||
License: The PHP License
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -15,11 +15,12 @@ URL: http://www.php.net/
|
||||
Source0: http://www.php.net/distributions/php-%{version}.tar.gz
|
||||
Source10: pear-RunTest.php
|
||||
Source20: http://pear.php.net/get/DB-1.7.6.tgz
|
||||
Source21: http://pear.php.net/get/HTTP-1.3.5.tgz
|
||||
Source22: http://pear.php.net/get/Mail-1.1.4.tgz
|
||||
Source21: http://pear.php.net/get/HTTP-1.3.6.tgz
|
||||
Source22: http://pear.php.net/get/Mail-1.1.8.tgz
|
||||
Source23: http://pear.php.net/get/XML_Parser-1.2.6.tgz
|
||||
Source24: http://pear.php.net/get/Net_Socket-1.0.6.tgz
|
||||
Source25: http://pear.php.net/get/Net_SMTP-1.2.6.tgz
|
||||
Source26: http://pear.php.net/get/XML_RPC-1.4.1.tgz
|
||||
Source50: php.conf
|
||||
|
||||
Patch2: php-5.0.1-config.patch
|
||||
@ -34,15 +35,14 @@ Patch11: php-4.3.8-round.patch
|
||||
Patch13: php-5.0.2-phpize64.patch
|
||||
Patch14: php-5.0.3-sprintf.patch
|
||||
Patch16: php-5.0.3-gdheaders.patch
|
||||
Patch17: php-5.0.3-gcc4.patch
|
||||
Patch18: php-5.0.4-streamcopy.patch
|
||||
Patch17: php-5.0.4-bug34435.patch
|
||||
|
||||
# Fixes for extension modules
|
||||
Patch21: php-4.3.1-odbc.patch
|
||||
Patch22: php-4.3.11-shutdown.patch
|
||||
Patch23: php-5.0.4-bug32282.patch
|
||||
Patch24: php-5.0.4-xmldom.patch
|
||||
Patch25: php-5.0.4-ldap.patch
|
||||
Patch26: php-5.0.4-gd.patch
|
||||
|
||||
# Functional changes
|
||||
Patch30: php-5.0.4-dlopen.patch
|
||||
@ -79,7 +79,7 @@ the embedded PHP language in Web pages.
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Files needed for building PHP extensions.
|
||||
Requires: php = %{version}-%{release}
|
||||
Requires: php = %{version}-%{release}, autoconf, automake
|
||||
|
||||
%description devel
|
||||
The php-devel package contains the files needed for building PHP
|
||||
@ -338,12 +338,10 @@ support for using the DBA database abstraction layer to PHP.
|
||||
%patch11 -p1 -b .round
|
||||
%patch13 -p1 -b .phpize64
|
||||
%patch16 -p1 -b .gdheaders
|
||||
%patch17 -p1 -b .gcc4
|
||||
%patch18 -p1 -b .streamcopy
|
||||
%patch17 -p1 -b .bug34435
|
||||
|
||||
%patch21 -p1 -b .odbc
|
||||
%patch22 -p1 -b .shutdown
|
||||
%patch23 -p1 -b .bug32282
|
||||
%patch24 -p1 -b .xmldom
|
||||
%patch25 -p1 -b .ldap
|
||||
|
||||
@ -374,13 +372,13 @@ rm -f ext/standard/tests/file/bug21131.phpt
|
||||
rm -f ext/standard/tests/file/bug22414.phpt \
|
||||
ext/iconv/tests/bug16069.phpt
|
||||
|
||||
# Missing file in 5.0.4 PEAR bundle:
|
||||
cp $RPM_SOURCE_DIR/pear-RunTest.php pear/PEAR/RunTest.php
|
||||
# Replaced by XML_RPC 1.4.1 upgrade:
|
||||
rm -f pear/packages/XML_RPC-1.4.0.tgz
|
||||
|
||||
# Add some standard PEAR packages which are no longer shipped upstream
|
||||
pushd pear/packages
|
||||
cp %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} \
|
||||
%{SOURCE24} %{SOURCE25} .
|
||||
%{SOURCE24} %{SOURCE25} %{SOURCE26} .
|
||||
gunzip *.tgz
|
||||
popd
|
||||
|
||||
@ -448,7 +446,7 @@ ln -sf ../configure
|
||||
--enable-calendar \
|
||||
--enable-dbx \
|
||||
--enable-dio \
|
||||
--with-mime-magic=%{_datadir}/file/magic.mime \
|
||||
--with-mime-magic=%{_sysconfdir}/httpd/conf/magic \
|
||||
--without-sqlite \
|
||||
--with-libxml-dir=%{_prefix} \
|
||||
--with-xml \
|
||||
@ -644,6 +642,12 @@ rm files.*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Sep 14 2005 Joe Orton <jorton@redhat.com> 5.0.5-3
|
||||
- update to 5.0.5
|
||||
- add fix for upstream #34435
|
||||
- devel: require autoconf, automake (#159283)
|
||||
- pear: update to HTTP-1.3.6, Mail-1.1.8, Net_SMTP-1.2.7, XML_RPC-1.4.1
|
||||
|
||||
* Thu Jun 16 2005 Joe Orton <jorton@redhat.com> 5.0.4-11
|
||||
- ldap: restore ldap_start_tls() function
|
||||
|
||||
|
9
sources
9
sources
@ -1,7 +1,8 @@
|
||||
c8f5fa441fd99c1b363bd2a071a0bd97 php-5.0.4.tar.gz
|
||||
3e14fef5bd418de87214a3271ffc4549 Mail-1.1.4.tgz
|
||||
9c01a682f5859a09e01fe5f305b3c353 HTTP-1.3.5.tgz
|
||||
f961deffb093a58eb4c48478de1b27ed Net_Socket-1.0.6.tgz
|
||||
96ebc0fc2f349249f1455389797e72a4 XML_Parser-1.2.6.tgz
|
||||
69bcb47d571b72060beed0a7d8d852a5 Net_SMTP-1.2.6.tgz
|
||||
b5ff032f7e8873174e3e7fc21b7ec696 DB-1.7.6.tgz
|
||||
a646a20e20634442eda43c21ed3f08fd XML_RPC-1.4.1.tgz
|
||||
69b1941019b686227123a879090241ab Mail-1.1.8.tgz
|
||||
b166af8069febd24699df675cf0d5b0f HTTP-1.3.6.tgz
|
||||
11c4de943b07206aab6193eefd8f328e Net_SMTP-1.2.7.tgz
|
||||
ae36a2aa35cfaa58bdc5b9a525e6f451 php-5.0.5.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user